Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
RaspBerry Pi + nrf24L01
Tengo instalado de nuevo el LAMP, y he copiado el contenido del zip en la rasp. He cargado los datos de muestra en la bd, pero la web no me los muestra. He cambiado los datos de acceso a la BD en el archivo de configuración.

Me falta cargar el plano de mi casa, igual por eso no carga datos en las gráficas.
Citar
Los datos de prueba son de las fechas 20 y 21 de diciembre. Si accedes a esos días en el calendario, ¿se muestran los datos?
Citar
No, no me salen datos de esos dias
Citar
Si acccedes a http://localhost/php/datos.php , puedes copiar y pegar aquí lo que te pone?
Citar
Código:
{"actual":[{"nodo":"1","bateria":null,"temperatura":"32.00","humedad":"88.40"},{"nodo":"2","bateria":"4.00","temperatura":"31.50","humedad":"57.20"}],"nodo":{"bateria":[],"temperatura":[],"humedad":[],"registro":[]}}
Citar
Vale, entonces es lo de la batería jejeje, has usado este script para crear la BBDD http://www.spainlabs.com/foro/viewtopic....=20#p46045 pero había que usar el que puse después: http://www.spainlabs.com/foro/viewtopic....=40#p46053 además, no te olvides de ejecutar esto también: http://www.spainlabs.com/foro/viewtopic....=40#p46370
Citar
Sigo sin representar datos:

Código:
{"actual":[{"nodo":"1","bateria":"4.10","temperatura":"31.50","humedad":"57.20"},{"nodo":"2","bateria":"4.00","temperatura":"31.50","humedad":"57.20"}],"nodo":{"bateria":[],"temperatura":[],"humedad":[],"registro":[]}}

He borrado la base de datos, y la he vuelto a crear con el script. La linea suelta que pusiste despues, la añado al final del script.
Citar
Perfecto, y si ahora accedes a http://localhost/php/datos.php?nodo=1&dia=2014-12-21
Citar
Obtengo esto:

Código:
{"actual":[{"nodo":"1","bateria":"4.10","temperatura":"31.50","humedad":"57.20"},{"nodo":"2","bateria":"4.00","temperatura":"31.50","humedad":"57.20"}],"nodo":{"bateria":{"0h":3.33,"1h":3.8,"2h":3.78,"3h":3.8,"4h":3.45,"5h":3.47,"6h":3.8,"7h":3.8,"8h":3.8,"9h":3.7,"10h":3.9,"11h":3.8,"12h":4.1},"temperatura":{"0h":25.7,"1h":25.4,"2h":25.8,"3h":25.1,"4h":24.6,"5h":21.9,"6h":25.7,"7h":21.2,"8h":24.8,"9h":27.7,"10h":29.7,"11h":30.1,"12h":31.5},"humedad":{"0h":77.4,"1h":67.4,"2h":56.8,"3h":88.9,"4h":45.7,"5h":67.1,"6h":34.2,"7h":55.6,"8h":56,"9h":56.3,"10h":56.6,"11h":56.9,"12h":57.2},"registro":[{"numero":14,"hora":"00:00:00","bateria":3.33,"temperatura":25.7,"humedad":77.4},{"numero":15,"hora":"01:00:00","bateria":3.8,"temperatura":25.4,"humedad":67.4},{"numero":16,"hora":"02:00:00","bateria":3.78,"temperatura":25.8,"humedad":56.8},{"numero":17,"hora":"03:00:00","bateria":3.8,"temperatura":25.1,"humedad":88.9},{"numero":18,"hora":"04:00:00","bateria":3.45,"temperatura":24.6,"humedad":45.7},{"numero":19,"hora":"05:00:00","bateria":3.47,"temperatura":21.9,"humedad":67.1},{"numero":20,"hora":"06:00:00","bateria":3.8,"temperatura":25.7,"humedad":34.2},{"numero":21,"hora":"07:00:00","bateria":3.8,"temperatura":21.2,"humedad":55.6},{"numero":22,"hora":"08:00:00","bateria":3.8,"temperatura":24.8,"humedad":56},{"numero":23,"hora":"09:00:00","bateria":3.7,"temperatura":27.7,"humedad":56.3},{"numero":24,"hora":"10:00:00","bateria":3.9,"temperatura":29.7,"humedad":56.6},{"numero":25,"hora":"11:00:00","bateria":3.8,"temperatura":30.1,"humedad":56.9},{"numero":26,"hora":"12:00:00","bateria":4.1,"temperatura":31.5,"humedad":57.2}]}}

la carpeta de php y las demas que contenian el archivo comprimido, estan guardadas en una subcarpeta, no cuelgan directamente de "www"
Citar
Fenomenal, el JSON se muestra correctamente. Ahora si accede a la página principal y seleccionas la fecha del 20 o del 21 de Diciembre te sale ya algo?
Citar
No, no me muestra nada. Aun no tengo el plano de casa cargado, puede influir?
Citar
Cuando dices que el plano no está cargado, es porque el fichero plano.jpg no está en la carpeta img? Si es porque no está será ese el problema, debido a que como se pinta con javascript si la función de carga falla ya no ejecuta el resto del código.
Citar
No carga tampoco el plano, lo acabo de meter, y no muestra la imagen. Si que esta el espacio donde deberia aparecer la imagen, pero no se carga.
Citar
¿Qué navegador estás usando? Si es el propio de la Raspberry Pi puede que tenga algunas carencias, ¿podrías acceder desde un ordenador a la url http://<ip de la raspberry pi> si tienes conectada la Raspberry Pi a tu red?
Citar
Accedo siempre remotamente. Tengo la rasp pinchada en el router y accedo desde mi ordenador. Tanto con Firefox como con Chrome, estoy en las mismas.
Citar
Ok, ya he encontrado el error. Cuando me has dicho lo de que estaba en una carpeta dentro de www no me he dado cuenta de si había alguna problema con las rutas, y efectivamente así ha sido. Edita el fichero js/script.js y donde pone
Código:
imagen.src = "../img/plano.jpg";
cambialo por
Código:
imagen.src = "img/plano.jpg";


A mi me funcionaba porque lo tenía en la raiz /var/www Sonrisa
Citar
Ahora si, perfecto. FUNCIONA!!!

Next step y creo que el ultimo. Pasar los datos recibidos de los nodos a la BD.

Hoy he recibido una cajita de metacrilato para la rasp ^^
Citar
Pues si, es el último paso ya, jeje. En python debes guardar los campos de la cadena recibida en variables y después insertarlos en la BBDD como comentas.

Para instalar la libreria de python para conectarte a mysql ejecuta:

Código:
sudo apt-get install python-mysqldb

Te paso un ejemplo de cómo se insertaría en la BBDD usando python:

http://marinoscar.com/inserta.py

Lo que hace es cada 5 minutos meter unos valores aleatorios en la tabla siempre siguiendo unos margenes.
Citar
Esto habria que meterlo en el archivo python que lee los datos del modulo nrf24l01, es correcto?
Citar
Si, pero hay que adaptarlo para que haga lo que tiene que hacer.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Raspberry quemada al conectar USB de placa xero83 4 436 24-07-2018, 01:09 PM
Último mensaje: xero83
  NOTICIA Os invito a mi blog "Raspberry Para todos" Turriano 0 251 14-07-2018, 05:16 PM
Último mensaje: Turriano
  Encendido/Apagado LED con pulsador Raspberry Javier_DC 2 705 16-04-2018, 08:12 AM
Último mensaje: Javier_DC
  [TUTORIAL] Como ejecutar scripts al iniciar nuestra Raspberry Electromecánico 7 15,150 18-03-2018, 11:52 PM
Último mensaje: yuber1992
Pregunta Plataforma educativa online para curso de Raspberry Pi Electromecánico 1 518 17-01-2018, 09:09 PM
Último mensaje: grafisoft