Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[RESUELTO] LCD no funciona correctamente
#1
Hola a todos,

He intentado configurar el LCD de distintas formas, al principio solo tenía el panel con todo verde, después de repasar las soldaduras y volver a cargar la configuración esto es lo que muestra, la primera y tercera línea con cuadros negros:

resim


¿Puede ser que me siga dando problemas alguna soldadura? ¿Cómo ponéis la configuración? ¿Sólo con descomentar esta línea: #define REPRAP_DISCOUNT_SMART_CONTROLLER?

Pongo también como tengo puestos los cables.

resim

Gracias por vuestra ayuda.
Poseedor Prusa i3 edición Conjunta.
Tinkercad: Principiante.
Openscad: Principante.
Thingiverse: http://www.thingiverse.com/vimajo/designs
Citar
#2
Eso tiene toda la pinta de ser el contraste, debes ajustarlo usando un potenciómetro (si es que viene) o a través del firmware (si es que existe esa opción).
Citar
#3
Mismo problema por aquí, yo sospecho de las soldaduras, porque no se que puede ser si no.
Citar
#4
hinjeniero escribió:Eso tiene toda la pinta de ser el contraste, debes ajustarlo usando un potenciómetro (si es que viene) o a través del firmware (si es que existe esa opción).
eso pensé yo pero no lo es, es un fallo de inicialización Guiño Si fuera un fallo de contraste/brillo se verían las 4 filas de cuadrados.

yo apuesto por algo de firmware o mala conexión.

Por cierto, ¿qué soldaduras has repasado? ¿ese panel no viene montado ya con su adaptador y todo?
Citar
#5
Son tres líneas.

http://reprap.org/wiki/RepRapDiscount_Smart_Controller

Enviado desde mi GT-N7100 usando Tapatalk 4
Citar
#6
Cito y traduzco para lo mas espesitos Mola .
Cita:Marlin V1 (nuevo)

- En el archivo "Configuration.h”
1. Cambiar la linea 46 a “#define MOTHERBOARD 33”
2. Cambiar la linea 306 a“#define REPRAP_DISCOUNT_SMART_CONTROLLER” (basta con retirar // en el principio)
3. Cambiar la linea 326 a“#define NEWPANEL // Activar si vas a usar un paner con encoder clickcable (puedes presionar la ruleta para lento)”
(basta con retirar // en el principio)

Cambiar a la pestaña "Pins.h" Cambiar la linea 318 a“#define RAMPS_V_1_3” (basta con retirar // en el principio)
Citar
#7
cansi22 escribió:Cito y traduzco para lo mas espesitos Mola .
Cita:Marlin V1 (nuevo)

- En el archivo "Configuration.h”
1. Cambiar la linea 46 a “#define MOTHERBOARD 33”
2. Cambiar la linea 306 a“#define REPRAP_DISCOUNT_SMART_CONTROLLER” (basta con retirar // en el principio)
3. Cambiar la linea 326 a“#define NEWPANEL // Activar si vas a usar un paner con encoder clickcable (puedes presionar la ruleta para lento)”
(basta con retirar // en el principio)

Cambiar a la pestaña "Pins.h" Cambiar la linea 318 a“#define RAMPS_V_1_3” (basta con retirar // en el principio)

Eso había visto por Internet, pero no estaba seguro si esa configuración es para la nuestra y no lo había probado aún. Además, no podía ver donde estaba el pins.h en la pestaña del programador, ya que no me lo muestra en la lista de ficheros en el programador, si lo tengo en el directorio de Marlin, y no lo pude cambiar.

Esta tarde hago los cambios y lo pruebo, si sigue fallando repasaré las soldaduras, pero por lo menos ya podré descartar la configuración. Ya os contaré los resultados.

¡Muchas gracias a todos! Mola
Poseedor Prusa i3 edición Conjunta.
Tinkercad: Principiante.
Openscad: Principante.
Thingiverse: http://www.thingiverse.com/vimajo/designs
Citar
#8
vimajo escribió:
cansi22 escribió:Cito y traduzco para lo mas espesitos Mola .
Cita:Marlin V1 (nuevo)

- En el archivo "Configuration.h”
1. Cambiar la linea 46 a “#define MOTHERBOARD 33”
2. Cambiar la linea 306 a“#define REPRAP_DISCOUNT_SMART_CONTROLLER” (basta con retirar // en el principio)
3. Cambiar la linea 326 a“#define NEWPANEL // Activar si vas a usar un paner con encoder clickcable (puedes presionar la ruleta para lento)”
(basta con retirar // en el principio)

Cambiar a la pestaña "Pins.h" Cambiar la linea 318 a“#define RAMPS_V_1_3” (basta con retirar // en el principio)

Eso había visto por Internet, pero no estaba seguro si esa configuración es para la nuestra y no lo había probado aún. Además, no podía ver donde estaba el pins.h en la pestaña del programador, ya que no me lo muestra en la lista de ficheros en el programador, si lo tengo en el directorio de Marlin, y no lo pude cambiar.

Esta tarde hago los cambios y lo pruebo, si sigue fallando repasaré las soldaduras, pero por lo menos ya podré descartar la configuración. Ya os contaré los resultados.

¡Muchas gracias a todos! Mola

al final de todas las pestañas tienes una flechita hacia abajo que te despliega la lista con todas ellas Guiño

sino pulsando CTRL+ALT+flecha_dirección también puedes seleccionar pestañas

Saludos!
Citar
#9
ark escribió:al final de todas las pestañas tienes una flechita hacia abajo que te despliega la lista con todas ellas Guiño

sino pulsando CTRL+ALT+flecha_dirección también puedes seleccionar pestañas

Saludos!

Gracias por el consejo, pero ya lo había probado, se me corta la lista al desplegarla. Lo que hago es ponerme sobre el último elemento que veo y darle 8 veces abajo y a enter para que me abra el pins.h, que lo logre encontrar así ayer.

Y lo de CTRL+ALT+flecha lo que me hace es girarme la orientación de la pantalla. Debe ser cosa del Windows Vista. :dale2:
Poseedor Prusa i3 edición Conjunta.
Tinkercad: Principiante.
Openscad: Principante.
Thingiverse: http://www.thingiverse.com/vimajo/designs
Citar
#10
vimajo escribió:
ark escribió:al final de todas las pestañas tienes una flechita hacia abajo que te despliega la lista con todas ellas Guiño

sino pulsando CTRL+ALT+flecha_dirección también puedes seleccionar pestañas

Saludos!

Gracias por el consejo, pero ya lo había probado, se me corta la lista al desplegarla. Lo que hago es ponerme sobre el último elemento que veo y darle 8 veces abajo y a enter para que me abra el pins.h, que lo logre encontrar así ayer.

Y lo de CTRL+ALT+flecha lo que me hace es girarme la orientación de la pantalla. Debe ser cosa del Windows Vista. :dale2:

Meparto
Citar
#11
cansi22 escribió:Cito y traduzco para lo mas espesitos Mola .
Cita:Marlin V1 (nuevo)

- En el archivo "Configuration.h”
1. Cambiar la linea 46 a “#define MOTHERBOARD 33”
2. Cambiar la linea 306 a“#define REPRAP_DISCOUNT_SMART_CONTROLLER” (basta con retirar // en el principio)
3. Cambiar la linea 326 a“#define NEWPANEL // Activar si vas a usar un paner con encoder clickcable (puedes presionar la ruleta para lento)”
(basta con retirar // en el principio)

Cambiar a la pestaña "Pins.h" Cambiar la linea 318 a“#define RAMPS_V_1_3” (basta con retirar // en el principio)

No funcionó, creo que toca repasar las soldaduras, si sigue igual habrá que pensar en que el lcd pueda tener algún problema...

Iré informando, gracias por vuestra ayuda.
Poseedor Prusa i3 edición Conjunta.
Tinkercad: Principiante.
Openscad: Principante.
Thingiverse: http://www.thingiverse.com/vimajo/designs
Citar
#12
A mi tampoco me funciona. Al conectarlo enciende y muestra datos y empieza a moverse como si le estuvieras dando al selector y al rato empiezan a salir caracteres extraños.
Resoldé las tiras de pines y nada.
Citar
#13
Me estais asustando. ¿Cómo quedó la cosa? Cuando llegue a casa pruebo la mia de una vez.
Citar
#14
A ver chavales... yo tengo el panel funcionando a la perfección.

El mío es el de Geeetech y creo que os confundis en la configuración. En Marlin solo teneis que descomentar la linea
Código:
//#define REPRAP_DISCOUNT_SMART_CONTROLLER
quitando las dos barras del principio, pero no teneis que marcar nada de pantalla clicable.
Citar
#15
Yo instale la de geeetech este finde que la tenia en casa desde hace 4 meses, pero me daba pereza soldar la ramps
Puesnada la he puesto y solo descomentando esa linea va perfecta
Saludos
Citar
#16
La mia también es de geeetech y funciona perfectamente descomentando esa linea, yo ya tenía todo soldado.
Citar
#17
Hola, entonces si conectas el lcd a la ramps y solo se encienden la 1y 3 linea con cuadros negros, es que esta mal, ya sea por la lcd o por las soldaduras? Lo digo sin tocar nada en ningun archivo. Guiño
Citar
#18
Tienes que descomentar una linea como te dicen los compañeros
Citar
#19
Ok, gracias lo probare. Guiño

Pd.: Una cosita aunque no es este lugar el adecuado me parece. Como se puede poner para que aparezca la numeracion de la lineas de codigo en el programa de arduino (tengo el que puso overcraft en su video) y es que no se cual es la linea 300 o 301 por ejemplo. Es que si tengo que contarlas me da algo.

Gracias por la ayuda. Guiño
Citar
#20
resim

No tengo ni idea de como se ponen las lineas, pero fijate en los numeros que hay abajo a la izquierda... ¿ves que pone 410-412? Pues es lo que tengo señalado en color amarillo...

Por cierto, para que funcione la pantalla de Geeetech solo hay que descomentar esa linea 412.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Rumba no funciona con LCD full graphics gale9010 1 443 13-10-2017, 09:43 PM
Último mensaje: poliveira1978
  [AYUDA] Autobed leveling no funciona correctamente Jrx07 8 1,016 29-11-2016, 01:55 AM
Último mensaje: Jrx07
Triste Calibracion eje Z y pelea con marlin TODO RESUELTO Jaimelito 4 5,614 18-01-2016, 04:20 PM
Último mensaje: Jaimelito
  LCD steel no funciona sin USB rusako 25 4,856 06-01-2016, 04:53 PM
Último mensaje: javi_tecla
  [RESUELTO] Cambiar pines del E1 al eje X dr.taly 1 714 18-10-2015, 11:19 AM
Último mensaje: dr.taly