Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[RESUELTO][Averia] Temperatura Extrusor incorrecta
#1
Bueno yo voy a avería por semana Meparto

Anoche estaba imprimiendo perfectamente, cuando termino la apagamos y sin ningún problema. Pero hoy al encenderla en frio marca el fusor a 98ºC

resim

Os cuento la batería de pruebas que hemos hecho.

Verificado que el termistor de la cama y del extrusor marca 100K a temperatura ambiente, bueno marcan 98K pero tampoco estamos exactos a CN Sisi3

Desenchufar los termistores de la placa. La cama marca 0 pero el fusor sigue en sus 98ºC

Intercambiar los conectores de los termistores en frio. Siempre marca la temperatura incorrecta en el fusor.

Desmontar y revisar toda la electrónica, no se ve nada quemada, defectuoso ... aparentemente esta bien.

Cargar de nuevo el firmware de marlin, comprobando que los valores de los termistores son los correctos

Código:
#define TEMP_SENSOR_0 5
#define TEMP_SENSOR_1 -1
#define TEMP_SENSOR_2 0
#define TEMP_SENSOR_BED 1

Enchufada por USB al ordenador marca exactamente lo mismo

Si pones a calentar sube de temperatura y al parar siempre vuelve a ese valor de 98ºC


En fin se me acaban un poco las ideas

Tengo una duda pero no se si es buena idea hacer la prueba o no. Quiero usar las patas del TEMP_SENSOR_2 para conectar el extrusor principal, la pregunta es como se le indica eso en el marlin??

me voy al apartado de pines e intercambio estos 2 pines??

#define TEMP_0_PIN 15 // ANALOG NUMBERING - default connector for thermistor *T0* on rumba board is used
#define TEMP_2_PIN 13 // ANALOG NUMBERING - default connector for thermistor *T2* on rumba board is used

¿Alguien tiene alguna sugerencia mejor?



Esta es la configuración en el archivo de pines
Código:
#if (TEMP_SENSOR_0==0)
#define TEMP_0_PIN         -1
#define HEATER_0_PIN       -1
#else
#define HEATER_0_PIN        2    // EXTRUDER 1
#if (TEMP_SENSOR_0==-1)
  #define TEMP_0_PIN         6    // ANALOG NUMBERING - connector *K1* on RUMBA thermocouple ADD ON is used
#else
  #define TEMP_0_PIN         15   // ANALOG NUMBERING - default connector for thermistor *T0* on rumba board is used
#endif
#endif

#if (TEMP_SENSOR_1==0)
#define TEMP_1_PIN         -1
#define HEATER_1_PIN       -1
#else
#define HEATER_1_PIN        3    // EXTRUDER 2
#if (TEMP_SENSOR_1==-1)
  #define TEMP_1_PIN         5    // ANALOG NUMBERING - connector *K2* on RUMBA thermocouple ADD ON is used
#else
  #define TEMP_1_PIN         14   // ANALOG NUMBERING - default connector for thermistor *T1* on rumba board is used
#endif
#endif

#if (TEMP_SENSOR_2==0)
#define TEMP_2_PIN         -1
#define HEATER_2_PIN       -1
#else
#define HEATER_2_PIN        6    // EXTRUDER 3
#if (TEMP_SENSOR_2==-1)
  #define TEMP_2_PIN         7    // ANALOG NUMBERING - connector *K3* on RUMBA thermocouple ADD ON is used <-- this can not be used when TEMP_SENSOR_BED is defined as thermocouple
#else
  #define TEMP_2_PIN         13   // ANALOG NUMBERING - default connector for thermistor *T2* on rumba board is used
#endif
#endif
Citar
#2
Bueno pues ya hemos encontrado el error. El arduino se ha roto, el pin 15 de los analógicos, donde esta enchufado el termistor del extrusor 1

Gracias a un amigo que nos ha prestado un arduino mega lo hemos podido averiguar, porque si en su arduino todo funciona bien y en el que tenemos da ese fallo de temperatura ... blanco y en botella ... Horchata :elrisas:

Bueno ahora toca ponerse en contacto con Ghosthawk para ver que solución le damos :lol:

Aqui la prueba de que funciona Mola
resim
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  problema con temperatura de extrusor pycreembass 2 143 09-05-2018, 10:54 AM
Último mensaje: pycreembass
  CONSULTA Problema de temperatura Anet a8 Snego 2 195 19-04-2018, 12:37 PM
Último mensaje: Shellmer
  Temperatura Hotend baja al imprimir zgz58 9 1,372 22-09-2017, 05:02 PM
Último mensaje: tximy
  GT2560 , no se estabiliza la temperatura del hotend monchofb 2 488 20-02-2017, 10:51 PM
Último mensaje: monchofb
Triste Calibracion eje Z y pelea con marlin TODO RESUELTO Jaimelito 4 5,095 18-01-2016, 04:20 PM
Último mensaje: Jaimelito