Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema sensor capacitativo.
#1
Hola a totdos,
He montado una Hypercube Evolution de 300x300x370 y últimamente estoy teniendo muchos problemas con la altura de la primera capa.
Creo que el sensor capacitativo LJC 12A3-4-Z/BX NPN DC6-36V no es muy preciso. Tengo que precalentar la cama a 50º, realizar el home, desplazarme al centro y volver a realizar un home Z.
Después de medir varias veces encuentro diferencias de casi 2 décimas.
De la primera capa depende mucho la impresión ya que si está demasiado levantada no se adhiere bien o al contrario si está muy ajustada no sale el plástico y el hobbed bold se come el filamento.

Estoy por cambiarlo por un BL touch pero me encuentro con precios desde los 43€ (que parece son originales) a los 9€ que deben ser copias. He leido que todos suelen funcionar bien.
Mi placa es una MKS Sbase V3.0 con smoothieware alimentada a 24v.

Alguien me puede aconsejar y si saben como configurarlo lo agradeceria.

Un saludo
Citar
#2
Hola, los sensores capacitivos son en general menos precisos que otros tipos y depende mucho de la calidad de fabricación del que tengamos.
Además, si se utiliza cama caliente, con el calor la desviación en las medidas aumenta de forma drástica.
De todas formas, 0,2mm es una desviación bastante grande, por lo que puede que la unidad que tienes sea más bien mala.
Los sensores tipo BLTouch-3DTouch son en general algo más precisos, pero también depende de su calidad. Parece lógico pensar que no pueden tener la misma uno de 40€ que otro de 9€.
En todo caso, este tipo de sensor tampoco es la panacea y hay muchos usuarios que han tenido problemas también con ellos (supongo que por la calidad de los mismos).
Por último una reflexión: ¿has comprobado si tu máquina necesita autolevel?
Porque en este tipo de impresoras, en las que se suele mantener bastante constante la nivelación con el tiempo, si la superficie de impresión está suficientemente plana el autolevel es innecesario.
Yo mi CoreXY (de diseño propio) la fabriqué pensando en utilizarar autolevel, suponiendo que una cama de 400x300 lo iba a necesitar y al final no he tenido que regular la cama desde que la monté e imprimo sin él perfectamente.
Citar
#3
Gracias Simemart,
al principio pensaba usar el autolevel pero no conseguí aclararme com la MKS Sbase y el smoothieware.
Encima de la cama llevo un cristal de 300x300 de borosilicato de 4,5mm, cuando consigo acertar la altura el perímetro de la primera capa queda perfecto por muy grande que sea. He podido comprobar que la he podido dejar perfectamente nivelada, por lo que ya he descartado romperme la cabeza con el autolevel.

Efectivamente el calor afecta mucho el disparo del sensor, es por eso que realizo la última comprobación en el centro de la cama y a la misma temperatura de 50º con eso consigo afinar bastante.
El problema surgió cuando quise separar el sensor y aumentar la sensibilidad, fué un desatre tenia el offset del Z sobre 5mm y las variaciones eran de hasta 5 décimas si la temperatura no estaba estable.
Hoy he puesto la altura del sensor lo más cerca posible de la cama y ajustado la sensibilidad del sensor al mínimo y el disparo del  sensor deja la boquilla en 0,8mm.

Tengo que poner la cama a 50º dejarla que se estabilice un poco, realizar el home, ir al centro y volver a realizar un home Z, (lo he colocado en el script) de está forma las lecturas tienen una variacion de 0,5 décimas.

De momento lo dejaré así pero tendré que mirar a que distancias queda la boquilla según la temperatura de la cama y asignar esa medida en el script del fileteado.
Tendré que realizar un perfil para cada temperatura de la cama (PLA o ABS) y asignar allí el offset correspondiente.

De todas formas si alguien tiene un sensor que le funcione bien se aceptan consejos.
Yo compré este.
Citar
#4
Pues si no piensas utilizar el autolevel, yo quitaría el sensor y colocaría un interruptor mecánico de final de carrera.
Es lo que yo tengo en mi CoreXY. No obtendrás mejores resultados con ningún tipo de sensor.
Citar
#5
(01-06-2019, 05:53 PM)Simemart escribió: Pues si no piensas utilizar el autolevel, yo quitaría el sensor y colocaría un interruptor mecánico de final de carrera.
Es lo que yo tengo en mi CoreXY. No obtendrás mejores resultados con ningún tipo de sensor.
Ayer mismo me comentó lo mismo un compañero que en su delta usa interruptor mecánico. 
Yo tengo algunos interruptores ópticos que me sobraron. Creo que son igual de precisos que los mecánicos. 
A ver si esta semana busco como colocarlo en la corexy. 
Saludos
Citar
#6
Pues siento decirte que los ópticos, en general, son de los menos fiables.
Puedes ver una prueba muy completa en este video.
Citar
#7
(02-06-2019, 11:03 AM)Simemart escribió: Pues siento decirte que los ópticos, en general, son de los menos fiables.
Puedes ver una prueba muy completa en este video.

Gracias Simermart,
este vídeo lo encontré y empecé a mirarlo pero el inglés no es mi fuerte. Hoy lo he visto todo completo (he usado los subtítulos traducidos) y me ha quedado bastante claro.
El tema que el óptico no sea tan preciso supongo que es por el modelo de la prueba. Yo los que uso son los que cortan el haz de luz y por lo que he leido son algo más exactos que los mecánicos, excepto si al mecánico le quitas la palanquita que acciona el microinterruptor.

Lo que si tengo claro es que quitaré el capacitativo y no compraré el BL touch, a no ser que más adelante decida usar el autolevel. Pero creo que de momento si la mesa se conserva bien alineada no me ara falta.

Un saludo
Citar
#8
Bueno deciros que al final nivelando bien la base y con el final de carrera óptico en el eje Z se acabaron los problemas.
He descubierto otro problema que también he podido solucionar. En mi corexy cuando realizo un movimiento en el eje Y de Y0 a Y280 por ejemplo este se desplaza casi 1cm hacia la derecha. Es decir que si realizo un cuadrado de 280x280cm la parte superior mide 1cm menos que la parte inferior. Los dos laterales también tiene una pequeña diferencia de 1 o 2 mm y la parte inferior sale un poco curvada.
Mientras he realizado piezas pequeñas no había observado ese error. Fue al realizar movimientos en el eje Y cuando la X estaba en la zona izquierda que observaba que se desplazaba a la derecha..

Le di mil vueltas ajustando las tensiones de las correas pero ni así.

Al final saqué las dos correas  y las encaré juntando los dientes y observé que en una zona la separación de los dientes no coincidia. La correa era de las blancas con hilos de acero en el interior. Creo que de fabrica debió sufrir algún tirón que hizo que aumentara la distancia de los dientes en esa zona. Al llevar hilos de acero interior quedo viciada.

Las he sustituido por las negras de toda la vida y he conseguido realizar un cuadrado exacto.
Subo una foto de como era el error.
resim
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  smoothieboard y sensor capacitivo shiryou 6 1,529 02-08-2019, 08:49 AM
Último mensaje: pere_gs
  Problema hotend y sensor al poner cama de silicona 220 Jesusev 3 226 15-04-2019, 03:42 PM
Último mensaje: Simemart
  DUDA Sensor Filamento (runout) ovm20 xavibox66 1 178 14-04-2019, 08:31 PM
Último mensaje: xavibox66
  Duda sensor capacitivo y reductor de voltaje Flautarian 2 359 12-11-2018, 09:45 PM
Último mensaje: norwix
  CONSULTA Ofset Z con sensor auto bed leveling dvera16 0 590 08-01-2018, 09:48 AM
Último mensaje: dvera16