Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema placa geeetech i3
#1
Hola, me han dejado una geeetech i3 Pro B, el problema es que ya la tengo toda montada y cuando conecto la placa que trae (GT2560). No me calienta la cama, he comprobado con un polimetro y no envía nada de corriente. Luego a la hora de conectarla al ordenador me cuenta varios intentos conectarla y cuando intento actualizar o acceder a ella suele interrumpirse la conexión ( he probado con varios puertos y varios cables). 

He pensado ponerle la placa de arduino mega 2560. Vale la pena o compraríais otra placa como la que lleva?
Se le puede cargar el marlin que uso para la otra placa? Estoy un poco verde.. no se si alguien lo habrá hecho
Citar
#2
Hola @norwito, bienvenido al foro.
Antes de pensar en cambiar la placa, yo investigaría algo más el problema que tienes.
La avería más típica en este tema es que caliente la cama todo el tiempo y no que no lo haga, como en tu caso.
Dices que estás usando Marlin, pero surgen varias dudas: ¿qué versión? ¿con qué configuración? ¿alguna vez funcionó?
Los problemas para conectarla al ordenador pueden ser debidos al driver del ordenador o a una velocidad de conexión inadecuada.
Mi recomendación es que instales Marlin en su última versión (1.1.9-bugfix), para descartar que sea el firmware que tienes instalado el problema.
Supongo que con lo de "placa de arduino mega 2560", te refieres junto con una RAMPS. Naturalmente, podrías utilizar dicho conjunto para sustituir a la GT2560, pero tendrías que cargarle Marlin con la configuración específica para dicho modelo. Es muy parecida a la de la GT2560, aunque no idéntica.
La GT2560 es, más o menos, un Arduino Mega 2560+RAMPS 1.4+smart conector(LCD), todo incluido en una sola placa.

P.S.: No me había fijado que ya llevas un año registrado en el foro, aunque es tu primera pregunta. Bienvenido a la acción, en todo caso.
Citar
#3
Pues si que es verdad que llevo tiempo leyendo por el foro, la verdad que había solucionado todas mis dudas buscando.

Pues tengo la ultima versión de marlin, le e puesto la configuración que hay en la carpeta ejemplos de Geeetech.

Me refiero a el ponerle mega 2560 con las ramps (lo tengo todo de otra impresora, solo seria cambiarlo) . la duda que me surge es que si le cargo la configuración  de esta impresora me sale con la placa gt2560 y la pantalla tampoco es la misma, igual ahi algo mas que se me pasa por alto.  

Es que estoy muy arto de la placa que lleva, ahora cuando intento cargarla el marlin, me da error de conexion y e leido que es por que no lleva bootloader, (yo e podido cargarle marlin y ahora no)  en fin avanzo un paso y retrocedo 3  Smash2
Citar
#4
Hola, los archivos de configuración de ejemplo vienen preparados para la impresora de serie, pero no hay problema en adaptarlos si se utiliza otra electrónica.
Si no se me escapa nada, creo que puedes utilizar esos mismos archivos, cambiando sólo el modelo de placa. Como te decía, casi son idénticas.
Y sobre la pantalla, tendrás que configurar el modelo concreto que tengas.
Sobre lo de no poder cargar Marlin, es posible que hayas perdido el bootloader, pero eso tiene solución. Realmente esa placa no está tan mal y es una pena desperdiciarla.
Citar
#5
Para cargarle el bootloader hay que hacerlo con una arduino y conectado unos cables? o hay otro sistema? de todas maneras la placa tiene la salida de la cama caliente rota la conectaba por la salida del exclusor 2 que no la usaba, pero ahora ni por ahi funcionaba, creo que seria cosa de configuración
Citar
#6
Me parece un poco raro que antes hayas cargado Marlin y ahora no tengas el bootloader bien. No es imposible, pero estás seguro de que la carga falla por eso? Que error te da?

Para cargar el bootloader el sistema es ese, no hay otro. Si que puedes usar un programador ISP compatible pero para usarlo una vez no merece la pena comprarlo, mejor otro Arduino y luego lo puedes usar para otro proyecto.
Citar
#7
(16-05-2019, 05:23 PM)Nullz escribió: Me parece un poco raro que antes hayas cargado Marlin y ahora no tengas el bootloader bien. No es imposible, pero estás seguro de que la carga falla por eso? Que error te da?

Para cargar el bootloader el sistema es ese, no hay otro. Si que puedes usar un programador ISP compatible pero para usarlo una vez no merece la pena comprarlo, mejor otro Arduino y luego lo puedes usar para otro proyecto.

Intento decirle que esta en el com 7 y solo me da opcion de com 3. Pero entro a la impresora con cualquier programa y si que me la reconoce. 
Este es el mensaje completo que me da:


Arduino:1.8.9 (Windows Store 1.8.21.0) (Windows 10), Tarjeta:"Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

El Sketch usa 110024 bytes (43%) del espacio de almacenamiento de programa. El máximo es 253952 bytes.
Las variables Globales usan 4136 bytes (50%) de la memoria dinámica, dejando 4056 bytes para las variables locales. El máximo es 8192 bytes.
avrdude: ser_open(): can't open device "\\.\COM3": Acceso denegado.


avrdude: ser_drain(): read error: Controlador no v�lido.


avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: Controlador no v�lido.


avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: Controlador no v�lido.


avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: Controlador no v�lido.


avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: Controlador no v�lido.


avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: Controlador no v�lido.


avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: Controlador no v�lido.


avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
el puerto seleccionado avrdude: stk500v2_getsync(): timeout communicating with programmer
 no existe o tu placa no esta conectada

Este informe podría contener más información con
"Mostrar salida detallada durante la compilación"
opción habilitada en Archivo -> Preferencias.
Citar
#8
Hola, comprueba en el Administrador de Dispositivos de Windows el puerto COM que tiene asignado realmente la impresora, pues el IDE de Arduino sólo muestra los puertos que están activos en ese momento.
Y cierra cualquier otra aplicación que pueda estar accediendo a ese puerto. Parece que el mensaje de acceso denegado al COM3 puede venir de ahí.
Los errores que estás teniendo no parecen indicar que hayas perdido el bootloader, sino que no se está comunicando correctamente con él.
Citar
#9
Lo raro es que cuando conecto el arduino mega me lo reconoce sin problema, en el mismo Puerto. Y la impresora la reconoce cualquier programa de los que uso
Citar
#10
Ya me parecía a mí... XD
Pues si que es raro, prueba a reinstalar ArduinoIDE por completo o actualizarlo sino tienes la última versión.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
Pregunta DUDA tengo una placa MKS V 2.4 y no se si trae el firmware Pedrodamian 1 185 17-04-2019, 05:41 AM
Último mensaje: Nullz
  Cama magnetica con placa pcb? poyccm 1 265 29-01-2019, 10:48 PM
Último mensaje: Triangulo
  ¿Me he cargado la placa de la impresora? Penitas 2 492 03-06-2018, 11:33 PM
Último mensaje: Penitas
  Configuracion mixta de drivers en la misma placa ? Dragons 0 419 03-06-2018, 06:05 PM
Último mensaje: Dragons
  Duda placa MKS-BASE V1.5 o v1.4 gen Mummra 1 1,139 31-03-2018, 11:16 PM
Último mensaje: dvera16