Calificación:
  • 1 voto(s) - 4 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema controladora GRBL
#1
Recientemente me ha llegado una cnc, concretamente el modelo 2632 y viene con la controladora que podeis ver en la imagen, como viene siendo habitual viene sin ningún manual ni referencia, y tampoco aparecen aclaraciones en la propia placa.
Hay dos cuestiones:
Alguien tiene referencia de esta placa para saber que uso tienen los conectores (me refiero a los pines negros que están en la parte superior).

pero el mayor problema que tengo es con el conector de alimentación (aparece en la parte inferior azul) indica que es para el motor, sin embargo mido y no llega voltaje alguno. al introducir el comando M3 tampoco le llega alimentación, lo cual me está haciendo pensar si no estará mal, pero antes de reclamar, me gustaría conocer vuestra opinión.

Gracias.
resim

Se me olvidada un detalle: si mido mido el positivo del conector azul, está conectado directamente al positivo de la alimentación, pero el negativo, no le veo continuidad con ningun punto de la placa, de ahí mi duda si ese polo negativo estará conectado a alguna parte de la circuitería a la cual no tengo acceso y permita su activación mediante el software de control.
Citar
#2
Pídele al vendedor la documentación y pon un enlace a la maquina a ver si alguien tiene la misma.

Saludos
Citar
#3
(07-02-2019, 06:07 PM)TonyTren escribió: Recientemente me ha llegado una cnc, concretamente el modelo 2632 y viene con la controladora que podeis ver en la imagen, como viene siendo habitual viene sin ningún manual ni referencia, y tampoco aparecen aclaraciones en la propia placa.
Hay dos cuestiones:
Alguien tiene referencia de esta placa para saber que uso tienen los conectores (me refiero a los pines negros que están en la parte superior).

pero el mayor problema que tengo es con el conector de alimentación (aparece en la parte inferior azul) indica que es para el motor, sin embargo mido y no llega voltaje alguno. al introducir el comando M3 tampoco le llega alimentación, lo cual me está haciendo pensar si no estará mal, pero antes de reclamar, me gustaría conocer vuestra opinión.

Gracias.
resim

Se me olvidada un detalle: si mido mido el positivo del conector azul, está conectado directamente al positivo de la alimentación, pero el negativo, no le veo continuidad con ningun punto de la placa, de ahí mi duda si ese polo negativo estará conectado a alguna parte de la circuitería a la cual no tengo acceso y permita su activación mediante el software de control.

Por lo que se aprecia en la foto, la salida la debe manejar el MOSFET que tiene al lado del conector azul, casi seguro que es PWM, es importante que le pongas los disipadores a los drivers y que verifiques si tiene bien el Firmware GRBL, porque sin el no va a funcionar, te dejo un link con más info. 

GRBL configuración

en el conector Negro va conectado el Display y los botones auxiliares, se vende por separado normalmente
y no es imprescindible. LCD y Botones

contanos luego como sigue...
Saludos cordiales
Fernando

Kaihatsu CNC
Bs.As. - Argentina
Citar
#4
La máquina, concretamente es esta: https://es.aliexpress.com/item/T-type-Sc...cfcc7cb7b1

No traia disipadores, por lo que de momento hasta tenerlos estoy usando un pequeño ventilador para disipar el posible calor.
Anteriormente he tenido otro modelo de cnc y usaba directamente arduino uno, por lo que esta he cargado la misma versión de grbl 1.1f. para seguir el mismo criterio. Lo que no me queda claro que significa que es PWM, tengo que activar algo? He probado con el comando M3 y no actua.
Hay alguna prueba que pueda realizar para verificar su funcionamiento?
Citar
#5
(07-02-2019, 07:16 PM)TonyTren escribió: La máquina, concretamente es esta: https://es.aliexpress.com/item/T-type-Sc...cfcc7cb7b1

No traia disipadores, por lo que de momento hasta tenerlos estoy usando un pequeño ventilador para disipar el posible calor.
Anteriormente he tenido otro modelo de cnc y usaba directamente arduino uno, por lo que esta he cargado la misma versión de grbl 1.1f. para seguir el mismo criterio. Lo que no me queda claro que significa que es PWM, tengo que activar algo? He probado con el comando M3 y no actua.
Hay alguna prueba que pueda realizar para verificar su funcionamiento?

perfecto, con el ventilador sobre los micros va a andar bien, te aseguro que calientan. Puede que haya alguna diferencia en los pines y tengas que modificarlos en el firmware, me trajeron una similar para reparar y estaban cambiados los de dirección y pulso y el seteo de los micropasos de los drivers. En cuanto al PWM es una variación de tensión por pulsos, sino prende el husillo proba de colocar en la linea del M3 S5000 ( donde S será la velocidad y por ende el Mosfet generará una tensión de salida distinta a 0V para que se mueva, si arranca el husillo podés ir probando variando ell valor de S para ver la diferencia. )
Saludos cordiales
Fernando

Kaihatsu CNC
Bs.As. - Argentina
Citar
#6
Sigo con las pruebas y he cambiado a la versión 0.9 de grbl pero el resultado es el mismo, por lo que he vuelto a instalar la 1.1
Con respecto a los botones, he verificado que el conector blanco superior (el único que está indicado) funciona perfectamente para hacer una parada de emergencia. El otro conectar justo debajo también blanco, le he colocado un pulsador, pero no actúa o al menos no se nota ningún efecto aparente.

Con respecto al motor, funciona perfectamente, si se alimenta exteriormente, es algo que no había comentado como dato importante.

(07-02-2019, 07:32 PM)Valvulin escribió:
(07-02-2019, 07:16 PM)TonyTren escribió: La máquina, concretamente es esta: https://es.aliexpress.com/item/T-type-Sc...cfcc7cb7b1

No traia disipadores, por lo que de momento hasta tenerlos estoy usando un pequeño ventilador para disipar el posible calor.
Anteriormente he tenido otro modelo de cnc y usaba directamente arduino uno, por lo que esta he cargado la misma versión de grbl 1.1f. para seguir el mismo criterio. Lo que no me queda claro que significa que es PWM, tengo que activar algo? He probado con el comando M3 y no actua.
Hay alguna prueba que pueda realizar para verificar su funcionamiento?

perfecto, con el ventilador sobre los micros va a andar bien, te aseguro que calientan. Puede que haya alguna diferencia en los pines y tengas que modificarlos en el firmware, me trajeron una similar para reparar y estaban cambiados los de dirección y pulso y el seteo de los micropasos de los drivers. En cuanto al PWM es una variación de tensión por pulsos, sino prende el husillo proba de colocar en la linea del M3 S5000 ( donde S será la velocidad y por ende el Mosfet generará una tensión de salida distinta a 0V para que se mueva, si arranca el husillo podés ir probando variando ell valor de S para ver la diferencia. )

Muchas gracias, efectivamente al añadir S al comando M3 comienza a girar. Supongo que esto me obliga a activar el motor de forma manual antes de iniciar cualquier trabajo.
Citar
#7
El grbl aparte de activar la salida para el motor o laser, le tienes que especificar un valor en el parametro Sxxx, si no, no se con que valor por defecto arranca.
Citar
#8
(Muchas gracias, efectivamente al añadir S al comando M3 comienza a girar. Supongo que esto me obliga a activar el motor de forma manual antes de iniciar cualquier trabajo.)

No es necesario activarlo manual, con que en el programa coloques el M3 Sxxxx (xxxx=Velocidad) y cuando termines de mecanizar colocá un M5 para detener el motor


resim
Saludos cordiales
Fernando

Kaihatsu CNC
Bs.As. - Argentina
Citar
#9
Mi interpretación de la programación era erronea, ya que como parámetro fijo le habia indicado que trabaja con una velocidad de 140000, suponiendo que con M3 ya tomaba ese valor, no es que suponga un problema activarlo de forma manual, pero desde luego es mucho mas èfectivo un par de líneas en el código directamente, especialmente para desactivarlo de forma automática al finalizar el proceso.

Ahora sigo investigando donde conectar la sonda, si es que esta controladora lo permite, así como la forma de gestionar el laser.
Gracias de nuevo Valvulin,
Citar
#10
El problema que tengo en estos momentos, es al intentar que funcione el laser de3,5W TTL, ya que este al conectarlo a la controladora no se activa; si alimento el láser externamente sin conectar a la controladora, este emite fuente de luz.

Lo primero que he realizado es el ajuste en los códigos grbl para activar el laser y ajustar la potencia:

        Activación laser               $32=1
        Potencia máxima laser     $30=255

El láser tiene dos conectores uno de alimentación a 12 voltios con un cable con clavija jack para una alimentación exterior y otro cable con un conector de dos hilos que procede de una conexión que indica ttl.
En el caso de la controladora (puede verse en la imagen superior) tiene dos conectores uno de alimentación (color rojo) y otro por encima (blanco) que indica pwm.

Las conexiones que he realizado ha sido conectar la alimentación del láser a su propia fuente de alimentación y la conexión ttl a pwm. 
La pregunta es si hay alguna forma de realizar esta conexión, o directamente láser y controladora no son compatibles?

Tenía pensado borrar esta entrada, pero creo que puede ser positivo para alguien que le ocurra lo mismo. Al final haciendo pruebas y escribiendo códigos he conseguido ponerlo en marcha, la solución ha sido la siguiente:

Escribir el siguiente código antes de comenzar:

    M3 S1000

no le encuentro mucha explicación, ya que todo lo que he leído hace referencia a que M3 activa el motor para fresar, tampoco entiendo ese valor 1000 ya que valores mas alto no actuan, por lo que si no escribo esto el láser no se ilumina.
Citar
#11
El firm grbl tiene internamente una relacion para el parametro Sxxx. Quizas tenga indicado como 1000 para su máximo (100%) y de ahi para abajo. Este parámetro, si mal no recuerdo, solo se puede cambiar en el código.
Citar
#12
Muchas gracias, he buscado información sobre como editar la configuración de código cargado en Arduino, no la he localizado, pero seguiré buscando.

Estoy intentando conectar la sonda en alguna conexion, por lo que mi caballo de batalla está en averiguar para que sirve la conexión que marco en un círculo, ya que el proveedor se ha limitado a enviar un archivo en chino con el proceso de montaje, con una controladora (sin indicaciones) que no coincide con la que han enviado.

resim
Citar
#13
He localizado una imagen de una controladora similar a la que tengo (está la diferencia del conmutador entremotor-laser), y según aparece en la inscripción en chino, la conexión que desconocía es PWM,
la cuestión ahora es como uso esa conexión, no es igual a la que aparece indicada como laser?

resim
Citar
#14
(20-02-2019, 04:15 PM)TonyTren escribió: He localizado una imagen de una controladora similar a la que tengo (está la diferencia del conmutador entremotor-laser), y según aparece en la inscripción en chino, la conexión que desconocía es  PWM,
la cuestión ahora es como uso esa conexión, no es igual a la que aparece indicada como laser?

resim

como estas ? el láser lo disparás con el M3 y la potencia se la das con el valor de S el Gcode no sabe si tenés un motor o un laser conectado a la placa, pero la función es la misma, tendrás que ir probando distintas Sxxxx para ver la potencia del Laser..
Saludos cordiales
Fernando

Kaihatsu CNC
Bs.As. - Argentina
Citar
#15
Gracias Valvulin, el laser lo controlo con la conexión correspondiente usando M3 y su correspondiente potencial, el problema está en no conocer para que sirve la conexión que indico.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Busco GRBL 0.9J Thulsa_Doom 8 170 02-04-2019, 07:05 AM
Último mensaje: PauFerlo
  CONSULTA Problema con protocolo GRBL - ARDUINO UNO en plotter de corte mariano3082 9 537 15-11-2018, 04:31 PM
Último mensaje: mariano3082
  Para un Cnc fresador y laser que es mejor ? Mks Sbase o grbl (arduino) diaconuliviu85 21 1,763 24-06-2018, 09:12 PM
Último mensaje: drow
  error grbl tazma 6 911 08-06-2018, 11:39 PM
Último mensaje: tazma
  Artículo sobre iniciación a GRBL staticboards 7 2,950 25-04-2018, 07:30 PM
Último mensaje: fontanares