Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con velocidad máxima en nema17 y parametros en UGCS
#1
Buenas!

Ante todo, soy totalmente nuevo en esto y estoy aprendiendo, recientemente me ha llegado una estructura laser que pedi en aliexpress, viene con Arduino NANO, unos nema17 de 04a y unos A4988, ya la he montado y la he configurado según el paso de mis correas y del rotor.

Le he metido el firmware GRBL 1.1f y todo correcto según el LaserGRBL (Software) y el Sketch Aarduino.

El primer problema y menos grave, es que en ambos softwares mencionados, me muestra la configuración del firmware, pero en el Universal Gcode Sender, me detecta la máquina y el firmware pero al darle a los comandos no me reconoce ninguno (Para ver los parametros), introduzco tanto el '$' como '$$' (Sin comillas) para ver la configuración o la ayuda y no me hace nada a pesar de que puedo mover manualmente la máquina desde el mismo. Icon_roto2
 ¿Alguna idea?

La otra duda que me trae más problemas es respecto a la velocidad de los ejes, según el manual del firmware 1.1f, la casilla 24 y 25 corresponden a la velocidad de movimiento tanto en carga como sin ella, la he configurado en 1000 en cada una pero solo veo más rapida el movimiento X pero el Y sigue lento (Tiene 2 motores, uno a cada lado) ¿Como hago para que me vaya a la misma velocidad el eje Y que el eje X?

Dejo configuración que tengo ahora mismo:

$0=10 (Step pulse time)
$1=25 (Step idle delay)
$2=0 (Step pulse invert)
$3=0 (Step direction invert)
$4=0 (Invert step enable pin)
$5=0 (Invert limit pins)
$6=0 (Invert probe pin)
$10=1 (Status report options)
$11=0.010 (Junction deviation)
$12=0.002 (Arc tolerance)
$13=0 (Report in inches)
$20=0 (Soft limits enable)
$21=0 (Hard limits enable)
$22=0 (Homing cycle enable)
$23=0 (Homing direction invert)
$24=1000.000 (Homing locate feed rate)
$25=1000.000 (Homing search seek rate)
$26=250 (Homing switch debounce delay)
$27=1.000 (Homing switch pull-off distance)
$30=1000 (Maximum spindle speed)
$31=0 (Minimum spindle speed)
$32=0 (Laser-mode enable)
$100=80.000 (X-axis travel resolution)
$101=80.000 (Y-axis travel resolution)
$102=1500.000 (Z-axis travel resolution)
$110=1500.000 (X-axis maximum rate)
$111=500.000 (Y-axis maximum rate)
$112=500.000 (Z-axis maximum rate)
$120=10.000 (X-axis acceleration)
$121=10.000 (Y-axis acceleration)
$122=10.000 (Z-axis acceleration)
$130=200.000 (X-axis maximum travel)
$131=200.000 (Y-axis maximum travel)
$132=200.000 (Z-axis maximum travel)
Citar
#2
Ni tengo láser, ni he usado nunca grbl. Pero homing suele ser el movimiento de buscar los 0s de cada eje que se hace al principio.

Si te fijas $110 y $111, tienes valores diferentes en la velocidad máxima y coincide con lo que te pasa.
Citar
#3
Pues si, efectivamente era ese parámetro Sonrisa

Respecto a lo del Universal Gcode, saben porque no me detecta la configuración en ese software cuando le doy comandos?
Citar
#4
Hola,

¿el problema con el Gcode sender es que no te cambia los parámetros?

Saludos.
Citar
#5
Hola!

No, directamente no me los muestra aunque puedo mover la maquina sin problemas desde el mismo software pero al querer eejcuter los parámetros de configuración del grbl, introduzco el $$ y no muestra nada.

Me estoy planteando bajar la versión del firmware de 1.1 a 0.9, empiezo a sospechar que no está bien fino
Citar
#6
Puedes probar con el ide de arduino a ver si te los muestra a través del monitor serial.

Saludos.
Citar
#7
(13-03-2019, 06:48 PM)drow escribió: Puedes probar con el ide de arduino a ver si te los muestra a través del monitor serial.

Saludos.

Si, ahí si me los muestra pero en el UGCS no hay manera Icon_roto2
Citar
#8
Nunca he usado el ugs, pero es posible que el programa filtre esos comandos y no los envié al Arduino y por eso no tiene respuesta

Enviado desde mi MI 6 mediante Tapatalk
Citar
#9
Hay dos versiones de UGS, la versión clásica y la Plataforma, en la segunda al principio yo tampoco veía los códigos, para poder visualizarlos tiene que estar activada la pestaña consola. Tal vez esté ahí el problema.
Citar
#10
(15-03-2019, 09:34 AM)TonyTren escribió: Hay dos versiones de UGS, la versión clásica y la Plataforma, en la segunda al principio yo tampoco veía los códigos, para poder visualizarlos tiene que estar activada la pestaña consola. Tal vez esté ahí el problema.

Vale. ahora instalé la versión 2 el UGS, y aquí si me lee los parametros y funciona el movimiento manual Sonrisa

Lo que al enviar un gcode, me saleun error que dice "Faltan comandos de movimiento G92" y no me funciona, ¿A que se debe?

Dejo captura
resim
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Laser nuevo y varias dudas con el encendido y velocidad de grabado Forsito 21 313 19-03-2019, 11:53 PM
Último mensaje: Forsito
Video 280w co2 que velocidad necesito para cortar 3mm de carbon steel giov83 6 792 18-06-2018, 10:08 PM
Último mensaje: gale9010