Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con tft mks32 v3.0
#1
Buenos días.

Voy a exponer mi problema. Tengo una Anet a8 comprada hace unos 4 meses, y ya no se parece en nada a lo que era cuando la monté. Le he echo las mil y una reformas. Además, le he puesto una Ramps 1.4 + Mega. La cuestión es que, aún escuchando que no era compatible con ramps, me he comprado una pantalla TFT Mks32, la versión 3.0. La conecto con el cable que viene y me enciende, la puedo actualizar y moverme por los menús, pero a la hora de querer mover algún motor o ver temperaturas, parece que no tiene conexión con la impresora. 

Después de leer mucho, le puse un módulo L7805 para darle alimentación de 5v por los pines Vcc y Gnd donde se conecta el módulo de wifi, y el problema persiste, no puedo mover motores. Incluso he intentado ponerle una versión de software mas antigua para ver si el problema venia por ahí. 
Le he puesto el mismo baudrate que tengo en el Marlin, 115500 (o algo así, no recuerdo exactamente los números).

También decir que con la pantalla que compré con la Ramps, me funciona perfectamente. Es la  REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER. Tal vez tenga que cambiarla en el Marlin.



Estoy desesperado con este tema, porque la pantalla me gusta mucho. Agradecería vuestra experta ayuda y así de esta manera también aportar algo de luz en el foro a este tema.

Saludos y gracias de antemano.
Citar
#2
Supongo que ya lo habrás solucionado, pero sólo quería comentarte que no necesitas modificar marlin para usar el tft.
Puedes usar las dos a la vez (si tienes una placa tipo mks gen que tiene puertos para la reprap separada).
Citar