Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con partición d SD
#1
Pregunta 
Buenas a tod@s:

Llevo todo el fin de semana peleándome con la SD de la raspberry. Esta tiene dos particiones, una que ocupa casi la totalidad de la capacidad de la SD y otra residual.

Formatée la partición grande en formato FAT32 y puse que el formateo fuese lento. Desde entonces no he podido recuperar dicha partición.

He probado con el programa Gparted, sin embargo dice que la SD es solo de lectura y por l tanto no me deja realizar los cambios.

También he probado de hacerlo en modo root y tampoco.

Alguna sugerencia?

Muchas gracias de antemano.


Y disculpad que últimamente frecuente tanto el foro con preguntas que posiblemente sean chorras. Pero he buscado por internet, he probado cosas y ninguna sin éxito.
Citar
#2
Para poder formatear la partición, tienes que "desmontarla" (unmount) primero.
Para poder usar la partición (acceder al contenido) tienes que "montarla" (mount), esto lo hará automáticamente al conectar la SD (posiblemente).

Para desmontarla (o montarla, pero en gparted no hace falta montar nada) seleccionas la partición > partition (menu de arriba) > unmount

En windows te sonará lo de "quitar el dispositivo con seguridad", pues eso hace un sync+unmount para que se desconecte de manera "segura" (es decir, que no haya ningún programa accediendo a los datos y se queden corruptos)
Citar
#3
Buenas a tod@s:

He probado lo que me comentas y no me sale habilitada esta opción.

Cuando abro el programa gparted por terminal ya que requiere permisos de root, al abrirlo me sale este mensaje:


"No se ha podido abrir /dev/sdb lectura/escritura (El sistema de ficheros es solo de lectura). /dev/sdb se ha abierto solo de lectura."

Como puedo habilitar la opción que me comentas o hacer que también se abra de modo que me permita escribir?


Muchas gracias de nuevo y te agradezco tu rapidez en responder Sonrisa
Citar
#4
Entonces prueba con dmesg, en la consola pon "dmesg", a ver si sale algo de "invalid access to FAT" o algo así

En caso de que así sea, probamos con lo siguiente

Código:
sudo apt-get install dosfstools
sudo umount /dev/sdb1
sudo dosfsck -t -a -w /dev/sdb1

dosfstools instalará el dosfsck que necesitamos
umount "desmonta" el disco para poder trabajar en el
dosfsck hace un chequeo del sistema de archivos
-t: chequea clusters defectuosos.
-a: repara automáticamente el sistema de archivos.
-w: escribe los cambios inmediatamente.
Citar
#5
(28-03-2016, 12:25 PM)ICEM4N escribió: Entonces prueba con dmesg, en la consola pon "dmesg", a ver si sale algo de "invalid access to FAT" o algo así

En caso de que así sea, probamos con lo siguiente

Código:
sudo apt-get install dosfstools
sudo umount /dev/sdb1
sudo dosfsck -t -a -w /dev/sdb1

dosfstools instalará el dosfsck que necesitamos
umount "desmonta" el disco para poder trabajar en el
dosfsck hace un chequeo del sistema de archivos
   -t: chequea clusters defectuosos.
   -a: repara automáticamente el sistema de archivos.
   -w: escribe los cambios inmediatamente.



Buenas a tod@s:

Gracias por tu gran aportación sin embargo cuando lo hago con el sdb2 que es la partición que tengo "jodida" (la sdb1 es la pequeña que está ok) me pone el siguiente mensaje:

open: el sistema de ficheros es solo de lectura

Mañana a ver si puedo arreglarlo con el Windows del trabajo.


Muchas gracias.

Mañana te informo si lo consigo Sonrisa
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Partición Linux Electromecánico 7 1,270 26-04-2015, 10:27 AM
Último mensaje: Lord Bergidum