Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con los Nema 17
#1
Saludos al foro:

Estoy reconstruyendo la prusa después de que se quemara generando un pequeño fuego que destruyo buena parte de la electrónica.
Ahora que he conectado la nueva electrónica, me encuentro con los dos primeros problemas. uno es que la antigua placa era una OVM 2.0, y va configurada con DRV8825, y ahora sólo conseguí en la isla los pololus a4988, así que tendré que aprender a modificar el hex cargado porque los motores que funcionan caminan más de lo debido  Nusenuse

Pero la primera cosa que tengo que solucionar y no sé porqué pasa es lo siguiente: sólo sustituí 2 Nema 17 que por el fuego quedaron inservibles. Los motores que tenía bien no los cambié, pero no funcionan. Son también Nema 17, aunque de otra marca y eso no debería influir. Los conecto a la Ramps y hacen como si les faltara potencia, como si saltaran pasos.
De hecho puedo moverlos girando el eje aun conectados.

Primera pregunta de novato ¿Se pueden mezclar motores de 3.2kg con otros de 4.8kg? Ambos son Nema, peor cambia esta especificación
¿Puede ser simplemente que al tener más potencia los Pololu a4988 no son capaces de moverlos?
Los que no consigo mover tienen estas especificaciones:
Especificaciones:

  • Torque: 4,8 kg / cm 47,1 N-cm 67 OZ-IN

  • Tensión alimentación: 3.1V

  • Diámetro del eje: 5mm

  • Eje plano para un mejor agarre de las poleas.

  • Paso: 1,8 grados

  • Diámetro del eje: 5mm

  • Corriente máxima: 2.5A

  • Peso: 332g

  • Nº. de cables: 4 (100 cm)

  • Cable con conector crimpado.

  • Motor bipolar
Prusa Steel MK2 - Electrónica OVM20 con drivers DRV8825  (muerta en acto de servicio) - Hotend E3D Lite V6 - de nuevo, electrónica OVM20 lite con drivers DRV8825
Citar
#2
Hola los motores da igual que sean iguales o diferentes no importa y esos motores que pones deberian funcionar.
Pero al cambiar los drivers tendras que ajustar la corriente de los nuevos drivers a los motores (desde el potenciometro del driver)
De todos modos que no se quemaran nada garantiza que los motores esten bien lo primero que yo haria es ver que los dos bobinados de los motores dan continuidad y que no estan en corto entre ellos antes de nada.
Citar
#3
Hola, el problema del movimiento con los A4988 respecto a los DRV8825, es debido a que estos van configurados a 32 micropasos por paso y los A4988 solo llegan a 16, por lo que tienes que cambiar los micropasos por milímetro a la mitad de los que tenías configurados para la OVM20. Es muy posible que no necesites cargar de nuevo el firmware, ya que se suele poder cambiar ese parámetro por pantalla o mediante comandos gcode.
Sobre los motores que has recuperado del siniestro, lo más probable es que los rotores de los mismos hayan perdido la mayor parte del magnetismo, debido al calor al que estuvieron expuestos. Seguramente no sirvan ya.
Citar
#4
Aportando mi granito de arena, has de saber que el .hex es un fichero compilado... estos ficheros no puedes modificarlos generalmente ya que es el resultado de la compilación del codigo fuente. Si tienes que reconfigurar los pasos necesitaras el codigo original (marlin o lo que uses) de tu impresora 3D.

Por otra parte ten en cuenta que si no estas instalando la misma placa los pines de la ovm y esa nueva placa no tienen por que coincidir, con lo que puede ser el caso de que estes mandando moverse un motor pero su driver no estw recibiendo nada ni habilitandose.
Citar
#5
He comprobado los motores según he visto por internet, y parecen estar bien.
También busqué información de los A4988 y encontré la guia de @Staticsboads, muy completa. Ahí veo que los A4988 soportan 1A, con picos de 2A ¿No puede ser que siendo los motores que fallan de 2.5A no estén recibiendo corriente suficiente? Precisamente la impresión que dan es como cuando usé la impresora por primera vez y alguno de los ejes no caminaba porque se saltaban pasos.  Icon_question
Lo de los pasos lo ví ayer mismo después de escribir el post. Pero pensé que podría cargar el hex en algún programa y modificar sólo ese punto. El que uso es el que venía con la impresora ya compilado. Veo que tendré que buscar y ajustar Marlin completo. Aprovecharé en lo que llegan los DRV8825 para estudiarlo y modificarlo.

Gracias a todos por las respuestas.
Prusa Steel MK2 - Electrónica OVM20 con drivers DRV8825  (muerta en acto de servicio) - Hotend E3D Lite V6 - de nuevo, electrónica OVM20 lite con drivers DRV8825
Citar
#6
He encontrado otra guía sobre los motores, y ahora sé que los Nema 17 sólo tienen como norma la medida (1.7 pulgadas). A partir de ahí, aunque coinciden generalmente en muchas cosas, pueden variar en asuntos como el voltaje necesario y potencia. Va a ser por ahí por donde tengo los problemas.

De momento he pedido en la web de Staticsboards los DRV8825 para cambiarlos y volver a tener una resolución de 32 pasos. Si una vez puestos no se soluciona, cambiaré los motores por otros que ya tengo por aquí, aunque no tienen la misma calidad.

De nuevo, gracias a foro por la ayuda.  Clap
Prusa Steel MK2 - Electrónica OVM20 con drivers DRV8825  (muerta en acto de servicio) - Hotend E3D Lite V6 - de nuevo, electrónica OVM20 lite con drivers DRV8825
Citar
#7
(24-01-2019, 02:33 PM)Smitter escribió: He encontrado otra guía sobre los motores, y ahora sé que los Nema 17 sólo tienen como norma la medida (1.7 pulgadas). A partir de ahí, aunque coinciden generalmente en muchas cosas, pueden variar en asuntos como el voltaje necesario y potencia. Va a ser por ahí por donde tengo los problemas.

De momento he pedido en la web de Staticsboards los DRV8825 para cambiarlos y volver a tener una resolución de 32 pasos. Si una vez puestos no se soluciona, cambiaré los motores por otros que ya tengo por aquí, aunque no tienen la misma calidad.

De nuevo, gracias a foro por la ayuda.  Clap


Lo de los pasos te va afectar cuando trates de imprimir que si en el software le tienes puesto x 32 y en realidad son de 16 pues te va a recorrer la mitad. Pero eso nada tiene que ver con que los motores funcionen. Luego aunque el driver solo de 1A y el motor sea de 2.5 no importa puesto que esta conectado a mas voltaje normalmente con entre 400 800mA deberia moverse.
Si has comprobado que las bobinas estan bien, lo tienes bien conectado, el driver esta bien y ajustaste la corriente y aun asi no se muve pues probablemente se hayan estropeado en el incendio.

(24-01-2019, 02:33 PM)Smitter escribió: He encontrado otra guía sobre los motores, y ahora sé que los Nema 17 sólo tienen como norma la medida (1.7 pulgadas). A partir de ahí, aunque coinciden generalmente en muchas cosas, pueden variar en asuntos como el voltaje necesario y potencia. Va a ser por ahí por donde tengo los problemas.

De momento he pedido en la web de Staticsboards los DRV8825 para cambiarlos y volver a tener una resolución de 32 pasos. Si una vez puestos no se soluciona, cambiaré los motores por otros que ya tengo por aquí, aunque no tienen la misma calidad.

De nuevo, gracias a foro por la ayuda.  Clap


Lo de los pasos te va afectar cuando trates de imprimir que si en el software le tienes puesto x 32 y en realidad son de 16 pues te va a recorrer la mitad. Pero eso nada tiene que ver con que los motores funcionen. Luego aunque el driver solo de 1A y el motor sea de 2.5 no importa puesto que esta conectado a mas voltaje normalmente con entre 400 800mA deberia moverse.
Si has comprobado que las bobinas estan bien, lo tienes bien conectado, el driver esta bien y ajustaste la corriente y aun asi no se muve pues probablemente se hayan estropeado en el incendio.
Citar
#8
OK. Pues toca cambiar esos motores.

Muchas gracias a todos  Clap
Prusa Steel MK2 - Electrónica OVM20 con drivers DRV8825  (muerta en acto de servicio) - Hotend E3D Lite V6 - de nuevo, electrónica OVM20 lite con drivers DRV8825
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  (SOLUCIONADO) conexion nema 17 en serie y paralelo Jmaster03 12 1,646 21-08-2018, 10:41 AM
Último mensaje: Comediaan
  Conector Motor Nema 17 Jomagom 3 1,973 06-01-2015, 02:15 AM
Último mensaje: Miquel
  Nema 17 para Prusa Steel 1.7a o 2.5a fondero 2 966 27-10-2014, 10:09 PM
Último mensaje: grafisoft
  Problema con ramps 1.4 y motores nema 17 Enrique 6 2,498 16-04-2014, 12:50 PM
Último mensaje: kilimanjarto
  Tipos de motores nema 17 y calibración de pololu Motilla 3 2,701 06-02-2014, 12:33 AM
Último mensaje: Motilla