Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con la temperatura del Hotend
#1
Hola, soy nuevo por aquí, hace poco que compré mi primera impresora 3D. Compré una Tronxy x5sa, basándome en un vídeo de Youtube en el que, tras unas modificaciones, la impresora daba unos resultados muy buenos.

El caso es, que después de invertir un tiempo y material en imprimir algunas de las piezas que se supone son necesarias para mejorar la propia impresora, esta dejo de funcionar como debería, haciendo desplazamientos diagonales de la zona de impresión con cada capa que subía.

Cuando esto empezó a pasarme, decidí desmontar la impresora y empezar a instalarle las mejoras que había comprado mirando el dicho vídeo de Youtube. Todo correcto excepto una cosa, desde que instalé el clón del E3D V6, la interfaz de la impresora siempre marca la misma temperatura, 286º, incluso recién encendida. He leído por ahí, que hay que ponerle unas lineas de código, algo tipo #define y un numero, que entiendo que es el valor de la resistencia. El caso es, que desconozco como integrar ese código en el firmware de la impresora, a ver si alguien pudiera echarme una mano porque no encuentro nadie que le haya pasado lo mismo por ningún lado.

Un saludo y gracias de antemano.
Citar
#2
Hola @Saigamle, bienvenido al foro.
El problema de temperatura que tienes es bastante común (recientemente he contestado a una pregunta similar a la tuya) y se debe a una lectura erronea de la resistencia del termistor que va en el cubo calentador.
Las causas pueden ser varias: el termistor puede estár defectuoso, bien el mismo o el cable, cosa que puedes comprobar conectándolo en lugar del de la cama.
Si la cama pasa a indicar los mismos 286º es que está mal el termistor o que está cortada la funda aislante del cable donde la aprisiona el tornillo de sujección, con lo que se comunican los dos cables dando por tanto una resistencia mínima que se traduce en una alta temperatura irreal.
Si el termistor está bien, entonces el problema está en el circuito que lo controla en la placa.
Si desconectando el termistor sigue marcando la misma temperatura o aproximada, alguno de los componentes que lleva el circuito de la placa estará defectuoso.
Citar
#3
El definir el tipo de termistor es unicamente necesario si cambias el firmware o el tipo de termistor. Si solo has implementado mejoras mecanicas basicas y no has tocado el codigo probablemente tengas algo mal en el circuito o termistor como te indica Simemart.

Si has cambiado el extrusor recuerda hacerle un pid autotune para no tener problemas en el calentamiento luego. Hay un post de un compañero en este foro que explica como hacerlo. Por ultimo si la impresora te empezo a hacer movimientos raros mas que tema de hardware o software suele ser que la tarjeta SD esta cascada o bien tienes interferencias por usb.

Si imprimias por sd, compra una buena y dejaras de tener ese problema. Si imprimias por usb busca un cable usb mas corto y alejalo de cableado electrico o aparatos como moviles, altavoces, etc.
Citar
#4
(12-12-2018, 11:35 PM)Simemart escribió: Hola @Saigamle, bienvenido al foro.
El problema de temperatura que tienes es bastante común (recientemente he contestado a una pregunta similar a la tuya) y se debe a una lectura erronea de la resistencia del termistor que va en el cubo calentador.
Las causas pueden ser varias: el termistor puede estár defectuoso, bien el mismo o el cable, cosa que puedes comprobar conectándolo en lugar del de la cama.
Si la cama pasa a indicar los mismos 286º es que está mal el termistor o que está cortada la funda aislante del cable donde la aprisiona el tornillo de sujección, con lo que se comunican los dos cables dando por tanto una resistencia mínima que se traduce en una alta temperatura irreal.
Si el termistor está bien, entonces el problema está en el circuito que lo controla en la placa.
Si desconectando el termistor sigue marcando la misma temperatura o aproximada, alguno de los componentes que lleva el circuito de la placa estará defectuoso.

Hola, tengo el mismo problema, cuando desconecto el termistor de la cama caliente sigue marcando la misma temperatura, pero al invertirlos y conectar el termistor de la cama caliente en el del hotend funciona, el problema es de la placa?? tengo que cambiar todo?
Citar
#5
Hola, pues los síntomas que indicas son de un problema en la placa.
Hay dos posibles soluciones: repararla si es factible o cambiarla por otra.
Para repararla, primero hay que identificar los componentes que van en el circuito de control del termistor de la cama, normalmente una resistencia y un condensador.
Primero tendrás que decir de qué placa estamos hablando para comprobar si hay esquemas.
En todo caso, hay que tener un soldador apropiado (punta muy fina) y algo de soltura con él, pues los componentes SMD son muy pequeños.
Citar
#6
(24-04-2019, 06:45 PM)Simemart escribió: Hola, pues los síntomas que indicas son de un problema en la placa.
Hay dos posibles soluciones: repararla si es factible o cambiarla por otra.
Para repararla, primero hay que identificar los componentes que van en el circuito de control del termistor de la cama, normalmente una resistencia y un condensador.
Primero tendrás que decir de qué placa estamos hablando para comprobar si hay esquemas.
En todo caso, hay que tener un soldador apropiado (punta muy fina) y algo de soltura con él, pues los componentes SMD son muy pequeños.

Bueno te cuento: tengo una "copia china" de una prusa i3.. Anet A8. Intenté buscar para reemplazarla directamente pero no se consigue la placa que tenga el mismo firmware que la anet a8, si no que trae el firmware de la anet a6 y yo tendría que ponerle el firmware de la anet a8, pero no me doy mucha idea con la programación y no quiero comprarla y que no funcione (ya compre termistor y cama calientes nuevos y bueno.. no funcionaron...) .
Por lo de
resim

 repararla , la placa es igual a esta https://www.mastoner.com/impresoras-3d/e...da-anet-3d.
Citar
#7
Hola, con respecto al firmware, lo mejor que puedes hacer es instalar Marlin en su versión 1.1.9-bugfix.
Y respecto a reparar esa placa, en esta respuesta puedes ver los componentes implicados.
Citar
#8
(25-04-2019, 07:18 PM)Simemart escribió: Hola, con respecto al firmware, lo mejor que puedes hacer es instalar Marlin en su versión 1.1.9-bugfix.
Y respecto a reparar esa placa, en esta respuesta puedes ver los componentes implicados.

Muchas gracias simemart! es de mucha ayuda!
Para instalar ese firmware tienes algún tutorial recomendado o simplemente alguno de YouTube tal vez?
Con respecto a los componentes, es una resistencia y un capacitor verdad? donde esta indicado la capacitancia y la resistencia de los mismos??

(25-04-2019, 07:29 PM)ojedamarina escribió:
(25-04-2019, 07:18 PM)Simemart escribió: Hola, con respecto al firmware, lo mejor que puedes hacer es instalar Marlin en su versión 1.1.9-bugfix.
Y respecto a reparar esa placa, en esta respuesta puedes ver los componentes implicados.

Muchas gracias simemart! es de mucha ayuda!
Para instalar ese firmware tienes algún tutorial recomendado o simplemente alguno de YouTube tal vez?
Con respecto a los componentes, es una resistencia y un capacitor verdad? donde esta indicado la capacitancia y la resistencia de los mismos??

Corrijo mi duda, por ahi no se entiende. 
En la respuesta dicen las medidas de los mismos , pero llego a ver que la resistencia dice 472, solo sirven del tipo smd 472?
Citar
#9
Cita:Bueno te cuento: tengo una "copia china" de una prusa i3.. Anet A8. Intenté buscar para reemplazarla directamente pero no se consigue la placa que tenga el mismo firmware que la anet a8, si no que trae el firmware de la anet a6 y yo tendría que ponerle el firmware de la anet a8, pero no me doy mucha idea con la programación y no quiero comprarla y que no funcione (ya compre termistor y cama calientes nuevos y bueno.. no funcionaron...) .
Por lo de
resim

repararla , la placa es igual a esta https://www.mastoner.com/impresoras-3d/e...da-anet-3d.
Pues yo si que encuentro placas para la a8, al menos eso pone. En el mismo link que has puesto tú, puedes comprar las versión para A6 o A8, y me imagino que la placa será la misma así que cambiará el firmware.


Hay un tutorial de autolevel en la sección de anet donde explica como instalarlo, aún que también te vale.cualquier vídeo del Youtube.


Te vale cualquier resistencia, no hace falta que sea smd, si eres capaz de soldarla. Busca de 470 o 475 ohm, sí tienes que alejarte más de ese valor mejor que sea hacia arriba por si acaso.
Citar
#10
En la respuesta que te indicaba pongo los valores de los componentes.
El código 472 quiere decir 4700 Ohms.
Citar
#11
Ya me parecía algo raro una resistencia de 472ohm, pensaba que mirabais el esquema, no la resistencia. Gracias.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Modificar la lectura de temperatura en display PEKY 0 492 13-04-2018, 09:03 PM
Último mensaje: PEKY
  Retirar hotend al pausar la impresión. jekerrortu 3 1,162 13-03-2017, 10:55 PM
Último mensaje: sacamantecas
  Hotend golpea la pieza omarlopez 6 3,203 04-04-2016, 10:50 AM
Último mensaje: nitrosito
  Problema con Marlin (creo) ,GCODE M80 y temperatura jgauchia 1 1,018 26-08-2015, 12:33 AM
Último mensaje: jgauchia
  Error en de temperatura en Marlin con dual extrusora Tallara 5 1,638 20-07-2014, 07:02 PM
Último mensaje: Tallara