Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con finales de carrera en ramps 1.4 (SOLUCIONADO)
#1
Buenas noches de nuevo.

Vereis, necesito que alguien me ayude pq de tanto hacer pruebas ya no se que es lo que he probado y lo que no.

He cambiado la sanguino de una de las prusa por una ramp + arduino para poder incorporar un segundo jhead, un lcd y el servo de nivelar la cama.

Todo iba a las mil marabillas pero me encuentro con un problema con los finales de carrera, al mover los motores manualmente me giran perfectamente hacia la posicion + pero si quiero que vaya hasta los finales de carrera no hace ni caso, hace el amago del ruido pero no va. No puedo hacer el homming pq la única manera de que me retroceda hasta la posicion de los finales de carrera es teniendolos pulsados, he cambiado la posicion de los conectores n la ramp pero si lo hago cuando pulso los mismos la impresora se desconecta y si los vuelvo a soltar se conecta de nuevo.

He de decir que la ramp que he comprado tiene mas conectores en la zona de los endstop que el esquema que hay por el foro, la mia tiene 6 filas de 3 conectores y una mas de 4 conectores y a lo mejor los he conectado mal. Tengo el eje X al primero, el Y al tercero y el Z al quinto pero deben estar mal o en su defecto se me ocurre que debería cambiar las lineas del config en el marlin que controlan los finales de carrera a TRUE.

A alguien le suena de que pueda ser???

Un saludo
Citar
#2
estan bien situados, prueba a darle la vuelta a los cables, por qe por lo que dices tiene pinta de que los tienes mal pinchados en la ramps
Citar
#3
Gracias por responder Coricoco, si les doy la vuelta cuando los pulso la impresora se desconecta y cuando los suelto vuelve a conectar, lo que me extraña es que estan tal y como los tenia en la sanguino y nunca tuve problemas
Citar
#4
Que cosa mas rara, haber si alguien tiene idea de lo que puede ser, si puedes pon una foto de las ramps tal y como tienes todo enchufado ahora
Citar
#5
Cuando pulsas homing, que pone en la consola del repetier? Si dice algo asi como que se esta deteniendo xk golpea el final de carrera, entonces es que los tienes mal conectados y para darles la vuela o los conectas bien o cambias el true a false que dices.
Citar
#6
otra opción.

que versión de marlín le as subido?

te lo digo porque a mi al actualizarlo el ultimo tiene algunas velocidades muy altas configuradas para el homming G28 y los motores no giraban, las baja un poco y solucionado.

saludos
Citar
#7
OverCraft escribió:Cuando pulsas homing, que pone en la consola del repetier? Si dice algo asi como que se esta deteniendo xk golpea el final de carrera, entonces es que los tienes mal conectados y para darles la vuela o los conectas bien o cambias el true a false que dices.

Cuando pulso homing no pone nada en el repetier, lo unico que hace es un ruido los motores en como reciben la señal pero no se mueven, Ademas otra cosa que me extraña es que desde que le doy corriente a la ramp hasta que me permite hacer movimientos manualmente pasa un minuto o asi, con la sanguino era instantaneo.

La posicion en la que tengo los finales de carrera es correcta???? el x al 1º, el Y al 3º y el Z al 5º????

Saludos
Citar
#8
teammariano escribió:otra opción.

que versión de marlín le as subido?

te lo digo porque a mi al actualizarlo el ultimo tiene algunas velocidades muy altas configuradas para el homming G28 y los motores no giraban, las baja un poco y solucionado.

saludos

La version del Marlin es la V1, Tal y como la subio Overcraft en un post, lo unico que he cambiado es la controladora 62 por la 33.

Saludos
Citar
#9
Teóricamente están donde tiene que estar, y si les diste la vuelta y te hace cosas raras, sera algo del marlin seguro. Pon una foto de tus ramps
Citar
#10
Tu RAMPS no será por casualidad una roja, ¿verdad?

Es que tengo una pedida en Aliexpress que hace exactamente lo mismo. Al final puse un sanguinololu y la aparté, pero me gustaría rescatarla.
Citar
#11
Pongo el post como solucionado.

Al final he optado con volver a cargar el marlin y lo he configurado segun mi prusa.

Gracias por vuestra ayuda.


PD: Sifou, la ramps que yo he comprado no es la roja, es verde, la he comprado en china a traves de ebay.

Un saludo
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Consulta TMC2208 y Ramps elaspi 9 276 22-11-2018, 01:58 PM
Último mensaje: Shellmer
  CONSULTA ventajas ramps 1.4 1.6 davlinares 1 149 08-11-2018, 09:18 PM
Último mensaje: Simemart
  Conectar TFT tactil a ramps Jaimelito 22 6,041 26-08-2018, 03:52 PM
Último mensaje: Leo
  (SOLUCIONADO) conexion nema 17 en serie y paralelo Jmaster03 12 751 21-08-2018, 10:41 AM
Último mensaje: Comediaan
  CONSULTA Ramps 1.4 hace el home al revés mocman 4 319 18-08-2018, 06:56 PM
Último mensaje: mocman