Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con STL NesPi
#1
Buenas a todos, estoy teniendo un problema con la impresión de una pieza de una carcasa para hacer una Nes con Raspberry Pi 3 B, os dejo el link del modelo:

http://www.thingiverse.com/thing:1887826

En concreto el STL que me falla es el top_light_gray_upside_down_pi.stl

Os explico, en principio, la carcasa superior y la inferior deben encajar perfectamente, y en el modelo 3d encaja perfectamente, esta bien diseñado. El problema viene cuando paso ese stl a gcode con cura, y al imprimirlo en mi anet a8, las dimensiones se distorsionan.

En principio pense que era fallo de la printer, pero luego vi que el resto de piezas me las saca perfectamente dimensionadas, incluso con las mismas opciones de configuración en cura. 

¿Alguno tiene idea de que puede estar fallando?

resim

resim

resim

fb image upload
Citar
#2
Para salir de dudas yo imprimiría el típico cubo de calibración, un cubo de 2cm de lado. Una vez impreso confirma que midas el lado que midas tienes 2cm.
Citar
#3
(14-02-2017, 01:43 PM)hectorri escribió: Para salir de dudas yo imprimiría el típico cubo de calibración, un cubo de 2cm de lado. Una vez impreso confirma que midas el lado que midas tienes 2cm.

He impreso ahora un cubo y sí, el problema estaba aquí, el eje Y tiene 2.2mm, alguno sabe como solucionar esto en la ANET A8? Soy algo novato en el tema y esto nunca me había pasado.
Citar
#4
(14-02-2017, 03:51 PM)javicasas16 escribió:
(14-02-2017, 01:43 PM)hectorri escribió: Para salir de dudas yo imprimiría el típico cubo de calibración, un cubo de 2cm de lado. Una vez impreso confirma que midas el lado que midas tienes 2cm.

He impreso ahora un cubo y sí, el problema estaba aquí, el eje Y tiene 2.2mm, alguno sabe como solucionar esto en la ANET A8? Soy algo novato en el tema y esto nunca me había pasado.

digamos que tienes en la línea de los pasos (skynet) 100,100,400 (son el eje x,y,z)
pues haces una regla de 3_:
sin con 100 pasos en el eje ,  tienes 2.2,
para tener 2 valdría "Y"

sustituyes el valor de Y por el nuevo y actualizas
Citar
#5
(14-02-2017, 08:35 PM)neoxM3 escribió:
(14-02-2017, 03:51 PM)javicasas16 escribió:
(14-02-2017, 01:43 PM)hectorri escribió: Para salir de dudas yo imprimiría el típico cubo de calibración, un cubo de 2cm de lado. Una vez impreso confirma que midas el lado que midas tienes 2cm.

He impreso ahora un cubo y sí, el problema estaba aquí, el eje Y tiene 2.2mm, alguno sabe como solucionar esto en la ANET A8? Soy algo novato en el tema y esto nunca me había pasado.

digamos que tienes en la línea de los pasos (skynet) 100,100,400 (son el eje x,y,z)
pues haces una regla de 3_:
sin con 100 pasos en el eje ,  tienes 2.2,
para tener 2 valdría "Y"

sustituyes el valor de Y por el nuevo y actualizas

Tiene el firmware original pero lo sustituiré por skynet supongo. Muchas gracias.
Citar
#6
Al final conseguí cambiar los valores de los pasos en el firmware original con Pronterface. Se puede cerrar el hilo, muchas gracias!
Citar