Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema con OctoPrint
#1
Buenas, hace unos meses monté una impresora 3D, al poco tiempo de montarla le añadí una Raspberry Pi con octopi para poder controlarla de forma remota. Después de 1 mes utilizando OctoPrint e imprimiendo bastante y todo de forma correcta, hoy, de la noche a la mañana, la impresora se pausa aleatoriamente durante unos 40s cada cierto tiempo mientras imprime. Supuestamente es un error de comunicación con el arduino, en terminal aparece el siguiente mensaje:

"Communication timeout while printing, trying to trigger response from printer. Configure long running commands or increase communication timeout if that happens regularly on specific commands or long moves."

Aparte de probar lo que dice en el mensaje de error, he probado a bajar el baudrate de 250000 a 115200 pero esto sigue ocurriendo. También he pensado que pueda ser el cable, ya que es el tipico azul chinorris, pero no tengo ningún otro para probar.

A ver si alguien me puede ayudar.

Gracias!
Citar
#2
Podría ser el cable que estas usando, yo por ahora desde que le puse el octoprint 0 problemas y lo llevó usando ya meses.


Enviado desde mi iPhone5 utilizando Tapatalk
Citar
#3
Conecta el ordenador a la impresora y empezaras a descartar cosas. Ya nos dirás qué ocurre.

Saludetes
Edu
Citar
#4
(26-04-2016, 08:10 PM)sorianillo escribió: Conecta el ordenador a la impresora y empezaras a descartar cosas. Ya nos dirás qué ocurre.

Saludetes
Edu

Pues acabo de probar a imprimir desde el ordenador y todo bien. Así que el cable no es, el problema esta en octoprint y la raspberry. Triste
Citar
#5
(27-04-2016, 01:10 PM)Antoniolr_95 escribió:
(26-04-2016, 08:10 PM)sorianillo escribió: Conecta el ordenador a la impresora y empezaras a descartar cosas. Ya nos dirás qué ocurre.

Saludetes
Edu

Pues acabo de probar a imprimir desde el ordenador y todo bien. Así que el cable no es, el problema esta en octoprint y la raspberry. Triste


Has probado a hacer una nueva reistalacion del octoprint. Y que tarjeta micro sd estás usando en la rasberry.
Citar
#6
Ya se de donde proviene el fallo, basicamente es un problema de interferencias de la fuente de alimentación con la raspberry pi. Hace unos dias las metí en una caja juntas. Desde entonces me ha estado fallando, pero no pensaba que podría ser por eso. Al sacarla de la caja funciona correctamente de nuevo.

El problema ahora esta en que no se como hacer que convivan juntas ya que no tengo mucho espacio por la impresora. He puesto una lamina de papel de aluminio pero esto no ha solucionado el problema... No se me ocurre otra forma de aislar la fuente.
Citar
#7
Prueba con una ferrita.

Es curioso, dentro de la fuente atx que uso en ambas impresoras, he instalado un conversor de 220v a 5v para tener alimentación con un solo enchufe en ambos dispositivos y de momento, no he encontrado problemas de interferencias.

Saludetes
Edu
Citar