Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema Relé y Octoprint
#1
Buenos días, ante todo disculpas por que no sabía donde poner el post, si aquí o en la sección de Raspeberry...

El caso es que he estado experimentando con la Raspeberry 3 y Octoprint. La conexión a la impresora la hace sin problemas, muevo ejes y veo lo que se imprime...

He estado toda la semana intentando conectar una placa con 3 relés a la raspeberry para poder encender y apagar unos led para la cámara sin éxito....

He seguido varios tutoriales pero nada, cuando parece que tengo todo y la raspeberry se ha tragado todo...
Me aparece una pantalla que me dice El servidor no ha podido comenzar... En inglés...

El caso es que en la wifi si que veo que está conectada y atrás es de putty entro en ella...

Ya no se que mas probar... Un saludo



Enviado desde mi Aquaris X5 mediante Tapatalk
Citar
#2
(04-02-2017, 09:42 AM)Zolber escribió: Buenos días, ante todo disculpas por que no sabía donde poner el post, si aquí o en la sección de Raspeberry...

El caso es que he estado experimentando con la Raspeberry 3 y Octoprint. La conexión a la impresora la hace sin problemas, muevo ejes y veo lo que se imprime...  

He estado toda la semana intentando conectar una placa con 3 relés a la raspeberry para poder encender y apagar unos led para la cámara sin éxito....

He seguido varios tutoriales pero nada, cuando parece que tengo todo y la raspeberry se ha tragado todo...
Me aparece una pantalla que me dice El servidor no ha podido comenzar... En inglés...

El caso es que en la wifi si que veo que está conectada y atrás es de putty entro en ella...

Ya no se que mas probar... Un saludo



Enviado desde mi Aquaris X5 mediante Tapatalk

No se si lo habrás visto, imagino que si, yo estoy pendiente de instalar todo el tema de Octoprint en mi Raspi, estuve viendo este tutorial donde lo veo bastante bien explicado, puede ser que ya lo hayas visto, pero bueno por si las moscas, yo estoy esperando los reles y a ver si saco tiempo para liarme con ello, bueno, AQUÍ te dejo el enlace.
Citar
#3
Una pregunta.

Pretendes controlar los relés con la Raspberry o con el arduino?
Citar
#4
(17-02-2017, 11:42 AM)Chester_37 escribió:
(04-02-2017, 09:42 AM)Zolber escribió: Buenos días, ante todo disculpas por que no sabía donde poner el post, si aquí o en la sección de Raspeberry...

El caso es que he estado experimentando con la Raspeberry 3 y Octoprint. La conexión a la impresora la hace sin problemas, muevo ejes y veo lo que se imprime...  

He estado toda la semana intentando conectar una placa con 3 relés a la raspeberry para poder encender y apagar unos led para la cámara sin éxito....

He seguido varios tutoriales pero nada, cuando parece que tengo todo y la raspeberry se ha tragado todo...
Me aparece una pantalla que me dice El servidor no ha podido comenzar... En inglés...

El caso es que en la wifi si que veo que está conectada y atrás es de putty entro en ella...

Ya no se que mas probar... Un saludo



Enviado desde mi Aquaris X5 mediante Tapatalk

No se si lo habrás visto, imagino que si, yo estoy pendiente de instalar todo el tema de Octoprint en mi Raspi, estuve viendo este tutorial donde lo veo bastante bien explicado, puede ser que ya lo hayas visto, pero bueno por si las moscas, yo estoy esperando los reles y a ver si saco tiempo para liarme con ello, bueno, AQUÍ te dejo el enlace.

Hola, con ese tutoria fue con el que empece y con ese tengo casi todo configurado
Ya lo tengo funcionando pero con una modificacion sobre el tutorial...  el paso donde dice "Ahora editaremos otro archivo para añadir las opciones al menu “System”  ese me lo salto, por que parece ser que a mi raspberry le sentaba mal...
Asi que para completar la instalacion, ne vez de hacer ese paso, me descargue un pluging de Octoprint, este: http://plugins.octoprint.org/plugins/sys...andeditor/
y ahi voy creandome mis "ordenes" para los gpio
 
action: printer on
command: gpio -g write 20 1

 name: Turn on the printer
 
Etc Etc, en mi caso 3 ordenes para 3 reles.
De esta manera a funcionar a la primera.

(17-02-2017, 03:08 PM)m4gn3to escribió: Una pregunta.

Pretendes controlar los relés con la Raspberry o con el arduino?
Hola, yo tengo esta placa integrada con 3 reles, los abro o cierro desde octoprint, asi podre controlar unos led para cuando miro por la camara
http://www.waveshare.com/wiki/RPi_Relay_Board
Citar
#5
Entonces no sé como ayudarte, yo seguí unos cuantos tutoriales para hacer lo mismo que tú y tampoco conseguí que me funcionase (aunque le eché la culpa a usar una orange-pi en lugar de la Raspberry original) al final he optado por controlar los relés desde la ramps con el arduino y funciona a la perfección.

Un saludo.
Citar
#6
(17-02-2017, 09:03 PM)Zolber escribió:
(17-02-2017, 11:42 AM)Chester_37 escribió:
(04-02-2017, 09:42 AM)Zolber escribió: Buenos días, ante todo disculpas por que no sabía donde poner el post, si aquí o en la sección de Raspeberry...

El caso es que he estado experimentando con la Raspeberry 3 y Octoprint. La conexión a la impresora la hace sin problemas, muevo ejes y veo lo que se imprime...  

He estado toda la semana intentando conectar una placa con 3 relés a la raspeberry para poder encender y apagar unos led para la cámara sin éxito....

He seguido varios tutoriales pero nada, cuando parece que tengo todo y la raspeberry se ha tragado todo...
Me aparece una pantalla que me dice El servidor no ha podido comenzar... En inglés...

El caso es que en la wifi si que veo que está conectada y atrás es de putty entro en ella...

Ya no se que mas probar... Un saludo



Enviado desde mi Aquaris X5 mediante Tapatalk

No se si lo habrás visto, imagino que si, yo estoy pendiente de instalar todo el tema de Octoprint en mi Raspi, estuve viendo este tutorial donde lo veo bastante bien explicado, puede ser que ya lo hayas visto, pero bueno por si las moscas, yo estoy esperando los reles y a ver si saco tiempo para liarme con ello, bueno, AQUÍ te dejo el enlace.

Hola, con ese tutoria fue con el que empece y con ese tengo casi todo configurado
Ya lo tengo funcionando pero con una modificacion sobre el tutorial...  el paso donde dice "Ahora editaremos otro archivo para añadir las opciones al menu “System”  ese me lo salto, por que parece ser que a mi raspberry  le sentaba mal...
Asi que para completar la instalacion, ne vez de hacer ese paso, me descargue un pluging de Octoprint, este: http://plugins.octoprint.org/plugins/sys...andeditor/
y ahi voy creandome mis "ordenes" para los gpio
 
action: printer on
command: gpio -g write 20 1

 name: Turn on the printer
 
Etc Etc, en mi caso 3 ordenes para 3 reles.
De esta manera a funcionar a la primera.

(17-02-2017, 03:08 PM)m4gn3to escribió: Una pregunta.

Pretendes controlar los relés con la Raspberry o con el arduino?
Hola, yo tengo esta placa integrada con 3 reles, los abro o cierro desde octoprint, asi podre controlar unos led para cuando miro por la camara
http://www.waveshare.com/wiki/RPi_Relay_Board

Gracias Zolber, le echaré un vistazo a ver que tal, como ya te comente debo ponerme aun con ello y estoy recopilando información de aquí y allá, en principio tengo ESTOS relé, pregunté a ver si era necesario poner el tema de los transistores y resistencias, porque me daba la impresión que los relé que pedí ya contaban con ellos, pero me comentaron que aún poniendo esos relé deberia de colocar los transistores y resistencia por el tema de que los GPIO de la RASPI iban justitos, así que por lo que cuestan ya los tengo pedidos y prefiero prevenir a curar, concretamente ESTOS, a ver si me llegan y me pongo, la verdad es que quiero dejarlo bien colocado porque me parece que el tema OCTOPRINT es realmente bueno, a ver que sale al final, porque también quiero buscar algo hecho en Python o similar para controlar los encendidos y apagados de relé, en fin que ya veremos en que acaba todo esto, jejejeje
Citar
#7
Resistencias? Mas bien necesitas un diodo en antiparalelo con la bobina del relé para evitar que al cortar la alimentacion a la bobina te fria el transistor. Acuerdate de ponerselo, pues no todos los transistores llevan esa proteccion, y nunca pasa nada hasta que lo haces 50 veces y el transistor muere.
Citar
#8
(21-02-2017, 02:47 PM)Shellmer escribió: Resistencias? Mas bien necesitas un diodo en antiparalelo con la bobina del relé para evitar que al cortar la alimentacion a la bobina te fria el transistor. Acuerdate de ponerselo, pues no todos los transistores llevan esa proteccion, y nunca pasa nada hasta que lo haces 50 veces y el transistor muere.

Las placas que nos ha puesto @Chester_37 ya llevan diodo antiparalelo para protección del opto (no del transistor que ponga por fuera). Al utilizar BJT lo normal es poner resistencia en la base, además de necesitar alguna de pullup o pulldown para el resto del montaje.

Los optos que lleva la placa, según el fabricante requieren unos 20mA cada uno, y el máximo de los GPIO de la RBPi3 es de 50mA, por lo que a nada que se conecte otra cosa, malo.
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar
#9
(21-02-2017, 04:45 PM)WeSo escribió:
(21-02-2017, 02:47 PM)Shellmer escribió: Resistencias? Mas bien necesitas un diodo en antiparalelo con la bobina del relé para evitar que al cortar la alimentacion a la bobina te fria el transistor. Acuerdate de ponerselo, pues no todos los transistores llevan esa proteccion, y nunca pasa nada hasta que lo haces 50 veces y el transistor muere.

Las placas que nos ha puesto @Chester_37 ya llevan diodo antiparalelo para protección del opto (no del transistor que ponga por fuera). Al utilizar BJT lo normal es poner resistencia en la base, además de necesitar alguna de pullup o pulldown para el resto del montaje.

Los optos que lleva la placa, según el fabricante requieren unos 20mA cada uno, y el máximo de los GPIO de la RBPi3 es de 50mA, por lo que a nada que se conecte otra cosa, malo.

Maquinaaaaa!!!!!, joder ya he visto que andas por aquí, yo de electronica la verdad es que poquito, sólo soy un aficionado que le gusta cacharrear a tope, el amigo @WeSo es quien me saca de mis cagadas (que paciencia tiene conmigo), jejjejejej,  me dijo lo que comenté más arriba, así que como siempre...... AMEN, todas sus ayudas me han ido estupendamente, por eso hice referencia a lo que me había comentado, el tema era igual o similar a lo que yo estaba intentando hacer, para no molestarlo demasiado voy mirando en foros y demás, tampoco quiero abusar, y fijate que sorpresa que también está por aquí, jajajjaja, pues nada, que cuando me lleguen los transistores que me aconsejó se los colocaré y probaré a ver que tal va esto, estoy seguro que bien  Icon_e_smile Icon_e_smile
Citar
#10
(23-02-2017, 01:19 PM)Chester_37 escribió:
(21-02-2017, 04:45 PM)WeSo escribió:
(21-02-2017, 02:47 PM)Shellmer escribió: Resistencias? Mas bien necesitas un diodo en antiparalelo con la bobina del relé para evitar que al cortar la alimentacion a la bobina te fria el transistor. Acuerdate de ponerselo, pues no todos los transistores llevan esa proteccion, y nunca pasa nada hasta que lo haces 50 veces y el transistor muere.

Las placas que nos ha puesto @Chester_37 ya llevan diodo antiparalelo para protección del opto (no del transistor que ponga por fuera). Al utilizar BJT lo normal es poner resistencia en la base, además de necesitar alguna de pullup o pulldown para el resto del montaje.

Los optos que lleva la placa, según el fabricante requieren unos 20mA cada uno, y el máximo de los GPIO de la RBPi3 es de 50mA, por lo que a nada que se conecte otra cosa, malo.

Maquinaaaaa!!!!!, joder ya he visto que andas por aquí, yo de electronica la verdad es que poquito, sólo soy un aficionado que le gusta cacharrear a tope, el amigo @WeSo es quien me saca de mis cagadas (que paciencia tiene conmigo), jejjejejej,  me dijo lo que comenté más arriba, así que como siempre...... AMEN, todas sus ayudas me han ido estupendamente, por eso hice referencia a lo que me había comentado, el tema era igual o similar a lo que yo estaba intentando hacer, para no molestarlo demasiado voy mirando en foros y demás, tampoco quiero abusar, y fijate que sorpresa que también está por aquí, jajajjaja, pues nada, que cuando me lleguen los transistores que me aconsejó se los colocaré y probaré a ver que tal va esto, estoy seguro que bien  Icon_e_smile Icon_e_smile
jajaja por aquí llevamos ya un tiempecillo Lengua Ya sabes, como siempre, que para cualquier cosa por aquí estamos (y ya ves que también la comunidad que tenemos, que es cojonuda!).

El montaje no debería tener complicación ninguna, es muy sencillo, así que cuando te lleguen nos das feedback a ver qué tal funciona el conjunto =)
NOVEDAD: CoreXY Eternal Edition (Custom) -> https://www.spainlabs.com/foros/tema-Ete...So-Edition
Mi Prusa i3, ¡con lista de componentes! -> http://www.spainlabs.com/foros/tema-Un-clon-mas
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  APORTE Octoprint en Synology con impresora ANet A8 mentxo 0 332 17-04-2018, 07:18 PM
Último mensaje: mentxo
  Octoprint y desplazamiento de capas Azofaifo 0 522 23-04-2017, 11:41 PM
Último mensaje: Azofaifo
  Octoprint para la impresión Anakin 0 511 21-02-2017, 09:13 AM
Último mensaje: Anakin
  Duda Rele sacha 7 954 19-10-2016, 05:33 PM
Último mensaje: sacha
  octoprint: thermal runaway nachoBcn 2 686 19-06-2016, 04:52 PM
Último mensaje: nachoBcn