Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Problema Ethernet
#1
Buenas!

Hace poco me hice con una shield ethernet para domotizar la calefaccion. La estuve probando en el router y todo genial, pero mi idea era conectarla a un repetidor wifi con salida RJ45 ( El WN3000RP ), pero cuando lo conecto con este, solo se enciende el led de PWR y el de FULLD parpadea...  Alguna idea??

Le he cargado el ejemplo de DhcpAddressPrinter y al principio muestra error de conexión, pero a los 10 minutos o asi se encienden también LINK, 100M y RX


Un saludo!
Código:
try {
   live();
}
catch (BestMoments) {
MessageBox.Show(Happy)
}

Citar
#2
Mira a ver si en la librería puedes forzar a full duplex 100mb para que no autonegocie, que es donde se puede liar...

En algunos switch malos había que desactivar la autonegociación a los pc para que conectaran ok. Prueba a ver si van por ahí los tiros...
Citar
#3
He estado mirando y lo unico que he encontrado ha sido unir un par de contactos en la placa que ya están unidos por una resistencia...

He probado tambien ha darle ip estatica al repetidor, cambiar la MAC...

Tres cosas de las que me acabo de dar cuenta :

-Si hago ping al crear un servidor con arduino (192.168.1.123) me devuelve desde otra ping la info (192.168.1.108)
-No se enciende ninguna de las dos luces del conector RJ45 del Arduino (A los 10 minutos que se encienden las otras luces sí)
-Si abro el monitor cuando estan todas las luces encendidas me sale que el servidor está en .123 pero se vuelve todo loco de nuevo y se pone FULLD a parpadear (pero si accedo a la ip no va nada)
Código:
try {
   live();
}
catch (BestMoments) {
MessageBox.Show(Happy)
}

Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  conversión código arduino ethernet 5100 a wemos d1 mini nbaglietto 0 345 24-11-2017, 02:05 AM
Último mensaje: nbaglietto
  Ethernet Shield freestyle 5 1,149 24-06-2013, 05:11 PM
Último mensaje: jukillo