Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Paro al iniciar la impresión
#1
¡Hola a todos¡
Tengo una prusa i3 con Ramps 1.3 y arduino mega desde hace años, la conecto desde el ordenador tengo cargado el marlin y el repetier, suelo usar ABS, hasta ahora todo iba bien. De un día para otro le doy a imprimir con el repetier, calienta cama y extrusor y al hacer el homing se para y no inicia la impresión, a continuación los motores no responden al control manual, la temperaturas empiezan a caer e indica que estoy conectado. He revisado las conexiones de motores, finales de carrera… todo parece estar bien. Esta bien calibrada, cuando hago home de XYZ por separado no hay problema pero si hago homing global es cuando se para.
He probado cambiando la configuración de la impresora en el repetier, he probado con el pronterface, he vuelto a cargar el sprinter, el marlin cambiando parámetros (prueba y error) y también he probado con otras versiones de arduino y siempre el  mismo problema. No sé qué pasa... ¿alguna idea?
Citar
#2
Ejecuta lo siguiente como prueba (a mano desde la consola del repetier mismo):

Primera prueba:
Código:
G28 X
G28 Y
G28 Z
G0 X100 Y100 Z10
G0 X20 Y20 Z15
G0 X100 Y100 Z10

Segunda prueba:
Código:
G28
G0 X100 Y100 Z10
G0 X20 Y20 Z15
G0 X100 Y100 Z10

Si se te mueve bien con la primera y no con la segunda comentalo... basicamente asi le estas enviando un programa a mano, deberia irte en los 2 casos de la misma manera, si no lo hace sube a algun lado algun fichero gcode que no te funcione y le echo un ojo, a ver si te esta sacando el fileteador alguna cosa rara en el gcode. Reinicia la impresora entre una prueba y la siguiente para que te pierda el home y empiece de 0.


PD: Si utilizas Cura con RepetierHost, ve a la configuración del fileteador CuraEngine, ve a la pestaña "Structures" y verifica que en "G-Code Flavour" tengas seleccionado el gcode de Repetier/Matlin/Sprinter, no vaya a ser que te este generando otro tip ode gcode diferente y te loquee la impresora.
Si utilizas Slic3r en repetier host, esta misma opción está en la configuración del Slic3r, en el apartado de "Printer Settings", General.
Citar
#3
Hola Shellmer:

He ejecutado lo g-codes que me has pasado con el pronterface y los hace sin problema. En las dos pruebas hace bien los movimientos (hace el home xyz bien). He combrobado el "G-Code Flavour" del repetier y lo tengo en Repetier/Matlin/Sprinter.
Despues he intentado imprimir con el pronterface y sale esto en la consola: (cuando hace el home xyz se peta)

Connecting...
start
Printer is now online.
echo: External Reset
Marlin 1.0.0
echo: Last Updated: Jun 5 2018 18:23:13 | Author: Darth Raul
Compiled: Jun 5 2018
echo: Free Memory: 4261 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
echo:SD init fail
ok T:0.0 /0.0 B:0.0 /0.0 @:0 B@:0
SENDING:M105
ok T:23.4 /0.0 B:22.3 /0.0 @:0 B@:0

(cargo una pieza en pronterface hace el slicing…, espero a que coja la temperatura, le doy a imprimir hace el home global (g28) y hay se queda)

ok T:222.7 /220.0 B:78.3 /110.0 @:0 B@:128
Print Started at: 12:41:56
start
Printer is now online.
echo: External Reset
Marlin 1.0.0
echo: Last Updated: Jun 5 2018 18:23:13 | Author: Darth Raul
Compiled: Jun 5 2018
echo: Free Memory: 4261 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
Error:Line Number is not Last Line Number+1, Last Line: 0
Resend: 1
echo:SD init fail
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Cambiar Gcode al iniciar la impresión Slic3r xero83 3 208 22-08-2018, 07:39 PM
Último mensaje: xero83
  Fallo de impresion a media impresion 21Curiosos 6 351 04-08-2018, 03:37 PM
Último mensaje: 21Curiosos
  CONSULTA Paro de impresión makertechnic 2 177 03-06-2018, 10:43 PM
Último mensaje: Shellmer
  Eje z se baja unos mm al iniciar la impresión Bertinolario 9 1,939 18-12-2017, 02:21 AM
Último mensaje: lucas_slam