Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Motor eje Z no se mueve
#1
Hola que tal este es mi primer post y espero ser un usuario activo en este foro, dado que veo que tiene una buena cantidad de usuarios y buenas respuestas.
Bueno aqui mi problema tengo una impresora prusa i3 imitación como hace un año y ahora se me rompiio la placa con la que vino que era una MKS GEN 2Z V1.2 y por equivocacion o desconocimiento compre una MKS BASE _L V2.1 y ahora tengo un problema dado que esta placa tiene un solo lugar para alimentar los motores del eje Z y entonces solo puedo mover correctamente uno a lba vez, lo que hice fue conectar en forma paralela los dos motores en la misma ficha pero no tienen fuerza suficiente es como que se dividio la energia un poco para cada uno entonces no suben hacen ruido pero no suben si los ayudo con la mano suben, los cables estan todos correctamente conectados.
Creo que mi problema esta en el marlin que le estoy cargando dado mi proveedor me vendio me vendio una placa para dos extrusores y no para dos eje z, 
tambien tengo los sensores de stop al reves, ese es otro problema.
Compre esta placa
https://articulo.mercadolibre.com.ar/MLA...ora-3d-_JM
Pero ahora no la puedo usar en esta impresora que compre el año pasado
http://gamercom.mx/inicio/13-impresora-p...00012.html

Como hago para que la placa funcione con mi impreso prusa i3 o me tengo que comprar otra placa ?
Si fuera asi que me recomiendan? La tengo sin usar como hace un mes y esto me entristese mucho ya que me gusta imprimir muchas cosas.

adjunto mi archivo de configuracion de marlin que estoy usando
Citar
#2
Hola, tienes que configurar en Marlin que el segundo extrusor funcione para el motor del eje Z, eso se hace en la pestaña configuration_adv de Marlin. No recuerdo la línea y no te lo puedo mirar pues escribo desde el móvil, si nadie te lo ha dicho ya te lo miro esta tarde noche pero si no recuerdo mal solo era descomentarla. Saludos.
Citar
#3
Gracias voy a investigar el archivo que nombras configuration_adv, voy a subir mi marlin a github a si puedes ver que estoy usando. Pero como dices creo que solo hay que cambiarle la funcion al segundo extrusor y se comporte como el segundo motor eje z
Citar
#4
Hola, tienes que activar el uso de "dual Z drivers", en el mencionado configuration_adv. Saludos.
Citar
#5
Hola buratatxo, gracias por la respuesta fue correcta
la linea decia asi

// A single Z stepper driver is usually used to drive 2 stepper motors.
// Uncomment this define to utilize a separate stepper driver for each Z axis motor.
// Only a few motherboards support this, like RAMPS, which have dual extruder support (the 2nd, often unused, extruder driver is used
// to control the 2nd Z axis stepper motor). The pins are currently only defined for a RAMPS motherboards.
// On a RAMPS (or other 5 driver) motherboard, using this feature will limit you to using 1 extruder.
#define Z_DUAL_STEPPER_DRIVERS
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
Triste Motor extrusora no funciona MonRa 6 242 11-10-2018, 09:32 AM
Último mensaje: MonRa
  CONSULTA Motor de eje "y" no se mueve fidepincha 0 361 01-12-2017, 08:25 PM
Último mensaje: fidepincha