Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Mi Tronxy X5S
(22-01-2018, 12:52 PM)Wilt Foster escribió: Buenas a todos! Bueno tengo una duda, ayer monte la Tronxy x5s y es una maravilla ... queria preguntar que tan seguro es ponerla en marcha sin los mosfets, ya que he pedido unos pero seguramente tarde un par de semana en llegar y mientras queria hacerle un par de mejoras a la impresora
resim
Me recomendais esperar¿? o me pongo a montar la parte electrica¿?
Facepalm Facepalm Icon_popcorn Icon_popcorn

Si no imprimes con la cama caliente no deberias tener problemas. El mosfet minimo para la cama.
Citar
muchisimas Gracias Jeje cogi dos como pusiste en tus primeros posts ... y os ire pasando fotos de como va quedando
Citar
Muy buenas Jeje he vuelto y ayer conecte la parte electronica y vi que tengo un Marlin 1.1.7 ... No tendreis por ahi un archivo para adaptar el Marlin al español en esta version no¿?
Citar
(23-01-2018, 01:12 PM)Wilt Foster escribió: Muy buenas Jeje he vuelto y ayer conecte la parte electronica y vi que tengo un Marlin 1.1.7 ... No tendreis por ahi un archivo para adaptar el Marlin al español en esta version no¿?

https://www.thingiverse.com/thing:2738690

Ese usuario subio un marlin 1.1.8, echale un ojo que cambiar el lenguaje esta chupado.
Citar
Buenas Cyberbask luego de una serie de problemas que consegui solucionar voy a darle a aceptar a ese marlin que me pasaste y me sale esto.... Lo paso por si sabes alguna manera de ayudarme

C:\Users\moise\Desktop\TronXY_X5S_Marlin_1.1.8_Firmware\files\X5S_Marlin_1.1.8\Marlin\Marlin.ino:45:110: fatal error: U8glib.h: No such file or directory

#include <U8glib.h> // library for graphics LCD by Oli Kraus (https://github.com/olikraus/U8glib_Arduino)

^

compilation terminated.

exit status 1
Error compilando para la tarjeta Sanguino.


-----------

Bueno consegui avanzar descargandome el archivo del link y metiendolo en la carpeta de arduino y ahora me aparece


Compilado


Archiving built core (caching) in: C:\Users\moise\AppData\Local\Temp\arduino_cache_785596\core\core_Sanguino_avr_sanguino_cpu_atmega1284p_a94ab6aaf61dfb93b4a8079c694a14c2.a
El Sketch usa 126244 bytes (97%) del espacio de almacenamiento de programa. El máximo es 130048 bytes.
Las variables Globales usan 4679 bytes (28%) de la memoria dinámica, dejando 11705 bytes para las variables locales. El máximo es 16384 bytes.

No se que hacer ahora :CCC

Por cierto como selecciono luego el español?¿ xD Muchas dudas

------

Vale encontre el boton de subir xD Ya lo subi y perfecto creo¿? Pero me falta pasarlo al español antes de probarlo
Si me pudierais ayudar.... Se que dentro del codigo esta pero no se como activarlo


------

Me encanta no paro de actualizar este post xD Bueno al final lo consegui el problema esta en que antiguamente el idioma se cambiaba desde
language.h y ahora se cambia en configuration.h ..... Bueno ya con tanta cosa se me hizo tarde asi que probare mañana el Marlin 1.1.8 y a ver que tal...

Para quien necesite ayuda porque quiere descargarlo me puede decir... Yo actualice a la 1.1.8

Por cierto que programa usais para el tema de imprimir(Cura por ejemplo¿?) Es que no se ahora si solo con subir un stl y cargarlo en la impresora vale o que opciones me deja el cura o yo que se xD Soy Novato

A parte en la primera mini prueba que hice uno de los stoppers no me funcionaba( El que para el hotend)... Jummm

Siento el post tan largo
Citar
(23-01-2018, 11:00 PM)Wilt Foster escribió: Buenas Cyberbask luego de una serie de problemas que consegui solucionar voy a darle a aceptar a ese marlin que me pasaste y me sale esto.... Lo paso por si sabes alguna manera de ayudarme

C:\Users\moise\Desktop\TronXY_X5S_Marlin_1.1.8_Firmware\files\X5S_Marlin_1.1.8\Marlin\Marlin.ino:45:110: fatal error: U8glib.h: No such file or directory

    #include <U8glib.h> // library for graphics LCD by Oli Kraus (https://github.com/olikraus/U8glib_Arduino)

                                                                                                             ^

compilation terminated.

exit status 1
Error compilando para la tarjeta Sanguino.


-----------

Bueno consegui avanzar descargandome el archivo del link y metiendolo en la carpeta de arduino y ahora me aparece


Compilado


Archiving built core (caching) in: C:\Users\moise\AppData\Local\Temp\arduino_cache_785596\core\core_Sanguino_avr_sanguino_cpu_atmega1284p_a94ab6aaf61dfb93b4a8079c694a14c2.a
El Sketch usa 126244 bytes (97%) del espacio de almacenamiento de programa. El máximo es 130048 bytes.
Las variables Globales usan 4679 bytes (28%) de la memoria dinámica, dejando 11705 bytes para las variables locales. El máximo es 16384 bytes.

No se que hacer ahora  :CCC

Por cierto como selecciono luego el español?¿ xD Muchas dudas

------

Vale encontre el boton de subir xD Ya lo subi y perfecto creo¿? Pero me falta pasarlo al español antes de probarlo
Si me pudierais ayudar.... Se que dentro del codigo esta pero no se como activarlo


------

Me encanta no paro de actualizar este post xD Bueno al final lo consegui el problema esta en que antiguamente el idioma se cambiaba desde
language.h  y ahora se cambia en configuration.h ..... Bueno ya con tanta cosa se me hizo tarde asi que probare mañana el Marlin 1.1.8 y a ver que tal...

Para quien necesite ayuda porque quiere descargarlo me puede decir...  Yo actualice  a la 1.1.8

Por cierto que programa usais para el tema de imprimir(Cura por ejemplo¿?)  Es que no se ahora si solo con subir un stl y cargarlo en la impresora vale o que opciones me deja el cura o yo que se xD Soy Novato

A parte en la primera mini prueba que hice uno de los stoppers no me funcionaba( El que para el hotend)... Jummm

Siento el post tan largo


Me alegro que lo consiguieses B1  .

La impresora solo entiende ficheros en formato gcode. Para generar un gcode tienes que pasar el stl por el cura, el slic3r, el symplify3d, o el que mas te guste, y luego meterlo en la impresora.

Para empezar el cura diria que es el mas sencillo y es gratuito. Solo tienes que configurar un par de cosas como el tamaño de la cama y listo. Con eso podras empezar a imprimir.

Lo del final de carrera revisa que este bien enchufado, que el cable no este aplastado, etc...

Un saludo.
Citar
Para el idioma, lo digo sin conocer el código exacto pero conociendo los de otras impresoras, busca dentro del IDE donde ponga "language" o algo similar, te saldrá varias veces como resultado, pero en alguna de las primeras, como comentario en la programación, un comentario en todo lo que va detrás de un punto y coma, te saldrá el código de idioma, normalmente "ES" para español.

Dentro del código sin ser comentario, casi con toda probabilidad justo después de las líneas de comentario en las que te digan el idioma, tendrás un línea donde diga algo como #define LCD_LANGUAGE (código de idioma). Lo cambias por el que quieras y compilas.

Esto no es un programa como los del ordenador, donde puedes cambiar ciertas opciones "en caliente", tienes que compilar.

resim
Citar
Ya lo siento molestar tanto jeje... pero bastantes dudas
La primera es si esta impresora el origen de cordenadas la tiene en el centro¿? Que yo diria que no pero es por si me equivoco

La segunda es el como hacer que la impresora sepa cuales son las cordenadas de inico o el punto 0.0 ... no se si me explico bien. Esto lo pregunto no quiero que cuando le ponga una pieza me la haga a un lado o algo asi
Citar
(24-01-2018, 01:00 PM)Wilt Foster escribió: Ya lo siento molestar tanto jeje... pero bastantes dudas
La primera es si esta impresora el origen de cordenadas la tiene en el centro¿? Que yo diria que no pero es por si me equivoco

La segunda es el como hacer que la impresora sepa cuales son las cordenadas de inico o el punto 0.0 ... no se si me explico bien. Esto lo pregunto no quiero que cuando le ponga una pieza me la haga a un lado o algo asi

El origen de cordenadas no es en el centro.

Por defecto cuando termina de hacer el homing, ese seria el 0.0, asi que no te deberia imprimir en un lado.
Citar
Una ultima pregunta jeje que altura dejais entre la punta del hotend y la cama¿?


Buff tendre que comprobar lo de los Stoppers porque le doy a la opcion a volver a origen y no para
Citar
(24-01-2018, 02:30 PM)Wilt Foster escribió: Una ultima pregunta jeje que altura dejais entre la punta del hotend y la cama¿?


Buff tendre que comprobar lo de los Stoppers porque le doy a la opcion a volver a origen y no para

Normalmente se comprueba en cada esquina de la cama pasando un folio entre el hotend y la cama. El folio tiene que rozar el hotend, pero no quedarse enganchado.

Un saludo.
Citar
Buenas tardes
Cuantos pasos le tenéis puesto al extrusor?
El caso es que yo tengo #define DEFAULT_AXIS_STEPS_PER_UNIT { 160,160,690,185.63 } y no me sale hilo al principio (imprimiendo un cubo), empieza a hacer ruido y no sale, pero al rato empieza a imprimir la pieza sin la cama ni el perímetro el Slicer lo tengo calibrado para que imprima antes el perimetro. En principio cuando cuando calibro los pasos para mover 100mm es ese valor (185.63) y me sale la distancia correcta de hilo.Estoy pensando que podría tener el extrusor fastidiado y me he pedido uno el Anycubic MK8 Extrusora Hotend ,¿como lo veis?
Saludos
Citar
Buenas a todos... Tras un paron que he hecho estos dias por las clases, volvi a ponerme con la impresora. Hoy intente ver que le pasaba al extrusor ya que cuando le doy a la opcion de mover el esxtrusor y no hace ningun movimiento (no se si hace falta que el hotend caliente para que este funcione como en algunas otras impresoras... si alguien sabe que me diga por favor).. Cuando pueda intentare solucionarlo.... porque no me apetece comprar un extrusor temporal ya que mi idea era hacer el combo de comprar un bondtech y un V6 cuando consiga dinero...

Por cierto tengo dos dudas mas , ya siento ser tan petardo  Qmeparto Qmeparto Qmeparto Qmeparto

Una es que hace poco me compre el filamento de fff world y pues que opinais de el

La segunda cosa es que donde cambiais la temperatura por defecto de la cama caliente (Que sigo esperando los mosfets xD), el hotend y la velocidad del extrusor.... En plan lo cambiais en arduino IDE o desde la misma pantalla ¿? Lo digo porque vi la opcion de precalentar PLA y me da que para cambiar esas opciones sera desde el Arduino IDE.... Ya que por lo que he visto que recomendais el hotend a 200 grados (que se pone en 180 al darle a precalentar PLA) y la velocidad a 60 (Que no se donde comprobarla)
Citar
(30-01-2018, 08:32 PM)Wilt Foster escribió: Buenas a todos... Tras un paron que he hecho estos dias por las clases, volvi a ponerme con la impresora. Hoy intente ver que le pasaba al extrusor ya que cuando le doy a la opcion de mover el esxtrusor y no hace ningun movimiento (no se si hace falta que el hotend caliente para que este funcione como en algunas otras impresoras... si alguien sabe que me diga por favor).. Cuando pueda intentare solucionarlo.... porque no me apetece comprar un extrusor temporal ya que mi idea era hacer el combo de comprar un bondtech y un V6 cuando consiga dinero...  

Por cierto tengo dos dudas mas , ya siento ser tan petardo  Qmeparto Qmeparto Qmeparto Qmeparto

Una es que hace poco me compre el filamento de fff world y pues que opinais de el

La segunda cosa es que donde cambiais la temperatura por defecto de la cama caliente (Que sigo esperando los mosfets xD), el hotend y la velocidad del extrusor.... En plan lo cambiais en arduino IDE o desde la misma pantalla ¿? Lo digo porque vi la opcion de precalentar PLA y me da que para cambiar esas opciones sera desde el Arduino IDE.... Ya que por lo que he visto que recomendais el hotend a 200 grados (que se pone en 180 al darle a precalentar PLA) y la velocidad a 60 (Que no se donde comprobarla)

Si el extrusor no esta caliente, no se mueve.

Desde la pantalla no se puede cambiar casi nada porque el firmware esta muy limitado. O actualizar el firm, o lo cambias mediante gcode de forma temporal.
Citar
(05-12-2017, 10:48 PM)cyberbask escribió: Buenas.

No te preocupes, que para eso estamos.

En el Arduino IDE, en las preferencias tienes que pegar primero esta linea:
https://raw.githubusercontent.com/Lauszu...index.json
dentro del cajetin que pone "Gestor de Urls adicionales de Tarjetas"

Luego te vas a Herramientas -> Placa -> Gestor de Tarjetas, buscas "Sanguino" y lo intalas.

Una vez instalado, vuelves a las preferencias del arduino ide, y abajo de todo te pone una ruta que termina en preferences.txt, pinchas sobre ella.
Se te deberia abrir una carpeta. Dentro de esa carpeta vas a packages\Sanguino\hardware\avr\1.0.2\boards.txt y lo editas.
Buscas la linea sanguino.menu.cpu.atmega1284p.upload.speed y la dejas asi:
sanguino.menu.cpu.atmega1284p.upload.speed=57600



Por otra parte, en el Arduino IDE, tienes un boton que es verificar. Lo que hace es compilar el Marlin y verificar que este todo bien, las librerias instaladas , etc...  Asi antes de subir el Marlin a la placa te aseguras de que esta todo bien.

Un saludo.

No tengo claro como comunicar con la Melzy. ¿Cómo paso el firmware a la tarjeta?
En customize-3d hablan de hacerlo mediante unos puentes entre la tarjeta Arduino y la Melzy, hice un esquema.

resim


Hola, me presento, mi nombre es Pedro y por fin esta semana me llegó la X5S que compré en noviembre.
En Repetier-Host al agregar un objeto lo situa en el centro de la base, Pero cuando importo un g-code generado en Cura entonces lo situa en un extremo de la base, creo que en el Home. He intentado editar el g-code dentro de Repetier pero no consigo desplazarlo al centro de la base.

resim
Citar
Ya está, creo que el otro sistema es usuado principalmente cuando la tarjeta pierde el loader quedando la pantalla en azul

resim
Citar
(11-02-2018, 01:56 PM)Plizze escribió: Ya está, creo que el otro sistema es usuado principalmente cuando la tarjeta pierde el loader quedando la pantalla en azul

resim

Efectivamente, el otro sistema es para cargar el bootloader.

Me alegro que te funcionase.

Un saludo.
Citar
Muy buenas he vuelto a ponerme con la impresora tras estos dias chungo en la Uni xD Y PARA MI SORPRESA cuando digo porfin tengo tiempo le doy a Precalentar y me aparece elsiguiente mensaje....

Error: Al calentar IMPRESORA PARADA Por favor, reinicie

Una de las cosas que mas me llamo la atencion es que cuando le doy a precalentar pasa de 0 a 17 grados la cama y el hotend segun la pantalla (Aunque en verdad no calienta), ahi se queda bloqueado y no varia la temperatura ... Y ahi es cuando aparece el mensaje que he dicho....

Ojala sepais que pasa busque un poco de informacion ya que no he tenido mucho tiempo y vi personas que tenias con otras impresoras problemas "parecidos" y se les recomienda cambiar de version de Marlin asi que seguramente pruebe la version 1.1.6 que pasasteis (Yo tengo la 1.1.8) a ver y tambien vi que en el peor de los casos puede estar algo dañado
Citar
(12-02-2018, 10:12 PM)Wilt Foster escribió: Muy buenas he vuelto a ponerme con la impresora tras estos dias chungo en la Uni xD Y PARA MI SORPRESA cuando digo porfin tengo tiempo le doy a Precalentar y me aparece elsiguiente mensaje....

Error: Al calentar IMPRESORA PARADA Por favor, reinicie

Una de las cosas que mas me llamo la atencion es que cuando le doy a precalentar pasa de 0 a 17 grados la cama y el hotend segun la pantalla (Aunque en verdad no calienta), ahi se queda bloqueado y no varia la temperatura ... Y ahi es cuando aparece el mensaje que he dicho....

Ojala sepais que pasa busque un poco de informacion ya que no he tenido mucho tiempo y vi personas que tenias con otras impresoras problemas "parecidos" y se les recomienda cambiar de version de Marlin asi que seguramente pruebe la version 1.1.6 que pasasteis (Yo tengo la 1.1.8) a ver y tambien vi que en el peor de los casos puede estar algo dañado

Buenas.

Parece mas un problema de cableado, o de la placa. ¿Tienes mosfets instalados?

Un saludo.
Citar
Hola,

Antes de Navidad compre la impresora y la he montado, he conseguido imprimir pero os comento algunas incidencias

El firmware que lleva es Marlin 1.1.7 y no lo he tocado.

Tuve un problema con las targetas micro SD, no las leia, hasta que compre una de 4Gb y con formato FAT la lee perfectamente.

Tuve un problema con con los cables de la cama y hice una pieza con acero.

resim

La cama no era plana y se comvaba hacia adentro por lo que le añadi tres perfiles de aluminio  y unas tiras de silicona como separadores (cortando una bandeja de horno de silicona).

resim

Con estos apaños consigo imprimir algo mas o menos decente en PLA. Si quiero calentar la cama para mejorar la aderencia a 60 grados o asi tarda 45 min en calentarse. Actualmente me ayudo de un secador para el pelo para calentar mas rapidamente la cama.

Por lo que deduzco que los 12voltios de la fuente de alimentacion no son suficientes para poder calentar esta cama de 330 x 330.
Tengo pedida una fuente de 400W y 24 voltios y un pequeño circuito MOSFET para control. Os dejo los links.

https://es.aliexpress.com/item/Salid...311.0.0.TdKz09

https://es.aliexpress.com/item/2017-...311.0.0.TdKz09

Seran demasiado 24 voltios, ¿que os parece?

¿Es suficiente con el MOSFET sin una fuente de alimentacion adicional?

Tambien quiero cambiar lor tornillos que sujetan la cama por unos más largos M3*50mm con las barras de aluminio y las tiras de silicona dejan poco marjen para el ajuste.

El ajuste del eje Z creo que es muy critico para un microruptor y aunque ahora funciona bien, creo que terminará fallando. 
Tengo que pensar alguna forma de colocar-le un sensor optico como final de carrera del eje Z.

(12-02-2018, 10:12 PM)Wilt Foster escribió: Muy buenas he vuelto a ponerme con la impresora tras estos dias chungo en la Uni xD Y PARA MI SORPRESA cuando digo porfin tengo tiempo le doy a Precalentar y me aparece elsiguiente mensaje....

Error: Al calentar IMPRESORA PARADA Por favor, reinicie

Una de las cosas que mas me llamo la atencion es que cuando le doy a precalentar pasa de 0 a 17 grados la cama y el hotend segun la pantalla (Aunque en verdad no calienta), ahi se queda bloqueado y no varia la temperatura ... Y ahi es cuando aparece el mensaje que he dicho....

Ojala sepais que pasa busque un poco de informacion ya que no he tenido mucho tiempo y vi personas que tenias con otras impresoras problemas "parecidos" y se les recomienda cambiar de version de Marlin asi que seguramente pruebe la version 1.1.6 que pasasteis (Yo tengo la 1.1.8) a ver y tambien vi que en el peor de los casos puede estar algo dañado

yo soy novato pero revisaria el cableado. yo cuando enciendo la impresora me pone la temperatura ambiente como temperatura del extrusor y como temperatura de la cama.

resim

Hay muchos conectores que son parecidos.

Yo revisaria los sensores de temperatura y el calefactor de la cama.
Citar