Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Marlin 1.1.9 en Anet A8
#1
Buenas tardes.
Estoy intentando actualizar Marlin a la última versión en mi A8 pero al terminar de compilar me muestra error compilando para la tarjeta Anet v1.0
A alguien le ha pasado?
Existe una definición de tarjeta reciente para arduino?
Compilando la 1.1.8 no me da ningún problema.
¡¡¡¡Los técnicos existimos porque los ingenieros también necesitan héroes!!!!
http://www.reballing.es/viewtopic.php?f=31&t=7591
Citar
#2
Hola, aún no me había enterado de la liberación de la nueva versión.
Estaba esperando su salida para poder implementar el Linear Advance v1.5, que ya viene en esta versión.
Respecto a tu pregunta, acabo de descargarla y he compilado con los archivos de configuración de la A8 sin ningún problema.
¿Puedes poner un pantallazo del error que tienes?
Citar
#3
Esto es lo que me sale. Se refiere al tipo de tarjeta que tengo seleccionada en el IDE

resim

Por lo visto, lo mejor de esta versión es la curva de aceleración, que evita vibraciones y atenúa el ghosting.
¡¡¡¡Los técnicos existimos porque los ingenieros también necesitan héroes!!!!
http://www.reballing.es/viewtopic.php?f=31&t=7591
Citar
#4
Lo que pones son sólo las 2 últimas líneas de log.
Lo que indican es que se aborta la compilación (debido a un error) y que estás compilando para la Anet v1.0, porque es la tarjeta que tienes seleccionada.
Pero antes de ellas hay más, donde se da más información.
Amplía la ventana de notificaciones hacia arriba para ver cual es el error concreto por el que no compila.
Citar
#5
Facepalm


resim
¡¡¡¡Los técnicos existimos porque los ingenieros también necesitan héroes!!!!
http://www.reballing.es/viewtopic.php?f=31&t=7591
Citar
#6
Tienes múltiples errores en los módulos gcode.cpp y parser.cpp, lo que parece indicar que están corruptos.
Te recomiendo que vuelvas a descargar Marlin desde la página oficial y compruebes si se soluciona el problema.
Citar
#7
Yo también me he actualizado al 1.1.9 pero me encuentro con que ahora no me carga la tarjeta sd automáticamente como me hacía en la versión anterior sino que tengo que darle a que la inicie. Os pasa? Si os pasaba y lo arreglasteis: cómo lo hicisteis?
La mía está de serie y lo que le he tocado es la curva de aceleración, el método de calentamiento de la cama y la pausa avanzada, nada de la sd (sdsupport viene por defecto habilitado en la config de la anet)
Citar
#8
(06-08-2018, 01:03 AM)marq3z escribió: Yo también me he actualizado al 1.1.9 pero me encuentro con que ahora no me carga la tarjeta sd automáticamente como me hacía en la versión anterior sino que tengo que darle a que la inicie. Os pasa? Si os pasaba y lo arreglasteis: cómo lo hicisteis?
La mía está de serie y lo que le he tocado es la curva de aceleración, el método de calentamiento de la cama y la pausa avanzada, nada de la sd (sdsupport viene por defecto habilitado en la config de la anet)

Hola, acabo de instalar la nueva versión en mi Anet y como indicas, viene desactivado el autoinicio de la tarjeta SD.
Para habilitarlo, tienes que editar el archivo cardreader.cpp y cambiar el valor del parámetro autostart_index de -1 a 0.
Quedaría así:

...

  // Disable autostart until card is initialized
  autostart_index = 0;

...


Hecho esto, ya inicializa la tarjeta SD al arranque.
Citar
#9
(06-08-2018, 12:14 AM)Simemart escribió: Tienes múltiples errores en los módulos gcode.cpp y parser.cpp, lo que parece indicar que están corruptos.
Te recomiendo que vuelvas a descargar Marlin desde la página oficial y compruebes si se soluciona el problema.

Acabo de descargar nuevamente el Marlin y sigue dando el mismo error en la compilación.
Alguien me puede pasar el que está usando para la Anet A8 para que lo compare con el mío?

EDITO:
Me he descargado la versión 1.1.9 de Github en vez de marlin.org y ésta sí se ha compilado bien...
Nusenuse cosas de la informática...

EDITO2:
Los motores van mucho más suaves. Hacen menos ruido. Imprime más suave y se ha reducido el ghosting...
Genial esta versión.
¡¡¡¡Los técnicos existimos porque los ingenieros también necesitan héroes!!!!
http://www.reballing.es/viewtopic.php?f=31&t=7591
Citar
#10
hola,

recupero este tema para exponer el error de compilación que me sale a mi a ver si me podeis ayudar:

resim
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  ¿MKS Sbase + Marlin 2.0? 3Dsastre 3 82 Hace 5 horas
Último mensaje: Simemart
  El marlin no me hace caso spa_sergio 10 1,331 05-11-2018, 01:17 PM
Último mensaje: Simemart
  Problema autolevel con Marlin 1.1.9 klipendorf 3 802 07-08-2018, 06:15 PM
Último mensaje: Simemart
  CONSULTA Problema con marlin Vicente48 2 287 23-07-2018, 07:50 AM
Último mensaje: Vicente48
  DUDA Actualizar Marlin? JaumeS 1 401 18-07-2018, 05:17 PM
Último mensaje: andatovid