Calificación:
  • 1 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[MONTAJE] Ulticampy v2
#81
tintin_91 escribió:bfff yo he estado un par de horas esta montando los ejes x y y es complicado de narices. Cuando parecía que mas o menos la tenía dominada, apretando uno de los tornillos de las deslizaderas, la pieza de abs ha hecho crack... así que nada, me he quedao atrancao ahí. soys alguno de Zaragoza? a ver si encuentro alguien que sea de aquí para pedirle que me haga la pieza, porque hasta que no la tenga no puedo cseguir con el montaje... Triste

Tengo los carros X e Y originales y los nuevos que están en la wiki (los que siguen yendo con tornillos), los dos impresos por Campy, me cargué dos de los últimos tensando las correas. Llevo 3 veces quitada la parte superior para calibrar, la última ni se han movido las varillas al quitarla, hay que tener mucha paciencia y mucho tacto, pero se puede hacer.

Yo lo que estoy haciendo para tensar bien las correas es ponerlas mas o menos tensas con todo montado (menos la tapa de arriba), luego sacar las barillas y a ojo meter un par de dientes mas en los carros, vuelvo a montar varillas y queda muy tenso. Ahora ya casi lo tengo funcionando perfectamente pero uno de los carros pierde tensión, se ve que no aprieta bien. Cuando esté la versión final de los carros sin tornillos será mucho más sencillo, pero hay que hacerlos bien y requeteprobarlos, supongo que los que hay sin tornillos ahora en la wiki no terminan de ir bien.

Así que de momento no termino de hacer círculos perfectos, aunque la máquina está funcionando.
Citar
#82
shiryou escribió:- Mejoras y consejos... a ver el montaje se puede atragantar un poco, hay que tomárselo con calma, y tener en cuenta que estamos hablando de un producto "hecho en casa". Hay momentos en que yo la habría estampado contra la pared, pero si te lo tomas con calma y piensas al final todo termina encajando.
Sobre la impresora en si, tiene sus cosillas, pero se ve que se van a solucionar todas o casi todas, el no tener tornillos en las deslizaderas es un grandísimo avance, esos tornillos había que exterminarlos!! Ah! bueno, los agujeros para pasar los cables a la parte de abajo, un poquillos mas grandes estaría genial Lengua y tornillos, mejor pasarse que no ir tan justos, a mi me faltaron y menos mal que tenia por casa por que por aquí no tienen de estos tamaños en ningún lado..., el hueco donde va el servo tendría que ser mas grande y tener un huequecito para sacar el cable mas cómodamente... y las poleas, habria que ponerlas de manera que sean mas accesibles, hay 2 o 3 que están complicadetes... y hasta aquí mis quejas xDDDDD (lo siento campy)
saludos!

Gracias Shiryou por las sugerencias Guiño

Comentarte que ya hemos empezado las pruebas de los componentes nuevos, por lo que, si todo va bien, esperamos poder compartirlos pronto.

Efectivmante, estamos probando unas deslizderas laterales sin tornillos y un carro compacto que incluiría dos hotends, el ventilador de capa y el sensor capacitivo (o servo, aquí lo que cada uno quiera). Tenemos muchos más trabajos en curso, pero así que le urjan a la comunidad, sólo estos.

Con respecto a la tensión de las correas... tampoco os paséis tensando, o transimitéis demasiado esfuerzo a los rodamientos, poleas y varillas, haciendo que el mecanismo no vaya tan suave como podría.

En las pruebas que hemos hecho, las deslizaderas sin tornillos aguantan sin problemas 6 Kg de tensión, más que suficiente para la impresora. No están pensadas para que tirés con todas vuestras ganas hasta que parta el metacrilato, no es necesario Confundidois1:

Luego estamos dibujando y probando soportes para bobinas, empujadores, nuevos diseños de cama, nueva ubicación del LCD...

Esperamos poder traer novedades pronto Mola
Citar
#83
JPS escribió:
tintin_91 escribió:bfff yo he estado un par de horas esta montando los ejes x y y es complicado de narices. Cuando parecía que mas o menos la tenía dominada, apretando uno de los tornillos de las deslizaderas, la pieza de abs ha hecho crack... así que nada, me he quedao atrancao ahí. soys alguno de Zaragoza? a ver si encuentro alguien que sea de aquí para pedirle que me haga la pieza, porque hasta que no la tenga no puedo cseguir con el montaje... Triste

Tengo los carros X e Y originales y los nuevos que están en la wiki (los que siguen yendo con tornillos), los dos impresos por Campy, me cargué dos de los últimos tensando las correas. Llevo 3 veces quitada la parte superior para calibrar, la última ni se han movido las varillas al quitarla, hay que tener mucha paciencia y mucho tacto, pero se puede hacer.

Yo lo que estoy haciendo para tensar bien las correas es ponerlas mas o menos tensas con todo montado (menos la tapa de arriba), luego sacar las barillas y a ojo meter un par de dientes mas en los carros, vuelvo a montar varillas y queda muy tenso. Ahora ya casi lo tengo funcionando perfectamente pero uno de los carros pierde tensión, se ve que no aprieta bien. Cuando esté la versión final de los carros sin tornillos será mucho más sencillo, pero hay que hacerlos bien y requeteprobarlos, supongo que los que hay sin tornillos ahora en la wiki no terminan de ir bien.

Así que de momento no termino de hacer círculos perfectos, aunque la máquina está funcionando.

Cita:shiryou escribió:
- Mejoras y consejos... a ver el montaje se puede atragantar un poco, hay que tomárselo con calma, y tener en cuenta que estamos hablando de un producto "hecho en casa". Hay momentos en que yo la habría estampado contra la pared, pero si te lo tomas con calma y piensas al final todo termina encajando.
Sobre la impresora en si, tiene sus cosillas, pero se ve que se van a solucionar todas o casi todas, el no tener tornillos en las deslizaderas es un grandísimo avance, esos tornillos había que exterminarlos!! Ah! bueno, los agujeros para pasar los cables a la parte de abajo, un poquillos mas grandes estaría genial Lengua y tornillos, mejor pasarse que no ir tan justos, a mi me faltaron y menos mal que tenia por casa por que por aquí no tienen de estos tamaños en ningún lado..., el hueco donde va el servo tendría que ser mas grande y tener un huequecito para sacar el cable mas cómodamente... y las poleas, habria que ponerlas de manera que sean mas accesibles, hay 2 o 3 que están complicadetes... y hasta aquí mis quejas xDDDDD (lo siento campy)
saludos!

JPS ya esta solucionado el problema del backlash en los círculos Gran sonrisa con un marlin que termine anoche con corrección,

Shiryou jajajajaa, se que lo dices con cariño, esta noche en el otro hilo pongo fotillos de los avances y carros nuevos, ahora se desmontan en un momento al igual que el carro central y las correas se tensan con la mano :one: , yo tambien e ganado calidad de vida con este nuevo sistema :elrisas:
Impresoras 3D Open Source
3DCampy.com
Citar
#84
campy escribió:
JPS escribió:
tintin_91 escribió:bfff yo he estado un par de horas esta montando los ejes x y y es complicado de narices. Cuando parecía que mas o menos la tenía dominada, apretando uno de los tornillos de las deslizaderas, la pieza de abs ha hecho crack... así que nada, me he quedao atrancao ahí. soys alguno de Zaragoza? a ver si encuentro alguien que sea de aquí para pedirle que me haga la pieza, porque hasta que no la tenga no puedo cseguir con el montaje... Triste

Tengo los carros X e Y originales y los nuevos que están en la wiki (los que siguen yendo con tornillos), los dos impresos por Campy, me cargué dos de los últimos tensando las correas. Llevo 3 veces quitada la parte superior para calibrar, la última ni se han movido las varillas al quitarla, hay que tener mucha paciencia y mucho tacto, pero se puede hacer.

Yo lo que estoy haciendo para tensar bien las correas es ponerlas mas o menos tensas con todo montado (menos la tapa de arriba), luego sacar las barillas y a ojo meter un par de dientes mas en los carros, vuelvo a montar varillas y queda muy tenso. Ahora ya casi lo tengo funcionando perfectamente pero uno de los carros pierde tensión, se ve que no aprieta bien. Cuando esté la versión final de los carros sin tornillos será mucho más sencillo, pero hay que hacerlos bien y requeteprobarlos, supongo que los que hay sin tornillos ahora en la wiki no terminan de ir bien.

Así que de momento no termino de hacer círculos perfectos, aunque la máquina está funcionando.

Cita:shiryou escribió:
- Mejoras y consejos... a ver el montaje se puede atragantar un poco, hay que tomárselo con calma, y tener en cuenta que estamos hablando de un producto "hecho en casa". Hay momentos en que yo la habría estampado contra la pared, pero si te lo tomas con calma y piensas al final todo termina encajando.
Sobre la impresora en si, tiene sus cosillas, pero se ve que se van a solucionar todas o casi todas, el no tener tornillos en las deslizaderas es un grandísimo avance, esos tornillos había que exterminarlos!! Ah! bueno, los agujeros para pasar los cables a la parte de abajo, un poquillos mas grandes estaría genial Lengua y tornillos, mejor pasarse que no ir tan justos, a mi me faltaron y menos mal que tenia por casa por que por aquí no tienen de estos tamaños en ningún lado..., el hueco donde va el servo tendría que ser mas grande y tener un huequecito para sacar el cable mas cómodamente... y las poleas, habria que ponerlas de manera que sean mas accesibles, hay 2 o 3 que están complicadetes... y hasta aquí mis quejas xDDDDD (lo siento campy)
saludos!

JPS ya esta solucionado el problema del backlash en los círculos Gran sonrisa con un marlin que termine anoche con corrección,

Shiryou jajajajaa, se que lo dices con cariño, esta noche en el otro hilo pongo fotillos de los avances y carros nuevos, ahora se desmontan en un momento al igual que el carro central y las correas se tensan con la mano :one: , yo tambien e ganado calidad de vida con este nuevo sistema :elrisas:

Esperamos con impaciencia ese marlin y esos carros laterales nuevos! Por cierto, me uno a las felicitaciones tanto a Campy, fndangulo y demás usuarios que están colaborando en la sombra por el trabajo que estais haciendo! Tiene todo una pinta increíble
Citar
#85
campy escribió:
JPS escribió:
tintin_91 escribió:bfff yo he estado un par de horas esta montando los ejes x y y es complicado de narices. Cuando parecía que mas o menos la tenía dominada, apretando uno de los tornillos de las deslizaderas, la pieza de abs ha hecho crack... así que nada, me he quedao atrancao ahí. soys alguno de Zaragoza? a ver si encuentro alguien que sea de aquí para pedirle que me haga la pieza, porque hasta que no la tenga no puedo cseguir con el montaje... Triste

Tengo los carros X e Y originales y los nuevos que están en la wiki (los que siguen yendo con tornillos), los dos impresos por Campy, me cargué dos de los últimos tensando las correas. Llevo 3 veces quitada la parte superior para calibrar, la última ni se han movido las varillas al quitarla, hay que tener mucha paciencia y mucho tacto, pero se puede hacer.

Yo lo que estoy haciendo para tensar bien las correas es ponerlas mas o menos tensas con todo montado (menos la tapa de arriba), luego sacar las barillas y a ojo meter un par de dientes mas en los carros, vuelvo a montar varillas y queda muy tenso. Ahora ya casi lo tengo funcionando perfectamente pero uno de los carros pierde tensión, se ve que no aprieta bien. Cuando esté la versión final de los carros sin tornillos será mucho más sencillo, pero hay que hacerlos bien y requeteprobarlos, supongo que los que hay sin tornillos ahora en la wiki no terminan de ir bien.

Así que de momento no termino de hacer círculos perfectos, aunque la máquina está funcionando.

Cita:shiryou escribió:
- Mejoras y consejos... a ver el montaje se puede atragantar un poco, hay que tomárselo con calma, y tener en cuenta que estamos hablando de un producto "hecho en casa". Hay momentos en que yo la habría estampado contra la pared, pero si te lo tomas con calma y piensas al final todo termina encajando.
Sobre la impresora en si, tiene sus cosillas, pero se ve que se van a solucionar todas o casi todas, el no tener tornillos en las deslizaderas es un grandísimo avance, esos tornillos había que exterminarlos!! Ah! bueno, los agujeros para pasar los cables a la parte de abajo, un poquillos mas grandes estaría genial Lengua y tornillos, mejor pasarse que no ir tan justos, a mi me faltaron y menos mal que tenia por casa por que por aquí no tienen de estos tamaños en ningún lado..., el hueco donde va el servo tendría que ser mas grande y tener un huequecito para sacar el cable mas cómodamente... y las poleas, habria que ponerlas de manera que sean mas accesibles, hay 2 o 3 que están complicadetes... y hasta aquí mis quejas xDDDDD (lo siento campy)
saludos!

JPS ya esta solucionado el problema del backlash en los círculos Gran sonrisa con un marlin que termine anoche con corrección,

Shiryou jajajajaa, se que lo dices con cariño, esta noche en el otro hilo pongo fotillos de los avances y carros nuevos, ahora se desmontan en un momento al igual que el carro central y las correas se tensan con la mano :one: , yo tambien e ganado calidad de vida con este nuevo sistema :elrisas:

Por supuesto campy! siempre con las miras puestas en mejorar!, pero espera que sigo!!! que me voy acordando de cosas, jajaja!!!

Una cosa importante y que seguro que os han comentado, hay una tuerca de los laterales que toca con los motores de los extrusores, no se los demas, pero Soer y yo hemos optado por no poner ese tornillo y listo... pero lo suyo seria mover el motor un poquillo mas para arriba ¿no?

@fdoangulo: Ya vi las fotos del doble extrusor y tiene una pinta alucinante!!!! GENIAL TRABAJO!!! lo habeis probado ya??? que tal el ventilador de capa? suelta una buena cantidad de aire??? sebes lo que estaria genial??? poder girar la salida de aire, hacerla en 2 piezas vamos para poder hacer que el aire de mas a la pieza o mas a la punta del hot end...
en general lo que me ha ido enseñando campi tiene muy buena pinta, como le decia, ahora que he conseguido hacerla funcionar, veo las piezas y me entra la SAV-pereza!!! xDDDD cuando saqueis suficientes updates y me de para pillar otro e3d, monto todo de nuevo, y ya aprovechare para recablear y reorganizar todo un poco, jejeje

gracias de nuevo gente! un saludo!
Citar
#86
campy escribió:
JPS escribió:
tintin_91 escribió:bfff yo he estado un par de horas esta montando los ejes x y y es complicado de narices. Cuando parecía que mas o menos la tenía dominada, apretando uno de los tornillos de las deslizaderas, la pieza de abs ha hecho crack... así que nada, me he quedao atrancao ahí. soys alguno de Zaragoza? a ver si encuentro alguien que sea de aquí para pedirle que me haga la pieza, porque hasta que no la tenga no puedo cseguir con el montaje... Triste

Tengo los carros X e Y originales y los nuevos que están en la wiki (los que siguen yendo con tornillos), los dos impresos por Campy, me cargué dos de los últimos tensando las correas. Llevo 3 veces quitada la parte superior para calibrar, la última ni se han movido las varillas al quitarla, hay que tener mucha paciencia y mucho tacto, pero se puede hacer.

Yo lo que estoy haciendo para tensar bien las correas es ponerlas mas o menos tensas con todo montado (menos la tapa de arriba), luego sacar las barillas y a ojo meter un par de dientes mas en los carros, vuelvo a montar varillas y queda muy tenso. Ahora ya casi lo tengo funcionando perfectamente pero uno de los carros pierde tensión, se ve que no aprieta bien. Cuando esté la versión final de los carros sin tornillos será mucho más sencillo, pero hay que hacerlos bien y requeteprobarlos, supongo que los que hay sin tornillos ahora en la wiki no terminan de ir bien.

Así que de momento no termino de hacer círculos perfectos, aunque la máquina está funcionando.

Cita:shiryou escribió:
- Mejoras y consejos... a ver el montaje se puede atragantar un poco, hay que tomárselo con calma, y tener en cuenta que estamos hablando de un producto "hecho en casa". Hay momentos en que yo la habría estampado contra la pared, pero si te lo tomas con calma y piensas al final todo termina encajando.
Sobre la impresora en si, tiene sus cosillas, pero se ve que se van a solucionar todas o casi todas, el no tener tornillos en las deslizaderas es un grandísimo avance, esos tornillos había que exterminarlos!! Ah! bueno, los agujeros para pasar los cables a la parte de abajo, un poquillos mas grandes estaría genial Lengua y tornillos, mejor pasarse que no ir tan justos, a mi me faltaron y menos mal que tenia por casa por que por aquí no tienen de estos tamaños en ningún lado..., el hueco donde va el servo tendría que ser mas grande y tener un huequecito para sacar el cable mas cómodamente... y las poleas, habria que ponerlas de manera que sean mas accesibles, hay 2 o 3 que están complicadetes... y hasta aquí mis quejas xDDDDD (lo siento campy)
saludos!

JPS ya esta solucionado el problema del backlash en los círculos Gran sonrisa con un marlin que termine anoche con corrección,

Shiryou jajajajaa, se que lo dices con cariño, esta noche en el otro hilo pongo fotillos de los avances y carros nuevos, ahora se desmontan en un momento al igual que el carro central y las correas se tensan con la mano :one: , yo tambien e ganado calidad de vida con este nuevo sistema :elrisas:

Cojonudo, ya veo que está el firmware nuevo en la wiki, en cuanto pueda lo actualizo. Ahora a esperar los carros nuevos como agua de mayo, mucho más cómodo que ir desmontando y montando, por que aunque ya tengo facilidad para quitar la tapa superior se lleva un ratito.
Citar
#87
Hola, ya he terminado de montar todo. Ahora creo que vendrá lo más complicado, hacerla funcionar.
A ver si alguien me puede ayudar. He metido el marlin, y me he descargado Pronterface para intentar calibrar los motores, pero no consigo que se mueva nada... He probado solo con 1 motor (descomentando en el marlin los parámetros mínimos de temperatura para imprimir), con varios motores distintos, conectándolos a distintos pines y nada... He de decir que en la pantalla LCD no se me ve nada, se queda todo el rato en azul.
Lo último que he probado ha sido conectar todo, y he de decir que se me mueven tanto el ventilador de la ramps como el del cuerpo del extrusor, y la lcd se enciende, los motores cuando pulso desde protnterface que se muevan, hacen intención de moverse sólo la primera vez, luego ya no hacen nada. Desde pronterface también me deja calentar la cama y el extrusor, el único problema que tengo es el de los motores... A ver si alguien me puede arrojar algo de luz! Gracias de antemano y un saludo (adjunto foto de como se me queda la pantalla).


Archivos adjuntos Miniatura(s)
   
Citar
#88
Shiryou, a que tuercas te refieres exactamente?

Tintín, primero hay que solucionar lo de la pantalla, ¿La tienes bien conectada y en el Marlin descomentada la línea adecuada? Péganos esa parte del Marlin para poder comprobarlo y ayudarte.
Por otro lado, lo de los motores, vendría muy bien si nos haces un croquis de como tienes exactamente conectados los cables de los motores. También puedes hacer la prueba de continuidad con el polímetro para asegurarte de que está bien el orden del cableado con respecto a las bobinas de dentro.
Citar
#89
resim

Este q te pongo pero en el lado izquierdo. Lo tuve q quitar porque no había manera de apoyar bien el motor del extrusor. A razoner y a soer les paso exactamente lo mismo... Es la tuerca del tornillo a media altura de los paneles laterales, de la Unión del panel trasero

Un saludo


Enviado desde mi iPhone utilizando Tapatalk
Citar
#90
repente escribió:Shiryou, a que tuercas te refieres exactamente?

Tintín, primero hay que solucionar lo de la pantalla, ¿La tienes bien conectada y en el Marlin descomentada la línea adecuada? Péganos esa parte del Marlin para poder comprobarlo y ayudarte.
Por otro lado, lo de los motores, vendría muy bien si nos haces un croquis de como tienes exactamente conectados los cables de los motores. También puedes hacer la prueba de continuidad con el polímetro para asegurarte de que está bien el orden del cableado con respecto a las bobinas de dentro.

Hola repente, gracias por tu ayuda. Efectivamente al hacer la prueba de los motores no coincidían los colores del motor para ir a la ramps, así que cambiándolos ya he conseguido mover los ejes x e y, mañana a ver si lo consigo con el z.

Por otra parte, te adjunto a continuación la parte del Marlin correspondiente a la pantalla. He probado comentando y descomentando varias opciones y nada (he adjuntado también la librería u8glib). Sigue todo igual, se enciende pero no muestra nada, y al pulsar el botón si que hace el bipp. Tengo la oficial de la conjunta que es la full graphics.

Lo dicho, gracias por la ayuda y a ver si encuentras el fallo de la LCD que me tiene loco.

Código:
[spoiler]
//==============================LCD and SD support=============================

// Define your display language below. Replace (en) with your language code and uncomment.
// en, pl, fr, de, es, ru, it, pt, pt-br, fi, an, nl, ca, eu
// See also language.h
//#define LANGUAGE_INCLUDE GENERATE_LANGUAGE_INCLUDE(en)

// Character based displays can have different extended charsets.
#define DISPLAY_CHARSET_HD44780_JAPAN     // "ääööüüß23°"
//#define DISPLAY_CHARSET_HD44780_WESTERN // "ÄäÖöÜüß²³°" if you see a '~' instead of a 'arrow_right' at the right of submenuitems - this is the right one.

//#define ULTRA_LCD  //general LCD support, also 16x2
//#define DOGLCD  // Support for SPI LCD 128x64 (Controller ST7565R graphic Display Family)
//#define SDSUPPORT // Enable SD Card Support in Hardware Console
//#define SDSLOW // Use slower SD transfer mode (not normally needed - uncomment if you're getting volume init error)
//#define SD_CHECK_AND_RETRY // Use CRC checks and retries on the SD communication
//#define ENCODER_PULSES_PER_STEP 1 // Increase if you have a high resolution encoder
//#define ENCODER_STEPS_PER_MENU_ITEM 5 // Set according to ENCODER_PULSES_PER_STEP or your liking
//#define ULTIMAKERCONTROLLER //as available from the Ultimaker online store.
//#define ULTIPANEL  //the UltiPanel as on Thingiverse
//#define LCD_FEEDBACK_FREQUENCY_HZ 1000    // this is the tone frequency the buzzer plays when on UI feedback. ie Screen Click
//#define LCD_FEEDBACK_FREQUENCY_DURATION_MS 100 // the duration the buzzer plays the UI feedback sound. ie Screen Click

// PanelOne from T3P3 (via RAMPS 1.4 AUX2/AUX3)
// http://reprap.org/wiki/PanelOne
//#define PANEL_ONE

// The MaKr3d Makr-Panel with graphic controller and SD support
// http://reprap.org/wiki/MaKr3d_MaKrPanel
//#define MAKRPANEL

// The Panucatt Devices Viki 2.0 and mini Viki with Graphic LCD
// http://panucatt.com
// ==> REMEMBER TO INSTALL U8glib to your ARDUINO library folder: http://code.google.com/p/u8glib/wiki/u8glib
//#define VIKI2
//#define miniVIKI

// The RepRapDiscount Smart Controller (white PCB)
// http://reprap.org/wiki/RepRapDiscount_Smart_Controller
//#define REPRAP_DISCOUNT_SMART_CONTROLLER

// The GADGETS3D G3D LCD/SD Controller (blue PCB)
// http://reprap.org/wiki/RAMPS_1.3/1.4_GADGETS3D_Shield_with_Panel
//#define G3D_PANEL

// The RepRapDiscount FULL GRAPHIC Smart Controller (quadratic white PCB)
// http://reprap.org/wiki/RepRapDiscount_Full_Graphic_Smart_Controller
//
// ==> REMEMBER TO INSTALL U8glib to your ARDUINO library folder: http://code.google.com/p/u8glib/wiki/u8glib
#define REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER

// The RepRapWorld REPRAPWORLD_KEYPAD v1.1
// http://reprapworld.com/?products_details&products_id=202&cPath=1591_1626
//#define REPRAPWORLD_KEYPAD
//#define REPRAPWORLD_KEYPAD_MOVE_STEP 10.0 // how much should be moved when a key is pressed, eg 10.0 means 10mm per click

// The Elefu RA Board Control Panel
// http://www.elefu.com/index.php?route=product/product&product_id=53
// REMEMBER TO INSTALL LiquidCrystal_I2C.h in your ARDUINO library folder: https://github.com/kiyoshigawa/LiquidCrystal_I2C
//#define RA_CONTROL_PANEL

//automatic expansion
#if defined (MAKRPANEL)
#define DOGLCD
#define SDSUPPORT
#define ULTIPANEL
#define NEWPANEL
#define DEFAULT_LCD_CONTRAST 17
#endif

#if defined(miniVIKI) || defined(VIKI2)
#define ULTRA_LCD  //general LCD support, also 16x2
#define DOGLCD  // Support for SPI LCD 128x64 (Controller ST7565R graphic Display Family)
#define ULTIMAKERCONTROLLER //as available from the Ultimaker online store.

  #ifdef miniVIKI
   #define DEFAULT_LCD_CONTRAST 95
  #else
   #define DEFAULT_LCD_CONTRAST 40
  #endif
  
#define ENCODER_PULSES_PER_STEP 4
#define ENCODER_STEPS_PER_MENU_ITEM 1
#endif

#if defined (PANEL_ONE)
#define SDSUPPORT
#define ULTIMAKERCONTROLLER
#endif

#if defined (REPRAP_DISCOUNT_FULL_GRAPHIC_SMART_CONTROLLER)
#define DOGLCD
#define U8GLIB_ST7920
#define REPRAP_DISCOUNT_SMART_CONTROLLER
#endif

#if defined(ULTIMAKERCONTROLLER) || defined(REPRAP_DISCOUNT_SMART_CONTROLLER) || defined(G3D_PANEL)
#define ULTIPANEL
#define NEWPANEL
#endif

#if defined(REPRAPWORLD_KEYPAD)
  #define NEWPANEL
  #define ULTIPANEL
#endif
#if defined(RA_CONTROL_PANEL)
#define ULTIPANEL
#define NEWPANEL
#define LCD_I2C_TYPE_PCA8574
#define LCD_I2C_ADDRESS 0x27   // I2C Address of the port expander
#endif

//I2C PANELS

//#define LCD_I2C_SAINSMART_YWROBOT
#ifdef LCD_I2C_SAINSMART_YWROBOT
  // This uses the LiquidCrystal_I2C library ( https://bitbucket.org/fmalpartida/new-liquidcrystal/wiki/Home )
  // Make sure it is placed in the Arduino libraries directory.
  #define LCD_I2C_TYPE_PCF8575
  #define LCD_I2C_ADDRESS 0x27   // I2C Address of the port expander
  #define NEWPANEL
  #define ULTIPANEL
#endif

// PANELOLU2 LCD with status LEDs, separate encoder and click inputs
//#define LCD_I2C_PANELOLU2
#ifdef LCD_I2C_PANELOLU2
  // This uses the LiquidTWI2 library v1.2.3 or later ( https://github.com/lincomatic/LiquidTWI2 )
  // Make sure the LiquidTWI2 directory is placed in the Arduino or Sketchbook libraries subdirectory.
  // (v1.2.3 no longer requires you to define PANELOLU in the LiquidTWI2.h library header file)
  // Note: The PANELOLU2 encoder click input can either be directly connected to a pin
  //       (if BTN_ENC defined to != -1) or read through I2C (when BTN_ENC == -1).
  #define LCD_I2C_TYPE_MCP23017
  #define LCD_I2C_ADDRESS 0x20 // I2C Address of the port expander
  #define LCD_USE_I2C_BUZZER //comment out to disable buzzer on LCD
  #define NEWPANEL
  #define ULTIPANEL

  #ifndef ENCODER_PULSES_PER_STEP
    #define ENCODER_PULSES_PER_STEP 4
  #endif

  #ifndef ENCODER_STEPS_PER_MENU_ITEM
    #define ENCODER_STEPS_PER_MENU_ITEM 1
  #endif


  #ifdef LCD_USE_I2C_BUZZER
    #define LCD_FEEDBACK_FREQUENCY_HZ 1000
    #define LCD_FEEDBACK_FREQUENCY_DURATION_MS 100
  #endif

#endif

// Panucatt VIKI LCD with status LEDs, integrated click & L/R/U/P buttons, separate encoder inputs
//#define LCD_I2C_VIKI
#ifdef LCD_I2C_VIKI
  // This uses the LiquidTWI2 library v1.2.3 or later ( https://github.com/lincomatic/LiquidTWI2 )
  // Make sure the LiquidTWI2 directory is placed in the Arduino or Sketchbook libraries subdirectory.
  // Note: The pause/stop/resume LCD button pin should be connected to the Arduino
  //       BTN_ENC pin (or set BTN_ENC to -1 if not used)
  #define LCD_I2C_TYPE_MCP23017
  #define LCD_I2C_ADDRESS 0x20 // I2C Address of the port expander
  #define LCD_USE_I2C_BUZZER //comment out to disable buzzer on LCD (requires LiquidTWI2 v1.2.3 or later)
  #define NEWPANEL
  #define ULTIPANEL
#endif

// Shift register panels
// ---------------------
// 2 wire Non-latching LCD SR from:
// https://bitbucket.org/fmalpartida/new-liquidcrystal/wiki/schematics#!shiftregister-connection

//#define SAV_3DLCD
#ifdef SAV_3DLCD
   #define SR_LCD_2W_NL    // Non latching 2 wire shiftregister
   #define NEWPANEL
   #define ULTIPANEL
#endif


#ifdef ULTIPANEL
//  #define NEWPANEL  //enable this if you have a click-encoder panel
  #define SDSUPPORT
  #define ULTRA_LCD
  #ifdef DOGLCD // Change number of lines to match the DOG graphic display
    #define LCD_WIDTH 22
    #define LCD_HEIGHT 5
  #else
    #define LCD_WIDTH 20
    #define LCD_HEIGHT 4
  #endif
#else //no panel but just LCD
  #ifdef ULTRA_LCD
  #ifdef DOGLCD // Change number of lines to match the 128x64 graphics display
    #define LCD_WIDTH 22
    #define LCD_HEIGHT 5
  #else
    #define LCD_WIDTH 16
    #define LCD_HEIGHT 2
  #endif
  #endif
#endif

// default LCD contrast for dogm-like LCD displays
#ifdef DOGLCD
# ifndef DEFAULT_LCD_CONTRAST
#  define DEFAULT_LCD_CONTRAST 32
# endif
#endif[/spoiler]
Citar
#91
Igual es una pregunta tonta pero: ¿has movido el potenciómetro para ajustar el contraste? Si es así vas a tener que poner una resistencia en 2 pines de la pantalla LCD, a la mía le pasaba lo mismo y era eso... ya me dices y te explico como ponerla
Citar
#92
Si, lo he movido y nada... Algo he leído por ahí de una ressistencia
Citar
#93
Aqui lo tienes puesto ;D

http://spainlabs.com/foro/viewtopic.php?f=32&t=3138
Citar
#94
Bueno, pues en efecto se ha solucionado soldando la resistencia. Poco a poco va saliendo todo. A ver si mañana puedo avanzar mas. Gracias por la ayuda!


Archivos adjuntos Miniatura(s)
       
Citar
#95
shiryou escribió:Aqui lo tienes puesto ;D

http://spainlabs.com/foro/viewtopic.php?f=32&t=3138

Tendré que probar por que a mi también me pasa, lo curioso es que me pasa solo cuando está conectada la placa al USB, si quito el USB y enciendo la impresora el LCD funciona, probaré lo de la resistencia.

Otra cosa que también me pasa y que es bastante jodida es que el servo me hace interferencias y se vuelve loco, cuando está calentado el extrusor y llega a temperatura máxima el servo empieza a moverse a lo loco. Creo que debe haber algún problema con la alimentación a 5v, no se si os a pasado alguno mas. La solución por el momento es hacer manualmente el G28 y G29 y después imprimir, ya que si lanzo la impresión con esos códigos, el G29 no termina por que el servo se ha vuelto loco.
Citar
#96
Eso le pasa a Razoner, desde que montó el servo, cada vez que toca el extrusor con unas pinzas para quitar restos de plastico, el servo se le vuelve loco y se le baja solo y cosas asi xD
a mi en cambio eso no me pasas.

y lo otro que comentas del USB ni idea, a mi prusita le pasaba al reves, enchufada al usb del pc funcionaba a las mil maravillas, pero sin el USB se me quedaba la pantalla en azul. Claramente es cosa del regulador, pero bueno, como no la tenia autonoma me daba un poco lo mismo...
Citar
#97
Buenas tardes a todos, tengo serior problemas a la hora de compilar el marlin con mi Mac... estoy bastante harto del mac porque no es un ordenador, es una caja bonita con internet... y me jode porque me capa muchas cosas. Alguien, por favor, ¿puede iluminarme el camino y echarme una mano con la compilación del marlin en mac? Os lo agradezco de corazón. Espero que la solución no sea comprarme un pc...
Citar
#98
Spoiler_3D escribió:Buenas tardes a todos, tengo serior problemas a la hora de compilar el marlin con mi Mac... estoy bastante harto del mac porque no es un ordenador, es una caja bonita con internet... y me jode porque me capa muchas cosas. Alguien, por favor, ¿puede iluminarme el camino y echarme una mano con la compilación del marlin en mac? Os lo agradezco de corazón. Espero que la solución no sea comprarme un pc...


Yo también uso Mac y no he tenido ningún problema.
-Te descargas arduino y lo pasas a la carpeta aplicaciones.
-Abres la aplicación
-Una vez abierto arduino, eliges el puerto al que has conectado tu impresora y la placa controladora (arduino mega 2560).
-Te descargas el Marlin de la wiki subido por Campy y abres el archivo marlin.ino en arduino
-Debes importar la librería u8glib , que está en la carpeta:
Marlin + Hysteresis/Marlin-Development/ArduinoAddons/Arduino_1.5.x/hardware/marlin/avr/libraries
-Compilas (no debería darte ningún error)
-Archivo subir

Y si todo está bien mientras se sube el firmware a la placa debería parpadear.
Citar
#99
Después de desmontar las poleas 3 o 4 veces y reconfigurar varias veces la parte mecánica he probado a ajustar los drivers desde 380mA hasta 1050mA, en principio los de los ejes Y, X y Z los tuve funcionando a 500mA. Después de subirlos hasta 1000mA a ver si solucionaba un problema que tenía, me puse a probar a la baja y los tengo funcionando en 380mA, así los motores no calientan casi y todo funciona correctamente.

Digo esto por que he leído de todo y tenía un pequeño lío, no se quién comentó que los tenía a 350mA y funcionaban, creo que dracnas los tenía funcionando a 1050mA, si no, no movía ejes. Yo tengo la configuración oficial de Campy, le compré todos los materiales a él, no se si las potencias variarán en función de electrónicas y motores diferentes. Las potencias las he medido todas con multímetro y la parte mecánica me funciona muy suave, se puede mover fácilmente con la mano, ayer realicé una impresión de 3 horas y la máquina estuvo funcionando sin problemas.

Por cierto el extrusor lo tengo a 550mA, todo lo anterior hace referencia a los ejes Y, X y Z

Me gustaría ver un poco como lo tenéis los demás para comprar y dejar constancia a lo que vengan detrás.
Citar
Gracias por compartir esos datos JPS. La verdad es que es interesante si compartimos todos esos ajustes
¿Que pololus usas? ¿Que config de pasos tienes (1/16, 1/32)?

Un saludo!!
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  dudas montaje Heat Bed Cama caliente Silicona Asier esnal 26 5,705 10-09-2018, 10:59 AM
Último mensaje: Thingibox
  [PROYECTO] Ulticampy impresora 3D tipo Ultimaker o Makerbot campy 977 123,691 26-10-2017, 07:42 PM
Último mensaje: shaftman
  Extrusor directo ulticampy fbforos 0 529 05-06-2017, 04:25 PM
Último mensaje: fbforos
  [ULTICAMPY] ¿Alguien ha diseñado espejos intercambiables? Lepes 9 1,407 08-09-2016, 11:51 AM
Último mensaje: Lepes
  [HUMOR] La verdad al descubierto: Montaje impresora DIY Lepes 5 1,193 24-06-2016, 09:36 AM
Último mensaje: Lepes