Calificación:
  • 1 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[MONTAJE] Ulticampy v2
(10-02-2016, 10:43 AM)neoxM3 escribió: G29 E ya no funciona en el marlin nuevo, porque G29 ya no levanta el brazo del servo en cada prueba, en el marlin nuevo...

Pues debo de tener uno antiguo ya que el mio parece una maquina de coser Guiño

Lo probaré, gracias
Citar
Hola a todos. Soy nuevo con la ulticampy, y con todas las demas, jeje.

La tengo montada y funcionando con el firm 1.0.2 que subio campy a github.

Solo he ajustado lo basico, pasos de motores y area de impresion, y la cosa va bien por ahora.

Como le empiezo a perder un poco de miedo a esto del arduino, se me dio por cargar el marlin 1.1 rc3.

He ido "copiando" las configuraciones de la version anterior y he conseguido imprimir bien.

El problema es que si muevo el eje z desde el control, este se vuelve loco...

Os dejo un video:



Otros problemas de montaje..

Pues los conectores del lcd me roza con la base de impresion. Vosotros como lo solucionais? Si la acerco mas al metacrilato no me entra la sd por la ranura.


En cuanto a la base de impresion, estoy por "copiar" sin escrupulos la de la ultimaker. En aluminio y con los clips para sujetar el cristal.

Mas que nada, es que el con las pinzas típicas, me tropieza el blower.

Incluso he pesado en imanes.

Estoy abierto a comentarios e ideas.


Muchas gracias y perdonad el ladrillo. Vaya forma de estrenarme.

Gracias.
Citar
Hola, buenas tardes.

Dada la poca precisión del autolevel por el tema de que la bandeja es la que sube y baja, y viendo que Campy hace tiempo comentó de prescindir del servo, he decidido quitarlo.
Había impresiones que me las hacia bien, pero había otras que por muy poca diferencia pero no se llegaba a pegar el plástico al cristal como yo quería. Eso hacia que hasta que comenzaba una impresión en condiciones tenia que estar tocando el z_offset hasta ajustarlo, así cada impresión.

Lo que hice es, partiendo del Malin de la versión v2 de Campy (la que siempre he usado y me funcionaba muy bien con el servo) descomentar todo lo referente al autolevel, es decir, mirar de nuevo el tutorial colgado en el foro y hacer lo contrario para quitarlo.

Pero tengo un problema, cuando acaba la impresión, en el end gcode, le tengo puesto que baje la bandeja hasta 170mm. Pero después, al mandar el comando G28 me hace cosas raras, me sube aleatorio hasta un punto, hace como si tocase el endstop (y aun le queda para llegar) y tengo que volver a ponerle el g28 para que ésta vez toque el endstop y se pare. Hay veces que tengo que repetir la operación hasta 3 veces, es aleatorio como dije. 

He estado tocando el Marlin y la verdad, ya no se que más tocar. Simplemente quiero que comience a subir la bandeja (esté donde esté) y hasta que no toque el endstop no se pare.

La última prueba que he hecho es poner de nuevo como lo tenía antes, como si tuviese el servo instalado y pasa lo mismo, pero ésta vez, me he dado cuenta, que la primera vez que se para es donde más o menos teóricamente estaba el endstop colocado en el servo. Después le vuelvo a dar homing y ya me toca con el endstop real.

Los offsets los tengo todos a 0.

A ver si me podeis echar una mano, porque llevo dos días liado con ésto y ya no se donde tocar.

Saludos.
resim resim
-Eh! Mira detrás de tí, ¡¡UN MONO de TRES CABEZAS!!
-Piratas importantes: ¿Que quieres chico?
-Guybrush: Quiero ser bombero.
Citar
(12-02-2016, 06:22 AM)JmTru escribió: Hola a todos. Soy nuevo con la ulticampy, y con todas las demas, jeje.

La tengo montada y funcionando con el firm 1.0.2 que subio campy a github.

Solo he ajustado lo basico, pasos de motores y area de impresion, y la cosa va bien por ahora.

Como le empiezo a perder un poco de miedo a esto del arduino, se me dio por cargar el marlin 1.1 rc3.

He ido "copiando" las configuraciones de la version anterior y he conseguido imprimir bien.

El problema es que si muevo el eje z desde el control, este se vuelve loco...

Os dejo un video:



Otros problemas de montaje..

Pues los conectores del lcd me roza con la base de impresion. Vosotros como lo solucionais? Si la acerco mas al metacrilato no me entra la sd por la ranura.


En cuanto a la base de impresion, estoy por "copiar" sin escrupulos la de la ultimaker. En aluminio y con los clips para sujetar el cristal.

Mas que nada, es que el con las pinzas típicas, me tropieza el blower.

Incluso he pesado en imanes.

Estoy abierto a comentarios e ideas.


Muchas gracias y perdonad el ladrillo. Vaya forma de estrenarme.

Gracias.
Yo también he probado el nuevo Marlin y me pasa lo mismo, concretamente en el eje Z, no se a que se deberá. Al final volví a la versión anterior que tenía.

Saludos

Enviado desde mi GT-I9505 mediante Tapatalk
resim resim
-Eh! Mira detrás de tí, ¡¡UN MONO de TRES CABEZAS!!
-Piratas importantes: ¿Que quieres chico?
-Guybrush: Quiero ser bombero.
Citar
Yo he hecho igual. Me he vuelto a la 1.0.2

Gracias por la respuesta.

Como hacer con las pinzas para sujetar el cristal? No os tropieza en el conducto del ventilador de capa?
Citar
(24-02-2016, 05:15 AM)JmTru escribió: Yo he hecho igual. Me he vuelto a la 1.0.2

Gracias por la respuesta.

Como hacer con las pinzas para sujetar el cristal? No os tropieza en el conducto del ventilador de capa?
Si son tipicas pinzas para papeles, le puedes quitar poner las clavijas de metal que te permiten abrir la pinzade manera sencilla, yo lo tengo asi

Imprimamos un mundo mejor!
Citar
Hola, buenas tardes.

Aparte del error aleatorio que me hace al llega al home del eje Z, hay veces que se para como si tocase el endstop y no está ni rozándolo (para que os hagáis una idea como ejemplo a veces me lo hace a 150mm del punto 0 de Z, así que aún le queda mucho recorrido) y que lo hace cuando quiere, he estado revisando las conexiones y todas están bien, el endstop es el que usaba con el servo del autolevel. Pero tengo otro problema, por el cual me quité el autolevel del servo.

Hago la medición en el cristal de los cuatro puntos con un folio (aunque los puntos más a la derecha dado el carro preparado para doble extrusor no puede llegar a las esquinas), luego me voy al medio y está mucho más pegado, vuelvo a realizar las mediciones para comprobarlo y están bien, así que me da que pensar que puede que el cristal esté un poco abombado por el centro.

Le doy a imprimir y para empezar la medición del endstop es muy distinta a la anterior, se queda más alto. La cama está a 100 grados. Con la consecuencia que en la parte delantera el nozzle está en el aire y en la parte trasera del cristal el plástico se pega demasiado, temiendo alguna vez que se obstruya el hotend, así que la cama está desnivelada, cosa que al hacer las mediciones anteriormente estaba correcta.

Mañana probaré poner un espejo, a ver si todo se debe al cristal, pero lo que no me cuadra los las medidas tan diferentes al hacer el homing.

Saludos.
resim resim
-Eh! Mira detrás de tí, ¡¡UN MONO de TRES CABEZAS!!
-Piratas importantes: ¿Que quieres chico?
-Guybrush: Quiero ser bombero.
Citar
He estado realizando más pruebas referente a la nivelación de la cama. Me quité el autolevel y solo uso el endstop justo detrás del husillo.

Si la cama la nivelo en frio, luego cuando va a imprimir, estándo a 100 grados, cuando hace el homing hay una diferencia grande entre el nozzle y el cristal. Cuando se enfría todo vuelve a la normalidad.


Así que lo que estoy haciendo es nivelarla con la cama encendida a 100 grados, porque a la hora de hacer g28 en la impresión lo hará después del calentamiento de la cama.

La verdad, no se a que se debe.

Saludos.
resim resim
-Eh! Mira detrás de tí, ¡¡UN MONO de TRES CABEZAS!!
-Piratas importantes: ¿Que quieres chico?
-Guybrush: Quiero ser bombero.
Citar
Bueno, ayer, domingo 13 de marzo de 2016 fue un día para marcarlo en el calendario, después de meses y meses liado con la nivelación de la cama, al final encontré la solución.

Me había peleado constantemente con la nivelación de la cama, la había montado con muelles más fuertes, menos fuertes, sin muelles, con mi mujer sujetándola ... y siempre el mismo resultado.

De hecho, he estado a punto de desmontar por completo todo el eje Z y liarme a hacer pruebas, ya pensando que era un fallo mecánico, el cual no encontraba y ya me volvía loco.

Me quité el servo, para poner el endstop fijo al final de la impresora, detrás del husillo, pero no llegué a encontrar bien la medida de altura después de pelear mucho, así que no llegué ni a sacar una pieza pegada decentemente a la base.

Me monté el autolevel con sensor capacitivo, por si todo el problema venía por el autonivelado del servo/endstop. El resultado el mismo y encima agregabas otro problema, la poca fiabilidad de las medidas en cuanto la cama se encontraba por encima de los 30-40 grados, las variaciones eran muy grandes.

Lo que más me mosqueaba era que la cama estaba perfectamente nivelada, pero a la hora de hacer la impresión siempre me pasaba lo mismo, la parte central bien, la parte posterior muy pegado el nozzle y la parte frontal muy separado del nozzle, lo que siempre me limitaba en un área pequeña de impresión en el centro, no podía imprimir una pieza grande que ocupase toda la base.

Había probado todos los Marlin que campy subió y el resultado siempre era el mismo, incluso puse la nueva versión 1.1.0 RC3 y más de lo mismo.

El sábado encontré el Marlin que tenía de la i3 (pensaba que ya no lo tenía), modifiqué los valores para adaptarla a la Ulticampy y me di cuenta de una cosa, al hacer el autolevel, el Bed Level Correction Matrix me marcaba unos valores muy distintos en comparación con los que me mostraban los otros Marlin que comenté anteriormente, hice varias pruebas y como es normal esos valores en cada G29 se iban modificando, muy poco, pero había alguna variación y eso quería decir algo ...

Cargué los Marlin de campy y 1.1.0 RC3 y observé los siguientes valores:

Bed Level Correction Matrix:
+1.000000 +0.000000 +0.000000
+0.000000 +1.000000 +0.000000
+0.000000 +0.000000 +1.000000

Pusiese el Marlin que pusiese de esos, los valores eran fijos, eso quiere decir que el autolevel, aparte de que no hacía su trabajo, me estaba modificando la nivelación de la cama. Ya le podía dar yo vueltas a fallos mecánicos, del fileteador, etc. El problema estaba en el Marlin.

Como lo solucioné? al final después de mucho y mucho buscar llegué a una web extranjera donde una persona muy amable directamente te ofrecía descargar el archivo vector_3.cpp, el cual tenías que sustituir por el del Marlin que tenía instalado. Creo entender que dicho archivo era el original del Marlin de Erik Zalm (https://github.com/ErikZalm/Marlin). La descarga del archivo vector_3.cpp aqui: http://forums.reprap.org/file.php?151,fi...ctor_3.cpp

Fue sustituirlo y comenzar a mostrar unos valores similares a éstos:

Bed Level Correction Matrix:

+0.999984 +0.000000 +0.005676
+0.000024 +0.999991 -0.004245
-0.005676 +0.004245 +0.999975

Ahora el autolevel estaba haciendo su trabajo. 

Ahora faltaba la prueba de fuego, comencé a imprimir un archivo para calibrar la cama, la cual te dibuja diversos cuadrados ocupando toda la base de impresión. Y si, todas las capas perfectas en altura, todas iguales.

Perdón el tocho, pero quería compartir mis experiencias y de como lo he solucionado por si a alguien le pasase lo mismo.

Un Saludo.
resim resim
-Eh! Mira detrás de tí, ¡¡UN MONO de TRES CABEZAS!!
-Piratas importantes: ¿Que quieres chico?
-Guybrush: Quiero ser bombero.
Citar
Hola que tal, alguien tiene armada la version 3?, tengo una duda sobre las varillas, las he puesto como mejor se han acomodado pero me queda la duda de porque son diferentes las medidas de 2 de ellas, yo supondría que irian en pares, aparte nadie tiene problemas con que se salgan de la estructura al girarlas o como solucionan eso?, y las poleas a que distancia deben de ir, o igual a ojo?, un saludo.
Citar
Yo recuerdo, sino recuerdo mal, que para organizar las varillas, vi el vídeo del montaje de la Ulticampy, aparte de mirarme toda la información de componentes en la web de la Ulticampy.
Para las poleas, yo primero las coloqué y por último las fui apretando, quedando cada correa de forma lineal con el carro.
Cuando tengas todo apretado, por lo menos a mi, no se me salen.
Una vez puestas las varillas, las carreras colocadas y las poleas apretadas, mide bien las distancias, desde las barras centrales hasta las barras los ejes X e Y, para que en todos los puntos que midas tengan la misma distancia y no hayas apretado alguna correa de más y el eje central quede descuadrado.

Saludos

Enviado desde mi GT-I9505 mediante Tapatalk
resim resim
-Eh! Mira detrás de tí, ¡¡UN MONO de TRES CABEZAS!!
-Piratas importantes: ¿Que quieres chico?
-Guybrush: Quiero ser bombero.
Citar
Muchas gracias Xsion, de momento ya quedó y parece que no se salen, espero que con mas movimiento se mantengan fijas, las bandas las puse lo mas tensas que pude y todo se mueve bien, creo no me ha quedado descuadrado porque muevo el carro con la mano y todo va suave, he descargado el archivo que subiste para tener todo listo en cuanto me llegue el servo y demás piezas, estoy como a un 90% de poder terminarla y me muero de ansias de verla funcionando, saludos y gracias!
Citar
bueno acabo de leer este post completo de la pagina uno hasta acá Gran sonrisa

mas otro hilo de la misma impresora es decir este hilo Lengua http://www.spainlabs.com/foros/tema-PROY...ot?page=45

terminado de leer ambos post me encuentro con el siguiente problema:

Tengo muchas ganas de armar esta Impresora, pero no encuentro en las publicaciones de mi país (Argentina) el siguiente componente

http://www.3despana.com/husillos-varilla...uerca.html

es decir Husillo trapezoidal roscado 300X8mm Paso1 con su tuerca correspondiente no tengo la menor idea de donde pueda conseguirlo Triste si alguno sabe de alguna tienda Argentina que venda esta pieza o como remplazarla es decir si se puede remplazar por, Una varilla roscada milimétrica de 8mm con una tuerca que puedo maquinar para dejara igual a la del husillo.

esto para no hacer fabricar con el torno la pieza ya que yo estoy muy oxidado para usar el torno y hacer algo de presicion espero alguna idea ya que por lo que vi es lo único que no consigo, lo demás, todo lo demás ya lo tengo hasta presupuestado Lengua

aviso que voy a armar la V3 con la base de imprescion de la V4, si consigo las tuercas armare el antiblacklash, con este extursor Bowden, ya que esta pregunto este lleva el MK8 para 1.7 y 3 mm?

ademas pienso usar el Sensor De Proximidad Inductivo Lj12a3 para el autolevel.
sigo preguntando Gran sonrisa los motores Nema17 1.8 tienen que ser alto torque? 6kh o 4.5kg o recomiendan otro motor a la hora de comprarlos?

Driver que pienso usar son los DRV8825, espero que me salga y no renegar demasiado para calibrarla Lengua

Tengo una duda con respecto a la electronica ya que la V3 se le quita el EndStop del eje Z y se coloca en la Ramps donde esta el EndStop supuesta mente el otro extuder pero no logro entender el esquema ya que tampoco veo donde esta conectado el otro hotend, es decir es lo que por el momento no encuentro para largarme con la idea de que no me va a faltar nada, Lengua

otra cosa que no creo me sea sencillo encontrar son las Correa Cerrada GT2 de 100 dientes 200mm, espero conseguirlas.

bueno disculpen lo largo de el post pero quería sacarme estas dudas antes de comenzar a construir esta impresora

PD: Aclarar que es mi primer impresora que voy a tratar de construir Lengua
Citar
Yo he comprado un husillo de M8 paso 1 y 300mm de longitud en Aliexpress. Me llegó ayer y todo perfecto. Te dejo el enlace:

http://es.aliexpress.com/item/3D-Printer...77503.html
Citar
ok muchas gracias voy a hacer el pedido y veo si consigo correa GT2 de 200mm 100 dientes que tampoco las consigo Triste ya el resto esta en marcha.

es decir mande a maquinar a los paneles, las piezas conseguí quien me las imprima, y el resto de cosas ya las tengo listas para pedirlas.

No entiendo del todo el tema de la electrónica como esta montada con los 2 hotends espero no mandarme alguna cagada cuando llegue a ese punto ya estudiare el Firmware después para ver como esta conectada la electrónica ya que programación de AVR algo manejo no tanto arduino si algo pero no tanto lo mio fue mas assembler Lengua peroo calculo que llegado el momento de montar la electrónica ya este resuelta esa inquietud Gran sonrisa
Citar
No sé si es exactamente lo que buscas, pero la correa GT2 también la compré en Aliexpress a muy buen precio:

http://es.aliexpress.com/item/5pcs-lot-S...43618.html
Citar
[quote pid='65321' dateline='1460359306']
No sé si es exactamente lo que buscas, pero la correa GT2 también la compré en Aliexpress a muy buen precio:

http://es.aliexpress.com/item/5pcs-lot-S...43618.html
[/quote]



no pero si Gran sonrisa

voy a armarlo con esas correas quería las cerradas pero ya modifique los planos en el solidWork para usar ese tipo de correas estoy mandando a cortar las piezas en estos días espero tenerlas , lo que si las partes que pida a china a esperar nomas :Triste fácil 30 días minimo Lengua


esta es la vercion final que voy a mandar a cortar Lengua

resim
resim

para evitar el problem de las correas voy a usar 752-2gt-6 y 696-2gt-6
para que sean correas cerradas y no renegar con la tencion de las mismas esto para poder sacar los motores dentro de la carcaza y ponerlos en la parte de abajo junto con la electronica
Citar
Buenas,

Ya llevo casi 3 meses imprimiendo con mi ulticampy con la que estoy muy contento.
Tienes sus fallos, sus ajustes cada 5 min. Pero me encanta.

Le he ido mejorando poco a poco, cambiado la Ramps que no le gustó algun error de principiante...
Le he puesto la cama de 25cm, puesto doble extrusor, ...
Todavia me falta ponerle el sensor capacitativo para el autolevel. (a ver si ya le llegan las piezas a 3Despaña)

He diseñado un soporte trasero para 2 bobinas de filamento.
(a ver si me creo ya una cuenta thingivers para compartirlo)

Pero os vengo a preguntar por algo raro que me pasa.
Cada vez que imprimo algo "grande" se me para la impresion mas o menos a las 3 horas.

He mirado la configuracion de la Ramps y no encuentro nada
ninguna variable de limite de tiempo o limite de temperatura.

¿Alguna idea de porque me pasa esto?

Saludos
Citar
Imprimes desde SD o desde el ordenador?


Enviado desde mi iPad utilizando Tapatalk
Citar
(25-04-2016, 01:45 PM)satoo escribió: Imprimes desde SD  o desde el ordenador?


Enviado desde mi iPad utilizando Tapatalk

Desde SD pero con el USB conectado al ordenador.

Esto cambia algo?
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  dudas montaje Heat Bed Cama caliente Silicona Asier esnal 26 5,705 10-09-2018, 10:59 AM
Último mensaje: Thingibox
  [PROYECTO] Ulticampy impresora 3D tipo Ultimaker o Makerbot campy 977 123,689 26-10-2017, 07:42 PM
Último mensaje: shaftman
  Extrusor directo ulticampy fbforos 0 529 05-06-2017, 04:25 PM
Último mensaje: fbforos
  [ULTICAMPY] ¿Alguien ha diseñado espejos intercambiables? Lepes 9 1,407 08-09-2016, 11:51 AM
Último mensaje: Lepes
  [HUMOR] La verdad al descubierto: Montaje impresora DIY Lepes 5 1,193 24-06-2016, 09:36 AM
Último mensaje: Lepes