Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[MARLIN] Cortar corriente motores despues de homing
#1
Muy buenas señores.

Estoy toqueteando una versión de marlin (mas bien estudiándolo), y algo que ya me mosqueaba en mi i3 mercenaria es el tema de la corriente en los motores despues de hacer un homing.

Normalmente los motores cortan corriente tras pasar unos segundos después de hacer homing, pero en una printer nueva en la que ando metido, no lo hace. Los motores se quedan con corriente y los drivers se calientan cosa mala. Puedo desactivarlos por soft (en este caso repetier), o con el gcode M18, pero quiero que se desactiven solos y sin pasar tanto tiempo en ese "stanby caliente".

En steppers.h encuentro algo relacionado con este tema, pero es justo lo contrario:

Código:
// The stepper subsystem goes to sleep when it runs out of things to execute. Call this
// to notify the subsystem that it is time to go to work.
void st_wake_up();

Alguna idea o pista de donde modificar esto¿?

gracias!
Citar
#2
Solucionado. Lo dejo por aquí por si a alguien le interesa:

En el fichero Configuration_adv.h

Código:
// Default stepper release if idle. Set to 0 to deactivate.
#define DEFAULT_STEPPER_DEACTIVE_TIME 60
Modificamos el valor de 60 por el que nos interese.

Mis 10 a triggerr por encontrarlo, que casi me muerde ahí tan bien puesto, :dale2: :dale2:
Citar
#3
Hola jukillo, a mi me ignora marlin le ponga el valor que le ponga hace lo mismo tengo que mandarle yo el comando M84 a mano.

Un saludo.
Citar
#4
Muy buenas.

Perdona que no te contestase antes. La desactivación de los motores se hace tal cual escribo en el segundo comentario.

Para asegurarte de que no te funciona, pon ese valor a cero a ver que pasa. Si no te funciona, tendríamos que ver si es cosa de tu marlin o que...
Citar
#5
A mi me suena que los últimos rc no le hacen caso, no se si por alguna cosa que están implementando o que, pero el rc3 que hay ahora mismo en dev me hacía eso en una delta
Citar
#6
creo q no hace caso ninguno porque he probado repetier y si que se desconectan pero con marlin nanai.

Bueno algo estarán cocinando.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Marlin se para davlinares 5 132 05-12-2018, 03:28 PM
Último mensaje: Estrallator
  Power_loss_Recovery en marlin 1.1.9 Otero 2 168 01-12-2018, 12:01 AM
Último mensaje: neoxM3
  ¿MKS Sbase + Marlin 2.0? 3Dsastre 6 328 27-11-2018, 02:22 PM
Último mensaje: 3Dsastre
  CONSULTA mejoras marlin 2.0 davlinares 4 225 27-11-2018, 01:46 AM
Último mensaje: Simemart
  El marlin no me hace caso spa_sergio 11 1,431 22-11-2018, 05:30 PM
Último mensaje: mundo2017