Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Lcd no funciona si desconecto del usb
#1
Hola a todos,

llevo ya días imprimiendo, siempre desde el PC.

El otro día quise imprimir desde la SD y me llevé una sorpresa. El LCD si no lo conecto (el arduino) al pc, no visualiza nada.

Ya he probado a tocar el potenciómetro del lcd, pero era un sinsentido, ya que por usb funciona y se ve perfectamente.

Alguien podría orientarme o sabe donde puede estar el problema?

Saludos y gracias.
Citar
#2
Tienes soldado el diodo D12 (esta debajo de el pololu de X o Y)
"Enseñar es aprender dos veces".
Citar
#3
Quiza antes de poner mi problema deberia haber puesto lo que tengo. Por usb imprime perfectamente, mejor o peor pero imprime.

Uso una ramps 1.4SB que ya lleva diodos antiparalelo en las clemas de la cama y Extrusores. Solo tiene dos semanas por lo que caso decarto que sea cosa de mosfets.

También uso rele, sin diodo.

edit: veo que te refieres al regulador del arduino. En caso de estar roto, tiene algun sintoma? Perdonad mi ignorancia, podria ser el regulador, pero entonces no entiendo que el pc reconozca todo correctamente.

Repito que la pantalla se enciende, aunque parpadea un poco , pero no sale nada.
Citar
#4
Para descartar, esta tarde pruebo con otro arduino mega que tengo. Asi salgo de dudas de si es el regulador, porque cortos por los endstop si que he tenido.
Citar
#5
Os cuento,

he probado otro Arduino mega y ha funcionado, la lcd se veía sin conectar el Arduino al usb, pero a los pocos segundos ha salido olor a quemado, que viene, efectivamente del regulador Ams. No se si merece la pena cambiarlo, porque se volverá a quemar. Este arduino que he probado tiene muy poco uso, asi que desconozco que puede estar fallando. Los endstop estan bien, sin cortos...

Edit: Lo que veo que se ha quemado son el condensador y alguna resistencia de las que estan justo detras del conector usb del arduino. El regulador parece que está bien.
Citar
#6
Bueno, vuelvo con lo mismo. Ya he cambiado el regulador del arduino y sigue igual, sigue sin encenderse sin conectarla al usb.

Es un problema porque dependo del pc para imprimir.

A ver si alguien me echa una mano.
Citar
#7
Hola Jarryson.

Conseguiste solucionar el problema??

Yo tengo el mismo problema:
RAMPS v1.4 con los diodos D1 y D2 montados.
LCD smart controller de Reprap Discount
Arduino MEGA 2560

.... y sólo funciona la LCD con alimentación de USB!!!
También he revisado el regulador de voltage de la Arduino con el polímetro y salen 5V. Por lo que intuyo que está bien.

Si alguien sabe dónde puedo encontrar una solución lo agradecería!!!
Saludos.
Citar
#8
Es el regulador ams1117. Yo lo que hice fue quitarlo y poner un LM7805. Y desde entonces sin problemas
Citar
#9
OK. Gracias. Lo probaré a ver qué tal!!!
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Rumba no funciona con LCD full graphics gale9010 1 524 13-10-2017, 09:43 PM
Último mensaje: poliveira1978
  [AYUDA] Autobed leveling no funciona correctamente Jrx07 8 1,122 29-11-2016, 01:55 AM
Último mensaje: Jrx07
  LCD steel no funciona sin USB rusako 25 5,237 06-01-2016, 04:53 PM
Último mensaje: javi_tecla
  [Ayuda] Ventilador de capa no funciona Odirse 1 1,163 07-09-2015, 09:51 PM
Último mensaje: Odirse
  Ramps 1.4 al conectar Fuente no funciona goroldi 10 2,041 26-03-2015, 05:35 AM
Último mensaje: Tora