Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
He perdido la raspberry :(
#1
Pregunta 
Buenas a tod@s:

De un momento a otro la raspberry me ha dejado de funcionar por ssh. No puedo conectarme por ssh desde el PC.

La raspberry funciona correctamente y si hago un ping en el router desde la raspberry este responde. Por lo tanto está conectada en la red.

Pero si hago un ping desde la raspberry a mi pc este no responde y a la inversa igual.

Puede ser algo del router? :S 

Sin tocar nada??? :S

Es muy extraño :S

Muchas gracias de antemano
Citar
#2
¿Cómo puedes hacer un ping en el router desde la RPi?

Comprueba que no se haya desconectado momentáneamente y el router le haya dado otra IP y por eso no puedas acceder.
Citar
#3
(20-04-2016, 09:56 PM)ICEM4N escribió: ¿Cómo puedes hacer un ping en el router desde la RPi?

Comprueba que no se haya desconectado momentáneamente y el router le haya dado otra IP y por eso no puedas acceder.

Buenas a tod@s:

He conectado una pantalla, el mouse y el teclado en la raspberry. Y directamente con la Raspberry estando "físicamente" en la raspberry he hecho el ping.

Sin embargo, no me puedo conectar mediante ssh desde el pc.

Y estando físicamente en la rpi hago un ifconfig y me da la ip correcta con la que me conecto.
Citar
#4
Ummmm, el problema es que no devuelve ni ping, lo cual puede ser por un problema en la red, o porque hayas configurado la RPi para queno devuelve ping (algo raro, pero bueno). Por ssh... qué error te da? que no encuentra la máquina? error de autentificación?


Si unicamente fuera problema de SSH (pero parece que es algo de la red y ahí si que no te peudo ayudar), desde la RPi y como root, haz

Código:
service sshd status

sshd es el daemon de ssh, que permite que otros se conecten a la RPi. con "service {SERVICIO} status" estás preguntando por el estado del daemon. Debería salir algo como
Cita:Active: active (running)
(además, salirte un log abajo)

Si está inactivo, prueba con
Código:
service sshd start
Citar
#5
(21-04-2016, 09:05 AM)ICEM4N escribió: Ummmm, el problema es que no devuelve ni ping, lo cual puede ser por un problema en la red, o porque hayas configurado la RPi para queno devuelve ping (algo raro, pero bueno). Por ssh... qué error te da? que no encuentra la máquina? error de autentificación?


Si unicamente fuera problema de SSH (pero parece que es algo de la red y ahí si que no te peudo ayudar), desde la RPi y como root, haz

Código:
service sshd status

sshd es el daemon de ssh, que permite que otros se conecten a la RPi. con "service {SERVICIO} status" estás preguntando por el estado del daemon. Debería salir algo como
Cita:Active: active (running)
(además, salirte un log abajo)

Si está inactivo, prueba con
Código:
service sshd start

Buenas a tod@s:

Parece algo de la propia red ya que he probado desde otro PC hacer un ping a mi propio PC y me dice que no lo puede encontrar. Igual que con la rpi.

Tendré que investigar qué pasa.
Citar
#6
(22-04-2016, 06:53 PM)Electromecánico escribió:
(21-04-2016, 09:05 AM)ICEM4N escribió: Ummmm, el problema es que no devuelve ni ping, lo cual puede ser por un problema en la red, o porque hayas configurado la RPi para queno devuelve ping (algo raro, pero bueno). Por ssh... qué error te da? que no encuentra la máquina? error de autentificación?


Si unicamente fuera problema de SSH (pero parece que es algo de la red y ahí si que no te peudo ayudar), desde la RPi y como root, haz

Código:
service sshd status

sshd es el daemon de ssh, que permite que otros se conecten a la RPi. con "service {SERVICIO} status" estás preguntando por el estado del daemon. Debería salir algo como
Cita:Active: active (running)
(además, salirte un log abajo)

Si está inactivo, prueba con
Código:
service sshd start

Buenas a tod@s:

Parece algo de la propia red ya que he probado desde otro PC hacer un ping a mi propio PC y me dice que no lo puede encontrar. Igual que con la rpi.

Tendré que investigar qué pasa.

Buenas a tod@s:

He probado conectando la raspberry directamente al router y allí se han terminado los problemas. Puedo acceder mediante ssh desde el PC a la rpi. Sin embargo por wifi no funciona. Me dice que no encuentra el host, ya puedo probar con el que sea que siempre me dice lo mismo. Sin embargo, si pruebo de hacer un ping al router este responde sin problemas.

Qué puede ser que el router no redireccione el ping al dispositivo de esa ip? En teoría no he tocado nada de la configuración del router, porque ya digo, me pasó mientras estaba en el pc y sin toquetear nada.


Muchas gracias de antemano
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Raspberry quemada al conectar USB de placa xero83 5 510 28-11-2018, 07:06 PM
Último mensaje: Alexp
  NOTICIA Os invito a mi blog "Raspberry Para todos" Turriano 0 292 14-07-2018, 05:16 PM
Último mensaje: Turriano
  Encendido/Apagado LED con pulsador Raspberry Javier_DC 2 763 16-04-2018, 08:12 AM
Último mensaje: Javier_DC
  [TUTORIAL] Como ejecutar scripts al iniciar nuestra Raspberry Electromecánico 7 15,719 18-03-2018, 11:52 PM
Último mensaje: yuber1992
Pregunta Plataforma educativa online para curso de Raspberry Pi Electromecánico 1 544 17-01-2018, 09:09 PM
Último mensaje: grafisoft