Calificación:
  • 2 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Firmware (copia de seguridad y restauración) y bootloader.
#21
@aotxoa , no se muy bien a que juegas con tus intrigas pero quizá le interese a alguien más en el foro.
Parece ser que @aotxoa lleva el canal de Youtube Dron3D 8A, que tiene entre muchos otros, videos sobre las impresoras Anet.
Por lo menos eso es el primero de los enlaces que adjunta. El segundo ya ni lo he mirado.
Por lo que veo en ese video, parece ser que está preparando uno cuyo guión parece ser mi tutorial sobre copia de seguridad y restauración del firmware.
Naturalmente, es muy libre de hacer su propia versión en video de este tutorial, pero quiero dejar bien claro que yo no tengo ninguna participación en ello.
Y, por supuesto, el ocultismo que mantiene sobre los videos cuyos enlaces pone más arriba, no obedece a las razones que indica.
Mi tutorial, tal y como yo lo redacté, funciona perfectamente. Parece ser que a él/ella no le funciona bien algo, cualquiera sabe el qué.
Eso, si es cierto que no le ha funcionado. Que ya no sé que pensar de este asunto.
Citar
#22
(22-04-2018, 09:13 PM)Simemart escribió: @aotxoa , no se muy bien a que juegas con tus intrigas pero quizá le interese a alguien más en el foro.
Parece ser que @aotxoa lleva el canal de Youtube Dron3D 8A, que tiene entre muchos otros, videos sobre las impresoras Anet.
Por lo menos eso es el primero de los enlaces que adjunta. El segundo ya ni lo he mirado.
Por lo que veo en ese video, parece ser que está preparando uno cuyo guión parece ser mi tutorial sobre copia de seguridad y restauración del firmware.
Naturalmente, es muy libre de hacer su propia versión en video de este tutorial, pero quiero dejar bien claro que yo no tengo ninguna participación en ello.
Y, por supuesto, el ocultismo que mantiene sobre los videos cuyos enlaces pone más arriba, no obedece a las razones que indica.
Mi tutorial, tal y como yo lo redacté, funciona perfectamente. Parece ser que a él/ella no le funciona bien algo, cualquiera sabe el qué.
Eso, si es cierto que no le ha funcionado. Que ya no sé que pensar de este asunto.

No juego, ni jugamos a nada, no se porque te molestas desde el principio.

Nosotros lo unico que queremos es que no le pase a mas gente lo que nos ha pasado a nosotros siguiendo este tutorial.

Ya sea por fallo nuestro que como bien puedes ver en los videos no creo que hemos cometido ninguno. Ahi te los pusimos pero por lo que parece no quieres verlos.

Nosotros en nuestro canal solo mostramos las mejoras y avances que hacemos en nuestras impresoras y en el mundo de la impresión 3D, no somos ningunos genios y no nos ponemos las medallas de nada de lo que colgamos en nuestro canal, solo queremos compartirlo con el resto de usuarios de impresoras 3d nuestros avances en este bonito mundillo.

En La descripción del video tambien tenemos intención de poner enlace a este hilo ya que como bien dices TU has sido el crador de el y de este foro solo podemos decir cosas buenas. Pero tu actitud en este caso nos deja muy sorpendidos.

El unico ocultismo (como tu dices) es por no dañar la imagen del foro e intentar descubrir de donde puede venir el error para no le vuela a pasar a nadie mas, de ahi que quisieramos hablar por privado, para no dañar la imagen del foro si es que hay algun error en este hilo.

Como muy bien has podido ves hasta ahora no hemos mencionado en ningun momento nuestro canal, porque nuestra intención no es publicitarlo en este, ni en ningun otro foro de impresión 3D.

Esperamos haberte contestado lo mas respetuosamente y sinceramente te hemos contestado sin intentar ofenderte, cosa que creemos que tu no has hecho hacia nosotros.

Y te reiteramos que nuestra unica intención es descubrir el fallo para que no le vuelva pasar a nadie.

Si queres intentar ayudarnos a descubrir de donde puede ser el error aquí estamos.

Si quieres volver a contestarnos atacandonos preferimos no recibir respuesta.

Un saludo y sentimos todas las molestias y malentendidos ocasionados
Citar
#23
No es mi intención entablar un debate contigo sobre esta cuestión, pero debo responder a lo que indicas.
En mi anterior mensaje no hay ningún ataque, solo constato la realidad de una situación que no me gusta.
Desde el principio ya me extrañó todo lo que planteabas y con tu petición de comunicación por privado ya empecé a mosquearme. A mi me gustan las cosas claras y no ha sido el caso.
Sobre lo de la imagen del foro nada tengo que decir, pero vuelvo a repetir que yo no tengo ningún copyright sobre las ideas que contiene mi tutorial y ni quiero, ni necesito, que se me mencione en ningún sitio.
Son de dominio público y las sabe cualquier versado en la materia, por lo que sois muy libres de utilizarlas como consideréis oportuno, tal y como dije en mi respuesta.
Y, por supuesto, yo no os he acusado de copiar ni apropiaros de nada, así que tu alegato no tiene mucho sentido.
Sobre lo de ayudaros a dar con el problema que tenéis, os he contestado lo mejor que sé a las preguntas que habéis hecho, como hago con los demás usuarios del foro a los que les contesto preguntas.
Nada más puedo añadir, tal y como indicaba en mi respuesta a tu última pregunta.
Y con esto, por mi parte, doy este tema por cerrado.
Un saludo.
Citar
#24
Hola, buenas.
Tengo el mismo problema en mi anet A8.
Hice lo mismo que Aotxoa, primero una copia de seguridad según tu estupendo tutorial, después instalé Skynet y todo perfecto según tu otro tutorial, y luego por no tener el autolevel y esperar a tenerlo volví a restaurar el SO original y también perfecto. Cual es mi sorpresa que ahora una vez recibido el sensor me propongo a instalar el marlin y no me deja. Os dejo una instantanea de los mensajes que me dá arduino... Publiqué hace unos días en Facebook el mismo problema pero nadie ha podido responderme.
Gracias por la ayuda de antemano. Un saludo y felicidades por el buen tutorial.
resim
Citar
#25
Hola, no se exactamente cual es el motivo que os está dando ese problema, pero con seguridad no está en el tutorial.
De todas formas, he vuelto a realizar en mi A8 (en la que tengo Marlin), todo el proceso del tutorial (como ya hice cuando consultó @aotxoa), es decir:
1- he vuelto a instalar el firm original desde el archivo que se incluye en Skynet3D, apareciendo el famoso OMNI que ya tenía olvidado;
2- he hecho la copia de seguridad del firm original en un archivo con formato Intel Hex;
3- he vuelto a instalar el Marlin que tengo normalmente, para hacer la restauración de la copia sobre él;
4- he restaurado desde la copia que he hecho en el punto 2, volviendo a tener operativo el firm original cargado desde la copia de seguridad;
5- he vuelto a cargar de nuevo el Marlin que tenía anteriormente.
Todo sin el menor problema.
Vuelvo a repetir que, con el software que se indica y siguiendo el tutorial, todo funciona correctamente, por lo que el problema no está en él.
Ese error puede que no sea por haber perdido el bootloader (si se marca la casilla Disable Flash Erase no me parece posible que suceda), sino a un fallo en la comunicación.
Comprueba la conexión USB (cable y/o conectores que usas). Prueba a cambiarlos.
No se me ocurre nada más.
Citar
#26
Ok muchas gracias.
Una pregunta. Cuando vuelves a poner Marlin ¿lo haces con un Hex o con arduino?
Gracias por el tutorial.
Citar
#27
Marlin lo subo con el IDE de Arduino.
¿Con un Hex te refieres a hacer una copia de seguridad del Marlin y restaurarlo desde ella como se indica en el tutorial? No veo que interés habría en hacerlo así.
Con el firm original no queda más remedio, ya que lo único que se tiene es lo que viene en la impresora (el firm ya compilado, por eso no se puede modificar).
Pero con el Marlin se suele necesitar subirlo cuando se modifica algo y me parece lo más lógico hacerlo con el programa en que se modifica.
Ten en cuenta que el IDE de Arduino genera un archivo .hex resultado de la compilación y utiliza el Avr que lleva incuído para subirlo a la impresora.
Solo que así, él se encarga de todo y tú te despreocupas del proceso.
Citar
#28
Ah, entiendo.
Bueno pues ayer después de volver a reintentar, cambiar cable usb, desactivar bluethoot, etc.. etc... me sigue dando el mismo error. es mas, la impresora hace como cuando apretas el reset justo cuando intenta subir el compilado. Empieza a dar esos mensajes y chin-pun. se queda de serie como si nada. Imprimo perfectamente, todo correcto pero no deja volver a meter marlin.
Saludos
Citar
#29
¿Has probado si te deja restaurar de nuevo el firm orginal desde la copia de seguridad?
Si no te deja tampoco, lo más probable es que hayas perdido el bootloader.
Si es así, tendrás que restaurarlo utilizando un ISP externo como se indica en el tutorial.
Citar
#30
Hola. Perdon por el retraso, pero llevo unos días de curro que no tengo tiempo ni para vivir. Bueno. Intentaré hacer lo que dices esta semana y si puedo antes de fin de semana y digo algo. A ver si arrojo algo de luz al tema.
Muchas gracias.
Citar
#31
Una pregunta que me asalta:

Si al quemar el bootloader, en vez de anet 1.0 le poner Anet optiboot, cargará este último bootloader? porque he intentado instalar el marlin con el sensor de altura, y no me deja por tamaño. Lo jntenté marcando anet optiboot y no deja tampoco. Da otro error. Ahora estoy imprimiendo, pero era algo así, pero más líneas

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x73

Es una pregunta entre el post de autolevel y este.

saludos
Citar
#32
Hola, hay que seleccionar la placa en función del bootloader que se tenga, sino dará un error como el que indicas.
Cuando seleccionas una tarjeta Anet, el IDE de Arduino busca su nombre en el archivo boards.txt que se encuentra en la ruta arduino-1.8.5\hardware\anet\avr\ y lee de él los parámetros necesarios.
Entre otros, la memoria libre que tiene para acomodar el firmware, la velocidad de conexión del ISP y el nombre del archivo que contiene el bootloader.
Este último es el que se utiliza cuando se da la orden de quemarlo. Se encuentra en la carpeta  arduino-1.8.5\hardware\anet\avr\bootloaders\atmega\.
Por ello, para cargar el bootloader Optiboot, primero hay que seleccionar la placa Anet v1.0 (Optiboot).
A partir de que se carga un tipo de bootloader en la placa, ya hay que seleccionar la placa que lo lleva para poder cargar el firmware en ella.
Las mejoras más visibles del bootloader Optiboot respecto al normal, son que aumenta tanto la velocidad de conexión del ISP (de 57600 baudios a 115200 baudios), como la memoria disponible para el firmware (en unos valiosos 3072 bytes).
Un saludo.
Citar
#33
Buenas:
Otra pregunta:
Si no he brickeado mi placa:¿ Puedo meterle el optiboot sin el arduino? ¿o es obligatorio?.

Saludos
Citar
#34
Hola, por lo general los bootloaders no pueden reprogramarse a sí mismos y creo que este no puede hacerlo.
Ten en cuenta que eso equivale a sobreescribir un código en ejecución con otro distinto, lo que no suele funcionar.
Me temo que tendrás que utilizar un ISP externo.
Un saludo.

Edito: Estaba revisando el Datasheet del ATMega1284P y por lo que creo entender, parece que sí puede reprogramarse a sí mismo el bootloader.
Habría que investigarlo con más detenimiento, pero en principio no creo que haya ningún problema en probar si se puede.
Si no funciona, creo que lo único que pasaría sería una corrupción del bootloader que está cargado y habría que volver a cargarlo, ahora sí, utilizando un ISP externo.
Por supuesto, esto es una cosa que cada uno tiene que probar por su cuenta y riesgo.
Citar
#35
Saludos:
Bueno, como uno no está para ponerse a probar cosas y después quedarme sin placa, probé el sistema seguro: le puse el optiboot a una placa 1-5 para ahora meterme con el autolevel. YA tengo otra vez cargado el marlin con los valores para mi máquina, con el linear_adv activado, pero pudiendo cambiar el valor desde el cura o similar, y mañana me meto con el autolevel cuando la monte en la placa con todos los cables.

Mañana más
Citar
#36
(30-09-2017, 10:53 AM)Simemart escribió: ¡ATENCIÓN! Hay que marcar, en el apartado Options, la opción Disable flash erase (-D). Si no se marca, antes de grabar se borra toda la memoria (incluído el bootloader) y como el firmware de la copia de seguridad no lo lleva incorporado, puede que nos quede operativa la impresora, pero no podremos volver a cargar nada por USB hasta que restauremos de nuevo el bootloader.

¿Estás seguro de esto?

Que conste que soy un recién llegado, que hasta hace nada desconocía la existencia del programa avrdude y que acabo de montar mi primera impresora 3d (Anycubic Linear Plus) sin siquiera haber empezado a imprimir con ella. Sin embargo quería asegurarme de tener un backup del firmware instalado, así que hice una búsqueda y encontré este post y algún otro sitio con información al respecto. Al final obtuve mi copia de la flash  ejecutando directamente el avrdude de la siguiente forma (Linux Debian):

Código:
avrdude -p atmega2560  -c stk500v2 -P /dev/ttyUSB0 -b 115200 -U flash:r:flash_backup_file.hex:i

Para ojear el contenido con un editor hexadecimal he convertido el fichero obtenido ( flash_backup_file.hex ) a binario aprovechando el programa avr-objcopy que viene con el arduino tal que así:

Código:
../arduino-1.8.5/hardware/tools/avr/bin/avr-objcopy -I ihex -O binary flash_backup_file.hex flash_backup_file.bin


Abriendo el fichero binario recién creado (flash_backup_file.bin) con un editor hexadecimal se pueden ver los textos de lo que parece ser el firmware Marlin del Anycubic casi al principio del fichero, luego hay una sucesión de bytes con el valor 0xFF (255 en decimal) que deberían ser los que ocupan la memoria no utilizada y, al final, lo que debería ser el bootloader, cuyo primer texto no debería dejar lugar a la duda:

Código:
ATmega256 Arduino explorer stk500V2 by MLS Bootloader> Huh?

De hecho, es lo razonable ¿no? Si el bootloader se guarda en la flash y tú le pides a avrdude que te lea el contenido de la flash lo lógico es que te lea tanto el firmware como el bootloader. Lo mismo debería suceder a la hora de escribir dicho backup en la flash. Cosa bien distinta es si esa parte se escribirá en la flash y quedará protegida sustituyendo la r de lectura por una w de escritura en la ejecución de avrdude o habrá que añadir algún argumento más.

En cualquier caso, muchas gracias por tu tutorial porque me ha hecho descubrir el avrdude que tendré que estudiar más a fondo.

Saludos.
Citar
#37
Hola, yo también llegué posteriormente a esa misma conclusión, aunque cuando escribí el tutorial no lo tenía tan claro.
Efectivamente, el avrdude realiza una copia íntegra de la memoria flash y dado que el bootloader reside en ella, se copiará tambien el bootloader.
A la hora de restaurar con esa copia, es lógico pensar que no debería haber ninguna diferencia si se utiliza el modificador -D o no (es el que se incluye en la linea del comando del avrdude cuando se marca la casilla indicada en el avrdudess), dado que también se escribe toda la memoria.
De todas formas, hay que tener cuidado de que efectivamente el bootloader esté en el archivo que se intenta cargar, como es lógico.
Con el Skynet que se utilizaba entonces, junto con el avrdude se incluían los firmwares originales de los modelos Anet y esos no lo llevan incluido.
Si quieres volver al firmware original y no has hecho una copia de seguridad, no te queda otra que hacerlo con esos archivos y entonces sí es necesario hacerlo.
Marcar la opción de no borrar la flash en el avrdudess (o poner el modificador -D en la linea del comando del avrdude) antes de grabar no afecta al proceso y actúa como un seguro en cualquier caso. Más vale prevenir que curar.
Muchas gracias por el apunte y por recordarme la forma de pasar los archivos .hex a .bin y viceversa. Llevo demasiado tiempo alejado de la programación Sisi3 .
Un saludo.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Problemas Cargar firmware con marlin config david3049 12 288 01-06-2018, 11:07 AM
Último mensaje: Simemart
  Autolevel, paso a paso (I): Cambiar el firmware. Simemart 38 6,281 22-04-2018, 03:04 PM
Último mensaje: SebaS
  Topes de impresion en firmware urrielu 1 136 17-04-2018, 06:38 PM
Último mensaje: Simemart
  CONSULTA FIRMWARE maximux 3 447 16-02-2018, 09:39 AM
Último mensaje: maximux
  AYUDA PARA REINSTALAR FIRMWARE ORIGINAL ANET 8 Nestor 12 3,679 18-01-2018, 03:49 PM
Último mensaje: Simemart