Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Fallos en trayectorias 3D
#1
Buenos tardes, acabo de registrarme en el foro, por que tengo un problema con la fresadora que he construido.

datos

software GRBL0.9j
hardware  Arfuino uno + cnc shield v3.0
4 motores nema 17 2A uno en x uno en z y dos en el eje  Y
fuente de 16A 12v
1/8 pasos por pulso

El problema es es siguiente, la fresadora corta y cajea de maravilla un error de -+ 0.15mm, , en tallado 3d cuando solo actual eje x y z a la vez, funciona muy bien.

el problema viene cuando intento tallados o grabados en V en los que intervienen los 3 ejes y 4 motores, es entonces cuando hace ruido rarro y pierde pasos el los eje z y en el y

he probado varias cosas pero sigue igual

Cambiar la fuente por otra de 36A 12v 
cambiar la versión de GRBL
Cambiar los A4988 por DRV8825
cambiar la aceleración   + y -
cambiar la velocidad de los motores + y -
cambiar la duracion del pulso

he medido el voltaje de la fuente cuando hace los ruidos y no cae ni un 0.1V


Os pido a los expertos si se os ocurre alguna idea.

Enviado desde mi Aquaris E10 mediante Tapatalk
Citar
#2
Tienes los dos motores de Y conectados a un solo driver?
Si es asi puede ser la causa del problema.

Saludos
Citar
#3
No, tengo un driver para cada motor, el problema es la placa cnc shield, la he cambiado y ahora funciona perfectamente

Enviado desde mi Aquaris E10 mediante Tapatalk

No dejaba pasar más de 1.4 A

Enviado desde mi Aquaris E10 mediante Tapatalk
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Fallos: Escalones en las curvas al fresar DM jfelipe 16 982 16-11-2014, 07:38 PM
Último mensaje: grafisoft