Calificación:
  • 1 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Fallo de diseño BRUTAL en la RAMPS que tortura a los MOSFET
Yo por ahora con los finales de carrera no he tenido problema....
Citar
Francisco escribió:Buenas
comprobasteis el ruido de los finales de carrera.
Con un condensador en paralelo se quita

Buenas Francisco,
yo tampoco he tenido problema (aún) con los finales de carrera. ¿Podrías darnos más detalles sobre el condensador? Capacidad, voltaje, cómo lo has implementado....
Un saludo
Citar
?
Citar
Perdonad el "up", pero creo que este hilo es siempre actual Sonrisa Tengo unas preguntillas sobre el apaño de fjgranado para sacar los fet fuera, incluir los diodos de vuelta, etc, etc.

Por lo que parece, has sacado el bloque entero "heater and fans" de la ramps hacia el exterior... sin embargo, hay alguna cosa que no acabo de comprender (no soy ningún experto en esto, como podréis comprobar):

¿Por qué has mantenido la resistencia de 10ohm de la salida del arduino (las R13, R14 y R15) cuando, según las simulaciones de fmalpartida, va a hacer que el arduino tenga que proporcionar un montón de corriente? ¿Ya puestos, no sería mejor poner 1K?

¿Cómo has resuelto la conexión de los pines D8, D9 y D10 a tu placa? ¿Quitando las R9 R2 y R4 de 100k de la ramps y uniendo con un cable cada pincho correspondiente a tu circuito? -suponiendo que se quiten los fet, claro? Me da un poco de cosa quitar esas resistencias smd :O... En mi ignorancia, me parece que se podría dejar todo (excepto los fets, claro). Se gastarían unos céntimos de miliamperio en la resistencia de 100k pero no debería importar.. ¿Alguien arroja algo de luz?

Otra cosa que me está matando es la foto esta:
http://spainlabs.com/foro/download/file.php?id=422
¿es un dibujo para poner en una placa de cobre? ¿no se están tocando descaradamente el drain y el source de los transistores???

Y por último... los fusibles están entre los 12v y la resistencia de 1.8, ¿no? En el programilla que usaste para la foto http://spainlabs.com/foro/download/file.php?id=420 , donde aparece 5A y 11A, ¿correcto?

Un saludo a todos!
Citar
Personalmente me he decantado por una resistencia de 1K en la puerta por varios motivos:
1. No estoy haciendo un diseño que conmuta a alta frecuencia, lo que es mejor, no tiene sentido con la inercia térmica.
2. al suavizar los flancos evito quítale la corriente muy rápido con lo que las inductancias parasitarias no ven un cambio tan brusco.
3. Evito un pico de corriente en las salidas del micro ya que la capacitación de la puerta se cargará más despacio.

El pull-down de 10K están por varios motivos, consumirá unos 50 micro amperios (una desgracia si lo comparas con el resto) y evitas transitorios incómodos.
Citar
Lo mejor para eliminar los problemas de la ramps es hacerla trabajar a 24V, los motores funcionan mejor y el fet de la cama ni se calienta, y no hace falta ningun ventilador par refrigerarla. Hay que hacerle unas pequeñas modificaciones y funciona de maravilla.

Saludos,

Miquel
Citar
Yo he montado unos MOSFET de Texas, con una Rdson baja, y buenas specs, y no se me calientan. Con cama a 100º. Todo es cuestion de dimensionar en condiciones los componentes. Amen de las pistas que eso poca solucion tiene. Pero yo mosfet nuevos y diodos en inversa en paralelo a la salida, y mano de santo.
Citar
Triggerr escribió:Yo he montado unos MOSFET de Texas, con una Rdson baja, y buenas specs, y no se me calientan. Con cama a 100º. Todo es cuestion de dimensionar en condiciones los componentes. Amen de las pistas que eso poca solucion tiene. Pero yo mosfet nuevos y diodos en inversa en paralelo a la salida, y mano de santo.

Ahhh, benditos CSD18502KCS... :one:
Citar
sifou escribió:Ahhh, benditos CSD18502KCS... :one:

O sea... que te fueron bien las muestras Sonrisa Yo estoy a ver si le pongo unos IRLB8743P... La RdsOn y el Vth es bastante parecido... y son mucho más baratos. Oigo hablar bien de ellos por aquí.

De todos modos me sigue preocupando el pico de corriente que sale del microcontrolador (aunque también es cierto que fets quemados hay a patadas, pero no veo a nadie que se le haya fastidiado el arduino...)
Citar
Hola! Soy nuevo en la comunidad y recién estoy aprendiendo más de electrónica gracias a todos estos comentarios, muchas gracias!

Solo tengo una pequeña duda, porfavor espero que puedan darme una mano :oops:

También tenía el problema de las borneras que se quemaban pero gracias al foro ya esta mejor ahora solo quiero reemplazar esas borneras quemadas y ahí está mi duda ¿las debo reemplazar por las mismas con las vino?

La bornera verde (la que conecta la ramps con la fuente de poder) era de 300v 15A y las borneras del D8, D9 y D10 eran de 250v 6A

Si mi fuente de poder bota 20A,

- ¿Reemplazo la bornera verde por una de 20A para hacerlo equivalente?

- En el caso de las borneras del D8,D9yD10 encontre unos de 300v 12A, ¿Tendré algún problema por duplicar la capacidad de amperios?

Muchas gracias de antemano espero que me puedan ayudar un poco para no quemar nada Cry
Citar
Si aguanta amperios de más, no hay problema (incluso mejor). El problema es si aguantan de menos.

Revisa el pitch (separación entre pines) de los conectores, que sean iguales a los originales.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Conectar TFT tactil a ramps Jaimelito 22 5,604 26-08-2018, 03:52 PM
Último mensaje: Leo
  CONSULTA Ramps 1.4 hace el home al revés mocman 4 223 18-08-2018, 06:56 PM
Último mensaje: mocman
  CONSULTA Salida de 12v en RAMPS 1.4 Rubenulo 6 354 04-06-2018, 08:13 PM
Último mensaje: Rubenulo
  Corto en las ramps 1.4sb robertote 3 249 30-05-2018, 08:37 PM
Último mensaje: Shellmer
  [PROBLEMA] RAMPS EJE Z eudaldgr 8 468 11-05-2018, 06:22 PM
Último mensaje: drow