Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Error con Eje Z (ruido, vibra y no se mueve)
#1
Hola a todos! Anoche termine de ensamblar mi Prusa I3 Pro B... el tema es que he tenido unos problemas:

El primero es que el motor de eje X se mueve en sentido contrario a donde se encuentra el StopEnd.

El segundo es que el carro del eje Z esta abajo, pero cuando lo llevo arriba para que baje y presione el el StopEnd, no se mueve, pero si hace mucho ruido y vibra. No he podido avanzar con esos dos temas.

Cabe aclarar que es la primera vez que tengo una impresora de estas, ademas de ser la primera vez que la armo.

Queria pedirles una mano y si tienen algunos consejos para poder hacerla funcionar (hace 4 dias que vengo entre ensamblado y pruebas.)

El modelo es una Geeetech Acrilyc Prusa I3 Pro B (pero el eje X es un upgrade metalico)

Muchas gracias a todos!!!
Citar
#2
(20-12-2016, 03:35 PM)mdiharce escribió: Hola a todos! Anoche termine de ensamblar mi Prusa I3 Pro B... el tema es que he tenido unos problemas:

El primero es que el motor de eje X se mueve en sentido contrario a donde se encuentra el StopEnd.

El segundo es que el carro del eje Z esta abajo, pero cuando lo llevo arriba para que baje y presione el el StopEnd, no se mueve, pero si hace mucho ruido y vibra. No he podido avanzar con esos dos temas.

Cabe aclarar que es la primera vez que tengo una impresora de estas, ademas de ser la primera vez que la armo.

Queria pedirles una mano y si tienen algunos consejos para poder hacerla funcionar (hace 4 dias que vengo entre ensamblado y pruebas.)

El modelo es una Geeetech Acrilyc Prusa I3 Pro B (pero el eje X es un upgrade metalico)

Muchas gracias a todos!!!

El problema de la inversion de sentido es facil de solucionar... hay dos formas, o inviertes el conector de los cables del motor en la ramps, o accedes al fichero configuration.h y cambias el valor de la siguiente declaración por el contrario:

Código:
#define INVERT_X_DIR true    // for Mendel set to false, for Orca set to true

Por otro lado, si el motor Z te vibra y no avanza, seguramente debas ajustar el potenciometro del pololu del eje z para darle algo más de intensidad, ya que no tendrá la suficiente para moverse bien. Hay guias y guias de ajuste de los driver PAP por internet, echales un ojo.
Citar
#3
Puede ser que lo del eje X lo haga con... Repetier Host? o con que aplicacion lo modifico? al igual que lo del Z con alguna aplicacion? Tenganme paciencia por favor! esto es nuevo, de valiente (y loco) me he metido en esto!
Tendras algun link que me sirva aunque sea de punta del ovillo?


Muchas gracias desde ya!!!
Citar
#4
El Eje X lo puedes invertir invirtiendo el orden de tu conector del motor en la ramps (Dandole la vuelta) o cargandole un nuevo firmware modificado, por lo que comentas, tu placa ya ha venido programada, asi que quizá sea mejor que no te metas en el fregado de reprogramarla hasta aprender un poco más. con invertir el conector debería ser suficiente.

Por otro lado, el pololu, que es el driver, el chip que controla tu motor, tiene un pequeño tornillo que puedes regular cerca del chip, con eso puedes proporcionarle más o menos intensidad a ese motor para que se mueva correctamente.
Mucha intensidad es mala, ya que el motor se calentará más, poca tambien lo es, pues el motor podria perder pasos o directamente, no moverse, como te está pasando.

Mirate esto: https://www.zonamaker.com/impresion-3d/c...juste-elec
Citar
#5
(20-12-2016, 04:37 PM)mdiharce escribió: Puede ser que lo del eje X lo haga con... Repetier Host? 

En Repetier vas al menu "Configurar impresora" arriba a la derecha.  A continuación en la pestaña "Impresora" tienes "Invert direction in controls for", en tu caso marcas o desmarcas "X-Axis"

Salut
Citar
#6
Para solucionar lo del eje X hay dos maneras, la que te dicen de girar los cables no se puede hacer fácil en esta tarjeta porque los conectores solo tienen una posición.

Tienes que modificar el firmware, esa línea que te indican.

Desafortunadamente el firmware que proporcionan no compila bien con la última versión del IDE de Arduino, que es el entorno que se utiliza para subir firmware nuevo a la placa de control. O bien tienes que usar una versión vieja del IDE de arduino (1.0.6 o anterior creo, me suena que recomiendan la 1.0.1)
o bien arreglas el hecho de que hay una variable con un nombre que ya está definida en otro sitio (y las versiones más recientes del Ide de Arduino ya no se tragan que eso ocurra y dan un error de compilación)

Yo opté por la segunda opción, renombrar esa variable con otro nombre en todos los sitios donde aparecía (creo que solo era un archivo o dos)

Si quieres te paso mi firmware modificado, pero vamos, es solo eso.

Y lo del Z tiene pinta de ser lo que te dicen, aparte de que estén un poco desalineados en el montaje. Siempre le cuesta más a los motores en Z bajar que subir. Ponle lubricación también si puede ser.


Espero que hayas montado la varillas lisas más largas en el eje Y como toca, no en el eje X, eso también está mal en las instrucciones. Si no tienes más de 200 mm de recorrido en Y y te sobresalen las varillas lisas mucho del eje X, las has puesto mal (espero que no)


El caso es que siguen mandando las impresoras meses después con exactamente los mismos errores aún a pesar de avisarles, los chinos son tremendos en su lamentable atención al cliente. Lo poco que les costaría poner el firmware correcto.

Yo desconozco si el cambio de dirección también se puede hacer desde el repetier. En cualquier caso como no sea algo que guarde en la eeprom de la tarjeta de control, al hacer el homming desde la propia pantalla de la impresora supongo que lo haría mal, te interesa cambiar el firmware.

Además de que te vendrá muy bien saber hacerlo para cuando quieras cambiarle más cosas, por ejemplo para añadirle el sensor de calibración de la cama, o cualquier otra cosa.

La placa es equivalente a un arduino mega 2560, los de geeetech dan manuales para hacer el cambio de firmware.

Supongo que aparte del manual de montaje te dieron el manual de uso en pdf, que tiene el tema de cambiar el firmware, si no pídemelo.




(20-12-2016, 04:54 PM)Shellmer escribió: El Eje X lo puedes invertir invirtiendo el orden de tu conector del motor en la ramps (Dandole la vuelta) o cargandole un nuevo firmware modificado, por lo que comentas, tu placa ya ha venido programada, asi que quizá sea mejor que no te metas en el fregado de reprogramarla hasta aprender un poco más. con invertir el conector debería ser suficiente.

Por otro lado, el pololu, que es el driver, el chip que controla tu motor, tiene un pequeño tornillo que puedes regular cerca del chip, con eso puedes proporcionarle más o menos intensidad a ese motor para que se mueva correctamente.
Mucha intensidad es mala, ya que el motor se calentará más, poca tambien lo es, pues el motor podria perder pasos o directamente, no moverse, como te está pasando.

Mirate esto: https://www.zonamaker.com/impresion-3d/c...juste-elec

En la placa de la geeetech, la GT2560 los conectores que vienen tienen un sentido de inserción, y en el lado de los motores también, así que el truco de girar el cable no es tan directo (habría que soltar cables del conector y volver a ponerlos/soldarlos en orden contrario)
Citar
#7
Buenos dias a todos! ya quedo solucionado (desarme y arme de nuevo)... y cuando empezaron a girar las varillas (con los motores) puse el "carro" y solo empezo a bajar... Guiño
No se si hay que marcarlo como solucionado. igual voy a abrir otro por otra cosa que me sucede... tenganme paciencia... son mis primeros pasos Sonrisa
Gracias a todos los que me ayudaron!
Citar
#8
me pasa lo mismo termine de armar la maquina y cuando hago autohome el axis x y y no se muevenm solo se mueve la cama caliente... se escucha ruido pero no se mueve nada.... como se soluciona?
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
Triste CONSULTA Error en una esquina de un cuadro jaimepineda23 2 226 11-07-2018, 05:18 PM
Último mensaje: jaimepineda23
  Extrusor deja de tirar material, motor mueve en falso el filamento alecq22 2 342 07-07-2018, 03:13 PM
Último mensaje: Simemart
  Error de temperaturas en la LCD Jaume Cat 9 841 31-05-2018, 06:59 PM
Último mensaje: AsdoMX
Exclamación Error en la Lectura de la SD durante la impresion Yko999 2 233 29-05-2018, 08:16 AM
Último mensaje: Funkflyer
  El motor del extrusor hace ruido y da saltitos homer32 8 4,285 09-04-2018, 08:35 PM
Último mensaje: bish