Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
El marlin no me hace caso
#1
Hola que tal. Os cuento uno de mis muchos problemas.
Cuando imprimo un cubo de calibracion. Las medidas no coinciden en el eje x. El eje z lo clava y el y casi tambien. Pero en el x me queda medio milimetro mas pequeño. Hice una regla de 3 con las medidas del cubo para modificar el marlin y que me saliesen mas precisas. Modifico, subo, imprimo y zas otra vez ese medio milimetro. Volvi a hacer la misma operacion y zas otra vez.
Alguien sabe porque puede ser?
Citar
#2
¿Has comprobado que el marlin se sube correctamente? Si tu impresora tiene LCD, puedes ver los valores de los ejes en ajustes creo (y modificarlos ahi directamente para hacer pruebas).
Citar
#3
Yo después de subir Marlin, apago la impresora y la enciendo. No sé si algún parámetro no lo lee de la EEPROM porque ya lo tiene cargado o qué. De hecho no sé por qué la apago, creo me dió algún problema similar en alguna ocasión.
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#4
Quizá el bootloader este dañado y no sube correctamente el nuevo firmware. Es algo que me ha pasado bastantes veces en algún arduino.
Tienes que comprobar si carga el programa correctamente, y si no carga, hay que reprogramarlo
Centrado en el blanco no te caes del banco :icon_e_biggrin: :icon_e_biggrin:
Citar
#5
sois la leche. no se me hanbia ocurrido. comprobe los datos en la pantalla y zas. los datos no se cambian en vez de los valores que le estaba metiendo sigue con los  valores originales.
voy a hacer la prueba a meterlos desde la propia impresora. que debo hacer para poder solucionar lo de que no le entren los datos desde el pc? un saludo
Citar
#6
Lo malo es que cuando apagues la impresora esos datos que cambies se borraran. Si es lo que yo te digo del bootloader, aqui tienes como arreglarlo:
http://zygzax.com/cargar-bootloader-en-a...nda-placa/
Centrado en el blanco no te caes del banco :icon_e_biggrin: :icon_e_biggrin:
Citar
#7
(14-07-2016, 02:37 PM)david55384 escribió: Lo malo es que cuando apagues la impresora esos datos que cambies se borraran. Si es lo que yo te digo del bootloader, aqui tienes como arreglarlo:
http://zygzax.com/cargar-bootloader-en-a...nda-placa/

no solo eso. estube cambiando los datos desde la impresora y cambiar me los cambia. el problema es que cuando hago cualquier otra cosa, conectar el usb, decirle que imprima.etc me los vuelve a resetear. vo a hecharle un vistazo a ver si consigo algo con lo del enlace y te cuento

lo estraño es que cuando cambie e sentido de los motores y los hotend me dejo hacerlo sin problemas

acabo de leerlo deos veces. que necesito otra placa para poder hacerlo??
he intentado hacer lo de la pagina que me pasaste con la placa y me sale esto
Arduino:1.6.9 (Windows 7), Tarjeta:"Arduino Mega ADK"

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xcc
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xc0
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x88
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xfb
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x18
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xf6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xf6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xf6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xf6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xf6
Problema subiendo a la placa. Visita http://www.arduino.cc/en/Guide/Troubleshooting#upload para sugerencias.

Este reporte podría tener más información con
"Mostrar salida detallada durante la compilación"
opción habilitada en Archivo -> Preferencias.
Citar
#8
(14-07-2016, 03:03 PM)spa_sergio escribió:
(14-07-2016, 02:37 PM)david55384 escribió: Lo malo es que cuando apagues la impresora esos datos que cambies se borraran. Si es lo que yo te digo del bootloader, aqui tienes como arreglarlo:
http://zygzax.com/cargar-bootloader-en-a...nda-placa/

no solo eso. estube cambiando los datos desde la impresora y cambiar me los cambia. el problema es que cuando hago cualquier otra cosa, conectar el usb, decirle que imprima.etc me los vuelve a resetear. vo a hecharle un vistazo a ver si consigo algo con lo del enlace y te cuento

lo estraño es que cuando cambie e sentido de los motores y los hotend  me dejo hacerlo sin problemas

acabo de leerlo deos veces. que necesito otra placa para poder hacerlo??
he intentado hacer lo de la pagina que me pasaste con la placa y me sale esto
Arduino:1.6.9 (Windows 7), Tarjeta:"Arduino Mega ADK"

avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0xcc
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0xc0
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x88
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0xfb
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x18
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0xf6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0xf6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0xf6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0xf6
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0xf6
Problema subiendo a la placa. Visita http://www.arduino.cc/en/Guide/Troubleshooting#upload para sugerencias.

Este reporte podría tener más información con
"Mostrar salida detallada durante la compilación"
opción habilitada en Archivo -> Preferencias.

he probado a descargarme el marlin para la mia de un foro de geeetech. a parte del marlin ahi dos enlaces mas para descargar, pero no se como usarlos 
en la pro b 
esta:
marlin
rampas
sanguino.
rampas y sanguino no se para que se usan. puede ser que el fallo lo tenga ahi? yo subo el firmware de la impresora que dice marklin y los otros no les doy uso. tampoco encontre una esplicacion en geeetech para que sirven
Citar
#9
Hola, a mi también me ocurrió lo mismo, investigando en la web, encontre que al conectar arduino al USB y tener conectada la LCD,  ocurre un fallo de escritura en la memoria, pero logré solucionarlo introduciendo los valores desde el PC o la LCD y luego desde la LCD le das a guardar, sin apagar el PC ni la impresora ni nada, sino estos cambios no se guardan y al darle a guardar los cambios desde la LCD se conservan. EL error es el mismo, solo pasa con el AXIS STEP PER UNITS, el resto de configuración se mantiene si la modifico desde el PC, tan solo no se modifica aquellos parámetros a los que tienes acceso desde la LCD.

Espero haber ayudado al menos a solucionar el problema, aunque sigamos sin conocer la explicación del problema, si alguno de los lectores conoce la razón y puede explicarla sería interesante conocer la raíz de este fallo.

Un saludo a todos.
Citar
#10
(17-01-2017, 08:03 PM)Alvaro Martín escribió: Hola, a mi también me ocurrió lo mismo, investigando en la web, encontre que al conectar arduino al USB y tener conectada la LCD,  ocurre un fallo de escritura en la memoria, pero logré solucionarlo introduciendo los valores desde el PC o la LCD y luego desde la LCD le das a guardar, sin apagar el PC ni la impresora ni nada, sino estos cambios no se guardan y al darle a guardar los cambios desde la LCD se conservan. EL error es el mismo, solo pasa con el AXIS STEP PER UNITS, el resto de configuración se mantiene si la modifico desde el PC, tan solo no se modifica aquellos parámetros a los que tienes acceso desde la LCD.

Espero haber ayudado al menos a solucionar el problema, aunque sigamos sin conocer la explicación del problema, si alguno de los lectores conoce la razón y puede explicarla sería interesante conocer la raíz de este fallo.

Un saludo a todos.

Me pasa lo mismo, no se modifican los AXIS STEP PER UNITS. 
¿Como conectas el PC al LCD?

Gracias Makers!
Citar
#11
Hola, este comportamiento es normal y se debe a tener definido EEPROM_SETTINGS en el archivo Configuration.h de Marlin.
Lo único que hay que hacer es recuperar los valores configurados en el firmware a la memoria SRAM y luego volver a guardarlos para que queden establecidos.
Se puede hacer de dos formas: por el menú de la pantalla o enviando comandos Gcode.
En en primer caso, la opción que restablece los valores del firmware es Control>Restaurar memoria y la que los guarda en la EEPROM Control>Guardar memoria.
En el segundo caso, hay que enviar el comando M502 para recuperarlos y M500 para grabarlos.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  ¿MKS Sbase + Marlin 2.0? 3Dsastre 5 162 Ayer, 09:54 PM
Último mensaje: neoxM3
  Marlin 1.1.9 en Anet A8 PatogomaII 9 1,406 18-10-2018, 07:45 PM
Último mensaje: jhony85
  Problema autolevel con Marlin 1.1.9 klipendorf 3 820 07-08-2018, 06:15 PM
Último mensaje: Simemart
  CONSULTA Problema con marlin Vicente48 2 290 23-07-2018, 07:50 AM
Último mensaje: Vicente48
  DUDA Actualizar Marlin? JaumeS 1 402 18-07-2018, 05:17 PM
Último mensaje: andatovid