Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
ERROR CONEXION TMC
#1
Buenas tardes,

Soy nuevo en el foro y también en el mundo de las impresoras 3D.

He montado mi primer KIT y al comprobar la electrónica, me da un error de conexión TMC.
La placa es un skr v1.4, los drivers son 2130 v3 y 2208 v3. Los 2130 van en SPI X, Y, Z. El 2208 en el extrusor en UART. con Marlin.
 
Adjunto foto de la placa.

resim

Muchas gracias de antemano.

Un saludo a todos.
Citar
#2
Hola @F.B.G., bienvenido al foro.
Con tan poca información, sería un ejercicio de adivinación saber cual es el problema que estás teniendo.
Para recabar datos, tendrás que habilitar en el archivo Configuration_adv.h el parámetro TMC_DEBUG y enviar el comando M122 para obtener un informe ampliado del estado de los drivers.
Citar
#3
(12-09-2020, 07:10 PM)Simemart escribió: Hola @F.B.G., bienvenido al foro.
Con tan poca información, sería un ejercicio de adivinación saber cual es el problema que estás teniendo.
Para recabar datos, tendrás que habilitar en el archivo Configuration_adv.h el parámetro TMC_DEBUG y enviar el comando M122 para obtener un informe ampliado del estado de los drivers.

Buenas noches,

Gracias por responder, he realizado el comando en el programa pronterface y adjunto el resultado obtenido, muchísimas gracias.

Un saludo.


Archivos adjuntos
.pdf   M122.pdf (Tamaño: 225.42 KB / Descargas: 9)
Citar
#4
Efectivamente, hay un problema de comunicación entre la MCU y los drivers, que puede ser debido a muchas causas.
Lo primero que debes hacer, si no lo tienes ya, es conectar la placa a la fuente de alimentación y colocar el puente para que utilice el regulador interno en lugar de la alimentación del conector USB: no estoy seguro, pero es posible que los drivers no funcionen si no tienen alimentación por la línea Vm.
Citar
#5
(12-09-2020, 11:05 PM)Simemart escribió: Efectivamente, hay un problema de comunicación entre la MCU y los drivers, que puede ser debido a muchas causas.
Lo primero que debes hacer, si no lo tienes ya, es conectar la placa a la fuente de alimentación y colocar el puente para que utilice el regulador interno en lugar de la alimentación del conector USB: no estoy seguro, pero es posible que los drivers no funcionen si no tienen alimentación por la línea Vm.

Buenos días,

Esa opción que me has comentado la he realizado, pero sigue dando error. Quizás sea la placa que está defectuosa, muchas gracias por responder.

Un saludo.
Citar
#6
hola buenas yo tengo la skr v1.3 y me daba ese error cuando tenia conectada la placa por usb al ordenador
Citar
#7
(22-09-2020, 04:18 PM)roa122 escribió: hola buenas yo tengo la skr v1.3 y me daba ese error cuando tenia conectada la placa por usb al ordenador
Si fuera la placa tendría lógica que no comunicara uno o nos driver, si no comunica ninguno es por configuración en el firmware o algo mal conectado. Has mirado que hayas activado el SPI en configuration_adv?

Enviado desde mi M2003J15SC mediante Tapatalk
Citar
#8
(24-09-2020, 04:55 PM)dvera16 escribió:
(22-09-2020, 04:18 PM)roa122 escribió: hola buenas yo tengo la skr v1.3 y me daba ese error cuando tenia conectada la placa por usb al ordenador
Si fuera la placa tendría lógica que no comunicara uno o nos driver, si no comunica ninguno es por configuración en el firmware o algo mal conectado. Has mirado que hayas activado el SPI en configuration_adv?

Enviado desde mi M2003J15SC mediante Tapatalk


Buenas tardes,

Lo solucioné, era por no soldar el puente de la famosa J2 de los drivers, muchas gracias a todos.

Un saludo.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  DUDA Conexión de Servomotor DC en Ramps Mekruh27 4 251 25-05-2020, 02:00 PM
Último mensaje: Mekruh27
  (SOLUCIONADO) conexion nema 17 en serie y paralelo Jmaster03 12 3,100 21-08-2018, 10:41 AM
Último mensaje: Comediaan
  APORTE Problemas conexión Arduino IDE placa MKS GEN [SOLUCIONADO] dvera16 2 2,076 29-01-2018, 07:18 PM
Último mensaje: dvera16
  Esquema conexión driver motor s118 6 7,170 12-10-2016, 11:05 AM
Último mensaje: s118
  Arduino y Ramps, ¿quemados o mala conexión? AntTuru 14 4,834 11-10-2016, 09:41 PM
Último mensaje: Shellmer