Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Duda error arduino.
#1
Hola. Primero de todo, felicitaros las fiestas y desearos un mejor año entrante.
Y ahora una duda.
He terminado de montar el multicoptero, con una Multiwii 2.0 SE, y al cargar el programa, al finalizar me sale este error:
avrdude: stk500_getasync(): not in sync: resp=0x00

Creo entender que es un error de sincronia, pero no alcanzo a ver que es. Por otra parte cuando abro el programa GUI, no se reconoce el quad. Sale una sola linea plana. En dias anteriores, probando, si que consegui que el programa reaccionara con el quad, y se movia el grafico con el movimiento del quad y salian todas las lineas de canales conectados. Pero hoy llevo varias pruebas y no hay manera. A ver si algun alma caritativa me ilumina sobre lo que pueda estar pasando. Algo hare mal, y no se que es.

Gracias.
Citar
#2
Pues resuelta la duda.
Sin querer habia cambiado el puerto com en el arduino, y claro, no cargaba. Tras varias pruebas me he dado cuenta del error y está solucionado.
Ahora el problema es que no se arma el quad. Hago el movimiento del stick para armarlo, (Stick derecha y abajo) pero no se arma.
Alguna sugerencia?
Citar
#3
Novedades:
He logrado armar y los motores giran. Uno de ellos se ha calentado muy rápido y su opuesto le cuesta arrancar. Da tirones. Me acabo de desmoralizar entero.
Citar
#4
regula el amperaje de los motores atraves de los drivers
Citar
#5
Como deberia hacerlo?
Citar
#6
Bueno. Tema resuelto. Lo explico por si a alguien le sirve como precaucion.
Resulta que habia puesto unos tornillos demasiado largos para anclar los motores. Los dos motores que fallaban, habia apretado mucho mas los tornillos, de modo que pasaban casi dentro del rotor, frenandolo. Por eso daba los tirones, y uno de ellos se ha quemado. Me despisté, porque dos funcionaban bien, (los que tenian los tornillos menos apretados) y los otros no. He verificado los ESC y estan bien programados. Finalmente, probando, motor por motor y cambiando de sitio, me he dado cuenta del error. He aprendido un monton. El sacrificio ha sido un motor.
Fallo de novato que me ha dolido mas por la estupidez del asunto, (con lo facil que era) que por perder el motor.
Ahora el tema es encontrar un motor igual o similar para sustituir.

Disculpad por la rayada.
Saludos.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Ayuda con Baseflight y error de puerto marcoswally 4 1,343 15-02-2015, 10:10 PM
Último mensaje: marcoswally