Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
DUDA Velocidad en GRBL
#1
Hola a todos,
Antes de poner la duda quisiera presentare en el foro, lo hago en este post ya que no he visto ninguno dedicado para ello. 
Mi nombre es Nichel y vengo de montar una Impresora 3D. Actualmente estoy cacharreando cosas varias...

Bueno, mi duda es la siguiente.

Estoy intentando configurar el GRBL, a la hora de modificar la velocidad, tanto en movimiento con peso como libre, los $4 y 5$, siempre que pongo un valor distinto de 0, sea cual sea, aparece cuando hago el $$ como que $4 o $5 es 1 (da igual esl valor que le ponga) poniendo cualquier valor en motor, cuando mando a que se mueva, comienza a sonar como si estuviera en bloqueo y no se mueve.
En cambio si el valor es 0 el motor se mueve perfectamente y sin ningun sonido extraño.

He de decir que estoy usando GRBL modificado para MEGA y RAMPS (no se si el problema viene de ahí)

La cosa es que estoy montando un carro para un terreno que tengo, dicho carro pesará unos 3 kilos a lo sumo, y quiero conseguir una velocidad media alta para mover dicho carro.
He intentado hacerlo con marlin pero por lo que tengo entendido marlin está un poco capado cosa que GRBL no, asi que estoy tirando por ahi.

Gracias de antemano por las respuestas!
Citar
#2
Seguro que modificas el parametro adeciado? No me suena que esos valores de cambien en 4 y 5, si no mas bien en la segunda mitad de la tabla.
Citar
#3
Hola y bienvenido,

no sé que versión de grbl estás usando pero te pongo los parámetros de la v 0.9:

$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=1 (homing dir invert mask:00000001)
$24=50.000 (homing feed, mm/min)
$25=635.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=314.961 (x, step/mm)
$101=314.961 (y, step/mm)
$102=314.961 (z, step/mm)
$110=635.000 (x max rate, mm/min)
$111=635.000 (y max rate, mm/min)
$112=635.000 (z max rate, mm/min)
$120=50.000 (x accel, mm/sec^2)
$121=50.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=225.000 (x max travel, mm)
$131=125.000 (y max travel, mm)
$132=170.000 (z max travel, mm)

En este caso la velocidad son $110, $111 y $112

Saludos
Citar
#4
Correcto, pero no se que tiene que ver en la velocidad los del 4 y 5. Porque los cambias?
Citar
#5
No obstante, estas usando valores muy bajos para velocidad y aceleracion. En aceleracion puedes meter 1500-200 y velocidad lo mismo o incluso subir a 3000. Depende de tu maquina. En el caso de usar correas.
Citar
#6
(26-12-2017, 05:24 PM)grafisoft escribió: No obstante, estas usando valores muy bajos para velocidad y aceleracion. En aceleracion puedes meter 1500-200 y velocidad lo mismo o incluso subir a 3000. Depende de tu maquina. En el caso de usar correas.

Él no ha puesto sus datos, los datos que pongo yo son de ejemplo y sacados de github Mola 

Saludos.
Citar
#7
Smash2 Smash2 Smash2
Citar
#8
ostrasssss, pues vaya armada metí.

Los valores de velocidad en el 4 y el 5 los saqué de un video de youtube, que o esta mal, o yo lo interpreté mal (seguramente lo segundo) Gran sonrisa
Aun no tengo valores, pq mi intención es con prueba error ir mirando hasta el punto que falle.
Muchísimas gracias por las respuestas, sobre todo por haber sido tan rapidos.




PD. El video que ví es del siguiente enlace y en el minuto 3 aparece.
Pero he visto que es de la versión 0.8c con lo que claro, ahora estará todo cambiado, siento molestar para esto, nuevamente mil gracias!
Citar
#9
De grbl usar mínimo la versión 0.9i. Lo recomendado es ir a la ultima. Para según que cosas, hay mucha diferencia.
Citar
#10
Buen dia con todos yo tengo problemas con mi cnc que arme, e configurado el grbl y lo e probado todo normal gira sin problemas, el error viene cuando va hacer un dibujo, comiensa a sonar y perder pasos en movimientos pequeños, a alguien le sucedio lo mismo si es asi pueden ayudarme por favor

Enviado desde mi Redmi Note 3 mediante Tapatalk
Citar
#11
(27-12-2017, 05:55 AM)ingrc escribió: Buen dia con todos yo tengo problemas con mi cnc que arme, e configurado el grbl y lo e probado todo normal gira sin problemas, el error viene cuando va hacer un dibujo, comiensa a sonar y perder pasos en movimientos pequeños, a alguien le sucedio lo mismo si es asi pueden ayudarme por favor

Enviado desde mi Redmi Note 3 mediante Tapatalk

Puede ser que no le des lanpotencia suficiente a los motores porque lo tengas configurado asi en sus respectivos drivers o que tu fuente de alimentacion no sea suficiente. Ponle los pasos al maximo (1/16 o 1/32)

Por fallo de software dudaria, por defecto la resolucion es buena.
Citar
#12
(26-12-2017, 09:48 PM)Nichel escribió: ostrasssss, pues vaya armada metí.

Los valores de velocidad en el 4 y el 5 los saqué de un video de youtube, que o esta mal, o yo lo interpreté mal (seguramente lo segundo) Gran sonrisa
Aun no tengo valores, pq mi intención es con prueba error ir mirando hasta el punto que falle.
Muchísimas gracias por las respuestas, sobre todo por haber sido tan rapidos.




PD. El video que ví es del siguiente enlace y en el minuto 3 aparece.
Pero he visto que es de la versión 0.8c con lo que claro, ahora estará todo cambiado, siento molestar para esto, nuevamente mil gracias!

Revisando el video de tu enlace es cierto que los parámetros de velocidad son $4 y $5. Yo comprobaria la aceleración. Es un arduino mega con ramps 1.4 ¿no? ¿los motores cuáles son? ¿cómo tienes regulada la corriente en el driver? Podrias poner tu configuración de grbl.

Saludos.
Citar
#13
[quote='drow' pid='86549' dateline='1514366808']
[quote='Nichel' pid='86531' dateline='1514321321']

Hola Drow,

Si, es una ramp 1.4 que estoy peleandome con ella para ver si consigo que funcione. Realmente no es para hacer una CNC pero como es algo que necesita fuerza pues he optado por este firmware.

Los motores son unos reciclados que me dejo un compi de una maquina que descuartizó, son unos nema 23 y la numeración que aparece en el motor es Stepb-Syn type 103H7123-0642 DE Sanyo Denky, no se si serán buenos, medios o mediocres jejeje

La configuración pues estoy trabajando en ella, ciertamente los parámetros de velocidad eran los que pusieron ustedes asi que ahora toca trastear ya que ahora no entiendo por que no se me conecta el arduino, pero prefiero, antes de preguntar, intentar saber el por qué

Muchas gracias
Citar
#14
(26-12-2017, 04:08 PM)drow escribió: Hola y bienvenido,

no sé que versión de grbl estás usando pero te pongo los parámetros de la v 0.9:

$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=1 (homing dir invert mask:00000001)
$24=50.000 (homing feed, mm/min)
$25=635.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=314.961 (x, step/mm)
$101=314.961 (y, step/mm)
$102=314.961 (z, step/mm)
$110=635.000 (x max rate, mm/min)
$111=635.000 (y max rate, mm/min)
$112=635.000 (z max rate, mm/min)
$120=50.000 (x accel, mm/sec^2)
$121=50.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=225.000 (x max travel, mm)
$131=125.000 (y max travel, mm)
$132=170.000 (z max travel, mm)

En este caso la velocidad son $110, $111 y $112

Saludos
Eso depende de cada motor en caso tengo dos motores de 7.5 de paso y un motor para el eje z que saque de una lectora de cd lo eh configurado pero cuando va a dibujar sale mal, cuando da la primera pasada todo normal la segunda comienza a fallar no sale en dirección a la primera pasada alguien de ayudarme por favorresimresimresimresim

Enviado desde mi Redmi Note 3 mediante Tapatalk
Citar
#15
(31-12-2017, 09:59 PM)ingrc escribió:
(26-12-2017, 04:08 PM)drow escribió: Hola y bienvenido,

no sé que versión de grbl estás usando pero te pongo los parámetros de la v 0.9:

$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=1 (homing dir invert mask:00000001)
$24=50.000 (homing feed, mm/min)
$25=635.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=314.961 (x, step/mm)
$101=314.961 (y, step/mm)
$102=314.961 (z, step/mm)
$110=635.000 (x max rate, mm/min)
$111=635.000 (y max rate, mm/min)
$112=635.000 (z max rate, mm/min)
$120=50.000 (x accel, mm/sec^2)
$121=50.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=225.000 (x max travel, mm)
$131=125.000 (y max travel, mm)
$132=170.000 (z max travel, mm)

En este caso la velocidad son $110, $111 y $112

Saludos
Eso depende de cada motor en caso tengo dos motores de 7.5 de paso y un motor para el eje z que saque de una lectora de cd lo eh configurado pero cuando va a dibujar sale mal, cuando da la primera pasada todo normal la segunda comienza a fallar no sale en dirección a la primera pasada alguien de ayudarme por favorresimresimresimresim

Enviado desde mi Redmi Note 3 mediante Tapatalk

Creo que tienes mal configurado los pasos por mm. Para ajustarlos es necesario saber los pasos del motor, los micropasos del driver y el paso de la varilla que estés usando.

Lo mismo tendria más visibilidad si crearas un post con el problema que comentas. A parte de lo que te he comentado, seria conveniente saber que electrónica estás usando y cómo (de corriente) están regulados los drivers.

Saludos.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Comando gcode velocidad ivcontrer 2 1,558 29-02-2016, 05:32 PM
Último mensaje: ivcontrer
Exclamación Cambio velocidad del homming ??????? krampman 5 3,659 24-12-2015, 07:23 PM
Último mensaje: daniocebra