Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
DUDA Problema Homing
#1
Buenas a todos,

Tengo montada una impresora 3D con todos los ejes calibrados. Soy capaz de mover los tres ejes sin problema en la dirección que quiera sin embargo, cuando hago un homing de todos los ejes, ya sea por comando o pulsando la "casita", solo se mueve el eje Z y en sentido contrario al que debería, el resto de motores no hacen ni el intento de moverse.
Esto me pasa tambien si trato de hacer homing del eje X o del eje Y, solo se mueve el eje Z y en sentido contrario. El unico homing que va bien es si soo hago home del eje Z, en ese caso la maquina si hace lo que debería.
He trato de cambiar la configuracion del Marlin de mil formas pero nada, haga lo que haga siempre me pasa lo mismo. ¿A alguno se le ocurre una solucion?

Gracias por su atención.
CNoble
Citar
#2
Hola, es raro que puedas mover los ejes en todas las direcciones y que no haga el "homing".
¿Estás seguro que los ejes se mueven en sentido negativo?
Porque los síntomas parecen típicos de finales de carrera siempre activados. Puedes comprobarlo enviando un comando M119.
Pero si fuese así, no te dejaría mover los ejes en la dirección del "home".
De todas formas, revisa también la configuración en Marlin de la dirección del "homing".
Se indica en las siguientes líneas:

// Direction of endstops when homing; 1=MAX, -1=MIN
// :[-1,1]
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1


Un saludo.
Citar
#3
He comprobado mil veces los finales de carrera y no están pulsados. Ahora mismo no me deja mover los ejes en sentido negativo pero por temas de límites de software no por endstops, si la máquina hiciera bien el homing no habría problema en ese ya que tendría el 0.0 bien posicionado.
Ayer fui capaz de hacer un home, antes de poner este post, y no hubo ninguno problema. Poco después quise hacer otro homing de prueba y fue cuando empezó a darme este error, desde entonces siempre que trato de hacer home de cualquier eje, lo único que se mueve es el eje Z hacia arriba.
He probado todo tipo de configuraciones y no hay manera, he buscado por internet información de todo tipo y no encuentro nada que me sirva de ayuda.
Es muy raro, ya que mandó la orden de hacer homing del eje X y... ¡¡Se mueven los motores del Z!! No consigo encontrarle una explicación y estoy empezando a desesperarme.
Citar
#4
Hola, mientras el firmware tenga indefinida la posición, no permitirá movimientos negativos de los ejes. Eso es correcto.
Lo raro es que, sin tener activados los finales de carrera, no realice el "homing".
Como es lógico, para hacerlo se salta esa limitación o nunca podria establecerse el 0 de los ejes.
Que se mueva el eje Z al ordenar el "home" es normal. Antes de realizar el "homing", se eleva ligeramente el eje Z para evitar posibles colisiones.
¿Qué versión de Marlin tienes instalada? Quizá tu mejor opción sea reinstalar desde cero con la última versión y con todo perfectamente controlado.
Citar
#5
Tengo la última versión de Marlin instalada, luego voy a probar skynet a ver si con ese firmware me va mejor.
Ya, el tema es que el eje Z sube pero nunca para, tengo que cortar la corriente.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Anomalia en el Homing Z CheddarOP 31 3,272 16-04-2016, 11:36 AM
Último mensaje: katraska
  Problemas con la impresora, Homing y más Jarryson 18 3,814 09-04-2016, 05:59 PM
Último mensaje: Jarryson
  (SOLUCIONADO)No hay forma de hacer homing HELP adc0891 5 1,224 19-01-2015, 01:06 PM
Último mensaje: adc0891
  la prusa i3 no me hace homing¡¡¡ AYUDA PORFAVOR wuasichu 3 813 19-09-2014, 10:03 AM
Último mensaje: wuasichu
  problemas con el homing y el extrusor zorro12345 3 692 14-06-2014, 09:05 PM
Último mensaje: zorro12345