Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
DUDA Desplazamiento capas eje Y
#1
Exclamación 
Buenos Dias.
Tras desmontar la Anet a8 completa para hacer algunas modificaciones me he encontrado con que ahora e desplaza las capas en el eje Y

Las mejoras que he hecho son

Armario Ikea STUVA
resim

Iluminacion LED + Reles
Fuente 420W
Caja para la electronica
Actualizacion de Pi 2 a 3B+
WebCam para OctoLapse
Cadena parametrica en el Eje X
Amortiguador Eje Z
MArlin 2.0 bugfix

El resto lo tengo igual..
Tensores en ambas cadenas(X,Y)
La Anet esta atornillada al mueble para evitar vibraciones, ademas de llevar los refuerzos del marco.

resim

El problema es que desde que he hecho toodo esto ahora tengo desplazamientos de Y batante brutales
He ido bajando la velocidad hasta los 40mm/s y no es eso, estoy casi seguro de que pierde pasos, pero no veo como arreglarlo


resim
resim

No hay nada que bloquee el Y ni la cadena ni la cama, ni la cadena..

Alguna idea de por donde atacar este fallo??


Gracias a todos.
Citar
#2
Hola, pueden ser varios los motivos de ese fallo: de tipo mecánico o electrónico.
Para los primeros, tendrás que comprobar que la cama se desliza suave sin tener la correa dentada y que está bien apretada la polea del motor del eje Y.
Los segundos pueden venir por sobrecalentamiento de los drivers y/o motores, cosa que puede ser más fácil que se produzca al estar la impresora cerrada.
Dices que has puesto en una caja la placa, supongo que con ventilación forzada, pero comprueba que está funcionando de forma efectiva la refrigeración.
La placa Anet trae una regulación de corriente de los drivers bastante generosa, lo que hace que se calienten más, tanto estos como los motores.
Comprueba su temperatura al tacto después de un tiempo de impresión.
Citar
#3
Pregunta tonta ... No tienes el sensor de autonivelación muy por debajo del nozzle?
Citar
#4
Podria ser un tema de temperaturas como te comentan, sin embargo, si nos fijamos exclusivamente en las imagenes, has impreso unas 4 piezas y curiosamente, parece que te ha fallado la impresión y se te han desplazado las capas al llegar a unas determinadas alturas.
Yo comprobaría la mecánica, puede que tengas algún problema en el eje Z y se te enganche algo, podría ser el extrusor contra la pieza por ejemplo o como te comentan, incluso que el propio sensor de autolevel te toque contra la pieza, te frene la base y pierdas pasos.

Por ultimo, no se si es efecto optico por como esta realizada la foto, pero la varilla lisa del lado derecho del eje Z parece algo doblada...
¿Ese tensor que estas usando para la correa del eje X hace la fuerza sobre las varillas del X o no está apoyado en nada? Lo digo porque en las impresoras cuando estan de serie la fuerza se hace sobre la pieza y acaba causando que las varillas del X se introduzcan mas en la pieza derecha y acaben doblando tanto las varillas lisas como las roscadas o husillos.
Citar
#5
Muchas gracias por los aportes, os cuento...

@Simemart

Para los primeros, tendrás que comprobar que la cama se desliza suave sin tener la correa dentada y que está bien apretada la polea del motor del eje Y.

He desmontado todo el tren Y, no hay obstaculos, los rodamientos se desplazan bien, se me ha ocurrido pensar que se hubiesen desplazado las varillas lisas del Y con todo el traqueteo, pero entonces tendrian que salir todas las capas desplazadas....

Los segundos pueden venir por sobrecalentamiento de los drivers y/o motores, cosa que puede ser más fácil que se produzca al estar la impresora cerrada.
Dices que has puesto en una caja la placa, supongo que con ventilación forzada, pero comprueba que está funcionando de forma efectiva la refrigeración.


La caja de electronica es esta

En lugar del dos mosfets, que no creo que valga la pena el de extrusor, tengo una [url= https://www.dx.com/p/usb-male-12v-24v-to...ck-2054584]fuente de alimentacion para la Pi.[/url]



Esta refrigerada con un ventilador de 12cm, aunque al tenerla cerrada, la idea era empezar con ABS, puede que no sea suficiente, el termometro me esta marcando unos 68ºC de temperatura ambiente dentro del mueble.


La placa Anet trae una regulación de corriente de los drivers bastante generosa, lo que hace que se calienten más, tanto estos como los motores.
Comprueba su temperatura al tacto después de un tiempo de impresión.

Se me ha ocurrido poner un par mas en la zona de los drivers, creo que con la pi podre poner al menos otros dos...
La idea es montar una extraccion con filtro de carbon gestionada por la temperatura, para mantener el ambiente todo el rato igual, me dado cuenta que con el aporte del extrusor va subiendo la temperatura poco a poco... y creo que lo ideal seria mantener la misma temperatura que la cama.


@3dwork

Pregunta tonta ... No tienes el sensor de autonivelación muy por debajo del nozzle?
El sensor esta a 2,4 mm por encima del extrusor, puede que sea poco, pero tengo pendiente montar el optoacoplador, como es el LJ18A3-8-Z/BX lo tengo directo a placa.

resim

@Shellmer
Podria ser un tema de temperaturas como te comentan, sin embargo, si nos fijamos exclusivamente en las imagenes, has impreso unas 4 piezas y curiosamente, parece que te ha fallado la impresión y se te han desplazado las capas al llegar a unas determinadas alturas.

Yo comprobaría la mecánica, puede que tengas algún problema en el eje Z y se te enganche algo, podría ser el extrusor contra la pieza por ejemplo o como te comentan, incluso que el propio sensor de autolevel te toque contra la pieza, te frene la base y pierdas pasos.

He estado haciendo pruebas de travelling de los ejes y no parece que esten tropezando con nada, ni tampoco hay ruidos raros.
Voy a ver si hago la misma prueba con todo calentito, a ver si es eso. Voy a grabar un video del travel y lo subo, a verdad es que en frio va muy bien. Cerrare la puerta y lo calentare todo hasta los 70ª a ver si falla algun motor.

Por ultimo, no se si es efecto optico por como esta realizada la foto, pero la varilla lisa del lado derecho del eje Z parece algo doblada...
¿Ese tensor que estas usando para la correa del eje X hace la fuerza sobre las varillas del X o no está apoyado en nada? Lo digo porque en las impresoras cuando estan de serie la fuerza se hace sobre la pieza y acaba causando que las varillas del X se introduzcan mas en la pieza derecha y acaben doblando tanto las varillas lisas como las roscadas o husillos.

Supongo que son las fotos, te subo unas lo mas paralelas posible....
resim

resim

Mejor???

El tensor que uso de X es este.


Un Saludo a todos y muchas gracias por los aportes.
Citar
#6
Hola de nuevo,

Es que en una de las fotos primeras que pones, esta bastante mas por debajo (o al menos me lo parece), en esta otra que pones esta correcto obviamente.

Un saludo!

En esta precisamente:

https://ibb.co/rkxnLk3
Citar
#7
65° de temperatura ambiente para la electrónica es mucho. La protección de los drivers salta a 80 grados, no me equivoco, así que yo apostaría por eso. También cuadra con que al hacer peqeuñas pruebas no te falle, ya que no tienen tiempo a calentarse.

Lo mejor, sacar la.electronica fuera aún que para ello suele haber que alargar los cables.

Yo tengo un cerramientos parecido y he dejado dentro la electrónica, simplemente he puesto el ventilador de la placa en la pared del cerramiento, metiendo aire fresco y he puesto la placa contra este, fijada a esa misma pared. Con eso y 2 agujeritos superiores para el filamento, la temperatura ambiente es difícil que me pase de 45° y no me da problema alguno. Todas las paredes y el resto de juntas las tengo selladas con silicona.
Citar
#8
Ojo que la temperatura de trabajo de los motores también es por debajo de 80º, si ya está a 70ºC con el trabajo subirá a 80 en muy poco tiempo.

Hay en thingiverse una "caja" para los motores al que se puede acoplar un ventilador y refrigerarlos, pero creo necesitarías tubos  desde el exterior hasta cada motor... https://www.thingiverse.com/thing:3021279

Lo siento, pero creo que no es la impresora más adecuada para estar completamente cerrada. En la ulticampy puedes poner los motores por fuera de la impresora (no es lo normal, pero puede hacerse) y el del eje Z ya está "fuera del horno"

Si te vas a gastar una pasta en control de temperatura, lo primero es sacar los motores y electrónica fuera.
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#9
Imprimiendo refrigeradores de motor.....
--
Anet A8 - Anycubic i3 Mega - Ender3 - Photon - Delta + Diamond Nozzle (in progress)
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  DUDA Desplazamiento eje Y Anet E12 Javivi61083 5 318 13-11-2018, 06:26 PM
Último mensaje: Nullz
  DUDA desplazamiento correa del eje y kirisutoxixu 5 351 18-10-2018, 03:34 PM
Último mensaje: Estrallator
  CONSULTA Desplazamiento erroneo eje Y Anet A6 DavidMJ 5 588 04-10-2018, 02:01 PM
Último mensaje: DavidMJ
  CONSULTA Desplazamiento de capas en anet a8 Agh_23 5 1,059 26-09-2018, 02:32 PM
Último mensaje: DavidMJ
  CONSULTA Capas desplazadas Anet A8 Ignicolist88 7 614 17-08-2018, 08:59 AM
Último mensaje: fbforos