Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
DUDA Autolevel
#1
Hola gente del foro! Ante todo gracias a aquellos que han aportado sus dudas y conocimiento con los que indirectamente me han ayudado y enseñado!

Tengo un problema un tanto extraño, acabo de instalar un autolevel con servo con parada en Z_MAX, al probar desde Prontface el comando G29 zondea sin problema alguno y me muestra el resultado. Por ende decidí colocar el gcode en slic3r para que lo haga cada vez que ppngo a imprimir.. El problema viene cuando desde la SD pongo a imprimir.. Este es el gcode al start

G21
G28
G29
G0 X-5 Y-5 Z5 F4500
M109 S200
G1 E30 F600
G92 E0
M160 S60
M117 Imprimiendo...

El homing lo hace sin problema y luego se reinicia, he probado otro archivo sin G29 e imprime sin dramas..

Estoy usando Marlin 1.1.9 em una RAMPS 1.4

[edito] pruebo hacer el autolevel desde el menu del LCD y sucede lo mismo, se reinicia.. Es curioso que con la impresora conectada al ordenador, hice la misma prueba y sondeo sin reiniciar..

Desde ya gracias a todos y espero puedan darme una orientacion.
Citar
#2
Antes del G29 ejecuta un G26 con las características de tu cama.

Aunque para mi lo mejor, mientras no muevas la cama es hacer el G29 una vez, en cualquier momento fuera de una impresión y guardarlo con un M500 y meter un M501 antes del G28 al inicio de un programa. Si no la cama no la mueves no tiene mucho sentido hacer un sondeo cada vez que algo empieza.

resim
Citar
#3
Hola, sólo un apunte a lo comentado por @Fendetestas: si no se ejecuta el comando G29 y se cargan con M501 los valores almacenados en la EEPROM, en caso de tener deshabilitado el parámetro RESTORE_LEVELING_AFTER_G28 en el archivo Configuration.h (está así por defecto), hay que poner un comando M420 S1 para activar el autolevel, ya que el "homing" lo desactiva.
En todo caso, Marlin recomienda ponerlo siempre.
Que puedas hacer el G29 desde Pronterface y no desde el archivo gcode es bastante raro. Quizá tengas un problema de alimentación del Arduino Mega cuando no está conectado por USB y seguramente se resetea a causa del servo del sensor. Puedes probar con la SD, pero sin desconectar el cable USB (sin ninguna aplicación abierta que controle ese puerto en el ordenador).
Por otra parte, entiendo que la finalidad de la línea G0 X-5 Y-5 Z5 F4500, es sacar fuera de la cama la boquilla antes de cebarla con la orden G1 E30 F600 pero, ¿te permite el firmware hacer ese movimiento?
Citar
#4
Hola chicos!! Gracias por responder! 

(02-02-2019, 05:24 PM)Simemart escribió: Hola, sólo un apunte a lo comentado por @Fendetestas: si no se ejecuta el comando G29 y se cargan con M501 los valores almacenados en la EEPROM, en caso de tener deshabilitado el parámetro RESTORE_LEVELING_AFTER_G28 en el archivo Configuration.h (está así por defecto), hay que poner un comando M420 S1 para activar el autolevel, ya que el "homing" lo desactiva.
En todo caso, Marlin recomienda ponerlo siempre. 
Anteriormente utilizaba BED_MESH_LEVELING y luego de G28 usaba M240 S1 sin problema luego de haber nivelado desde el LCD..

(02-02-2019, 05:24 PM)Simemart escribió: Que puedas hacer el G29 desde Pronterface y no desde el archivo gcode es bastante raro. Quizá tengas un problema de alimentación del Arduino Mega cuando no está conectado por USB y seguramente se resetea a causa del servo del sensor. Puedes probar con la SD, pero sin desconectar el cable USB (sin ninguna aplicación abierta que controle ese puerto en el ordenador).
 
Voy a verificar hacerlo con el USB conectado y desde un archivo en la SD asi descarto el tema de corriente..

(02-02-2019, 05:24 PM)Simemart escribió: Por otra parte, entiendo que la finalidad de la línea G0 X-5 Y-5 Z5 F4500, es sacar fuera de la cama la boquilla antes de cebarla con la orden G1 E30 F600 pero, ¿te permite el firmware hacer ese movimiento?
Disculpen que no haya comentado el gcode.. edite desde el celular sin tiempo, efectivamente G0 X-5 Y-5 Z5 F4500 es para purgar, los endstop los tengo a X-30 Y-10 por lo que puedo tranquilamente ir a esa posición
Citar
#5
Hola chicos! gracias por la ayuda! resulto ser que el problema era el LCD, termine cambiandolo y ahora funciona sin problema! un abrazo!!
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Mi BCN3D+ con autolevel y caja cerrada mezanu 2 1,327 15-12-2014, 01:01 PM
Último mensaje: AlexQuad