Calificación:
  • 3 voto(s) - 4.33 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Cortadora FOAM XXL 4 ejes 1,5m x 1,5m x 2 m BBB (Buena, bonita y barata)
#61
Hola de nuevo, solo quería confirmarte que el firmware que estamos usando si que funciona aunque muestre ese mensaje en el GrblController. Ayer estuve probando el movimiento de la mía con los 4 motores y sin problemas.

Los avances sobre mi proyecto los iré poniendo en ese hilo.
Citar
#62
Pues ni idea que puede ser
voy a probar con otro pc , no vaya a ser que sea problema del pc algun programa que no le deje ir bien
la electronica se me atraganta un poco

Yo sigo con la electronica, a la espera de la placa mega y a probar en pc diferente
Si alguno tiene alguna idea de como soluciono para la lo que me pasa le agradeceria
Saludos
Citar
#63
Tengo en mente preparar un pequeño video sobre la electrónica, pero aún tardará un poco.
Citar
#64
Puede que sea muy malo, pero tres arduinos uno, tres shield y esto no funciona ni bien ni mal con ninguno, ya no se que hacer, supongo es muy complicado pero no se me ocurren mas cosas
me va a llegar la placa mega con lo demas y presupongo que pasara lo mismo
alguien sabe como puedo detectar que pasa, porque con otro ordenador, con antivirus sin el, da exactamente lo mismo
alguien puede ponerme los parametros del grbl settings por si es eso (es lo unico que se me ocurre)
resim
pongo foto todas no pueden estar mal, estadisticamente es muy improbable
se me acaban las ideas y ya paso de gastar mas pasta sin tener claro que esto funcione,
muchas gracias por vuestra ayuda
Citar
#65
Has conectado los motores?, que problema tienes exactamente?
Citar
#66
EL mayor problema esta descrito, solo van tres motores
el cuarto no reconoce, el porque ni idea
sigo dandole vueltas
Citar
#67
No se si las fotos son actuales de como tienes configurada la cnc shield, pero para que se mueva el cuarto motor debes poner dos jumper en la zona donde se define como actúa el cuarto eje.  Mas concretamente cerrando D12 y D13...

resim

Los jumper quedarian en la parte de arriba de la entrada de corriente.

Si los pones donde pone X, el 4º eje será esclavo del eje X, si los pones donde marca Y, será esclavo del eje Y, así mismo pasaría con el eje Z, pero si los colocas en D12 y D13 se convierte en un eje independiente.
Citar
#68
Pues no se de que me hablas, me figuro que sera algun puente pero ni idea, yo la tengo asi tal cual la foto lo unico que tengo puestos puentes es para medios pasos que creo que va así, no se donde lo he leido, el resto no tengo puesto nada (no he leido que haya que poner en otro sitio, solo para clonar ejes, pero no es el caso¿no?, porque van independientes
Gradcias y perdona las molestias, no lo pillo ni bien ni mal.

resim
Citar
#69
Justo arriba del conector azul de corriente tienes una zona para colocar jumpers y determinar el comportamiento del 4 motor.

Fíjate que pone X, Y, Z y D12. Tienes que poner dos jumper cerrando D12 y D13.

Eso indica a la shield que el cuarto ejr será independiente.

Mañana pondré alguna foto de la mía.
Citar
#70
Hola, y por fin una mejora gracias a tus conocimientos
he cerrado el d12 -d13 y por lo menos han movido los motores por un instante, pero se ha parado se ha bloqueado ela placa arduino y ahora no se ve nada y si intento reinstalar me da errores a monton, sigo con ella me ha animado
Por fin ha llegado arduino mega pero no localizo por ningun lado el firmware a instalar y los terminales(o como se llamen) a cerrar me parecio ver que habia para mega en https://github.com/LETARTARE
pero da que no existe nada asi que no se que firmeare instalar a ver si esto arranca con el mega
aun asi me ha animado tanto el que se muevan los motores que he comprado otra arduino uno y otra shield, con esto van 5 placas arduinos con sus shield o ramps, vamos una ruina pero bueno
voy a intentar arrancar de cero con arduino uno con placas nuevas
a la mega no le pongo nada hasta ver que le instalo, eso si cuando lo consiga prometo poner los pasos de uno en uno para los que no somos capace de arrancar la electronica
Graciassss
Citar
#71
por fin funciona, y os cuento todo el proceso
el mega no lo he probado, pero me ha llegado de españa en dos dias el material nuevo


Arduino Uno R3 MEGA328P ATMEGA16U2
CNC Shield V3 para Arduino uno
Driver StepStick A4988 (16 Micropasos)

paso uno
instalo arduino version 1.6.7
luego en
herramientas >placa > arduino uno
herramientas > puerto > el que sea
elimino el texto que hay y pego esto para limpian la eprom

/*
* EEPROM Clear
*
* Sets all of the bytes of the EEPROM to 0.
* Please see eeprom_iteration for a more in depth
* look at how to traverse the EEPROM.
*
* This example code is in the public domain.
*/
#include <EEPROM.h>
void setup() {
// initialize the LED pin as an output.
pinMode(13, OUTPUT);
/***
Iterate through each byte of the EEPROM storage.
Larger AVR processors have larger EEPROM sizes, E.g:
- Arduno Duemilanove: 512b EEPROM storage.
- Arduino Uno: 1kb EEPROM storage.
- Arduino Mega: 4kb EEPROM storage.
Rather than hard-coding the length, you should use the pre-provided length function.
This will make your code portable to all AVR processors.
***/
for (int i = 0 ; i < EEPROM.length() ; i++) {
EEPROM.write(i, 0);
}
// turn the LED on when we're done
digitalWrite(13, HIGH);
}
void loop() {
/** Empty loop. **/
}

lo subo al arduino
borro esto y voy dentro de arduino a

programa > incluir libreria > añadir linreria zip > seleccionar grbl-xyuv-master.zip y ok
programa > incluir libreria > grbl-xyuv-master
 subo esto y me da subido osea todo ok

desenchufo usb arduino y le inserto la v3 con los A4988
pongo los dos jumper cerrando D12 y D13.  no pongo ni uno mas

vuelvo a enchufar el usb

ajusto los a4988 como dice este video
https://www.youtube.com/watch?v=zIiZ_gSi77Y

en mi caso 1,7 x 8 x 0,1=1,36 como he puestpo pasos completos el 70% osea 0,95
desenchufo usb y conecto motores y alimentacion
vuelvo a conectar usb

ejecuto grbl controler 3.6.1

pongo el puerto a 115200 baudios
conecto y ahora si detecta los cuatro ejes

la tabla grbl settings esta vacia sin parametros y le meto estos
resim

subirfotos

abro un archivo de muestra y todo se mueve
por finnn luz
eso si va a toda pastilla pero ya es un avance importante
si alguien sabe unos parametros razonables para  grbl settings para que no vaya la cosa desbocada agradecido
espero haberlos esplicado bien

tengo el mega y la ramps recien llegados tambien y me encantaria saber si se puede hacer algo con ella

lo dicho muchas gracias
Citar
#72
Felicidades!!, me alegro mucho.

Te falta ajustar los pasos por milimetro. Eso dependerá de como tengas montada la maquina. Es necesario saber si usas micropasos o no (en tu caso creo que no por que no has puesto más jumper que los de D12 D13) si usas usillo o correa dentada tipo GT2 o GT3, etc.

Busca una calculadora prusa en Google y pon tus parametros para averiguar los pasos/mm que corresponden.

Para saber si están bien ajustados, con un metro puedes salir de dudas, pones el comando G1 X100 y se debería mover 100mm. Otra cosa es que estés probando con los motores al aire....

Cualquier duda lo vemos...si quieres puedes abrir tu propio hilo y lo vamos comentando allí.
Citar
#73
Buenos dias,
estoy siguiendo vuestro proyecto y la verdad es que estoy encantado. Ya me faltan menos de 2 semanas para terminar mi cortadora aunque estoy con el soft y ahi es donde vienen mis problemas. creo que vosotros me podeis ayudar. Si no es el sitio por favor, echadme un cable y decirme donde dirigirme.

Controladora; CNC shield con el arduino uno. Cargado con el GRBL correspondiente para 4 ejes.
Soft para generar Gcode; Tanto Jedicut como profili2 son validos, he generado Gcode con ambos y en Mach3 parece todo correcto.
Soft para lanzar Gcode; GRBL controller.

Bueno, pues el caso es que en el visualizer del GRBL controller no aparece bien el Gcode y cuando lanzo el corte se para.
Si cargo el Gcode de muestra que habeis puesto en este post, el Gcode con la palabra "OK" al lanzarlo va todo OK.

Esto es lo que aparece:
resim

os adjunto dos Gcode para que podais comprobarlos si os viene bien.

Si podeis arrojar algo de luz os lo agradecería y tambien si podeis adjuntar un Gcode de un perfil alar con el que habeis cortado a traves del GRBL controller.

Muchas gracias por adelantado,


Archivos adjuntos
.txt   profili.txt (Tamaño: 33.25 KB / Descargas: 20)
.txt   jedicut.txt (Tamaño: 4.49 KB / Descargas: 34)
Citar
#74
Buenas!!!
Excelente trabajo, me ha picado el gusanillo y ya he empezado a gastar perras en material.
Una duda que tengo. Voy a montarla de cuatro ejes y la mayoría de placas que estoy viendo solo tienen para poner 3 finales de carrera. ¿Como lo habéis solucionado para añadir el cuarto fin de carrera?
Muchas gracias!!!
Citar
#75
Hola,

Necesito ayuda con los perfiles y accesorios. Escribí un correo a info@motedis.es para preguntar unas dudas, esto hace ya 2 semanas y aun no me han contestado. Si les escribí por Facebook y me contestaron en inglés, me dijeron que nos les había llegado nada. Se que alguien habló con ellos en español. Sabéis de otro correo o como ponerme en contacto con ellos. Gracias.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA ¿Cuál es la CNC más barata capaz de trabajar con acero y titanio? skan 13 674 04-06-2018, 04:30 PM
Último mensaje: josem-gar
  otro intento de cortadora de foam cnc Alexo 21 1,207 26-03-2018, 08:44 AM
Último mensaje: Alexo
  fresadora 3 ejes chasis 700x500 josem-gar 6 676 22-03-2018, 10:18 AM
Último mensaje: josem-gar
  cortadora cnc foam 140x140 trinamita 30 2,863 04-03-2018, 01:39 PM
Último mensaje: ecore
  [PROYECTO] Cortadora CNC de Foam por hilo caliente de 4 ejes vcode 58 18,712 22-02-2018, 08:53 PM
Último mensaje: garfieldf