Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Calibracion sensor TRONXY XY-08N NPN
#1
Buenas, no consigo calibrar el sensor.

Os cuento. Tengo Anet A8, con firmware skynet 2.3.2, el sensor es un  TRONXY XY-08N NPN NO (contacto normalmente abierto) de tipo INDUCTIVO

[Imagen: sensor_montado.jpg.png]

La carga del firmware la hice correcta, eligiendo mi tipo de pantalla LCD12864 (la de la anet a6) y sensor a la izquierda.

El sensor me detecta la cama, teniendo correctamente los cables del conector Azul - Marron - Negro. Hay que cambiarles el orden.

Le doy a nivelar cama, y me hace los nueve puntos correctamente, sin salirse de la cama en ninguno de ellos y detectando en todos (led rojo se enciende).

Pero me queda alta la boquilla.

Me falta el paso que es calibrar el sensor. Para esto hago lo siguiente, que es lo que hago mal.

Muevo los ejes desde el menu: Preparar / Mover ejes / Mover Z / Mover 0.1 mm y lo dejo ajustado con el papel, y en la pantalla me queda por ejemplo Mover Z: -001.8

Me voy al menu Control / Movimiento / Desface Z: y le pongo -001.8

Ahora me voy al menu Preparar / Ajustar desfases y me da Err: Too Far (error demasiado lejos)

Y a partir de aqui ya no se como calibrarlo.
Citar
#2
Pues ya está solucionado.

Lo tenía que hacer del siguiente modo:

Muevo los ejes desde el menu: Preparar / Mover ejes / Mover Z / Mover 0.1 mm y lo dejo ajustado con el papel, (ir sumando en un papel las veces que se le da a -0.1) y en la pantalla me queda por ejemplo Mover Z: -001.8 (o sea que he necesitado darle 18 veces a -0.1 para que me baje 1.8 milimetros)

Me voy al menu Control / Movimiento / Desface Z: y le pongo -001.8

Ahora hay que irse atras en ese menu y darle a Guardar memoria. Cometía este error de no darle aquí.

Y no hay que tocar para nada el menu de Preparar / Ajustar desfases, que era el error que cometía.

Y ya lo tenemos listo. Para comprobarlo hacemos un HOME y con este firmware cuando termina el home levanta siempre el eje Z 10 milimetros y entonces en la pantalla me marca el eje Z con 11,9 (los 10 milimetros que sube el programa mas los 1,9 que ha subido del offset que le hemos marcado antes).

Repetimos esto varias veces con la cama caliente, hacer home y bajar lo que ponga en el eje Z con pronterface por ejemplo hasta que Z esté a 0, y en 0 comprobar que nos roza el papel levemente por la boquilla.

Sensor funcionando Sonrisa
Citar
#3
Yo no hice nada de eso, simplemente lo hice todo manual y midiendo ambas barras del eje Z con calibre digital, ajustando todo y después con el clásico papelito para medir la punta. Básicamente hice como si tuviera un fin de carrera común y no un sensor y listo funcionó. El problema es que cuando se le quiera poner un cristal el sensor no va a funcionar, por eso estoy buscando un fin de carrera para desconectar el sensor y listo. Si no la otra es un sensor capacitivo, pero tengo que pedirlo en China como hice con la impresora, veré qué hago. Pero a mí me imprime de puta madre
Citar
#4
Con cristal el sensor si funciona perfectamente, ya que la cama no la quitas, sigue estando el metal debajo del cristal, que es lo que el sensor detecta. Pero claro no serviría de nada, ya que calibraría según el metal y no según el cristal y pueden no coincidir, si hay separación del cristal con el metal en alguna esquina. El rango de actuación de este sensor alimentándolo con 5 voltios, es de unos 4 mm, muy justo para un cristal de 3mm por ejemplo. Si se alimenta a 12 voltios pues aumenta el rango de detección o sea que podemos tener la punta del sensor más separada de la cama en el momento que detecta. Pero lo suyo para cristal es pasarse a un sensor capacitivo.

Yo sigo con la cama y la cinta de carrocero jeje, por ahora me va bien.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  duda power supply 3d printer y sensor capasitivo edgarc 9 194 07-11-2018, 05:38 PM
Último mensaje: Simemart
  CONSULTA No queda bien el cubo de calibración. lamosca01 27 2,992 06-11-2018, 05:25 PM
Último mensaje: Simemart
  Calibración cama caliente Garbeth 9 805 21-09-2018, 02:59 PM
Último mensaje: NBla
  Problema con primera calibración Mendone 29 811 13-08-2018, 11:33 AM
Último mensaje: calimocho
  Este sensor me vale como autolevel? vegetto 2 306 28-06-2018, 02:37 AM
Último mensaje: vegetto