Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA primera configuracion ender 3
#1
Buenas noches,
primero decir que acabo de comprar una ender 3, la he montado y he podido empezar a imprimir cositas. El primer problema que me he encontrado es que no me hace círculos sino óvalos, he impreso un círculo de 100mm de diámetro y ha hecho cosas raras.
resim

internet imagenes

He estado mirando el foro y veo que puede ser porque los ejes no estén a 90º, entiendo que esto se refiere al X e Y y que tengo que coger una escuadra y comprobarlo mecánicamente. En caso de que no estén a 90º tampoco tengo muy claro como moverlos. Esto todavía no lo he probado.
La segunda posibilidad es algo relacionado con los pasos del motor, he impreso un cubo de 20x20x20mm como he leído por aquí, tanto el Z como el Y me dan un lado de 20mm o muy cercano, pero el X me da de 19, eso es 1mm de diferencia y me parece mucho, el problema es que no sé como arreglar eso.

¿Alguien podría echarme una mano?

Gracias!
Citar
#2
Hola @Windkaze, bienvenido al foro.
Es un poco raro que con la impresora de serie haya esa disparidad en el eje X (aunque no imposible), pero yo investigaría un poco en la mecánica del eje, no vaya a ser que esté fuerte y te pierda pasos.
Tienes dos opciones para regular los pasos por milímetro: modificando el firmware y volviéndolo a grabar (algo complicado en tu impresora) o cambiándolo por el menú de la pantalla (cosa bastante más sencilla).
Para corregir esa desviación, el valor que tienes que poner para ese parámetro sale de aplicar la fórmula: nuevo valor= valor antiguo x 20 / 19.
La opción para cambiarlo se encuentra en Control>Movimiento>Pasos/mm>X pasos/mm. Si lo tienes en inglés: Control>Motion>Steps/mm>Xsteps/mm).
Una vez hayas cambiado el valor, tendrás que grabar el cambio en la EEPROM para que se mantenga al apagar la impresora.
Para ello, utliza la opción del menú Control>Guardar memoria, en inglés Control>Store settings.
De todas formas, por la imagen parece que no tienes bien regulada la altura inicial de impresión, ya que esos hilos parecen demasiado altos y cilíndricos.
Si no la tienes bien, no se pegan correctamente a la cama y el círculo tiende a deformarse en algunos puntos.
Si es así, tendrás que regular esa altura bien antes de probar nada más.
Citar
#3
Gracias
Mañana aflojar un poco la correa del X y probaré lo de los pasos.
Con respecto a lo de la altura inicial, yo hice lo de poner un folio hasta que rasque la boquilla, y pegarse se pega que me cuesta quitarlo luego xD y solo me lo hace con círculos o curvas, con líneas rectas no, por ejemplo el dado salio bien y las esquinas puntiagudas. Mañana pongo si he conseguido algo.
gracias de nuevo!
Citar
#4
Bueno, creo que ahora ya hace círculos cambiando lo de los pasos, digo creo porque se me ha añadido un problema más.
Esta mañana he recibido la cama de cristal y he cambiado la que lleva de serie por esta. El problema que a pesar de haber ajustado con lo del folio la altura nueva no consigo que las primeras camas se peguen (la cama la precaliento a 60 durante un minuto antes de imprimir para que el cristal coja temperatura y también he bajado la velocidad de impresión de primera cama).

Me funcionaba mejor con la cama metalica chunga que trae por defecto xD

¿es normal que cueste tanto configurar la cama? porque estoy de las ruedecitas que trae hasta el gorro, además que el recorrido de los muelles es muy corto.

Saludos!
Citar
#5
Hola, para el cristal necesitas un poco de laca Nelly. La normal va perfectamente.
Tranquilo que con un poco de laca te olvidarás rápidamente de la cama anterior.
Lo del ajuste con las ruedecitas y los muelles es una pesadilla. La mejor opción es poner la cama fija, mediante unas contratuercas en los tornillos de ajuste y suprimir los muelles.
Con ello te olvidarás por mucho tiempo de la nivelación de la cama.
Citar
#6
(12-07-2019, 02:51 PM)Simemart escribió: Hola, para el cristal necesitas un poco de laca Nelly. La normal va perfectamente.
Tranquilo que con un poco de laca te olvidarás rápidamente de la cama anterior.
Lo del ajuste con las ruedecitas y los muelles es una pesadilla. La mejor opción es poner la cama fija, mediante unas contratuercas en los tornillos de ajuste y suprimir los muelles.
Con ello te olvidarás por mucho tiempo de la nivelación de la cama.

He probado con otra laca y nada, que no coge, mañana comprare la nelly. Lo he calibrado tantas veces que ya e perdido la cuenta xD hotend a 200º y cama a 60º. Por si acaso era la altura lo he acercado tanto que en una zona a dejado marca en el cristal. Que desespero. Que utilice el Cura no tendrá algo que ver?

Es que me da la sensación que solidifica demasiado rápido pero no debería ser con esas temperaturas. Estoy por cambiar la bobina aunque sea casi nueva aunque con esta ya había hecho otras cosas.
Citar
#7
Qué velocidad de impresión usas para imprimir los círculos?? Si los círculos son cerrados prueba con una velocidad no superior a 30 mm/ seg. A mi me pasó lo mismo y era por una velocidad alta. Como dijo el compañero para la adhesión usa laca Nelly de la normal q se vende en Mercadona. Yo también bajaría la temperatura de la cama a 50 grados.

otra cosa a ver si vas a tener el diámetro del filamento en una cifra diferente a 1.75 mm pues a veces el Cura juega malas pasadas. Y sobre todo paciencia... al principio todos nos desesperamos... es cuestión de ir probando y aprendiendo. Si rayaste el cristal quizá no tengas bien a nivel la cama o muy cerca el hotend del cristal
Citar
#8
La velocidad de impresión la tengo en 20mm/s. Bajaré la temp de la cama aunque yo pensaba que a más temp se cogería mejor pero igual es eso. Y probaré la Nelly mañana que ya la tengo. El filamento está bien en el cura y lo rayar el cristal ya a sido por desesperación de andar arriba y abajo xD
Gracias, seguiré contando mis penas mañana, con la tontería se me ira el carrete de pla con las pruebas
Citar
#9
Parece que a 50 coge mejor. Sin embargo los círculos son raros. Pongo fotos. Y en piezas pequeñas me las despega mientras las hace, supongo que xq no están bien adheridas (pongo laca Nelly y la cama esta ajustada al roce de folio).

resim

image hosting

resim
Citar
#10
Hola, pues viendo esas fotos yo diría que no está bien regulada la altura, así que quizá tienes algo que te está falseando esa regulación.
En algunas partes se aprecian claramente los hilos de forma cilíndrica, lo que indica demasiada separación entre cama y boquilla.
¿La estás realizando con todo a temperatura de impresión? ¿Tienes interruptor de final de carrera en el eje Z o sensor?
En principio, con el cristal y la laca, da un poco igual que pongas 50º o 60º en la cama. En teoría debería agarrar mejor con 60º.
Mientras no consigas que se adhiera bien a la cama, no podrás comprobar si te hace bien los círculos o no.
En esas fotos, las partes que están rectas se deben a que no agarra el hilo a la cama y al contraerse forman rectas.
Citar
#11
Lo de la cama y yo daría para una peli de terror. Las ruedas tienen un margen muy pequeño, yo creo que xq los muelles están cedidos. He nivelado con nivel para asegurarme que está plana pero cuando hago lo del folio siempre hay una esquina que se queda más arriba o abajo que el resto. Estoy esperando muelles nuevos para cambiarlos y sino probaré lo de la contratuerca.
Menuda vista tienes con lo de los hilos redondos xD
Todo lo imprimo a 195 y tengo el final de carrera de Z que me indica posición 0.
Altura de capa 0,2 (la primera de 0,3) y boquilla estándar de 0,4.
Siento daros tanto el coñazo, pero al menos no me desánimo y sigo probando cosas.
Citar
#12
Tranquilo que ningún problema es un coñazo y lo lógico es que preguntes hasta que se solucione o tires la toalla.
La posición 0 del eje Z la marca el interruptor de final de carrera, por lo que siempre te marcará eso, aunque la boquilla esté lejos de la cama cuando lo haga.
Lo que tienes que conseguir es que cuando el eje Z marque 0, entre la boquilla y la cama entre justo el folio.
No te preocupes por el nivel, pues no es muy relevante, siempre que no llegue a estar visiblemente inclinada la impresora.
Lo que importa es respecto a la boquilla, por eso se hace en las cuatro esquinas en relación con ella.
Prueba a configurar la primera capa también a 0,2mm. Ten en cuenta que si calibras con el folio (0,1 mm) y la primera capa es de 0,3 mm, esta capa la está haciendo a 0,4 mm, que ya es demasiada separación.
Citar
#13
resim

subir fotos online

resim

resim



Esos son mis parametros, en algunas zonas se coge y en otras no, pero es raro que en una circunferencia de 10 cm haya esa diferencia, las dobleces esas en algunos puntos no sé porque las hace, ¿puede ser que se solidifique demasiado rápido o que el hotend esté taponado y no salga suficiente material?

(13-07-2019, 06:56 PM)Simemart escribió: Tranquilo que ningún problema es un coñazo y lo lógico es que preguntes hasta que se solucione o tires la toalla.
La posición 0 del eje Z la marca el interruptor de final de carrera, por lo que siempre te marcará eso, aunque la boquilla esté lejos de la cama cuando lo haga.
Lo que tienes que conseguir es que cuando el eje Z marque 0, entre la boquilla y la cama entre justo el folio.
No te preocupes por el nivel, pues no es muy relevante, siempre que no llegue a estar visiblemente inclinada la impresora.
Lo que importa es respecto a la boquilla, por eso se hace en las cuatro esquinas en relación con ella.
Prueba a configurar la primera capa también a 0,2mm. Ten en cuenta que si calibras con el folio (0,1 mm) y la primera capa es de 0,3 mm, esta capa la está haciendo a 0,4 mm, que ya es demasiada separación.
Citar
#14
Hola, pues sí que es raro ese comportamiento.
Yo por esas fotos diría que la altura inicial está muy mal, demasiado lejos de la cama e incluso que la cama está algo desnivelada.
Pero si dices que la tienes bien regulada, entonces o esa superficie no agarra nada de nada o ese filamento que estás utilizando esta mal.
Las dobleces que dices no son tales, sino cuerdas de arco de círculo que unen los dos puntos donde sí se ha pegado el filamento a la cama.
Entre esos dos puntos, dado que no hay sujección, el hilo tiende a formar líneas rectas.
Te recomiendo que uses el cristal con laca Nelly, con la cama a 60º y que compruebes que cuando Z esté en 0, pase el folio bien ajustado entre el cristal y la boquilla, con los dos a la temperatura de impresión.
Sobre los ajustes de CURA, lo primero comprueba que tienes bien en las propiedades de la impresora el diámetro de la boquilla y el del filamento que estés usando.
Prueba con altura de capa 0,2mm (todas), ancho de línea (todos) igual al diámetro de la boquilla (tienes que habilitar la visualización de este parámetro) y de la primera capa 100%, 3 líneas de pared (grosor 3xdiámetro de boquilla), 3 capas superiores e inferiores (grosor 0,6mm), temperatura 200º (todas), temperatura cama 60º (todas), flujo de capa inicial 100%, velocidad inicial del ventilador 0%, velocidad normal a altura 0,2mm (por capa 2). Comprueba esto último, no sea que tengas activado al 100% el ventilador de capa en la primera y por eso notes que se solidifica demasiado rápido.
Si con eso no se pega al cristal, vete pensando en cambiar el filamento que usas.
Citar
#15
resim

resim

Voy a poner paso por paso a ver si se me escapa algo:

Hago autohome
Preheat PLA a 200º boquilla y 60º cama y espero 1 minuto

Dissable steppers y muevo a mano el eje X e Y para situar el hot end en mitad de la cama (no toco el Z). Ya está bastante cerca pero aún así lo reajusto con las 4 ruedas hasta que el folio roza pero puedo moverlo.
Hago autohome de nuevo
En el cura pongo todas las especificaciones tal como me las has descrito, fijandome en el tema de la capa primera (lo del tamaño de filamento y boquilla lo tenia correcto pero lo he revisado por si acaso)
Meto la tarjeta, le pongo laca y le doy a imprimir.

Y me sale lo de la foto, sin tener en cuenta el círculo deformado, la primera capa (imagen que se ve en mi mano) ya no es consistente aunque a base de amontonar consigue hacer la forma.
He hecho 3 pruebas y solo se "pega" cuando pongo laca, no creo que sea normal tener que poner laca en cada impresión. ¿Cada cuanto se limpia el vidrio?

Asique solo veo 2 opciones:
- El vidrio tiene algun defecto.
- El filamento es malo a rabiar. (pongo enlace https://www.amazon.es/gp/product/B07CPT1...UTF8&psc=1 )

Descarto lo de la distancia porque lo he hecho ya como 50 veces, he visto decenas de videos en youtube y leido foros y lo hago igual a como sale.
Mañana me llega otra bobina, pero es del mismo fabricante aunque otro color, veremos a ver. Esto va a dar para un tutorial de errores xD me lo tomaré con humor

(14-07-2019, 06:55 PM)Simemart escribió: Hola, pues sí que es raro ese comportamiento.
Yo por esas fotos diría que la altura inicial está muy mal, demasiado lejos de la cama e incluso que la cama está algo desnivelada.
Pero si dices que la tienes bien regulada, entonces o esa superficie no agarra nada de nada o ese filamento que estás utilizando esta mal.
Las dobleces que dices no son tales, sino cuerdas de arco de círculo que unen los dos puntos donde sí se ha pegado el filamento a la cama.
Entre esos dos puntos, dado que no hay sujección, el hilo tiende a formar líneas rectas.
Te recomiendo que uses el cristal con laca Nelly, con la cama a 60º y que compruebes que cuando Z esté en 0, pase el folio bien ajustado entre el cristal y la boquilla, con los dos a la temperatura de impresión.
Sobre los ajustes de CURA, lo primero comprueba que tienes bien en las propiedades de la impresora el diámetro de la boquilla y el del filamento que estés usando.
Prueba con altura de capa 0,2mm (todas), ancho de línea (todos) igual al diámetro de la boquilla (tienes que habilitar la visualización de este parámetro) y de la primera capa 100%, 3 líneas de pared (grosor 3xdiámetro de boquilla), 3 capas superiores e inferiores (grosor 0,6mm), temperatura 200º (todas), temperatura cama 60º (todas), flujo de capa inicial 100%, velocidad inicial del ventilador 0%, velocidad normal a altura 0,2mm (por capa 2). Comprueba esto último, no sea que tengas activado al 100% el ventilador de capa en la primera y por eso notes que se solidifica demasiado rápido.
Si con eso no se pega al cristal, vete pensando en cambiar el filamento que usas.
Citar
#16
No se yo la capa inicial la pongo a 0,2 y después reguló la cama con el folio. Que roce.
Pon cristal o espejo y laca. A mi meda que no se pega en la plataforma. O que está baja
La regulación de la cama caliento el cristal 10 minutos, 60grados. Pero el nozzle no lo caliento y que este limpio.
Puede probar hacer un cuadrado plano. Osea solo una capa que ocupe la cama y imprimela. Así verás por si se te pega. Y por donde tienes que bajar o subir. La cama
Lo puedes hacer mientras está imprimiendo pero poco a poco no valla ser que te pases.
Por cierto el ventilador de capa. La primera capa lo tienes apagado?

https://www.thingiverse.com/thing:2948908

Enviado desde mi SGP712 mediante Tapatalk
Citar
#17
Hola, con esa forma de calibrar la altura inicial es normal que te quede siempre alta la boquilla. Y yo discrepo con esos videos y foros si lo indican así.
Cuando desactivas los motores, el eje Z tiende a bajar por gravedad (aunque sea unas décimas de milímetro) y más si mueves a mano el eje X. Para hacer bien esa calibración, hay que mover los ejes con los motores.
Para los que tenéis la regulación mediante muelles, lo más conveniente es tener habilitada en el firmware la opción LEVEL_BED_CORNERS, ya que los movimientos están programados y solo hay que ir pulsando el botón. Pero hay que modificar el firmware y volverlo a cargar en la máquina, ya que no viene activada de serie y en las Ender 3 este proceso es algo laborioso.
Si no se quiere andar con el firmware, tenemos que hacer nosotros mismos los movimientos.
Hay que mover la boquilla a las cuatro esquinas y al centro, de forma sucesiva y como mínimo dos veces, ajustando con la hoja de papel en cada posición, pero sin que se desactive el motor de Z.
Para ello, antes de empezar con la calibración, hay que mandar el comando M18 Sxxx, donde xxx es el número de segundos que queremos que permanezcan activos los motores (como mínimo, lo que tardemos en hacer toda la calibración). Una vez terminada esta, hay que mandar el comando M18 S120 para dejar el valor que tiene el firmware de serie o reiniciar la máquina.
La forma más sencilla de realizar todo esto es mediante un archivo gcode que incluya todos los comandos necesarios.
Sería algo así:

; Script de nivelación de cama y calibración de altura inicial de impresión
G90 ; Posicionamiento absoluto
G21 ; Medidas en milímetros
M18 S1800 ; Motores activados media hora
M190 S60 ; Calienta cama a 60º - Cambiar si se utiliza otra cuando se imprime
M109 S200 T0 ; Calienta fusor a 200º - Cambiar si se utiliza otra cuando se imprime
G28 ; Llevar al origen todos los ejes
M0 Pulsa para esquina 1
G1 Z4 F300
G1 X30 Y30 F3600
G1 Z0 F300
M0 Pulsa para esquina 2
G1 Z4
G1 X190 F3600
G1 Z0 F300
M0 Pulsa para esquina 3
G1 Z4
G1 Y190 F3600
G1 Z0 F300
M0 Pulsa para esquina 4
G1 Z4
G1 X30 F3600
G1 Z0 F300
M0 Pulsa para el centro
G1 Z4
G1 X110 Y110 F3600
G1 Z0 F300
M0 Pulsa para esquina 1
G1 Z4
G1 X30 Y30 F3600
G1 Z0 F300
M0 Pulsa para esquina 2
G1 Z4
G1 X190 F3600
G1 Z0 F300
M0 Pulsa para esquina 3
G1 Z4
G1 Y190 F3600
G1 Z0 F300
M0 Pulsa para esquina 4
G1 Z4
G1 X30 F3600
G1 Z0 F300
M0 Pulsa para el centro
G1 Z4
G1 X110 Y110 F3600
G1 Z0 F300

M0 Pulsa para terminar
G1 Z4
M104 S0 ; Enfría el fusor
M140 S0 ; Enfría la cama
M18 ; Desactiva motores
M18 S120 ; Fija el valor de desactivación de serie
; Fin del script



Ya solo queda ejecutarlo en la impresora como cualquier otro archivo de impresión. Naturalmente, tal y como está es para camas de 220x220mm.
El código anterior es aproximadamente lo que hace, con la configuración por defecto, la utilidad LEVEL_BED_CORNERS de Marlin (sin el calentamiento).
Una vez calienta cama y fusor a las temperaturas normales de impresión, se posiciona por orden en los distintos puntos a calibrar y espera a que se pulse el botón de la pantalla para pasar al siguiente.
Tal y como lo he puesto, repite el proceso completo una vez y termina. Si se quieren más repeticiones, hay que colocar el bloque completo de lineas verdes, tantas veces seguidas como repeticiones se quieran.
Citar
#18
Buenas de nuevo,
no es que haya tirado la toalla, es que e estado liado jejeje, pero más o menos ya lo e resuelto.

Hice lo que me dijisteis simemart y rafa330 sobre un .gcode que me ayudara con la nivelación. Use el de thingiverse y genial, casi siempre se pega ya a la cama y de vez en cuando hecho laca.
Además también me di cuenta que el eje X cada 4 centimetros pegaba un saltito y era porque las ruedas estaban demasiado apretadas, las afloje un poco y a simple vista ya me hace los círculos bien (estoy esperando un calibre para ajustarlo mejor).
Asique por el momento ya he impreso las "mejoras" que te recomiendan para esta impresora y en cuanto reciba los muelles y los ttl smooth para los motores le pondré todos los accesorios xD

Gracias!
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Primera capa defectuosa ender 3 Windkaze 8 163 23-11-2019, 11:42 AM
Último mensaje: Simemart
  APORTE Configuración inical de la impresora. Simemart 5 266 18-10-2019, 07:01 PM
Último mensaje: Simemart
  CONSULTA Caida de temperatura al empezar la primera capa de la pieza Nefreyu 10 1,309 27-08-2019, 12:08 AM
Último mensaje: Nefreyu
  APORTE Configuración de driver TMC2208 con UART y Marlin 1.1.8 shiryou 21 8,159 27-06-2019, 07:12 PM
Último mensaje: charly12344
  CONSULTA Primera impresora Orri_ElPega9 6 444 16-05-2019, 08:27 AM
Último mensaje: Orri_ElPega9