Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Problema con final de carrera
#1
Hola! Soy nuevo en el foro, aunque llevo un tiempo leyedo.

Tengo una Geeetech i3 pro B desde hace una par de años y funcionando bien. Desde hace 2 semanas veo que la cama no calienta y hace extraños, se apaga sola y luego se vuelve a encender, el fusor se calienta muy lentamente etc.

Llego a la conclusión que es la fuente de alimentación y hoy tras estar por la mañana imprimiendo sin problemas, cambio la fuente por otra y la cama y el fusor van perfectos.

Compré una fuente de 12v y 20A para sustituir a la 12v y 15A que trae de serie.

Pues ahora en cuanto se activa un final de carrera me aparece un mensaje "homing failed printer halted".

Es justo al hacer home, si lo pulsas en otro momento no ocurre nada.

He hecho un M119 y todo aparentemente normal.

¿ Alguien puede ayudarme?

Muchas gracias de antemano


Enviado desde mi SM-J510FN mediante Tapatalk
Citar
#2
A mí ese error me ha salido cuando la impresora, por algún motivo, no llega a hacer el homing. En mi caso era la cama que pegaba contra la pared y no llegaba a pulsar un final de carrera, sino recuerdo mal.

Has probado a ir pulsando los finales de carrera uno por uno y mandar M119? A ver si todos cambian a "triggered" y vuelta. Podría ser un final de carrera roto o mal conectado.
Citar
#3
(20-12-2018, 12:32 AM)Nullz escribió: A mí ese error me ha salido cuando la impresora, por algún motivo, no llega a hacer el homing. En mi caso era la cama que pegaba contra la pared y no llegaba a pulsar un final de carrera, sino recuerdo mal.

Has probado a ir pulsando los finales de carrera uno por uno y mandar M119? A ver si todos cambian a "triggered" y vuelta. Podría ser un final de carrera roto o mal conectado.
Si, he probado con el M119 y parece todo normal ( Open sin pulsar, triggered pulsado y triggered con el endstop desconectado)

El caso es que el homing lo hace bien, el eje se para al pulsar el endstop, rebota y luego aparece el mensaje "homing failed printer halted" .

También probé otros endstop ayer y nada. Es raro porqué pasa al hacer home en todos los ejes y la impresora iba perfecta a excepción de la cama, el único cambio es la fuente.


Voy a probar con el noise filter a ver.

Enviado desde mi SM-J510FN mediante Tapatalk
Citar
#4
Hola, si no estoy equivocado, en esa impresora con los interruptores de final de carrera desconectados de la placa debería dar open y no triggered.
Es raro que el interruptor funcione correctamente, pero te indique eso desconectado. Quizá te está fallando de forma esporádica el circuito de control en la placa.
En todo caso, si hace lo que indicas, no está realizando bien el "homing".
Cuando pulsa el interruptor la primera vez, tiene que volver en sentido contrario una distancia (que se configura en el archivo Configuration_adv.h) para que se desactive el final de carrera y después volver a pulsarlo (a menor velocidad, tambien configurable en el mismo archivo).
Pero si no se desactiva después de recorrer esa distancia (porque siga activado el final de carrera), entonces el firmware supone que hay un mal funcionamiento y genera el error.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  APORTE Sensor de final de filamento. Simemart 1 804 28-10-2018, 04:40 PM
Último mensaje: kokeeeeee
  SEGUIMIENTO Gracias spainlabs por ayudarme en mi carrera pedroperez 0 368 28-05-2018, 01:01 PM
Último mensaje: pedroperez
  Final de Carrera Z con la propia boquilla PedroAngel 2 701 26-03-2017, 02:09 PM
Último mensaje: PedroAngel
  Como sujetar finales de carrera (prusa i3 metacrilato) nachoBcn 18 3,627 27-03-2016, 11:37 AM
Último mensaje: nachoBcn
  Los personajes de Final Fantasy VII impresos en 3D Andoni686 9 1,585 12-09-2013, 10:19 AM
Último mensaje: ruloma