Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Problema con conexión entre Cura y mi Prusa i3
#1
Muy buenas,
Desde ayer por la noche que mi impresora no conecta bien al Ultimaker Cura 3.6, el software la detecta pero cuando le doy la orden de imprimir via usb no manda la orden y me aparece la pestaña de monitor sin la información que suele dar (básicamente las dos fuentes de temperatura, extrusor y cama caliente). Adjunto pantallazo:
resim

También al mismo tiempo me aparece el mensaje ‘Wait for user...’ en la pantalla LCD
resim
Se queda así durante horas y no realiza la impresión.
Los drivers estan actualizados y el firmware también, al menos según la web de la impresora (es una Athorbot Brother), y el único componente que he añadido últimamente es un nuevo nozzle de 0.6 con los cambios que pertocan en los parámetros de impresión desde Cura.

Alguien me puede echar un cable?

Muchas gracias!


Enviado desde mi iPhone utilizando Tapatalk
Citar
#2
Hola, cuando aparece ese mensaje en la pantalla significa que la impresora está esperando una confirmación del usuario para continuar.
Prueba a pulsar el botón de confirmación para ver si continúa con la impresión.
Citar
#3
Cual es el pulsador de confirmación? Si es el de ‘print via usb’, es el que pulso y me aparece lo del pantallazo...


Enviado desde mi iPhone utilizando Tapatalk
Citar
#4
Quizás Simemart se refiere a pulsar el botón del LCD, cuando tienes el mensaje, otra cosa no se me ocurre.
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#5
Hola, sí, me refiero al botón de la pantalla con el que se confirman las selecciones del menú.
Citar
#6
Pues no se si ese sería el problema, pero hoy he encendido de nuevo la impresora y el pc y no me ha dado problema alguno...


Enviado desde mi iPhone utilizando Tapatalk
Citar
#7
Bueno, reabro esto por que me vuelve a pasar...esta mañana me ha dejado imprimir sin problemas como de costumbre, pero he vuelto a intentarlo ahora y no manda la orden, ya ni sale el mensaje 'waiting for user", simplemente salta la pestaña de monitor y no hay actividad alguna...a qué se puede deber?

El tema de los puertos sé que me dió un poco de dolor de cabeza... qué tipo de driver de puerto com tendría que tener? Tengo el COM3 (arduino mega 2560).

Añado! Mientras escribía esto, la pantalla LCD ha mostrado el waiting for user... he pulsado el botón y ha cambiado a "resuming print", pero no hace nada, ni calienta ni muestra otro tipo de información nueva ni en el pc ni en la pantalla LCD.
Citar
#8
Hola, es posible que tus problemas sean debidos a la conexión por USB. Podría ser el driver, los conectores o el cable.
El driver depende del chip que lleve tu placa. El más utilizado es el CH340 y suele venir con el software que trae la impresora. Si usas Windows 10 debería instalarlo de forma automática.
Por cierto, no tiene nada que ver el puerto COM que le asigne el S.O. del ordenador. Eso depende del conector USB que se use.
Sobre conectores y cable, lo único que se puede hacer es cambiar para ver si se soluciona.
Usa otro cable y/o conectalo en otro puerto USB del ordenador (ten en cuenta que te variará el número del puerto COM)
Si es problema de comunicación, puede que una solución sea reducir un poco la velocidad de conexión.
Citar
#9
Pues lo he probado con otro cable y sigue igual, la he reiniciado y entonces aparece el mensaje de error MINTEMP.

Esto se complica por momentos....


Enviado desde mi iPhone utilizando Tapatalk
Citar
#10
Hola, sigo sin poder imprimir, no detecta la impresora.
Como puedo hacer para bajar la velocidad de conexion, que habeis comentado que podria ser una causa?


Enviado desde mi iPhone utilizando Tapatalk
Citar
#11
Hola, para variar la velocidad de conexión sólo tienes que cambiarla en el firmware, CURA la detecta automáticamente.
Se hace en el archivo Configuratión.h, parámetro BAUDRATE.
Los valores más habituales son 250000, 115200, 57600. Prueba de mayor a menor y si ninguno de esos tres te funciona, es que el problema viene de otro lado.
De todas formas, comprueba en el administrador de dispositivos de Windows que se crea un puerto COM al conectar la impresora y en sus propiedades que funciona correctamente.
Citar
#12
Pues parece que deberías dar un minisalto, o el salto completo.

Se sabe que la comunicación USB es mala, no sé si en las últimas versiones habrá mejorado, pero en el peor de los casos (el mío) se paraba a mitad de impresión, así por las buenas, tras 1 hora más o menos.

minisalto: tarjeta SD y andar con la dichosa tarjeta desde el ordenador a la Prusa.
Problemas:
- La SD algunas veces el ordenador la detecta protegida y no te deja escribir, hay programas para saltarse esa protección, pero tarde o temprano falla y vuelves a tener el mismo problema. Solución: cambiar de SD
- La impresora se vuelve loca, cometiendo errores y destrozando la impresión: Tarjeta mala, compra otra.
- La SD termina fallando con el tiempo.

Salto completo: Hay 2 opciones que yo conozca:
- Tarjeta SD con Wifi: Es una tarjeta que crea una wifi, se introduce en el LCD y si tu ordenador permite conetarse a wifi, mandas el archivo a la impresora.
- Octoprint: Controlas toda la impresora via wifi.

Lo que más me gustaría sería una impresora con lector USB, creo es lo más barato y para mí dura más que las SD, pero no conozco nada.
Ulticampy V2: fundiendo plástico sin descanso...
Citar
#13
Si la SD la detecta como protegida suele ser sintoma de que ha pasado a mejor vida... esto se hace al parecer porque se detectan demasiados errores en la sd como para que sea fiable, por tanto se blowuea y se queda en modo solo lectura para que puedas recuperar tus datos ya que si escribieses podria corromperse algo.

Si comprais una SD buena va a duraros... yo uso la misma desde hace mas de 3 años y jamas he tenido ningun problema. Racanear en la SD no es la mejor forma de ahorrar dinero a la larga.
Citar
#14
El problema que veo en mi caso es que mi impresora no detecta ninguna sd, y el maravilloso servicio técnico de chichinabo que tiene Athorbot no me respondió los mails preguntando por qué mi impresora no detecta las tarjetas si representa que lleva un lector...


Enviado desde mi iPhone utilizando Tapatalk
Citar
#15
Comprueba que tienes habilitada la tarjeta SD en el firmware.
Citar
#16
Vale... cómo puedo acceder al firmware? Como veis estoy verde verde....


Enviado desde mi iPhone utilizando Tapatalk
Citar
#17
Si tienes el firmware de serie, no puedes cambiar ni la velocidad de conexión ni el uso de la tarjeta SD.
Lo que te decía era por si tenías cargado por tu cuenta Marlin. De todas formas, si tienes el firmware original de la impresora, entonces no creo que esté deshabilitada la SD.
El firmware que está grabado en la MCU de la placa en este momento no se puede cambiar directamente, hay que hacerlo sobre los archivos de los que se compiló.
Pero Athorbot no los facilita, por lo que para cambiar algo hay que pasarse al Marlin libre.
Si tienes problemas tanto con la SD como con la conexión USB puede que la placa esté mal, aunque quizá te convenga reinstalar el firmware original, por si tiene algún problema el que está cargado.
Tienes el archivo .hex y las instrucciones para hacerlo en la página del fabricante.
Citar
#18
El firmware está actualizado, es el Reprap, de hecho lo volví a instalar al tener estos problemas.
Es muy difícil pasarse al Marlin?


Enviado desde mi iPhone utilizando Tapatalk
Citar
#19
No sé que placa lleva esa impresora y la verdad es que no he visto nunca un comentario de alguien que haya instalado Marlin en ella, pero supongo que no será diferente a cualquier otra.
La única dificultad, si puede llamarse así, es que Marlin no trae los archivos preconfigurados para esa impresora, por lo que hay que hacerlo uno mismo. Aunque esto no es demasiado difícil.
Citar
#20
En la web no pone la placa que lleva y eso si que escapa a mi comprensión...
Según el controlador de dispositivos tengo instalados los drivers de arduino mega 2560, no se si eso vale para saber la placa.


Enviado desde mi iPhone utilizando Tapatalk
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  DUDA Znas que no se van a imprimir CURA crisbenf 6 156 13-11-2018, 08:03 PM
Último mensaje: Simemart
  CONSULTA Problemas con cura miferu 5 324 21-10-2018, 08:01 PM
Último mensaje: PrimeraRata
  CONSULTA pausas inexplicables entre capas LUIS SANMARTIN 11 440 12-09-2018, 06:53 PM
Último mensaje: LUIS SANMARTIN
  No imprime desde el cura mariosalzarIN 5 265 11-07-2018, 01:14 AM
Último mensaje: mariosalzarIN
  Perfiles Legio para Cura fmateosc 0 270 20-06-2018, 12:42 PM
Último mensaje: fmateosc