Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Movimiento motores eje Z - Resuelto
#1
Dedo arriba 
Mola
Hola que tal, tyengo un problema grave y no se por donde encararlo.

Soy nuevo en esto de las impresoras 3d y mi experiencia se limita a una reprap tipo prusa steelp con ramps 1.4 que arme yo mismo.

En un principio todo funcionaba bien, pero despues no se porque se me ocurrio actualizra el marlin a la ultima version  y apartir de ahi empezo el problema. Incluso el problema sigue volviendo a la version anterior de marlin.

El problema es que el eje Z , con o sin carga (solo los motores) no se mueve, hace un zumbido y no se mueven, si regulo la corriente de los pololu consigo que se muevan un poco pero se traban y hace un ruido/zumbido horrible.

La unica buena noticia es que si cargo el SPRINTER, y uso proterface, los motores (todos) se mueven suavemente como manteca sobre cuchillo caliente... Sisi1  asique debe ser algo del firmaware, pero la verdad es que no se....
Alguna idea? yo la verdad es que estoy perdido....


Estoy usando drivers pololu a4988 y motores Nema 17 a 1.7A. Como fuente uso una fuente ATX con sus salidas de 12v, cada una en 12.30V y supuestos 18A de corriente maxima.  Vale aclarar que estoy usando un display FULLGRAPHICS REPRAP DISCOUNT, de todas formas este comportamiento lo hace con y sin la pantalla conectada....

Repito, lo raro es que antes funcionaba todo bien.

Si me pueden guiar que configuraciones de Marlin deberia ver, se los agradezco!

Aca les dejo unos videitos donde se ve lo que pasa con Marlin  1.0.x y con Sprinter









 Segui investigando por ahi y di con que este tema se presenta cuan do los valores de aceleracion y feed_rate establecidos en el firmaware no son correctos, bajandolos y subiendolos de apoco obtuve resultados optimos.

// default settings

#define DEFAULT_AXIS_STEPS_PER_UNIT   {80,80,4000,726.7}  // default steps per unit for Ultimaker
#define DEFAULT_MAX_FEEDRATE          {500, 500, 1, 25}    // (mm/sec)
#define DEFAULT_MAX_ACCELERATION      {9000,9000,25,10000}    // X, Y, Z, E maximum start speed for accelerated moves. E default values are good for Skeinforge 40+, for older versions raise them a lot.





Gracias y saludos!
Rodrigo :mola:
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Motores eje Z bloqueados jjimenez 16 1,917 19-03-2018, 03:41 PM
Último mensaje: Thingibox
  CONSULTA Movimiento ejes X e Y Oscar 2 300 05-02-2018, 08:52 PM
Último mensaje: Oscar
  Los dos motores se descompensan rigimo 1 360 23-09-2017, 05:12 PM
Último mensaje: Ronies
  movimiento delta. ssb98 0 456 01-06-2017, 01:49 PM
Último mensaje: ssb98
  Marcas en las capas por el movimiento del extrusor Sarusman 9 1,202 13-05-2016, 08:57 PM
Último mensaje: ICEM4N