Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA MKS-GEN 1.4 en Anet A6... se puede?
#1
Hola recientemente mi placa base de la Anet A6, se quedo frita y he comprado una MKS-gen 1.4...
¿Como puedo ponerle un frimware? y como conectarla en la Anet A6.. que hay que hacer exactamente?
Sabéis de algún tutorial o algo?
Un saludo.
Citar
#2
Hola, claro que se puede. al fin y al cabo esa placa es como un arduino+Ramps todo junto, eso sí debes de ponerle drivers para los motores ya que no vienen integrados en la placa. El firmware se lo tienes que instalar desde arduino, ponle el marlin, de eso tutoriales hay a patadas, en ese aspecto tratala igual que si de un arduino +ramps se tratara, no hay diferencia, eso sí, tendrás que tocar parámetros del mismo para que te quede bien configurada. Por otro lado te pongo una página de la placa es de la 1.1 pero básicamente es lo mismo para que veas como van las conexiones y unos vídeos de gente que la ha puesto en la anet a 8 para que te hagas una idea. Saludos.
Importante! tienes que poner el segundo motor de Z en la parte donde iria el segundo extrusor en placa E01 y entrar en el configuration_adv de marlin y activar el uso de "dual Z drivers"

http://reprap.org/wiki/MKS_GEN_V1.1

https://www.youtube.com/watch?v=3w1KCz1jlQk

https://www.youtube.com/watch?v=gDeWjLyyEbo&t=74s
Citar
#3
buratatxo muchas gracias por la ayuda y la información, me pondré ha mirarme todo lo que me has pasado, los driver me han llegado hoy (la placa mañana)
Los driver que me recomendo un amigo fueron los a4988... que te parecen?
Un saludo.
Citar
#4
(22-11-2017, 05:57 PM)fustris escribió: buratatxo muchas gracias por la ayuda y la información, me pondré ha mirarme todo lo que me has pasado, los driver me han llegado hoy (la placa mañana)
Los driver que me recomendo un amigo fueron los a4988... que te parecen?
Un saludo.

De nada hombre, para eso estamos Guiño, yo le tengo puestos los DRV8825, y los tuyos te irán perfectos tambien, creo que eso va más a gustos dicen que los DRV8825 hace como una especie de "aguas" al imprimir en figuras curvas, yo no he notado nada pero hace como 2 semanas que los tengo así que no se... Importante, conectarlos en el sentido que toca para no cargártelos y regula la intensidad, a mi el de la tienda me dijo que los dejara como estaba que ya venian bien configurados y los motores no ardían, lo siguiente, no podías dejar el dedo ni medio segundo. Al final tuve que comprar un polímetro y regularlos con la técnica de medir el voltaje, hay otra de medir los amperios pero es bastante más liosa, al menos para mi. yo lo que hacia era poner el polímetro en en modo medir hasta 20V porque es lo mínimo que tiene ya que es baratero y con el positivo tocar el regulador metálico del driver, y con el negativo el tornillo de donde entra el cable negativo en placa e iba midiendo intensidades de menor a mayor y probando hasta que los motores movían los carros con fluidez (hay formulas por ahí pero a mi aplicándolas se me seguían calentando) , fuí probando de 0v (que no se movían evidentemente) a 0,40v que para mi ha resultado ser lo óptimo, y al extrusor un poquito más, 0,50v creo recordar ya que este necesita más caña, así me van fluidos y no se calientan en absoluto los motores lo cual no quiere decir que está configuración sea la óptima para tí.

Te dejo la guía que usé yo para hacerlo http://www.dima3d.com/motores-paso-a-pas...corriente/

Saludos.
Citar
#5
Genial...!!! así da gusto, ya iré contando mi experiencia... lo que mas miedo me da es el configurar el Marlin, ya que la placa de la Anet A6 palmo metiendo el Skynet .(
Citar
#6
(22-11-2017, 06:34 PM)fustris escribió: Genial...!!! así da gusto, ya iré contando mi experiencia... lo que mas miedo me da es el configurar el Marlin, ya que la placa de la Anet A6 palmo metiendo el Skynet .(

Si como dices la placa "palmó" al meterle el nuevo firmware, es muy posible que simplemente se haya perdido el bootloader.
Si es así, solo necesitas volver a cargarlo y te funcionará de nuevo perfectamente.
Puedes ver como hacerlo aquí.
@buratatxo , el problema de los DRV8825 es que pierden pasos a bajas velocidades por un problema de diseño del driver.
Esto se refleja en unas ondas que se aprecian en las impresiones. Hay bastante información sobre ello en internet.
Y sobre la regulación que has hecho de los drivers, no sería mala idea que comprobases la intensidad real que están mandando los drivers a los motores.
Yo creo que esa forma tan "sui generis" que has utilizado (mediante el voltaje de referencia, pero a "ojímetro") es más complicada que mediante la intensidad, pero para gustos ...
Obijuan, en su clásico video de Youtube, explica bastante bien como hacerlo por intensidad.
@fustris cuidado con este tema si utilizas un destornillador metálico. Te puedes cargar el driver si se te escapa y  tocas donde no debes.
Un saludo.
Citar
#7
Simemart muchísimas gracias, le estoy echando un ojo ha ese tutorial y creo que lo que fastidie fue el bootloader, no se por que razón pedí un arduino y me llega mañana... quizás eso recupere la placa...
Citar
#8
(22-11-2017, 07:41 PM)Simemart escribió:
(22-11-2017, 06:34 PM)fustris escribió: Genial...!!! así da gusto, ya iré contando mi experiencia... lo que mas miedo me da es el configurar el Marlin, ya que la placa de la Anet A6 palmo metiendo el Skynet .(

Si como dices la placa "palmó" al meterle el nuevo firmware, es muy posible que simplemente se haya perdido el bootloader.
Si es así, solo necesitas volver a cargarlo y te funcionará de nuevo perfectamente.
Puedes ver como hacerlo aquí.
@buratatxo , el problema de los DRV8825 es que pierden pasos a bajas velocidades por un problema de diseño del driver.
Esto se refleja en unas ondas que se aprecian en las impresiones. Hay bastante información sobre ello en internet.
Y sobre la regulación que has hecho de los drivers, no sería mala idea que comprobases la intensidad real que están mandando los drivers a los motores.
Yo creo que esa forma tan "sui generis" que has utilizado (mediante el voltaje de referencia, pero a "ojímetro") es más complicada que mediante la intensidad, pero para gustos ...
Obijuan, en su clásico video de Youtube, explica bastante bien como hacerlo por intensidad.
@fustris cuidado con este tema si utilizas un destornillador metálico. Te puedes cargar el driver si se te escapa y  tocas donde no debes.
Un saludo.

Hola Simemart, lo de las ondas que comentas lo había leido, pero tambien he leido que en realidad apenas se aprecia. Ahora que si empiezo a ver cosas raras ya te digo que cambio de drivers, soy un tanto maniático cuando necesito calidad en una pieza. El video de obijuan es con el primero que intente calibrar los drivers, y te aseguro que me pasé horas intentándolo pero sospecho que como mi polímetro es tan malo no puede manejarse con amperajes tan bajos porque no me cuadraba nada la información que me devolvía, de hecho medía el amperaje, movía el motor hacia un lado, desconectaba motores desde el pronterface, me daba una lectura, volvía a hacer exactamente lo mismo y me daba otra Nusenuse . Y buscando más información también leí que la intensidad idónea para los drivers es la más baja que le puedas dar para que los motores trabajen adecuadamente, de ahí mi  manera de calibrarlos, denominada a ojo de buen cubero XD, pero que es la única que me ha funcionado
Citar
#9
Supongo que las ondas estarán influidas por más factores. Yo he visto fotos por internet del efecto y en esos casos parecía bastante apreciable. Pero la verdad es que no lo sé de primera mano.

Si que es necesario una escala de amperaje adecuada en el polímetro. Estamos hablando de unos cientos de miliamperios.

Efectivamente, esa sería la calibración optima si siempre demandasen la misma corriente los motores. Pero no es así y por ello hay que calibrar la corriente de forma que no se quede corta en alguna situación.

En otro post estamos hablando sobre el tema de la velocidad y no creerás que los motores necesitan la misma intensidad imprimiendo a 40mm/s que a 200mm/s, ¿no?.

Por eso te comentaba lo de saber cuanta intensidad está mandando realmente el driver, para saber si tienes margen para cubrir todas las situaciones que se pueden presentar.

Aunque si has medido bien el voltaje de referencia, se puede calcular a partir de él a cuanta intensidad corresponde en tus drivers. Para ello hay que mirar de que valor son las resistencias de referencia en el circuito del driver y utilizar la formula que viene en la hoja de datos del DRV8825.
Citar
#10
(23-11-2017, 12:34 AM)Simemart escribió: Supongo que las ondas estarán influidas por más factores. Yo he visto fotos por internet del efecto y en esos casos parecía bastante apreciable. Pero la verdad es que no lo sé de primera mano.

Si que es necesario una escala de amperaje adecuada en el polímetro. Estamos hablando de unos cientos de miliamperios.

Efectivamente, esa sería la calibración optima si siempre demandasen la misma corriente los motores. Pero no es así y por ello hay que calibrar la corriente de forma que no se quede corta en alguna situación.

En otro post estamos hablando sobre el tema de la velocidad y no creerás que los motores necesitan la misma intensidad imprimiendo a 40mm/s que a 200mm/s, ¿no?.

Por eso te comentaba lo de saber cuanta intensidad está mandando realmente el driver, para saber si tienes margen para cubrir todas las situaciones que se pueden presentar.

Aunque si has medido bien el voltaje de referencia, se puede calcular a partir de él a cuanta intensidad corresponde en tus drivers. Para ello hay que mirar de que valor son las resistencias de referencia en el circuito del driver y utilizar la formula que viene en la hoja de datos del DRV8825.

Gracias, en cuanto me vea con moral para ello, pues algo aparentemente tan sencillo para mi se volvió muy tedioso por culpa del polímetro cutre que tengo le daré una vuelta de tuerca y me miraré bien las fórmulas.
Citar
#11
La formula para calcular la intensidad máxima en funcion del voltaje de referencia es (según su hoja de datos): Imax= Vref / (5 * Rref), donde Imax es la intensidad máxima, Vref el voltaje de referencia y Rref la resistencia de referencia.
Si tus DRV8825 tienen resistencias de referencia R100 (que es lo más común):

resim

la fórmula para calcular la intensidad máxima que el driver enviará al motor es: Imax= Vref * 2, ya que la R100 es de 0,1 Ohms.

Por tanto, para un Vref de 0,4V que dices tener en los ejes X, Y y Z, la intensidad máxima serían 0,8A o lo que es lo mismo, 800 miliamperios. Y para el extrusor, sería 1A.

Eso es una barbaridad y si dices que has probado con más no me extraña que se calentasen los motores.

Tienes suerte que los DRV8825 aguantan mucha más corriente que los A4988. Si lo hubieses hecho con estos últimos, seguro que habrías quemado ya alguno.

Los motores tienen que funcionar correctamente con mucho menos.

Es raro que no se calienten con esas intensidades. O no están bien medidos los voltajes de referencia. Algo no cuadra en todo esto.

Cuando recibí la impresora, medí lo que mandaba la placa Anet. Lo puedes ver aquí.


P.S.: Es raro que un polímetro, por muy sencillo que sea, no pueda medir este rango de intensidades.
¿Estás seguro que lo usas correctamente?
Citar
#12
Hola. Gracias por la explicación, dentro de poco me va a tocar calibrar otros diversos y voy a intentarlo según explicas. Y eso sí, te aseguro que a 0.4V los motores no se calientan, otra cosa es que el polímetro este mal y tampoco mida bien los voltajes, cosa que me extrañaria. Respecto a lo de medir amperios, te aseguro que lo probé en todas las posiciones, pero bueno, todo puede ser.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  pantalla anet 6 para la Anet 8 Nestor 12 3,735 12-04-2018, 08:35 PM
Último mensaje: Josnaro
  Problema Motor Eje Y ruido, no puede con correa Camarena 8 1,234 08-02-2018, 11:41 PM
Último mensaje: Camarena