Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CONSULTA Dudas con Marlin 1.1.8
#1
He bajado Marlin 1.1.8
He copiado en el directorio del Marlin.ino, los archivos de configuración de la carpeta examples_configuration de la Anet A6
Estoy usando Arduino 1.8.0 para compilar. En el proceso de compilado, me pone esto

In file included from C:\Users\XXXX \AppData\Local\Temp\arduino_build_261676\sketch\Marlin_main.cpp:314:0:

endstop_interrupts.h:124: error: missing binary operator before token "("

     #if digitalPinToInterrupt(X_MIN_PIN) != NOT_AN_INTERRUPT

                              ^

endstop_interrupts.h:144: error: missing binary operator before token "("

     #if digitalPinToInterrupt(Y_MIN_PIN) != NOT_AN_INTERRUPT

                              ^

endstop_interrupts.h:164: error: missing binary operator before token "("

     #if digitalPinToInterrupt(Z_MIN_PIN) != NOT_AN_INTERRUPT

                              ^

Usando librería U8glib con versión 1.19.1 en la carpeta: C:\Users\XXXX\Downloads\Marlin-1.1.8\arduino-1.8.0\portable\sketchbook\libraries\U8glib 
exit status 1
missing binary operator before token "("

Qué puedo hacer?  Nusenuse

Muchas gracias de antemano con vuestro tiempo
Citar
#2
Buenas,
A ver yo tengo esa misma configuración de versiones. Arduino 1.8 y Marlin 1.1.8 y no tengo problemas, por lo que en principio se me ocurren tres cosas, si ya tienes implementadas algunas, empieza a mirar por las que te falten Gran sonrisa:

1.- No tienes actualizado el IDE de Arduino con las especificaciones de tu placa. Descárgalas desde aquí y debería solucionarse: https://github.com/SkyNet3D/anet-board
     Por si no te apañas con Git, te dejo el enlace directo al fichero https://github.com/MarlinFirmware/Marlin...rdware.zip, que debes descomprimir y copiar en la carpeta (o donde tengas tus ficheros de Arduino): C:\Users[username]\Documents\Arduino

2.- Los ficheros de configuración de la Anet al ser de la 1.1.6 de Marlin, no funcionan tal cual con la 1.1.8, abre cada una al lado del otro y modifica el 1.1.8 con los cambios que veas razonables de la original de Anet.

3.- No tienes la versión de la librería U8glib adecuada. 

Como ves por el tamaño de cada punto de mi respuesta, tengo mucha fe en que el problema se resuelva con el punto 1 Gran sonrisa

Suerte!
Citar
#3
Creo que en el ide de arduino no tiene seleccionada la placa correcta


Enviado desde mi iPad utilizando Tapatalk Pro
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  ¿MKS Sbase + Marlin 2.0? 3Dsastre 5 141 Hace 6 horas
Último mensaje: neoxM3
  El marlin no me hace caso spa_sergio 10 1,337 05-11-2018, 01:17 PM
Último mensaje: Simemart
  Marlin 1.1.9 en Anet A8 PatogomaII 9 1,401 18-10-2018, 07:45 PM
Último mensaje: jhony85
  Problema autolevel con Marlin 1.1.9 klipendorf 3 816 07-08-2018, 06:15 PM
Último mensaje: Simemart
  CONSULTA Problema con marlin Vicente48 2 289 23-07-2018, 07:50 AM
Último mensaje: Vicente48