Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
[CONJUNTA] Kit Prusa i3
HankMoody escribió:Hola, el tema de los pololus aunque en otro hilo hemos hablado, al ser de la conjunta y ya estar todo enviado me gustaria tratarlo por aqui
Ya he comprobado que si pongo otro pololu lo puedo calibrar a 400ma sin problema, gracias a esto las piezas me quedan bien de altura
Si uso el pololu de la conjunta el cubo de calibracion me queda pequeño, supongo que me pierde pasos
Entiendo que la impresora funciona pero no como deberia y para dejarlo como debe ser tuve que poner pololus nuevos
No se si alguien mas esta como yo

Yo estoy igual y no sólo con el eje Z, sobretodo con el extrusor.
Si lo aconsejable es ponerle 400 mA por algo será ....
Mismo problema por aquí.
Correcto, los pololus deben poder llegar a 1amperio Otra cosa que sea recomendable o no dejar pasar esa cantidad de corriente pero vamos diseñados estan para llegar a ese valor
Yo me comprado 2 de otro lado Para poder solucionar mi problema pero vamos lo suyo hubiese sido que estos pololus llegasen a 1 A y no tener que gastar dinero
Yo repito lo mio que en el otro hilo. Ghost deberia mirar el tema de la garantia con los chinos, no le echo la culpa a él, es del fabricante, pero al haberlo pedido el deberia responsabilizarse de pedir la garantia.
Es una opinion, si tenemos que comprar mas pololus no sale tan bien la conjunta

Enviado desde mi GT-N7100 usando Tapatalk 4
Si hay algo defectuoso nos tienen que arreglar el defecto!
a mi me es imposible con mis medios el comprobar los componentes de los pololus. sobre todo el mas importante, la resistencia que hay sobre el potenciometro

Los planos y lista de componentes los cogi de la wiki de reprap. (http://reprap.org/wiki/Stepstick) si todo esta segun los planos no hay nada que reclamar mas que al que hizo los calculos.

Si elegi la lista de 1A fue porque dentro de todos hay mucha gente novatilla y preferia que los drivers estuvieran seguros y mas fresquitos que tener que hacer envios posteriores por problemas de que alguno se hubiera quemado

Lo unico que se me ocurre es intentar hacer una tirada con los planos que supuestamente indican que pueden llegar a dar 1,5A y sustituiros 2 drivers por los nuevos

Si alguien tiene los medios necesarios para comprobar las resistencias de la lista de la wiki, se lo agradeceria. con las puntas que tiene mi multimetro es imposible poder medir la resistencia que comento, pero al menos el potenciometro es el mismo que otros pololus

Yo repito, y que no suene a excusa, estoy utilizando 2 electronicas cogidas al azar sin ni siquiera tocar los potenciometros, asi que me suena que es mas problema de aceleraciones en el firmware o falta de lubricacion que otra cosa. (las varillas roscadas M5 del eje Z tambien es recomendable engrasar/lubricar)
El viernes vuelvo a casa, si para entonces nadie ha podido hacer esas comprobaciones intento hacer algo a ver si sacamos conclusiones.

No he estrenado la impresora ni la tengo conmigo por lo que no puedo hablar de mi experiencia.
Ghosthawk escribió:a mi me es imposible con mis medios el comprobar los componentes de los pololus. sobre todo el mas importante, la resistencia que hay sobre el potenciometro

Los planos y lista de componentes los cogi de la wiki de reprap. (http://reprap.org/wiki/Stepstick) si todo esta segun los planos no hay nada que reclamar mas que al que hizo los calculos.

Si elegi la lista de 1A fue porque dentro de todos hay mucha gente novatilla y preferia que los drivers estuvieran seguros y mas fresquitos que tener que hacer envios posteriores por problemas de que alguno se hubiera quemado

Lo unico que se me ocurre es intentar hacer una tirada con los planos que supuestamente indican que pueden llegar a dar 1,5A y sustituiros 2 drivers por los nuevos

Si alguien tiene los medios necesarios para comprobar las resistencias de la lista de la wiki, se lo agradeceria. con las puntas que tiene mi multimetro es imposible poder medir la resistencia que comento, pero al menos el potenciometro es el mismo que otros pololus

Yo repito, y que no suene a excusa, estoy utilizando 2 electronicas cogidas al azar sin ni siquiera tocar los potenciometros, asi que me suena que es mas problema de aceleraciones en el firmware o falta de lubricacion que otra cosa. (las varillas roscadas M5 del eje Z tambien es recomendable engrasar/lubricar)

Para comprobar las placas es necesario desoldar los componentes y medirlos uno a uno, no se pueden medir sobre la placa porque el valor obtenido no sera correcto. Por lo que hay que canibalizar un pololu para comprobar que estan bien fabricados.

Yo como apunte indicar que tambien tengo problema de perdida de pasos en el eje z, ya que no obtengo la altura adecuada del cubo de calibracion. Despues de limar las varillas me dispuse a limpiarlas con disolvente para quitarlas los restos de limadura y suciedad que traian. Despues de su montaje las engrase bien con grasa consistente de mobdileno.

Tambien mencionar que dichas varillas no son de acero inoxidable como se indico en la lista de materiales, y como meciono otro compañero del foro no son muy buenas... son de calidad mediocre tirando a malas,limando se notaba que eran probablemente de hierro dulce (por lo facil que se comia la lima el material).

Un saludo.
O.O

Ojiplatico me hallo. en que te basas para decir eso? has probado a acercarle un iman??

Inoxidable 304 ó A2 como mas os guste. Es mas, el almacen con el que trabajo solo tiene aleaciones de acero inoxidable
Lo de hierro dulce..es exagerar un poco. No soy experto en varillas pero inox esta claro que son.
Ghosthawk escribió:O.O

Ojiplatico me hallo. en que te basas para decir eso? has probado a acercarle un iman??

Inoxidable 304 ó A2 como mas os guste. Es mas, el almacen con el que trabajo solo tiene aleaciones de acero inoxidable

Si y se pega, como es normal en cualquier aleación que lleve hierro por ser ferroso, ya sea hierro dulce o acero.

Lo comento porque el otro día compre una varilla roscada en la ferreteria del barrio, dicha varilla viene zincada (si era de las mas baratas) y con la misma lima no habia punto de comparacion en cuanto a la dureza de una varilla y de otra, la que compre en la ferreteria me costo bastante más limarla que las de la conjunta. Porque no tengo un resto de varilla, si no probaba a meterla en agua con sal y saliamos de dudas rapido.
hectorri escribió:Lo de hierro dulce..es exagerar un poco. No soy experto en varillas pero inox esta claro que son.

¿En que te basas para decir que es inoxidable?

Si el hierro dulce no tiene porque ser blando, te doy una chapa de 3 mm de hierro dulce y no la doblas con dos alicates. Pero como es lógico el acero es mucho más duro, y a las pruebas de limado que he comentado en el post anterior me remito.
pues nada, la proxima vez, para ti, 316, pero hay que pagarlo ehhh Guiño
Ghosthawk escribió:pues nada, la proxima vez, para ti, 316, pero hay que pagarlo ehhh Guiño

No se a cuento de que viene la ironia, a las pruebas me remito. Compro una varilla en la ferreteria de las mas baratas y resulta que me cuesta más limarla que las varillas de la conjunta, ¿No debería ser más dura la de la conjunta que se supone que es de acero?
y hablas de que si es dulce o no en funcion del trabajo que tienes que hacer al limar??

prueba a cortar las 2 varillas con una rotaflex y comentas. todos los inoxidables apenas sacan chispas, en cambio el acero al carbono (que es muy probable que sea lo que has comprado en la ferreteria) parece una fiesta

http://es.wikipedia.org/wiki/Acero_al_ca....C3.ADmica
http://es.wikipedia.org/wiki/Acero_inoxi...noxidables

Por que sea dulce tiene que ser malo?? yo solo busco que no tenga corrosion con el paso del tiempo, porque las zonas que no se utilizan en las varillas, con una de acero normal se oxidarian en poco tiempo en lugares de costa o con mucha humedad
Una pequeña aclaración sobre la corriente de los "pololus" para que no crucifiquéis a Ghosthawk. Digamos sencillamente que medir la corriente con el comprobador es:

1º Estúpido (sin ánimo de ofender a nadie)
2º Dependiente del comprobador (salvo que este sea True RMS)
3º Inexacto
4º Dependiente de la carga del motor (salvo comprobador True RMS)
5º Peligroso

Ese es el motivo por el cual vuestras medidas son inconsistentes, dependientes de "pololu" a "pololu", incapaces de superar los 200, 400 o whatever mA y difíciles de ajustar. El por qué tiene que ver con cómo trabaja el A4988 (el integrado que llevan los "pololus" para controlar los steppers y que realmente es quien hace absolutamente todo). Os cuento por qué ocurre todo esto:
[Tocho ON]

Lo primero es que lo que hay que limitar en un stepper para evitar que reviente es la corriente que circula por los conductores que forman las bobinas del motor. Los steppers tienen la particularidad de que pueden quedarse quietos en un punto. Eso implica que tiene que haber corriente circulando por las bobinas formando el campo magnético que sostiene al motor en su posición. Al ser una corriente continua durante esos momentos solo va limitada por la propia resistencia de los conductores (ley de Ohm I = V/R). Queremos limitar esa corriente, y podemos hacerlo de dos formas:

1º forma: limitando la tensión aplicada a las bobinas del motor. Si en I = V/R limitamos V, como R es la de los conductores I queda fijada a un valor límite. Esta es la forma tonta de hacer las cosas y es como no suele hacerse, ya que limitar las cosas de esta forma implica limitar la velocidad de respuesta del stepper y demás.

2º forma: limitando el valor medio de la corriente que circula por el motor de forma activa. Es decir, aplicamos la tensión que nos de la gana (dentro de unos márgenes razonables), esperamos a que la corriente fluya (tarda un poco por efectos inductivos de la bobina) vamos midiéndola y cuando se pase de la raya cortamos la alimentación al motor, esperamos un poco y volvemos a aplicar tensión y así todo el rato. De esta forma conseguimos que la corriente fluya a picos muy por encima del límite de corriente continua aplicable al motor pero que el valor medio de dicha corriente se sitúe por debajo de la corriente máxima que soporta el motor. Al fin y al cabo los cables del motor tienen cierta masa térmica y se comportan en cuanto a calentamiento como un sistema "lento" al que le da igual a efectos de disipación de calor que le metas 600mA continuos que pulsos periódicos de 50% del tiempo a 1200mA y 50% del tiempo a 0. Y es el calor lo que quema el motor, no la corriente en sí misma. De esta forma se consigue que la respuesta del motor sea más rápida cuando se le pide un cambio de posición (en tareas rápidas sí se notan los pulsos de 1200mA) mientras que la disipación térmica dentro del motor se mantiene dentro de los márgenes seguros.

Esto es esencialmente lo que hace el A4988 que tenéis en los pololus. ¿Y qué significa? que la corriente que demandan no es continua, sino que va pulsada. Y cuando intentas medir con un amperímetro cutre (los multímetros que tenéis y tenemos la mayoría son cutres) en modo de corriente contínua una señal a pulsos lo que dice en la pantalla debería ser el valor medio (lo que nos interesa) pero por desgracia las cosas no son tan sencillas y a saber lo que puede estar midiendo. Según cómo se esté portando el motor y la guarrería que esté metiendo a la corriente que pide los resultados de la medida pueden no tener nada que ver con la realidad, porque el multímetro no está preparado para medir corrientes pulsantes.

Salvo que tengais un multímetro bueno con función true RMS y suficiente ancho de banda y midáis en el modo de corriente alterna lo que os va a dar no va a tener que ver con la realidad.

¿Cómo medir la corriente de los pololus entonces? Muy sencillo. Es cuestión de ir aquí:
http://www.allegromicro.com/~/media/File...sheet.ashx
y leerse la página 9 donde explican cómo va el tema del control de corriente en el A4988 con el detalle necesario. Luego es irse al esquemático del "pololu" y medir en el sitio adecuado. Requiere saber calcular la tensión en un divisor de tensión resistivo.

Resumen:

1º Poner el multímetro en medida de voltios en continua (rango de 2V)
2º Colocar las puntas del multímetro con cuidado en estos sitios (tocando las soldaduras con cuidado de no cortocircuitar nada):
resim
3º El límite de corriente al motor se calcula PARA LOS POLOLUS CONCRETOS QUE TIENEN LAS PRUSA I3 DE GHOSTHAWK ASUMIENDO QUE SON LOS QUE HA DICHO QUE SON (LIMITADOS A 1A) como:
I = V/1,6
Es decir, si medís 1V entre los dos puntos que he dicho tenéis la corriente limitada a 1/1,6 = 0,625A = 625mA.
4º Ajustar el potenciómetro para subir/bajar la tensión en ese punto hasta conseguir la corriente deseada. Para limitar a una determinada corriente la tensión que tenéis que medir es V= Ideseada(en amperios)x1,6. Es decir, si queréis limitar a 300mA pues deberíais medir 0,3x1,6 = 0,48V

Y ya está, eso es todo. Eso es lo que hay que hacer para limitar correctamente la corriente en los motores de forma sencilla y sin medidas erróneas.

Ahora bien, todos los ajustes que se han comentado de limitar la corriente a 200mA por motor y demás puede que sean incorrectos fruto de la medida errónea que estaba haciendo la gente. Ghosthawk debería preguntar al fabricante de los motores para que nos de las características técnicas de los mismos y así poder saber REALMENTE cuánta corriente aguantan y a qué corriente los tenemos que poner midiendo los pololus de la forma correcta. Así que de momento no toquéis nada hasta que no tengamos esa información.

EDIT: añado que aunque no hace falta desconectar los motores si estos están parados y sin hacer fuerza conviene que los desconectéis todos, ajustéis todos los pololus de una vez como os he dicho y luego los volvais a conectar y a correr. No hace falta mover los motores ni nada de nada, el ajuste es independiente de lo que esté haciendo el motor y de la carga que tenga y de todo. Es una simple medida en la tensión que controla el limitador de corriente del driver de los steppers. La RAMPS tiene que estár encendida, claro. La máxima tensión que podréis medir es 1,66V. Si medis más de eso... o estáis midiendo mal o chungo.
Los motores son de 2,5A por fase, asi que podeis poner los pololus a 1A sin problemas.
es tan facil como buscar el modelo del motor en google

http://www.phidgets.com/documentation/Ph...asheet.pdf

Por cierto, gracias por la explicacion
Si a algunos os pierde pasos incluso con la corriente al máximo (estáis enchufando 1A por fase, nada de 400mA aunque el multímetro no os llegue a tanto) es que tenéis un problema mecánico importante. Algo mal montado, rozando, doblado, mal lubricado o alguna pieza impresa defectuosa o similares. Mejor que reviséis los acoplos flexibles del eje Z que estén libres y no estén forzando nada, que las varillas verticales van paralelas y no hay que forzarlas para que encajen en las esquinas de arriba y cosas así antes de culpar a los pobres drivers de los motores que ellos no han hecho nada y estoy seguro al 100% de que estaban dando 1A sin problemas.

En mi entorno hemos montado dos impresoras de esta conjunta y a la primera y sin calibrar drivers ni nada (estaban más o menos a la mitad) el cubo de calibración lo hicieron una de ellas de 20.00x19,98x10,01 y a la otra me parece que hubo que subirle un pelín la corriente pero también lo hizo a la perfección.
erdabyz escribió:Una pequeña aclaración sobre la corriente de los "pololus" para que no crucifiquéis a Ghosthawk. Digamos sencillamente que medir la corriente con el comprobador es:

1º Estúpido (sin ánimo de ofender a nadie)
2º Dependiente del comprobador (salvo que este sea True RMS)
3º Inexacto
4º Dependiente de la carga del motor (salvo comprobador True RMS)
5º Peligroso

Ese es el motivo por el cual vuestras medidas son inconsistentes, dependientes de "pololu" a "pololu", incapaces de superar los 200, 400 o whatever mA y difíciles de ajustar. El por qué tiene que ver con cómo trabaja el A4988 (el integrado que llevan los "pololus" para controlar los steppers y que realmente es quien hace absolutamente todo). Os cuento por qué ocurre todo esto:
[Tocho ON]

Lo primero es que lo que hay que limitar en un stepper para evitar que reviente es la corriente que circula por los conductores que forman las bobinas del motor. Los steppers tienen la particularidad de que pueden quedarse quietos en un punto. Eso implica que tiene que haber corriente circulando por las bobinas formando el campo magnético que sostiene al motor en su posición. Al ser una corriente continua durante esos momentos solo va limitada por la propia resistencia de los conductores (ley de Ohm I = V/R). Queremos limitar esa corriente, y podemos hacerlo de dos formas:

1º forma: limitando la tensión aplicada a las bobinas del motor. Si en I = V/R limitamos V, como R es la de los conductores I queda fijada a un valor límite. Esta es la forma tonta de hacer las cosas y es como no suele hacerse, ya que limitar las cosas de esta forma implica limitar la velocidad de respuesta del stepper y demás.

2º forma: limitando el valor medio de la corriente que circula por el motor de forma activa. Es decir, aplicamos la tensión que nos de la gana (dentro de unos márgenes razonables), esperamos a que la corriente fluya (tarda un poco por efectos inductivos de la bobina) vamos midiéndola y cuando se pase de la raya cortamos la alimentación al motor, esperamos un poco y volvemos a aplicar tensión y así todo el rato. De esta forma conseguimos que la corriente fluya a picos muy por encima del límite de corriente continua aplicable al motor pero que el valor medio de dicha corriente se sitúe por debajo de la corriente máxima que soporta el motor. Al fin y al cabo los cables del motor tienen cierta masa térmica y se comportan en cuanto a calentamiento como un sistema "lento" al que le da igual a efectos de disipación de calor que le metas 600mA continuos que pulsos periódicos de 50% del tiempo a 1200mA y 50% del tiempo a 0. Y es el calor lo que quema el motor, no la corriente en sí misma. De esta forma se consigue que la respuesta del motor sea más rápida cuando se le pide un cambio de posición (en tareas rápidas sí se notan los pulsos de 1200mA) mientras que la disipación térmica dentro del motor se mantiene dentro de los márgenes seguros.

Esto es esencialmente lo que hace el A4988 que tenéis en los pololus. ¿Y qué significa? que la corriente que demandan no es continua, sino que va pulsada. Y cuando intentas medir con un amperímetro cutre (los multímetros que tenéis y tenemos la mayoría son cutres) en modo de corriente contínua una señal a pulsos lo que dice en la pantalla debería ser el valor medio (lo que nos interesa) pero por desgracia las cosas no son tan sencillas y a saber lo que puede estar midiendo. Según cómo se esté portando el motor y la guarrería que esté metiendo a la corriente que pide los resultados de la medida pueden no tener nada que ver con la realidad, porque el multímetro no está preparado para medir corrientes pulsantes.

Salvo que tengais un multímetro bueno con función true RMS y suficiente ancho de banda y midáis en el modo de corriente alterna lo que os va a dar no va a tener que ver con la realidad.

¿Cómo medir la corriente de los pololus entonces? Muy sencillo. Es cuestión de ir aquí:
http://www.allegromicro.com/~/media/File...sheet.ashx
y leerse la página 9 donde explican cómo va el tema del control de corriente en el A4988 con el detalle necesario. Luego es irse al esquemático del "pololu" y medir en el sitio adecuado. Requiere saber calcular la tensión en un divisor de tensión resistivo.

Resumen:

1º Poner el multímetro en medida de voltios en continua (rango de 2V)
2º Colocar las puntas del multímetro con cuidado en estos sitios (tocando las soldaduras con cuidado de no cortocircuitar nada):
resim
3º El límite de corriente al motor se calcula PARA LOS POLOLUS CONCRETOS QUE TIENEN LAS PRUSA I3 DE GHOSTHAWK ASUMIENDO QUE SON LOS QUE HA DICHO QUE SON (LIMITADOS A 1A) como:
I = V/1,6
Es decir, si medís 1V entre los dos puntos que he dicho tenéis la corriente limitada a 1/1,6 = 0,625A = 625mA.
4º Ajustar el potenciómetro para subir/bajar la tensión en ese punto hasta conseguir la corriente deseada. Para limitar a una determinada corriente la tensión que tenéis que medir es V= Ideseada(en amperios)x1,6. Es decir, si queréis limitar a 300mA pues deberíais medir 0,3x1,6 = 0,48V

Y ya está, eso es todo. Eso es lo que hay que hacer para limitar correctamente la corriente en los motores de forma sencilla y sin medidas erróneas.

Ahora bien, todos los ajustes que se han comentado de limitar la corriente a 200mA por motor y demás puede que sean incorrectos fruto de la medida errónea que estaba haciendo la gente. Ghosthawk debería preguntar al fabricante de los motores para que nos de las características técnicas de los mismos y así poder saber REALMENTE cuánta corriente aguantan y a qué corriente los tenemos que poner midiendo los pololus de la forma correcta. Así que de momento no toquéis nada hasta que no tengamos esa información.

EDIT: añado que aunque no hace falta desconectar los motores si estos están parados y sin hacer fuerza conviene que los desconectéis todos, ajustéis todos los pololus de una vez como os he dicho y luego los volvais a conectar y a correr. No hace falta mover los motores ni nada de nada, el ajuste es independiente de lo que esté haciendo el motor y de la carga que tenga y de todo. Es una simple medida en la tensión que controla el limitador de corriente del driver de los steppers. La RAMPS tiene que estár encendida, claro. La máxima tensión que podréis medir es 1,66V. Si medis más de eso... o estáis midiendo mal o chungo.

Siempre cabe la posibilidad de usar un amperimetro analógico Confundidois1: , tan fácil como preguntar al abuelo aficionado y listo :elrisas:


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Tamaño nozzle de la 1a conjunta prusa isma 2 486 17-05-2017, 11:47 PM
Último mensaje: Ovt
  Marlin para Prusa i3 Conjunta Freire thejumman 0 667 18-05-2016, 07:07 PM
Último mensaje: thejumman
  HILO OFICIAL - Conjunta Prusa Steel freire1986 orcinsu 164 12,412 08-02-2015, 06:44 PM
Último mensaje: chuano
  [Prusa i3][CONJUNTA-3DE] Dudas montaje Marvel_vs_dc 1,059 86,629 02-02-2015, 09:50 AM
Último mensaje: walter white
  Maltrato al cliente conjunta Prusa Steel Jesustabakko 11 1,459 28-11-2014, 04:37 PM
Último mensaje: NeoGames76