Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
CNC laser RSV model2
#21
(04-02-2017, 12:22 AM)Njoyneering escribió: Es raro, lo de que haga los dibujos en diagonal.

A ver, lo del laser, tienes que conectar si es posible 3 leds de 1w en paralelo(los leds), y poner pwm maximo o 5v en la entrada positiva del conector pwm. Con el switch un una.posicion, configuras uno de los potenciometros. Se trata de configurar el limite maximo de corriente que el driver entragara. La otra posicion es para configurar otro limite de corriente, pero no te hara fslta, pues vas a regular el driver con pwm. Usa un multi.etro conectado en Isens. En posicion Voltios ( estamos midiendo la caida de tension en la resistencia ceramica). La relacion tension:amperios es 1:1, es decir, si leemos en el multimetro 1v, querra decir que tenemos 1A.

Sobre la distancia del material a la lente, con 6-7cm deberia bastar.

Como tienes las correas puestas?

Saludos

Carga el firm de la mixy, te deberia funcionar.

Tego el firm de la mixy puesto, tengo el grbl_0_9j_revB pero cambiado lo de los pasos en el x y en el y y lo de activar los finales de carrera que no me van demasiado bien de momento. Como la máquina es igual excepto porque es algo más grande y las coronas un poco más grandes creo (diámetro 25mm) supuse que debería funcionar exactamente igual.
¿Vuelvo a cargar el firm?

Las correas las tengo asi (pero los niveles intercambiados, rojo arriba y azul abajo, pero eso da igual):
resim

Lo del laser ¿con estos led valdria? http://www.ebay.com/itm/100PCS-Light-Emi...2410191453
¿Se podría hacer sin poner los led y usando el multimetro en la posición 20v dando en los pines de isen del driver a ver si coge los 3v? o lo he entendido mal
resim
Citar
#22
Hola,

Sobre lo del multimetro, para poder configurar necesitas poner una carga en el driver, si no no circula corriente. Pero no pongas el laser, pues podrias quemarlo.

Con ese que pones en la foto sobra. Y recordar, la posicion de medida es en Voltios.

Sobre sacar el dibujo inclinado es muy raro, yo en la corexy que me monte, me fue bien a la primera. Creo que ese fallo es porque no edta tratando la maquina como corexy, sino como cartesiana. Vuelve a cargar el firm que te comentan a ver, fijate que tengas la linea que comentan en el codigo descomentada.
Citar
#23
Hola, he vuelto a meterle el firm y sigue igual, le he pasado el eepromclear y luego vuelto a meter el firm, incluso he desinstalado el arduino y borrado las librerias por si acaso. Sigue igual, he cambiado el nombre del archivo config por config.h para poder abrirlo con el ide de arduino y si que estaba descomentada la linea de define corexy. ¿Teneis idea de que puede pasar?
Respecto a regular el laser he puesto los leds y si que lucen pero estoy intentando mirar a ver como los puedo encender y medir voltaje sin que se mueva la máquina porque se me encienden al poner el programa de prueda ese pero metiendole una orden sin más no, seguro que estoy metiendo la orden mal...
Citar
#24
Desde el soft cnccontrol puedes encender y apagar el laser. Ademas lo pueded regular (cada vez que cambies la potencia, has de volver a encenderlo.

En forma de comandos, la potencia se configura con el parametro S. Hay anted un M para activarlo
Citar
#25
Solo por probar...has probado otro software para moverla? Grblcontroler, monitor serie de arduino....
Citar
#26
A mi el problema de que sale inclinado el dibujo me suena a que no esta pillanfo la maquina como corexy
Citar
#27
(08-02-2017, 12:49 PM)grafisoft escribió: A mi el problema de que sale inclinado el dibujo me suena a que no esta pillanfo la maquina como corexy

No la está pillando como corexy, solo mueve un motor para cada movimiento como en una cartesiana. Pero no se en el codigo del firm si parece que está bien. 

Los leds que he puesto para regular el laser encienden y se van apagando poco a poco, no se si los estoy quemando o que pero dando con el polímetro en el isen no me da apenas voltaje, por cierto en el pwm se supone que le tienen que llegar 5v?

pff que malisimo soy con la electrónica Triste Triste

(08-02-2017, 10:30 AM)vcode escribió: Solo por probar...has probado otro software para moverla? Grblcontroler, monitor serie de arduino....

No, solo he probado el grbl que tienen los de mixy ¿que puedo meter que soporte corexy para probar?
Citar
#28
Asegurate de que arduino esta cogiendo realmente ese grbl. Si tienes alguno mas instalado, no lo pillara bien. Borra el que tengas, cierra arduino, copia el nuevo que quieras meter y abre arduino.
Citar
#29
POR FIN YA VAN LOS MOTORES COMO DEBEN!!! Gran sonrisa Al final tras mucho insistir desinstalar e instalar y borrar la solución fue instalar un arduino anterior al que tenia y borrar todo lo que tenia de arduino en el pc, me puse a instalar todo de nuevo y ya por fin me cogió el movimiento corexy.

Lo que me falta ahora es el láser, antes me funcionaba pero cuando puse los tres led para regularlo con ellos en vez de con el láser puesto empezaron a cada vez lucir menos y menos y el isen me da 0'3v y no lucen nada ya, doy vueltas a los potenciómetros y como si nada, he puesto otra vez el láser porque si ha salido uno de los tres led como quemado a ver si el láser si que funcionaba y ahora ya no funciona. ¿Que puede pasar? ¿se ha quemado el driver? ¿he quemado algo? ¿Que hago? ¿Como lo arreglo?
Citar
#30
Tienes que configurar una vez el driver y ya, pero con los leds. Mira que tengas el disipador bien puesto, los cables que hagan buen contacto, algo que no queme demasiado. La fuente tiene potencia suficiente? diametro de los cables, la electronica que no te cambie el pwm. Ves midiendo.

Cuidado con el laser, que son muy delicados.

Asegurate tambien de que al poner el maximo en el soft de potencia, tienes 5v o casi 5v en la entrada de pwm.
Citar
#31
(20-02-2017, 10:43 PM)grafisoft escribió: Tienes que configurar una vez el driver y ya, pero con los leds. Mira que tengas el disipador bien puesto, los cables que hagan buen contacto, algo que no queme demasiado. La fuente tiene potencia suficiente? diametro de los cables, la electronica que no te cambie el pwm. Ves midiendo.

Cuidado con el laser, que son muy delicados.

Asegurate tambien de que al poner el maximo en el soft de potencia, tienes 5v o casi 5v en la entrada de pwm.

Tengo puesta una fuente de alimentación 12v 10A

Al hacer el código de prueba ese que tengo en la página anterior he probado en la salida de SPINEN de la cncboard con el polímetro y me da 4,39v así que se supone que está bien eso no? Luego poniendo el cable que va hasta el puerto pwm del driver he probado que alli también me da 4'39v. Da todo el rato 4,39 no cambia segun se va moviendo, bueno cuando para el movimiento se paran los 4,39v y se pone a 0v.

Poniendo en el soft cnccontrol lo de conectar el laser manualmente y dando a s200 me salen 4v y a s255 me salen 5v.

Por lo tanto entiendo que hasta el driver tengo todo correcto no?

Ahora en el driver lo tengo enchufado asi:
resim
asi es con el laser puesto
ahora foto de los led (patilla larga positivo no?)
resim
Y los led puestos respetando la polaridad
resim

Hasta aqui supongo que voy bien no? aunque lo de los led no lo tengo nada claro que lo esté haciendo bien...
Citar
#32
Pero esos leds no son Lengua

Tienes que probar con 3 leds de potencia de 1w.
Citar
#33
Si ya decia yo que seguro que no lo estaba haciendo bien lo de los leds... ¿cuales son los led de 1w? o 1 led de 3w no se, ¿Donde los encuentro? ¿como puedo saber que son realmente de 1w? vamos que estoy cogiendo lo que de verdad necesito.


PD: una cosa que me resulta rara en el driver es que las conexiones de alimentacion y del laser estén los positivos juntos es decir:
-
+
+
-
pensaba que normalmente se ponían las conexiones asi:
-
+
-
+
en plan uno positivo otro negativo luego el de al lado positivo y luego negativo, ya se que cada uno lo pone como quiere al hacer la placa y siguiendo el manual del driver no pasa nada, estoy teniendo cuidado de respetar las polaridades en todo, aunque no se si el pwm es necesario polaridad, en alimentación seguro que si y en el laser supongo que también, en los ventiladores solo cambiaría el sentido de giro ¿no?
Citar
#34
Hay que tener cuidado con las polaridades, en todas menos en la del laser (que si lo pones mal, no lucira. Tanto leds como laser)

En el resto de casos, quemaras algo.

Los leds mejor 3 de 1w. Usa los blancos mismamente. Si pones led white 1w en ebay, te saldran. Pilla los que llevan como una chapita, que es el disipador. Se calientan muchisimo.

Si tienes un laser de 3w, tendras que tener una lectura en Isens de 2v. Ojo que se mide en tension. Con relacion 1:1 entre tension y corriente.

Saludos
Citar
#35
http://www.ebay.es/itm/2x-4x-6x-8x-10x-p...Gnho7tjcMQ

¿compro esos entonces?

o estos que pone que llegan antes http://www.ebay.es/itm/10-und-Led-chip-1...9C6vXeL3hw
Citar
#36
Ambos te valen, los de 1w. Eso si, cuida porque no llevan disipador y se calientan muchisimo
Citar
#37
comprado el que llega antes, el de 10unidades, es que me escamaba que sean de 3,2-3,6v a ver si no iban a servir
Citar
#38
Eso esta bien, lo has comprao bien
Citar
#39
Nos alegra leer que ya tienes el problemilla controlado. A ver que tal anda la maquina!
Citar
#40
Tengo ya los led de 1w soldados y conectados, pero me hace la misma, se han encendido que deslumbraban y se han ido apagando y ya no lucen... no me dió tiempo a ver que voltaje daba el isens ¿que puede estar ocurriendo? Es que miro y ni me huele a quemado ni veo nada raro...
resim
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  CONSULTA Laser 30W Paralex 2 467 11-05-2018, 02:23 AM
Último mensaje: pservent
  CONSULTA CNC laser majjete 4 462 05-03-2018, 11:04 PM
Último mensaje: grafisoft
  Láser diy 15w josualo 16 1,505 15-05-2017, 08:48 AM
Último mensaje: BlackBit
  CNC Láser Miguel75 137 21,591 20-02-2015, 11:23 PM
Último mensaje: grafisoft