Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Autolevel por capacitancia
pues manda narices que los de marlin lo sepan y se la esten tocando... a mi de momento con este "truco" me funciona, pero vamos que voy a mandar el auto level a chuparla. los de marlin ya se podrian poner las pilas... no me importaria que sacasen un firm de pago, a precio razonable claro esta... editable.. si con eso se ponen las pilas... porque telita.
Citar
(08-01-2016, 04:28 PM)erteclas escribió: pues manda narices que los de marlin lo sepan y se la esten tocando... a mi de momento con este "truco" me funciona, pero vamos que voy a mandar el auto level a chuparla.  los de marlin ya se podrian poner las pilas... no me importaria que sacasen un firm de pago, a precio razonable claro esta... editable.. si con eso se ponen las pilas... porque telita.

yo entiendo quee es algo complejor, hai gente implicada española en el firm y tienen un buen equipo creo yo, pero ya desde hace tiempo realmente solo teneis que ver que en el canal DEV que ahora se llama RC de gitub de marlin las modificaciones que se hacen, y la cosa parece que no avanza para nada en ningun camino, lo ultimo que han hecho ha sido parece meter el idioma polaco y cambiar el logo... a ver si nos sorprendern con cosillas,, no se en que quedo lo del marlin para la ramps de 32bits...
Citar
Alguien lo tiene instalado el autolevel con superficie de 20x30? porque lo tengo montado y pese a que imprime bien, no imprime centrado aunque en Cura/Repetier lo situe en el centro...
Citar
(10-04-2016, 06:29 PM)Jarryson escribió: Alguien lo tiene instalado el autolevel con superficie de 20x30? porque lo tengo montado y pese a que imprime bien, no imprime centrado aunque en Cura/Repetier lo situe en el centro...
Seguramente sea la versión del marlin, a mi me pasaba, y al actualizar, se solucionó

Enviado desde mi Nexus 6 mediante Tapatalk
Citar
Al final es mejor capacitivo o inductivo?
Citar
No creo que sea cuestión de cual es mejor o peor. Los inductivos solo detectan metal con lo cual estas obligado a utilizarlos sobre la cama de aluminio. Por el contrario el capacitivo detecta cualquier superficie, así que puedes poner cristal o lo que quieras en la cama que va a funcionar. Los sensores capacitivos suelen ser más grandes y más raros de encontrar y los inductivos los tienes más pequeños y más fáciles de encontrar. Así que escoge el que mejor se adapte a lo que quieras.
Citar
El sensor debe ser PNP o NPN?
Citar
(25-05-2016, 11:49 AM)JuanKa escribió: El sensor debe ser PNP o NPN?

Da igual solo tienes que configurarlo en el firmware de que tipo es. El npn si se rompiera el cable o el sensor dejará de funcionar, activaria el final de carrera. El PNP en este caso no y el eje chocaría contra la cama. Digamos que el npn porta un extra de seguridad en este caso.
Citar
Hola como puedo saber si el sensor funciona? he soldado todo a la plaquita y con todo conectado entre el marron y aul tengo 0v entre el marron y negro -12 y entre el azul y negro 12v
Citar
A ver el marron es el posito el azul el negativo y el negro es la señal.

Entre el marron y el azul tienes que tener 12v, si tienes 0v algo esta mal conectado. Entre el marron y el negro o negro y azul deberias tener 12v o 0v dependiendo de si esta dando señal o no el detector.
No se como lo has conectado pero esta mal, revisa tus conexiones.
Citar
(30-06-2016, 08:41 PM)guillermohor escribió: Hola como puedo saber si el sensor funciona? he soldado todo a la plaquita y con todo conectado entre el marron y aul tengo 0v entre el marron y negro -12 y entre el azul y negro 12v
Donde conseguiste la plaquita?

Enviado desde mi Nexus 6 mediante Tapatalk
Citar
(30-06-2016, 11:03 PM)Triangulo escribió: A ver el marron es el posito el azul el negativo y el negro es la señal.

Entre el marron y el azul tienes que tener 12v, si tienes 0v algo esta mal conectado. Entre el marron y el negro o negro y azul deberias tener 12v o 0v dependiendo de si esta dando señal o no el detector.
No se como lo has conectado pero esta mal, revisa tus conexiones.

vale conectado a la fuente es como tu dices pero no consigo que se encienda el led ni aun dando vueltas al tornillo hay 12 etnre marron y azul, y 12 entre negro y azul pero 0 entre marron y negro
Citar
(01-07-2016, 06:29 AM)guillermohor escribió:
(30-06-2016, 11:03 PM)Triangulo escribió: A ver el marron es el posito el azul el negativo y el negro es la señal.

Entre el marron y el azul tienes que tener 12v, si tienes 0v algo esta mal conectado. Entre el marron y el negro o negro y azul deberias tener 12v o 0v dependiendo de si esta dando señal o no el detector.
No se como lo has conectado pero esta mal, revisa tus conexiones.

vale conectado a la fuente es como tu dices pero no consigo que se encienda el led ni aun dando vueltas al tornillo hay 12 etnre marron y azul, y 12 entre negro y azul pero 0 entre marron y negro

Con esos voltajes el Led debería estar encendido si es PNP pero si es npn apagado. No se que tipo de sensor tienes. Tampoco específicas si es inductivo o capacitivo.
Tal  como lo tienes conectado prueba acercarle hasta la punta algo de metal. Si el Led no se enciende, puede estar fundido, comprueba si el voltaje entre el negro y azul varia. Si no se varia estará estropeado
Citar
Buenos dias,

queria haceros unas consultas haber si me podeis echar un cable.

E leido las 21 paginas de este post, e resuelto partes del montaje y parte de codigo pero lo tengo casi listo, pero no consigo hacerlo funcinar bien.

1-
Ajusto el tornillo para que detecte la cama aprximadamente a unos 0.5-0.90 del nozzle para poder bajar.

El problema esque el tornillo manda sobre la configuracion

intruduzco g92 z10, ajusto la altura y el valor es -0.7, meto este valor mediante el m206 z-0.7, m500, y leeo m501, y esta ok, gurda la configuracion,
le doy para hacer un homming, y no baja esos 0.7, se queda a la altura que regulo el tornillo,

2- regulo el tornillo ya a ras se queda a 0.15- 0.20 le ago un homming, todo ok, le doy para hacer un g29, y en unos puntos tocas a ras y mas para la izquierda choca contra la cama, y tengo que dar un paro de emergencia.
la mia no es un prusa es un sparkube, y el husillo va directo de motor a la base de metraquilato y lo va a partir,

no consigo ajustar la altura, ya que le meta el valor que le meta manda el tornillo y si ajusto demasiado el tornillo para quedar a ras de la cama, este choca con el cristal.
si regulo la altura por ejemplo que el nozzle se quede a 1-1.5m de la cama me hace el g29 sin problema.

la verdad esque ya no se que hacer, os dejo mi config

el sensor tengo la sparkube defrente a mi lo tengo instalado a la izquierda del nozzle y hacia alante ( hacia mi )

#if ENABLED(AUTO_BED_LEVELING_GRID)

#define LEFT_PROBE_BED_POSITION 36//15 ok 36 36 OSFET
#define RIGHT_PROBE_BED_POSITION 180 //110 ok no tocar 180
#define FRONT_PROBE_BED_POSITION 48 //48 10
#define BACK_PROBE_BED_POSITION 150 //180 135
#define MIN_PROBE_EDGE 10 // The Z probe minimum square sides can be no smaller than this.

// Set the number of grid points per dimension.
// You probably don't need more than 3 (squared=9).
#define AUTO_BED_LEVELING_GRID_POINTS 3

#else // !AUTO_BED_LEVELING_GRID

// Arbitrary points to probe.
// A simple cross-product is used to estimate the plane of the bed.
#define ABL_PROBE_PT_1_X 15
#define ABL_PROBE_PT_1_Y 180
#define ABL_PROBE_PT_2_X 15
#define ABL_PROBE_PT_2_Y 20
#define ABL_PROBE_PT_3_X 170
#define ABL_PROBE_PT_3_Y 20

#endif // AUTO_BED_LEVELING_GRID

// Z Probe to nozzle (X,Y) offset, relative to (0, 0).
// X and Y offsets must be integers.
//
// In the following example the X and Y offsets are both positive:
// #define X_PROBE_OFFSET_FROM_EXTRUDER 10
// #define Y_PROBE_OFFSET_FROM_EXTRUDER 10
//
// +-- BACK ---+
// | |
// L | (+) P | R <-- probe (20,20)
// E | | I
// F | (-) N (+) | G <-- nozzle (10,10)
// T | | H
// | (-) | T
// | |
// O-- FRONT --+
// (0,0)
#define X_PROBE_OFFSET_FROM_EXTRUDER 36 // X offset: -left +right [of the nozzle]
#define Y_PROBE_OFFSET_FROM_EXTRUDER 48 // Y offset: -front +behind [the nozzle]
#define Z_PROBE_OFFSET_FROM_EXTRUDER 0 // Z offset: -below +above [the nozzle]

#define XY_TRAVEL_SPEED 8000 // X and Y axis travel speed between probes, in mm/min.

#define Z_RAISE_BEFORE_PROBING 15 // How much the Z axis will be raised before traveling to the first probing point.
#define Z_RAISE_BETWEEN_PROBINGS 5 // How much the Z axis will be raised when traveling from between next probing points.
#define Z_RAISE_AFTER_PROBING 15 // How much the Z axis will be raised after the last probing point.

acabo de ver otra cosa el punto cero de mi impresora, mirando de frente, es la parte trasera derecha,
el sensor deja de funcionar cuando pasa la mitad de la cama es decir si dividimos la cama en dos el lado derecho el sensor da señal,
pero segun lo muevo hacia el lado izquierdo y pasa no da señal en nigun lado de la cama
Citar
Para empezar si frente a la impresora tienes el sensor a la izquierda y hacia ti.
#define X_PROBE_OFFSET_FROM_EXTRUDER 36 // X offset: -left +right [of the nozzle]

Este parámetro esta mal, hacia la izquierda tienes que tener un numero negativo, -36 en este caso.

Luego tienes que ajustar la altura del sensor a mano o bien con el tornillo, de modo que este por encima de la punta del nozzle y de señal en cualquiera esquina de la cama, si dices que hacia el lado izquierdo no da señal, pues es que esta muy alto el sensor bajalo mas. Si se diera el caso de que para que diera señal tuviera que estar por debajo del nozzle el sensor no te valdria necesitarías uno con mas alcance.

Una vez que tienes echo esto manda la impresora a homming. En este punto el eje z esta parado porque el sensor dio señal, y el nozzle estara bastante separado de la cama. Como hiciste homming la posicion del eje Z sera 0, entonces no te va a dejar bajar el eje Z, aqui es donde entra el G92 Z10. Bajas y ajustas con el folio calculas la diferencia y el valor que te de. Es el que pones ya con el m206 y demas como has echo.

Ahora bien el error que tienes de concepto es pensar que cuando hagas homming la impresora va a bajar ese offset, cuando tu hagas homming la impresora va a parar en cuanto el sensor de señal. Pero no tienes que preocuparte, cuando la mandes a imprimir ella cuando lea la posicion Z0 va a restarle ese offset y bajara la cantidad que tu has calculado antes.

Espero haberme explicado bien.
Citar
Buenas tardes muchas gracias, ese último apunte del homing no lo sabía, todavía no e imprimido ya que como no tenía claro no lo e probado.

Si el sensor es como todos los vuestros lo único que yo le tengo con dos reístencias.

Otra pregunta, me lío un montón y no consigo entender que coordenadas dar aller si con unas pero no me queda clara la relación,

Si alguien me pudiera orientar, esta noche probaré haber.


Muchas gracias por tu respuesta


Enviado desde mi iPhone utilizando Tapatalk
Citar
A que coordenadas te refieres??
Citar
a estas teniendo encuenta lo que me as dicho de que tengo que poner el - en el 36

mi sensor quedaria asi

x-36
y +48

#define LEFT_PROBE_BED_POSITION 36//15 ok 36 36 OSFET
#define RIGHT_PROBE_BED_POSITION 180 //110 ok no tocar 180
#define FRONT_PROBE_BED_POSITION 48 //48 10
#define BACK_PROBE_BED_POSITION 150 //180 135
#define MIN_PROBE_EDGE 10 // The Z probe minimum square sides can be no smaller than this.
Citar
(01-07-2016, 11:28 PM)sacha escribió: a estas teniendo encuenta lo que me as dicho de que tengo que poner el - en el 36

mi sensor quedaria asi

x-36
y +48

#define LEFT_PROBE_BED_POSITION 36//15 ok 36 36 OSFET
#define RIGHT_PROBE_BED_POSITION 180 //110 ok no tocar 180
#define FRONT_PROBE_BED_POSITION 48 //48 10
#define BACK_PROBE_BED_POSITION 150 //180 135
#define MIN_PROBE_EDGE 10 // The Z probe minimum square sides can be no smaller than this.

A ver, el 36 y 48 es la distancia que hay de tu sensor a la punta del nozzle. Esos valores no van tampoco de un milimetro, los mides con una regla. Si te pones de frente a tu impresora si el sensor esta a la izquierda es negativo y si esta a la derecha positivo, el x 36 en tu caso. El eje y  si el sensor esta más hacia ti positivo sino negativo, el y 48 en tu caso.

Los 4 últimos parámetros que has puesto son los 4 puntos donde va a ir a tomar muestras el sensor.  
Le estas dando dos valores del eje x 36,180 y dos valores del eje y 48,150. Con esos 4 valores hace un cuadrado y el sensor iría a medir en sus vértices.  
Que serían  (36,48) (36,150) (180,48) (180,150).
Citar
buenas muchas gracias por la aclaracion, ayer ya hice en una impresion y genial, lo que pasa que el g29 me calculo solo en 1/4 de la cama.

esto ajustando las coordenadas para el g29, pero no consigo hacer que llege a todo dejo mis cordenadas y explico abajo

#define LEFT_PROBE_BED_POSITION 0//15 ok 36 36 OSFET
#define RIGHT_PROBE_BED_POSITION 113 //110 ok no tocar 180
#define FRONT_PROBE_BED_POSITION 48 //48 10
#define BACK_PROBE_BED_POSITION 180 //180 135
#define MIN_PROBE_EDGE 10 // The Z probe minimum square sides can be no smaller

la mia es una sparkube, pero si tubieramos una prusa y la cama defrente. el nozzle hace homing, en la parte final trasera, derecha de la cama de desplaza hacia la izquierda ( define RIGHT_PROBE_BED_POSITION 113), se queda a ras de cristal, pero a la hora de, tomar la siguiente medida se desplaza hacia la derecha LEFT_PROBE_BED_POSITION 0, pero aunque ponga 0, hay como unos 40mm aprx hacia la derecha que se quedan sin medir, luego los otras dos puntos perfectos, baja hacia abajo BACK_PROBE_BED_POSITION 180 y va hacia la izquierda, como puedo hacer para que en la segunda cordenada llege hasta el final ?

gracias
baja hacia aba
pero a la hora de, tomar la siguiente medida
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Sensor autolevel kingpin82 8 1,504 22-09-2017, 05:08 PM
Último mensaje: tximy
  Autolevel witbox josualo 1 930 16-01-2015, 11:53 AM
Último mensaje: Coricoco
  SAV MKI y autolevel holaktal3 3 1,281 13-10-2014, 03:23 AM
Último mensaje: fmalpartida