Calificación:
  • 4 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Autolevel, paso a paso (III): configuración (ACTUALIZADO y EDITADO).
#21
Hola, según indicas, tienes las siguientes medidas: cama de 220x220mm, A=0, B=-4, C=-31 y D=20. Sensor a la izquierda y detrás de la boquilla del extrusor.
Para esas medidas, la rejilla centrada máxima sería la que indicas:
#define LEFT_PROBE_BED_POSITION 31
#define RIGHT_PROBE_BED_POSITION 189
#define FRONT_PROBE_BED_POSITION 31
#define BACK_PROBE_BED_POSITION 189

Las pones comentadas, supongo que no lo tendrás así cuando compilas o no te las tendrá en cuenta.
Si con la configuración anterior no te centra los puntos de medición del autolevel, es que no están bien las medidas. Verifica que están bien.
Respecto al home, con el Safe Home por defecto, lo que indicas de su posición es correcto.
Ahí es donde se encuentra la boquilla cuando el sensor está en el centro de la cama.
Citar
#22
Hola buenos dias!

Utilizo una coreXY y el proceso de toma de datos y autonivelación de cama me lo realiza correctamente, pero luego cuando esta imprimiento una pieza no veo que se realize ningun ajuste por parte de los motores del eje z para compensar los desniveles. ¿Alguna sugerencia o algo que comprobar que se me haya pasadopor alto?

Saludos Gracias a todos!
Citar
#23
Hola, si la cama está bien nivelada y su planitud es buena, es bastante difícil ver los movimientos que realiza el ajuste del autolevel. Son muy pequeños.
¿Los resultados de la impresión son buenos? Porque eso es lo que finalmente se intenta conseguir con él.
Con este tema del autolevel pasa un poco como con el del cambio del firmware.
Parece que muchos usuarios lo consideran como una especie de fetiche que, una vez implementado, va ha solucionar todos sus problemas de impresión drásticamente. Y no es así. Solucionan unos problemas muy concretos.
Por ejemplo, el cambio de firmware solo es totalmente necesario si se quiere implementar algo que no permite el de seríe, como por ejemplo, el autolevel. Por sí mismo, no mejora las impresiones.
Y el autolevel solo lo es si hay un ligero problema de planitud de la cama, que no es posible corregir mediante la nivelación. Por ejemplo, una cama muy grande que se comba ligeramente por el centro.
Cuando la cama es perfectamente plana y se nivela correctamente, no tiene sentido poner el autolevel. Con ello solo se consigue incrementar el tiempo de las impresiones.
Quizá este sea tu caso y por eso no lo ves actuar. Puede que no lo necesite hacer.
Citar
#24
Acabo de actualizar este capítulo del tutorial, para adaptarlo a los cambios de la nueva versión 1.1.8 de Marlin.
Citar
#25
Buenas noches, he seguido el tutorial paso a paso pero al comentar esta línea : #define MIN_SOFTWARE_ENDSTOP_Z el homing del eje z no se detiene si no lo paro continúa hacia la cama sin parar, y desde el pronterface aunque sólo baje 1 mm el eje z empieza a bajar sin parar y tengo que detener la impresora.... A que puede ser debido?? Un saludo.
Citar
#26
(23-02-2018, 12:38 AM)Punisher escribió: Buenas noches, he seguido el tutorial paso a paso pero al comentar esta línea :   #define MIN_SOFTWARE_ENDSTOP_Z el homing del eje z no se detiene si no lo paro continúa hacia la cama sin parar, y desde el pronterface aunque sólo baje 1 mm  el eje z empieza a bajar sin parar y tengo que detener la impresora.... A que puede ser debido?? Un saludo.

Hola, se necesita algo más de información para saber cual es tu problema. Podrías explicar que tipo de montaje estás haciendo (impresora, sensor, etc.) y los pasos que has realizado.
Dices que has seguido el tutorial, pero en el capítulo del sensor se indica que hay que comprobar que se activa el sensor y funciona como final de carrera del eje Z. Por lo que comentas, parece que en tu caso no lo está haciendo.
Al descomentar la línea que indicas, lo único que se hace es permitir movimientos en el eje Z más allá de la activación del sensor (para que pueda bajar a la altura de la primera capa).
Pero no influye en absoluto para la activación del final de carrera durante el homing del eje Z.
Citar
#27
Buenas tardes, es una i3 steel, con ramps 1.4 y el sensor va conectado en el z min del final de carrera, si quito comentarios de dicha línea la impresora hace el homing perfectamente pero si la comento hace el homing bien , pero al bajar el eje con pronterface una vez puesto g92 z10 para poder bajar más el eje no se detiene. Incluso si sólo pulso 0,1 mm empieza a bajar y no para.
Citar
#28
(23-02-2018, 07:11 PM)Punisher escribió: Buenas tardes, es una i3 steel, con ramps 1.4 y el sensor va conectado en el z min del final de carrera, si quito comentarios de dicha línea la impresora hace el homing perfectamente pero si la comento hace el homing bien , pero al bajar el eje con pronterface una vez puesto g92 z10 para poder bajar más el eje no se detiene. Incluso si sólo pulso 0,1 mm empieza a bajar y no para.

No entiendo a que te refieres con eso de "... una vez puesto G92 Z10 para poder bajar más el eje ...". Con seguridad, eso no lo has leído en el tutorial.
Si la impresora hace bien el home, las ordenes del Pronterface tendría que seguirlas la impresora. Si le dices que baje 1 mm, debería bajar 1 mm y pararse.
Una vez comentada la línea #define MIN_SOFTWARE_ENDSTOP_Z, es responsabilidad tuya no indicar movimientos equivocados que puedan comprometer la integridad de la máquina.
Pero la impresora tiene que obedecer las órdenes. Por lo menos es lo que hacen todas las que conozco.
Te recomiendo que sigas el tutorial completo paso a paso y compruebes si sigues teniendo ese problema.
Citar
#29
Buenas noches cierto ha sido error mío, ya lo he solucionado, no hacía falta ese comando en este caso, muchas gracias por la ayuda.
Citar
#30
Buenas, una duda al respecto. Yo tengo el sistema de autolevel configurado y demás, me hace la malla y patatín patatán. Mi duda es, que leyendo el manual de la página de Marlin dice, o eso he entendido yo con mi inglés gadimaño, que en el código de inicio de impresión hay que añadir la línea M420 S1. Y leyendo guias y más guias ninguno dice que haya que escribirlo. ¿Esto puede ser porque según la guia, guardas los datos capturados en la EEPROM y hace el autolevel con ellos? Pero es que iendo a la página de Reprap de la wiki de GCODES me habla de que ese comando es de colores RGB entonces ya es cuando me enajeno y no tengo ni idea de que c*****s estoy haciendo
resim
resim


Enviado desde mi iPhone utilizando Tapatalk
Citar
#31
(26-02-2018, 02:50 AM)dvera16 escribió: Buenas, una duda al respecto. Yo tengo el sistema de autolevel configurado y demás, me hace la malla y patatín patatán. Mi duda es, que leyendo el manual de la página de Marlin dice, o eso he entendido yo con mi inglés gadimaño, que en el código de inicio de impresión hay que añadir la línea M420 S1. Y leyendo guias y más guias ninguno dice que haya que escribirlo. ¿Esto puede ser porque según la guia, guardas los datos capturados en la EEPROM y hace el autolevel con ellos? Pero es que iendo a la página de Reprap de la wiki de GCODES me habla de que ese comando es de colores RGB entonces ya es cuando me enajeno y no tengo ni idea de que c*****s estoy haciendo
resim
resim


Enviado desde mi iPhone utilizando Tapatalk

Hola, el tutorial lo realicé para configurar un autolevel sencillo y funcional, del tipo LINEAR o BILINEAR (según gustos), sin entrar en mayores complicaciones.
Y es por ello que está pensado para que realice las mediciones al comienzo de cada impresión, mediante un comando G29 incluído en el script de inicio.
Los datos de las mediciones realizadas se almacenan en RAM, por lo que se pierden en cada reinicio a no ser que se guarden en la EEPROM.
Naturalmente, hay otros métodos de autolevel más sofisticados y que pueden consultarse en la documentación en línea de Marlin.
Existen varios comandos en Gcode para salvar y recuperar mediciones, pero eso escapa al nivel básico del tutorial.
Si tienes interés en ello, en la documentación en línea de Marlin (eso sí, en inglés), se explican en detalle los métodos y los comandos implicados.
Desde la versión 1.1.2 de Marlin, se incorporó un método denominado UBL (Unified Bed Leveling), que toma lo mejor de los otros métodos y que parece consigue unos resultados muy buenos.
Sobre todo, con las mejoras que se han realizado en la última versión lanzada, la 1.1.8. Incluso sin sensor (haciendolo a mano, claro).
Aún no lo he mirado, pero lo tengo en la agenda.
Si no te manejas bien en inglés, puedes comenzar por este post de @pfvidal , donde habla de él y traduce partes de la documentación de Marlin.
Citar
#32
(26-02-2018, 07:01 PM)Simemart escribió:
(26-02-2018, 02:50 AM)dvera16 escribió: Buenas, una duda al respecto. Yo tengo el sistema de autolevel configurado y demás, me hace la malla y patatín patatán. Mi duda es, que leyendo el manual de la página de Marlin dice, o eso he entendido yo con mi inglés gadimaño, que en el código de inicio de impresión hay que añadir la línea M420 S1. Y leyendo guias y más guias ninguno dice que haya que escribirlo. ¿Esto puede ser porque según la guia, guardas los datos capturados en la EEPROM y hace el autolevel con ellos? Pero es que iendo a la página de Reprap de la wiki de GCODES me habla de que ese comando es de colores RGB entonces ya es cuando me enajeno y no tengo ni idea de que c*****s estoy haciendo
resim
resim


Enviado desde mi iPhone utilizando Tapatalk

Hola, el tutorial lo realicé para configurar un autolevel sencillo y funcional, del tipo LINEAR o BILINEAR (según gustos), sin entrar en mayores complicaciones.
Y es por ello que está pensado para que realice las mediciones al comienzo de cada impresión, mediante un comando G29 incluído en el script de inicio.
Los datos de las mediciones realizadas se almacenan en RAM, por lo que se pierden en cada reinicio a no ser que se guarden en la EEPROM.
Naturalmente, hay otros métodos de autolevel más sofisticados y que pueden consultarse en la documentación en línea de Marlin.
Existen varios comandos en Gcode para salvar y recuperar mediciones, pero eso escapa al nivel básico del tutorial.
Si tienes interés en ello, en la documentación en línea de Marlin (eso sí, en inglés), se explican en detalle los métodos y los comandos implicados.
Desde la versión 1.1.2 de Marlin, se incorporó un método denominado UBL (Unified Bed Leveling), que toma lo mejor de los otros métodos y que parece consigue unos resultados muy buenos.
Sobre todo, con las mejoras que se han realizado en la última versión lanzada, la 1.1.8. Incluso sin sensor (haciendolo a mano, claro).
Aún no lo he mirado, pero lo tengo en la agenda.
Si no te manejas bien en inglés, puedes comenzar por este post de @pfvidal , donde habla de él y traduce partes de la documentación de Marlin.


Gracias!! Ahora ya lo tengo más claro. Yo había seguido el tutorial oficial de Marlin. El método manual que dices lo he probado y es algo engorroso, es un ajuste de offset pero en todos los puntos, pienso que será más exacto que el auto pero este es más comodo. Muchas gracias y enhorabuena, tremendo tutorial


Enviado desde mi iPhone utilizando Tapatalk
Citar
#33
Hola! lo primero de todo felicitar por este pedazo de curro con el tutorial. 
Lo segundo decir que he seguido los pasos y consigo hacer todo excepto cuando voy a imprimir. Me explico, cuando hace la comprobación de los 9 puntos la boquilla toca la cama tal y como debería a la distancia que tendría que imprimir después, sin embargo, cuando empieza la impresión la boquilla empieza a imprimir unos milímetros mas arriba con lo que deja caer el plástico y no consigo arreglarlo. Alguien podría ayudarme? muchas gracias !!
Citar
#34
(28-02-2018, 11:28 PM)nazgul_25 escribió: Hola! lo primero de todo felicitar por este pedazo de curro con el tutorial. 
Lo segundo decir que he seguido los pasos y consigo hacer todo excepto cuando voy a imprimir. Me explico, cuando hace la comprobación de los 9 puntos la boquilla toca la cama tal y como debería a la distancia que tendría que imprimir después, sin embargo, cuando empieza la impresión la boquilla empieza a imprimir unos milímetros mas arriba con lo que deja caer el plástico y no consigo arreglarlo. Alguien podría ayudarme? muchas gracias !!

Hola, por lo que comentas me da la impresión de que no estás siguiendo correctamente los pasos del tutorial.
Cuando se realizan las mediciones del autolevel (las nueve, si lo has configurado como en el tutorial), la boquilla no debe bajar hasta la altura en que debería imprimir, dado que el sensor se tiene que activar antes si está colocado como se indica.
Después de realizada la última medición, en el momento de comenzar la impresión, es cuando tiene que bajar a la altura de la primera capa. Esa altura se consigue configurando correctamente el Z Offset.
Te recomiendo que vuelvas a leer el tutorial con calma, siguiendo todos los pasos tal y como se indican.
Y si tienes alguna duda indícalo y te la intentaré aclarar.
Citar
#35
(01-03-2018, 01:55 PM)Simemart escribió:
(28-02-2018, 11:28 PM)nazgul_25 escribió: Hola! lo primero de todo felicitar por este pedazo de curro con el tutorial. 
Lo segundo decir que he seguido los pasos y consigo hacer todo excepto cuando voy a imprimir. Me explico, cuando hace la comprobación de los 9 puntos la boquilla toca la cama tal y como debería a la distancia que tendría que imprimir después, sin embargo, cuando empieza la impresión la boquilla empieza a imprimir unos milímetros mas arriba con lo que deja caer el plástico y no consigo arreglarlo. Alguien podría ayudarme? muchas gracias !!

Hola, por lo que comentas me da la impresión de que no estás siguiendo correctamente los pasos del tutorial.
Cuando se realizan las mediciones del autolevel (las nueve, si lo has configurado como en el tutorial), la boquilla no debe bajar hasta la altura en que debería imprimir, dado que el sensor se tiene que activar antes si está colocado como se indica.
Después de realizada la última medición, en el momento de comenzar la impresión, es cuando tiene que bajar a la altura de la primera capa. Esa altura se consigue configurando correctamente el Z Offset.
Te recomiendo que vuelvas a leer el tutorial  con calma, siguiendo todos los pasos tal y como se indican.
Y si tienes alguna duda indícalo y te la intentaré aclarar.

Hola! gracias por la respuesta. El tutorial es la cuarta vez que lo hago desde el principio para descartar que me esté saltando algo. De hecho una de las veces un amigo lo hizo siguiendo el tutorial y le pasa lo mismo. Las 9 mediciones las hace correctamente pero cuando llega a la ultima, baja, detecta la superficie, sube normal y vuelve a subir un poco y ya se dirige al punto de imprimir y se queda por encima y extruye dejando caer el plastico. Lo que si que me he dado cuenta es que al generar el gcode con simplify3d se queda mas arriba incluso que con cura el cual baja la boquilla algo mas, se queda cerca de donde deberia pero tampoco, no se si tendra algo que ver...
He grabado un video de lo que hace la impresora por si ayuda de algo si se necesita mas informacion solo dímelo y te indico. Muchas gracias por la ayuda!


Citar
#36
(01-03-2018, 07:29 PM)nazgul_25 escribió:
(01-03-2018, 01:55 PM)Simemart escribió:
(28-02-2018, 11:28 PM)nazgul_25 escribió: Hola! lo primero de todo felicitar por este pedazo de curro con el tutorial. 
Lo segundo decir que he seguido los pasos y consigo hacer todo excepto cuando voy a imprimir. Me explico, cuando hace la comprobación de los 9 puntos la boquilla toca la cama tal y como debería a la distancia que tendría que imprimir después, sin embargo, cuando empieza la impresión la boquilla empieza a imprimir unos milímetros mas arriba con lo que deja caer el plástico y no consigo arreglarlo. Alguien podría ayudarme? muchas gracias !!

Hola, por lo que comentas me da la impresión de que no estás siguiendo correctamente los pasos del tutorial.
Cuando se realizan las mediciones del autolevel (las nueve, si lo has configurado como en el tutorial), la boquilla no debe bajar hasta la altura en que debería imprimir, dado que el sensor se tiene que activar antes si está colocado como se indica.
Después de realizada la última medición, en el momento de comenzar la impresión, es cuando tiene que bajar a la altura de la primera capa. Esa altura se consigue configurando correctamente el Z Offset.
Te recomiendo que vuelvas a leer el tutorial  con calma, siguiendo todos los pasos tal y como se indican.
Y si tienes alguna duda indícalo y te la intentaré aclarar.

Hola! gracias por la respuesta. El tutorial es la cuarta vez que lo hago desde el principio para descartar que me esté saltando algo. De hecho una de las veces un amigo lo hizo siguiendo el tutorial y le pasa lo mismo. Las 9 mediciones las hace correctamente pero cuando llega a la ultima, baja, detecta la superficie, sube normal y vuelve a subir un poco y ya se dirige al punto de imprimir y se queda por encima y extruye dejando caer el plastico. Lo que si que me he dado cuenta es que al generar el gcode con simplify3d se queda mas arriba incluso que con cura el cual baja la boquilla algo mas, se queda cerca de donde deberia pero tampoco, no se si tendra algo que ver...
He grabado un video de lo que hace la impresora por si ayuda de algo si se necesita mas informacion solo dímelo y te indico. Muchas gracias por la ayuda!


Qué z te marca al empezar la primera capa? Haciendo home en z y después moviendo despacio asegura que z=0 esta tocando la cama. Si no, guarda valor con M851 Zx y después M500 ( usando pronterface y x es espesor de un folio). Esto lo he tenido que hacer yo alguna vez. Saludos

Sent from my VTR-L29 using Tapatalk
Citar
#37
(01-03-2018, 10:59 PM)bernard69 escribió: Qué z te marca al empezar la primera capa? Haciendo home en z y después moviendo despacio asegura que z=0 esta tocando la cama. Si no, guarda valor con M851 Zx y después M500 ( usando pronterface y x es espesor de un folio). Esto lo he tenido que hacer yo alguna vez. Saludos

Sent from my VTR-L29 using Tapatalk

Lo que indicas no es de aplicación cuando se tiene un sensor como final de carrera. El punto 0 de Z es donde se activa el sensor al hacer home y no tiene por qué ser a la altura de la primera capa.
Por contra, conviene que sea antes para tener margen si el sensor falla en la activación y así poder evitar el choque de la boquilla con la cama.
Es con el Z Offset con lo que se ajusta la altura para la impresión (un valor siempre negativo, por tanto).
Por eso hay que habilitar en el firmware, que ese eje pueda sobrepasar el punto cero.


(01-03-2018, 07:29 PM)nazgul_25 escribió: Hola! gracias por la respuesta. El tutorial es la cuarta vez que lo hago desde el principio para descartar que me esté saltando algo. De hecho una de las veces un amigo lo hizo siguiendo el tutorial y le pasa lo mismo. Las 9 mediciones las hace correctamente pero cuando llega a la ultima, baja, detecta la superficie, sube normal y vuelve a subir un poco y ya se dirige al punto de imprimir y se queda por encima y extruye dejando caer el plastico. Lo que si que me he dado cuenta es que al generar el gcode con simplify3d se queda mas arriba incluso que con cura el cual baja la boquilla algo mas, se queda cerca de donde deberia pero tampoco, no se si tendra algo que ver...

He grabado un video de lo que hace la impresora por si ayuda de algo si se necesita mas informacion solo dímelo y te indico. Muchas gracias por la ayuda!



Hola, te comento algunas cosas que veo en el video.
No entiendo por qué te extruye durante las mediciones del autolevel.
¿Que script de inicio tienes?. Porque eso podría explicar las diferencias al usar diferente fileteador.
Cuando dices que haces el tutorial desde el principio, ¿te refieres a las tres partes?. Porque me parece que el sensor lo tienes con poca sensibilidad o, si está al máximo, demasiado alto.
En la parte II del tutorial se indica como colocar el sensor. Como decía en la anterior respuesta, no conviene que quede tan cerca la boquilla de la cama cuando se activa.
Visto lo cerca que queda, ¿que Z Offset tienes configurado?.
Cuando termina las mediciones, debe subir ligeramente, bajar a 0 y después el Z Offset para llegar a la altura de la primera capa y en tu caso no baja lo suficiente, bien porque no tengas el valor correcto o porque algo está modificándolo.
Citar
#38
(02-03-2018, 01:29 AM)Simemart escribió:
(01-03-2018, 10:59 PM)bernard69 escribió: Qué z te marca al empezar la primera capa? Haciendo home en z y después moviendo despacio asegura que z=0 esta tocando la cama. Si no, guarda valor con M851 Zx y después M500 ( usando pronterface y x es espesor de un folio). Esto lo he tenido que hacer yo alguna vez. Saludos

Sent from my VTR-L29 using Tapatalk

Lo que indicas no es de aplicación cuando se tiene un sensor como final de carrera. El punto 0 de Z es donde se activa el sensor al hacer home y no tiene por qué ser a la altura de la primera capa.
Por contra, conviene que sea antes para tener margen si el sensor falla en la activación y así poder evitar el choque de la boquilla con la cama.
Es con el Z Offset con lo que se ajusta la altura para la impresión (un valor siempre negativo, por tanto).
Por eso hay que habilitar en el firmware, que ese eje pueda sobrepasar el punto cero.


(01-03-2018, 07:29 PM)nazgul_25 escribió: Hola! gracias por la respuesta. El tutorial es la cuarta vez que lo hago desde el principio para descartar que me esté saltando algo. De hecho una de las veces un amigo lo hizo siguiendo el tutorial y le pasa lo mismo. Las 9 mediciones las hace correctamente pero cuando llega a la ultima, baja, detecta la superficie, sube normal y vuelve a subir un poco y ya se dirige al punto de imprimir y se queda por encima y extruye dejando caer el plastico. Lo que si que me he dado cuenta es que al generar el gcode con simplify3d se queda mas arriba incluso que con cura el cual baja la boquilla algo mas, se queda cerca de donde deberia pero tampoco, no se si tendra algo que ver...

He grabado un video de lo que hace la impresora por si ayuda de algo si se necesita mas informacion solo dímelo y te indico. Muchas gracias por la ayuda!



Hola, te comento algunas cosas que veo en el video.
No entiendo por qué te extruye durante las mediciones del autolevel.
¿Que script de inicio tienes?. Porque eso podría explicar las diferencias al usar diferente fileteador.
Cuando dices que haces el tutorial desde el principio, ¿te refieres a las tres partes?. Porque me parece que el sensor lo tienes con poca sensibilidad o, si está al máximo, demasiado alto.
En la parte II del tutorial se indica como colocar el sensor. Como decía en la anterior respuesta, no conviene que quede tan cerca la boquilla de la cama cuando se activa.
Visto lo cerca que queda, ¿que Z Offset tienes configurado?.
Cuando termina las mediciones, debe subir ligeramente, bajar a 0 y después el Z Offset para llegar a la altura de la primera capa y en tu caso no baja lo suficiente, bien porque no tengas el valor correcto o porque algo está modificándolo.

En verdad he querido decir lo que tu explicas en el hilo con la configuración del desfase. Por mi poca experiencia y si sirve de ayuda el sensor no es exacto y hay que calibrarlo con el m500. Yo por lo que sea tuve que hacerlo varias veces (bien porque no lo hiciera bien o por lo que sea) porque no se guardaba bien el valor de z offset. Es más, una vez moví la impresora, y de imprimir bien anteriormente, volvió a imprimir mal y tuve que recalibrar... rarísimo...pero solucionado con el m500. Espero pueda ayudar..

Sent from my VTR-L29 using Tapatalk
Citar
#39
Hola,
Soy nuevo en esto de las impresoras 3D (Anet A6) y despues de hacerla funcionar unos dias tal como biene, le he querido poner un autolevel siguiendo el tutorial, que por cierto es para enmarcar( He califiado con 5 estrellas), ahora biene el pero y es que nose si he hecho algo mal pero cuando copila antes de hacer "Z Offset" me sale:
El Sketch usa 127418 bytes (100%) del espacio de almacenamiento de programa. El máximo es 126976 bytes.
Variables globales usan 4685 bytes de memoria dinamica.
Programa muy grando: visite http://www.arduino.cc/en/Guide/Troubleshooting#size para ver cómo reducirlo.
Error compilando para la tarjeta Anet V1.0.
He visitado la paguina que dice de arduino y pone:
(El chip ATmega168 en la placa Arduino es barato, pero tiene solo 16 Kb de código de programa, que no es mucho (y el cargador de arranque usa 2 Kb).
Si está utilizando el punto flotante, intente volver a escribir su código con matemáticas enteras, lo que debería ahorrarle aproximadamente 2 Kb. Elimine las declaraciones #include en la parte superior del boceto para las bibliotecas que no esté utilizando.
De lo contrario, vea si puede acortar su programa.),
He entrado en el archivo Marlin y le colocado las dos barras // delante de los #include que estan en rojo para eliminar y sigue saliendome el mismo mensaje de programa muy grande.
Pregunta: ¿ que puedo hacer ?. placa Anet3d V1-5.
Citar
#40
Hola @Pacomt , el problema que tienes al compilar es debido a que el espacio de almacenamiento de la placa Anet, se queda corto cuando se utiliza junto con una pantalla del tipo gráfico, como es el caso de la A6.
Estas pantallas necesitan incluir la librería U8glib, lo que hace que aumente demasido el código.
Para solucionarlo hay que, como dices, eliminar algo.
La mejor opción que yo veo es quitar los mensajes de respuesta de las ordenes que se envían a la EEPROM.
Esto se hace comentando (poniendo // delante) la línea #define EEPROM_CHITCHAT, que ya indica en el comentario que ahorra memoria de programa.
Creo que con eso ya podrás compilar.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Autolevel, paso a paso (II): el sensor. Simemart 20 6,873 Hace 1 hora
Último mensaje: edgarc
  Autolevel, paso a paso (I): Cambiar el firmware. Simemart 59 11,657 11-08-2018, 09:37 PM
Último mensaje: Simemart
  CONSULTA Autolevel, vale la pena? marcre 6 458 08-08-2018, 10:48 PM
Último mensaje: Simemart
  Este sensor me vale como autolevel? vegetto 2 311 28-06-2018, 02:37 AM
Último mensaje: vegetto
  APORTE Autoapagado con Marlin (Editado). Simemart 7 1,265 15-06-2018, 02:03 PM
Último mensaje: Simemart