Calificación:
  • 2 voto(s) - 5 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Autolevel, paso a paso (II): el sensor.
#21
Solucionado y trabajando perfecto
Moraleja del asunto NO confien mucho en la net cuando dicen usar XoY resistencias
mejor siempre medir por si el valor que queremos o necesitamos en este caso Placa Anet v1.0 (clone) =(5.1v)
y utilizando resistencias 15k y 10k obtube (3.8v) No medi voltage(novato al fin) jajaja (no se si estba una de ellas mala)
final y con mejor resultado a lo que necesito (R 4.7k y R 10k = (4.70v) entre negativo y señal
Gracias al tuto de verdad todo bien explicado para brutos como yop que lo logre
saludos y mis respeto
Citar
#22
Una pregunta, hablamos de sensores npn, pero un pnp en mks?
Citar
#23
Hola, a este tutorial ya le pesa un poco la edad.
Se pueden utilizar los dos tipos de sensor, sólo hay que conectarlo correctamente y configurar como corresponda la lógica del sensor en el firmware.
La mejor opción de conexión es mediante un optoacoplador, cuyo esquema es el siguiente:

resim

Como optoacoplador valen todos los 4N (4N25, 4N26,...).
Citar
#24
(14-06-2018, 08:46 PM)PopLaManopla escribió: Hola, he seguido los pasos como se indican en el esquema pero tengo un problema.
Resulta que aunque al poner un objeto a unos milímetros del sensor el led enciende pero no da la señal para que se detenga el eje z.

Lo único que creo que podría ser el modelo de sensor que no es como el que indicas:
Heschen Interruptor de sensor de proximidad capacitivo, detector LJC18A3-Z/BX, 10 mm, 6-36 V CC, 300 mA PNP, normalmente abierto (NO) 3 cables.

En la página web que lo compré había comentarios de que funcionaba bien en la anet A8.

Dejo una imagen del apaño:
resim

En el otro lado de los cables el marrón va a 12V +, el negro a la señal y azul a tierra, estos dos en una clema y directamente a la placa.

Gracias.

Hola estimados, utilicé el ejemplo de arriba pero no me funcionó como debía, al contrario el sensor siempre me aparece como triggered (al usar el comando m119) y nunca se apagaba. También lo utilice realizando un esquema de dos resistencias (una de 10k y la otra de 15k) pero tampoco funcionó (no marcaba nada con el comando m119, solo estaba open). Después utilice el esquema con dos resistencias de 10k pero tampoco funcionó (no marcaba nada con el comando m119, solo estaba open). Ayudenme porfavor. Mi sensor es Sensor de proximidad inductivo LJ12A3-4-Z/BX (NPN)
Citar
#25
Hola @RoyStandenB, bienvenido al foro.
Te has equivocado con el esquema por no leer la pregunta a que respondía con él y no fijarte bien. Ese es para un sensor PNP, como se indica claramente a la izquierda.
Si el tuyo tiene esa referencia, es NPN y el esquema correcto para él es este:

resim
Citar
#26
Hola a todos.

Mi impresora es una A6. Ya tengo montado el detector.

He realizado paso a paso el manual. En el momento de compilar me da este fallo..

El Sketch usa 130028 bytes (102%) del espacio de almacenamiento de programa. El máximo es 126976 bytes.
Variables globales usan 4635 bytes de memoria dinamica.
Programa muy grando: visite http://www.arduino.cc/en/Guide/Troubleshooting#size para ver cómo reducirlo.
Error compilando para la tarjeta Anet V1.0.

Que puedo hacer para solucionarlo..

He buscado en el foro y en mas sitios y no he encontrado nada.

Gracias por adelantado.
Citar
#27
Hola @pirados, bienvenido al foro.
El error que te está dando el IDE se debe a que no tienes suficiente memoria para albergar el firmware con todas las características que tienes activadas.
Se puede recuperar algo de memoria poniendo así las siguientes líneas del archivo Configuration.h:

#define DISABLE_M503
//#define EEPROM_CHITCHAT


Creo que con eso ya recuperarás suficiente memoria para poder compilar.
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  Autolevel, paso a paso (III): configuración (ACTUALIZADO y EDITADO). Simemart 278 58,314 11-04-2020, 03:33 PM
Último mensaje: Manelto
  CONSULTA Anet A8 Plus - Autolevel con servo furruz 2 200 18-03-2020, 06:42 PM
Último mensaje: furruz
  Problema con autolevel en anet A8 Txiki 5 479 14-01-2020, 06:25 PM
Último mensaje: Simemart
  Autolevel, paso a paso (I): Cambiar el firmware. Simemart 128 29,219 23-12-2019, 07:48 AM
Último mensaje: ec2daw
Triste No se enciende la pantalla, la cague con el sensor de temperatura infotoni 8 621 18-07-2019, 02:16 PM
Último mensaje: infotoni