Calificación:
  • 0 voto(s) - 0 Media
  • 1
  • 2
  • 3
  • 4
  • 5
Anomalia en el Homing Z
#1
Hola chicos!

He tenido un problema justo ahora.

Ayer arregle un problema mecanico que tenia con la fijacion del extrusor al carro, ya esta arreglado, unicamente toque eso, pues acabo de imprimir un cubo de calibracion, y me ha hecho 2x2x1,5 cuando deberia ser 2x2x2 y no he cambiado nada en el eje Z que creis que puede ser el problema?

Gracias!

Cabe decir que los ejes z estan a la misma altura, es decir que no he cambiado la distancia ni nada de nada.

Ademas cuelgo esto que me ha surgido ahora mismo... a ver si os sirve de ayuda

https://www.youtube.com/watch?v=uv5oaBBTwrg
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#2
Descarto que sea por el Marlin porque he probado otro y me pasa lo mismo...

a ver si me podeis ayudar...

Gracias
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#3
Nadie?
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#4
Tio, es que es raro de cojones.

Hay que repetir los pasos de siempre (mide bien! que no haya nada raro en el calibre)

1.- centra los ejes
2.- dile al eje Z que suba 10cm (100mm)
3.- mide lo que ha subido
4.- ajusta marlin

Pero como dices que antes si funcionaba y no has tocado nada, mira que el driver del eje Z este bien ajustado, comprueba las conexiones y que se mueven los dos motores etc etc
Citar
#5
el slic3r tiene un z offset en printer settings, no será eso???
Citar
#6
Tiene pinta del offset... te estará haciendo las primeras capas muy "pegadas" a la cama...
Citar
#7
(28-03-2016, 09:58 AM)ICEM4N escribió: Tio, es que es raro de cojones.

Hay que repetir los pasos de siempre (mide bien! que no haya nada raro en el calibre)

1.- centra los ejes
2.- dile al eje Z que suba 10cm (100mm)
3.- mide lo que ha subido
4.- ajusta marlin

Pero como dices que antes si funcionaba y no has tocado nada, mira que el driver del eje Z este bien ajustado, comprueba las conexiones y que se mueven los dos motores etc etc

(28-03-2016, 03:12 PM)kaituss escribió: el slic3r tiene un z offset en printer settings, no será eso???

No tiene z offset.

El marlin no hes porque he probado a cargar otro, intentar imprimir y lo mismo, luego he vuelto a volver a poner el "bueno" y mas de lo mismo.

Respecto al tema driver, creo que no es, porque el homing lo hace perfectamente el unico problema es a la hora de imprimir, que al comprobar a la hora de volver a tocar el endstop se queda unos milimetros arriba...

Aun asi voy a pillar mañana unos drivers nuevos, y he mandado imprimir a 3despaña unas piezas para hacerle el rework que veo mas que necesario, si con esas mañana no se arregla, le prendo fuego...
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#8
(28-03-2016, 07:25 PM)jgauchia escribió: Tiene pinta del offset... te estará haciendo las primeras capas muy "pegadas" a la cama...

Es justamente todo lo contrario :S xD

Si no has visto el video echale un vistazo, se explica mejor que yo.

Es que no llega a tocar el endstop cuando va a imprimir.

Y no no hay offset ninguno, voy a probar a intercambiar el driver del extrusor por el del eje z a ver que ocurre.
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#9
(28-03-2016, 09:07 PM)CheddarOP escribió: Es justamente todo lo contrario :S xD

Si no has visto el video echale un vistazo, se explica mejor que yo.

Es que no llega a tocar el endstop cuando va a imprimir.

Y no no hay offset ninguno, voy a probar a intercambiar el driver del extrusor por el del eje z a ver que ocurre.

Si, lo he visto hace poco....
Se queda levantado después de hacer el homing antes de imprimir?

lo único que se me ocurre , ya por decir algo xD , que no tengas nada raro en el GCODE al iniciar la impresión, no se si usas Cura o no, que no te hace bajar el extrusor esos milímetros
Citar
#10
(28-03-2016, 09:16 PM)jgauchia escribió:
(28-03-2016, 09:07 PM)CheddarOP escribió: Es justamente todo lo contrario :S xD

Si no has visto el video echale un vistazo, se explica mejor que yo.

Es que no llega a tocar el endstop cuando va a imprimir.

Y no no hay offset ninguno, voy a probar a intercambiar el driver del extrusor por el del eje z a ver que ocurre.

Si, lo he visto hace poco....
Se queda levantado después de hacer el homing antes de imprimir?

lo único que se me ocurre , ya por decir algo xD , que no tengas nada raro en el GCODE al iniciar la impresión, no se si usas Cura o no, que no te hace bajar el extrusor esos milímetros
Lo raro es que esto me paso despues de usar por primera vez el CURA para imprimir...

me lo hizo bien, pero ya despues de esa ni con cura ni con slicer me va bien...
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#11
(28-03-2016, 09:18 PM)CheddarOP escribió: Lo raro es que esto me paso despues de usar por primera vez el CURA para imprimir...

me lo hizo bien, pero ya despues de esa ni con cura ni con slicer me va bien...

Mira a ver que no tengas en la EEPROM algun offset memorizado.

En el pronterface (si lo usas) pon el gCode M501 y te saldrán lo que tienes en memoria

Busca el M206 a ver que te pone en X , Y y Z a ver si te está haciendo un offset adicional.

Si es así mira en este link http://airtripper.com/1799/marlin-firmwa...code-m206/

Por ir mirando cosas que no quede.
Citar
#12
Te e contestado en el video.
Citar
#13
(28-03-2016, 09:24 PM)jgauchia escribió:
(28-03-2016, 09:18 PM)CheddarOP escribió: Lo raro es que esto me paso despues de usar por primera vez el CURA para imprimir...

me lo hizo bien, pero ya despues de esa ni con cura ni con slicer me va bien...

Mira a ver que no tengas en la EEPROM algun offset memorizado.

En el pronterface (si lo usas) pon el gCode M501 y te saldrán lo que tienes en memoria

Busca el M206 a ver que te pone en X , Y y Z a ver si te está haciendo un offset adicional.

Si es así mira en este link http://airtripper.com/1799/marlin-firmwa...code-m206/

Por ir mirando cosas que no quede.

Eso me parece chino mandarin, aun no he probado con gcodes, pero desde Repetier se puede hacer imagino
no?
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#14
(28-03-2016, 10:35 PM)CheddarOP escribió:
(28-03-2016, 09:24 PM)jgauchia escribió:
(28-03-2016, 09:18 PM)CheddarOP escribió: Lo raro es que esto me paso despues de usar por primera vez el CURA para imprimir...

me lo hizo bien, pero ya despues de esa ni con cura ni con slicer me va bien...

Mira a ver que no tengas en la EEPROM algun offset memorizado.

En el pronterface (si lo usas) pon el gCode M501 y te saldrán lo que tienes en memoria

Busca el M206 a ver que te pone en X , Y y Z a ver si te está haciendo un offset adicional.

Si es así mira en este link http://airtripper.com/1799/marlin-firmwa...code-m206/

Por ir mirando cosas que no quede.

Eso me parece chino mandarin, aun no he probado con gcodes, pero desde Repetier se puede hacer imagino
no?
Si, pero no se exactamente dónde


Enviado desde mi CHC-U01 mediante Tapatalk
Citar
#15
Como borro la EEPROM? estoy por borrar todo el arduino y dejarlo de fabrica y meterlo otra vez, alguien me ilumina??
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#16
(29-03-2016, 07:38 PM)CheddarOP escribió: Como borro la EEPROM? estoy por borrar todo el arduino y dejarlo de fabrica y meterlo otra vez, alguien me ilumina??

Con M502 pones valores de fábrica , es decir valores de firmware y no de EEPROM
Con M500 Z0 pones a 0 el offset del eje Z,
Citar
#17
Yo lo que quiero es dejarlo virgen, como cuando me llego, porque me da la sensacion que hay algo que perturba, porque he cambiado los drivers y sigue igual.

Asique si con el M502 lo dejo virgen lo hago, pero claro eso no me cambia el marlin? yo quiero "formatearlo" que no se si es posible pero basicamente eso es lo que quiero.
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#18
(29-03-2016, 10:05 PM)CheddarOP escribió: Yo lo que quiero es dejarlo virgen, como cuando me llego, porque me da la sensacion que hay algo que perturba, porque he cambiado los drivers y sigue igual.

Asique si con el M502 lo dejo virgen lo hago, pero claro eso no me cambia el marlin? yo quiero "formatearlo" que no se si es posible pero basicamente eso es lo que quiero.

Con ese comando borras el contenido de la EEPROM,
Luego le subes el Marlin que quieras con la configuración que tengas o quieras y ya está.
Vamos como si volvieras a subir el firmware por primera vez.
Citar
#19
Ahora solo falta alguien que me diga como hacerlo desde el repetier

Pero muchas gracias @jgauchia !!! ;D
Prusa i3 Steel! Cuando imprima sere feliz xD
Citar
#20
(29-03-2016, 11:25 PM)CheddarOP escribió: Ahora solo falta alguien que me diga como hacerlo desde el repetier

Pero muchas gracias @jgauchia !!! ;D
Dentro de repetier en la siguiente pantalla hay un cuadro de texto. (Manual control)

resim

Dentro de G-Code pones el M502 y luego send.

Debería ser así



Enviado desde mi CHC-U01 mediante Tapatalk
Citar


Temas similares...
Tema Autor Respuestas Vistas Último mensaje
  DUDA Problema Homing CNoble 4 264 31-07-2018, 05:10 PM
Último mensaje: CNoble
  Problemas con la impresora, Homing y más Jarryson 18 3,949 09-04-2016, 05:59 PM
Último mensaje: Jarryson
  (SOLUCIONADO)No hay forma de hacer homing HELP adc0891 5 1,249 19-01-2015, 01:06 PM
Último mensaje: adc0891
  la prusa i3 no me hace homing¡¡¡ AYUDA PORFAVOR wuasichu 3 837 19-09-2014, 10:03 AM
Último mensaje: wuasichu
  problemas con el homing y el extrusor zorro12345 3 712 14-06-2014, 09:05 PM
Último mensaje: zorro12345